Re: [PATCH v3 14/21] repack: stop using magic number for ARRAY_SIZE(exts)

2013-12-07 Thread Thomas Rast
Jeff King  writes:

> We have a static array of extensions, but hardcode the size
> of the array in our loops. Let's pull out this magic number,
> which will make it easier to change.
>
> Signed-off-by: Jeff King 

Reviewed-by: Thomas Rast 

(Ok, this one was easy.)

-- 
Thomas Rast
t...@thomasrast.ch
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH v3 14/21] repack: stop using magic number for ARRAY_SIZE(exts)

2013-11-14 Thread Jeff King
We have a static array of extensions, but hardcode the size
of the array in our loops. Let's pull out this magic number,
which will make it easier to change.

Signed-off-by: Jeff King 
---
 builtin/repack.c | 8 
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/builtin/repack.c b/builtin/repack.c
index a0ff5c7..2e88975 100644
--- a/builtin/repack.c
+++ b/builtin/repack.c
@@ -115,7 +115,7 @@ static void remove_redundant_pack(const char *dir_name, 
const char *base_name)
 
 int cmd_repack(int argc, const char **argv, const char *prefix)
 {
-   const char *exts[2] = {".pack", ".idx"};
+   const char *exts[] = {".pack", ".idx"};
struct child_process cmd;
struct string_list_item *item;
struct argv_array cmd_args = ARGV_ARRAY_INIT;
@@ -258,7 +258,7 @@ int cmd_repack(int argc, const char **argv, const char 
*prefix)
 */
failed = 0;
for_each_string_list_item(item, &names) {
-   for (ext = 0; ext < 2; ext++) {
+   for (ext = 0; ext < ARRAY_SIZE(exts); ext++) {
char *fname, *fname_old;
fname = mkpathdup("%s/%s%s", packdir,
item->string, exts[ext]);
@@ -315,7 +315,7 @@ int cmd_repack(int argc, const char **argv, const char 
*prefix)
 
/* Now the ones with the same name are out of the way... */
for_each_string_list_item(item, &names) {
-   for (ext = 0; ext < 2; ext++) {
+   for (ext = 0; ext < ARRAY_SIZE(exts); ext++) {
char *fname, *fname_old;
struct stat statbuffer;
fname = mkpathdup("%s/pack-%s%s",
@@ -335,7 +335,7 @@ int cmd_repack(int argc, const char **argv, const char 
*prefix)
 
/* Remove the "old-" files */
for_each_string_list_item(item, &names) {
-   for (ext = 0; ext < 2; ext++) {
+   for (ext = 0; ext < ARRAY_SIZE(exts); ext++) {
char *fname;
fname = mkpath("%s/old-pack-%s%s",
packdir,
-- 
1.8.5.rc0.443.g2df7f3f

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html