On Sun, Jun 01, 2014 at 11:00:40AM +0200, René Scharfe wrote:

> The array header is defined as:
> 
>       static const char *header[MAX_HDR_PARSED] = {
>            "From","Subject","Date",
>       };
> 
> When looking for the index of a specfic string in that array, simply
> use strcmp() instead of memcmp().  This avoids running over the end of
> the string (e.g. with memcmp("Subject", "From", 7)) and gets rid of
> magic string length constants.
> 
> Signed-off-by: Rene Scharfe <l....@web.de>

Looks correct to me.

> ---
> This is a minimal fix.  A good question, however, would be: Why do we
> keep on looking up constant strings in a (short) constant string array
> anyway?

Yeah, this code is quite confusing. I suspect it would be more readable
to unroll any loops over the header array into a series of function
calls or even just cascading if/else. Some of the sites (e.g.,
check_header) already have a mix, like:

  for (i = 0; header[i]; i++)
    if (cmp_header(line, header[i]))
      ... do something for this header ...

  if (cmp_header(line, "some-other-header"))
      ... do something special for this header type ...
  else if (cmp_header(line, "another"))
      ... and something else again ...

The looping is not really helping much there in the first place, since
it is not dealing with half of the headers. And then adding on top that
the loop has its own special cases found by comparing the string to
"Subject", I think it would be simpler to just unroll it.

That's just from a quick 5-minute read of the code, though. This isn't
an area I'm very familiar with, so maybe the refactor would get ugly.

-Peff
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to