Re: Re: [PATCH v4 3/5] config: make parsing stack struct independent from actual data source

2013-05-13 Thread Heiko Voigt
On Sun, May 12, 2013 at 09:56:39PM -0700, Junio C Hamano wrote:
 Heiko Voigt hvo...@hvoigt.net writes:
 
   /*
  - * The fields f and name of top need to be initialized before calling
  + * All source specific fields in the union, name and the callbacks
  + * fgetc, ungetc, ftell of top need to be initialized before calling
* this function.
*/
  -static int do_config_from(struct config_file *top, config_fn_t fn, void 
  *data)
  +static int do_config_from_source(struct config_source *top, config_fn_t 
  fn, void *data)
 
 This renaming may have made sense if we were to have many different
 do_config_from_$type functions for different types of source, but as
 this patch introduces a nice config_source abstraction, I do not
 think it is unnecessary. Shortening do_config_from() to do_config()
 may make more sense, if anything.
 
 But that is a very minor point, as this is entirely internal with a
 single caller.

Did you really intent this double negation: ..., I do not think it
is unnecessary. ? The rest of the paragraph sounds like you would
think the rename is actually not necessary. I thought I recalled that
Jeff asked me to change the name but I can not find the email, so maybe
its just my wrong memory. I am happy to drop the rename here, if thats
what you meant.

Cheers Heiko
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: Re: [PATCH v4 3/5] config: make parsing stack struct independent from actual data source

2013-05-13 Thread Jeff King
On Mon, May 13, 2013 at 04:04:35PM +0200, Heiko Voigt wrote:

   -static int do_config_from(struct config_file *top, config_fn_t fn, void 
   *data)
   +static int do_config_from_source(struct config_source *top, config_fn_t 
   fn, void *data)
 [...]
 I thought I recalled that Jeff asked me to change the name but I can
 not find the email, so maybe its just my wrong memory. I am happy to
 drop the rename here, if thats what you meant.

I think you are thinking of:

  http://thread.gmane.org/gmane.comp.version-control.git/217018/focus=217170

where I criticize the name. But I think the comment you added makes its
purpose much more clear, so the name is less important (and for the
record, I think do_config or config_source_parse would be fine,
too).

-Peff
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html