GTK lockup when dialog closes

2015-01-06 Thread Tom Hughes
I've been trying to track down a problem where an application (gramps) written in python using GTK occasionally locks up when closing a dialog. The immediate symptom is that hitting causes the application to lock up with the CPU spinning and strace revealing that it is looping being told

Re: gtktreeview: highlighting a cell

2015-01-06 Thread Stefan Sauer
On 12/12/2014 06:57 PM, Allin Cottrell wrote: I'm using GtkTreeView to implement a simple spreadsheet. With GTK 2, if use gtk_tree_view_set_cursor() to place keyboard focus on a given cell, with the last argument set to FALSE so that editing mode is not entered immediately, I get a visual

Re: Documenting properties and signals with gtk-doc

2015-01-06 Thread Stefan Sauer
On 12/20/2014 01:39 PM, Wouter Verhelst wrote: Hi list, I've been pouring over the (fairly scarce) documentation https://developer.gnome.org/gtk-doc-manual/unstable/ if anything is unclear, let me know. ... and FYI there also is a gtk-doc mailing list and irc channel. Stefan and trying to

Re: GTK+_failed installation

2015-01-06 Thread Michael Torrie
On 01/05/2015 03:28 AM, Nabil Ferguen wrote: Dear Team GTK, I would like to install gtk+ (for OOF2D) on ubunto 12.04, and I have successfully installed all packages (pango, glib, gdk-pixbuf, atk) but the compiler fails and sends an error message linked to the atspi-2 package (requires

GTK+_failed installation

2015-01-06 Thread Nabil Ferguen
Dear Team GTK, I would like to install gtk+ (for OOF2D) on ubunto 12.04, and I have successfully installed all packages (pango, glib, gdk-pixbuf, atk) but the compiler fails and sends an error message linked to the atspi-2 package (requires version = 2.11.2). I have looked on the web in order to

Problem with MessageDialog boxes

2015-01-06 Thread Jim Charlton
I have been trying to compile some gtkmm code with Gtk::MessageDialog(). The icons do not appear and the buttons are packed full width of the message box. Running gtk3-demo shows the same problem. I am using libgtk-3.0 version number 1401.5.0. Older versions of libraries seem to work OK.