[hackers] [PATCH 17/17] Add TODO

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 8 1 file changed, 8 insertions(+) diff --git a/ed.c b/ed.c index fe68197..bf66f8b 100644 --- a/ed.c +++ b/ed.c @@ -1,4 +1,12 @@ /* See LICENSE file for copyright and license details. */ + +/* + * TODO: Multi-line commands don't work in g

[hackers] [PATCH 14/17] Improve doglobal()

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" Don't use directly the line numbers and call to getlst() when a line is matched. --- ed.c | 30 ++ 1 file changed, 18 insertions(+), 12 deletions(-) diff --git a/ed.c b/ed.c index 13c41c6..1e814e9 100644 --- a/ed.c +++ b/ed.c @@ -1

[hackers] [PATCH 06/17] Move join() to use String type

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/ed.c b/ed.c index 5d85b52..8951d4b 100644 --- a/ed.c +++ b/ed.c @@ -833,22 +833,22 @@ join(void) { int i; char *t, c; - size_t len = 0, cap =

[hackers] [PATCH 09/17] Fix type of c in getrhs()

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" C is compared against EOF, so it cannot be char. --- ed.c | 21 ++--- 1 file changed, 10 insertions(+), 11 deletions(-) diff --git a/ed.c b/ed.c index fb4faf9..0f86759 100644 --- a/ed.c +++ b/ed.c @@ -926,15 +926,14 @@ static void getrhs(int

[hackers] [PATCH 02/17] Define new String type

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" Current handling of strings is a bit messy. This type is copied from the sed implementation. Addchar_ is added to be able to live with String and old style chars based in 3 different variables. --- ed.c | 23 +++ 1 file changed, 23 insertio

[hackers] [sbase] ed patches

2018-03-06 Thread quinq
Hi, Here are some ed patches I send on the behalf of Roberto as he is having mailing problems.

[hackers] [PATCH 01/17] Set restore point before seeting signal handlers

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 14 ++ 1 file changed, 6 insertions(+), 8 deletions(-) diff --git a/ed.c b/ed.c index 2a84b60..5511a9e 100644 --- a/ed.c +++ b/ed.c @@ -1368,7 +1368,6 @@ sighup(int dummy) static void edit(void) { - setjmp(savesp); for

[hackers] [PATCH 16/17] Fix undo

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" Avoid incorrect values in the number of undo elements and restore lastln value after an undo operation. --- ed.c | 21 + 1 file changed, 17 insertions(+), 4 deletions(-) diff --git a/ed.c b/ed.c index dbdfe60..fe68197 100644 --- a/ed.c +++

[hackers] [PATCH 07/17] Move execsh() to use String type

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 21 ++--- 1 file changed, 10 insertions(+), 11 deletions(-) diff --git a/ed.c b/ed.c index 8951d4b..dcd91d1 100644 --- a/ed.c +++ b/ed.c @@ -887,38 +887,37 @@ quit(void) static void execsh(void) { - static char *cmd; -

[hackers] [PATCH 10/17] Move subline() to use String type

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 31 +++ 1 file changed, 15 insertions(+), 16 deletions(-) diff --git a/ed.c b/ed.c index 0f86759..2a66184 100644 --- a/ed.c +++ b/ed.c @@ -970,26 +970,26 @@ getnth(void) } static void -addpre(char **s, size_t *cap, s

[hackers] [PATCH 12/17] Allow overlapping transfer

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 18 ++ 1 file changed, 10 insertions(+), 8 deletions(-) diff --git a/ed.c b/ed.c index 58bdb45..70dd2a5 100644 --- a/ed.c +++ b/ed.c @@ -19,6 +19,8 @@ #define LINESIZE80 #define NUMLINES32 #define CACHESIZ 4096 +#define

[hackers] [PATCH 03/17] Move cmdline to String type

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 32 +--- 1 file changed, 17 insertions(+), 15 deletions(-) diff --git a/ed.c b/ed.c index 97fa5e8..ca55c61 100644 --- a/ed.c +++ b/ed.c @@ -61,9 +61,8 @@ static size_t sizetxt, memtxt; static int scratch; static int pf

[hackers] [PATCH 13/17] Fix copy()

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" Copy was using directly the line numbers and incrementing them without calling to nextln(). It also didn't worried about how line numbers are modified when we insert new lines. --- ed.c | 11 --- 1 file changed, 8 insertions(+), 3 deletions(-) diff --

[hackers] [PATCH 04/17] Move text to String type

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 15 +++ 1 file changed, 7 insertions(+), 8 deletions(-) diff --git a/ed.c b/ed.c index ca55c61..2cf2708 100644 --- a/ed.c +++ b/ed.c @@ -54,10 +54,9 @@ static jmp_buf savesp; static char *lasterr; static size_t idxsize, lastidx; stat

[hackers] [PATCH 05/17] Move lastre to String type

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 13 ++--- 1 file changed, 6 insertions(+), 7 deletions(-) diff --git a/ed.c b/ed.c index 2cf2708..5d85b52 100644 --- a/ed.c +++ b/ed.c @@ -44,7 +44,7 @@ struct undo { static char *prompt = "*"; static regex_t *pattern; static regmatch_t

[hackers] [PATCH 15/17] Use nextln() in scroll()

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" --- ed.c | 14 ++ 1 file changed, 10 insertions(+), 4 deletions(-) diff --git a/ed.c b/ed.c index 1e814e9..dbdfe60 100644 --- a/ed.c +++ b/ed.c @@ -841,14 +841,20 @@ join(void) static void scroll(int num) { - int i; + int max, ln, c

[hackers] [PATCH 11/17] Rename addchar_() to addchar()

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" All the ocurrences of addchar() were moved to addchar_(), so we can rename addchar_() and remove the old definition. --- ed.c | 63 --- 1 file changed, 24 insertions(+), 39 deletions(-) diff --git a/

[hackers] [PATCH 08/17] Fix type of c in execsh()

2018-03-06 Thread quinq
From: "Roberto E. Vargas Caballero" C is compared against EOF, so it cannot be char. --- ed.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/ed.c b/ed.c index dcd91d1..fb4faf9 100644 --- a/ed.c +++ b/ed.c @@ -888,8 +888,8 @@ static void execsh(void) { static St

Re: [hackers] [dwm][PATCH] Do not call die() upon '-v' invocation

2016-10-28 Thread quinq
> > If not, that's your fault (or the packager you trust do to it for > > you, actually again your responsability). > > Blaming someone else won't solve the issue. Exactly, hence “your responsability”.

Re: [hackers] [sent] Fix cmdline argument check

2016-03-06 Thread quinq
> I decided to fix it a little differently, since I did not like this > nested if. No problem!

Re: [hackers] [sent] Fix cmdline argument check

2016-03-06 Thread quinq
On Sun, 6 Mar 2016 07:51:47 +0100 k...@shike2.com wrote: > Hi, Hi k0ga, > > + if ((fp = ((argv[0] && strcmp(argv[0], "-")) ? > > fopen(argv[0], "r") : stdin))) { > > From my point of view this expresion is too complex and it should be > splitted in several subexpressions. Noted, I sent a mod

Re: [hackers] [surf-webkit2] Add Notification support

2016-01-20 Thread quinq
Hi Charles, Thank you for your interest in surf-webkit2. It is in (more or less) heavy development at this point and the status of the suckless repo is kind of frozen. I'm working on expanding it a bit in two principal branches outside. One for handling communication between the UI and the Renderi