Re: haproxy-1.8-rc4 - FreeBSD 11.1 - master-worker daemon parent staying alive/process-owner

2017-11-24 Thread Willy Tarreau
Hi Pieter, On Tue, Nov 21, 2017 at 04:34:16PM +0100, PiBa-NL wrote: > Hi William, > > I was intending to use the new feature to pass open sockets to the next > haproxy process. > And thought that master-worker is a 'requirement' to make that work as it > would manage the transferal of sockets. >

Re: haproxy-1.8-rc4 - FreeBSD 11.1 - master-worker daemon mode does not bind.?.

2017-11-24 Thread Willy Tarreau
Hi Pieter, On Mon, Nov 20, 2017 at 10:24:04PM +0100, Willy Tarreau wrote: > On Mon, Nov 20, 2017 at 10:18:31PM +0100, PiBa-NL wrote: > > Hi Willy, > > > > Op 20-11-2017 om 22:08 schreef Willy Tarreau: > > > OK thank you. I suspect something wrong happens, such as the master > > > killing the

RE: HAProxy 1.7.9 Not Capturing Application Session Cookie

2017-11-24 Thread Coscend@Coscend
Hello Moemen, Thank you for your encouraging insights. Below is the information you asked. >>Also you mentioned the application extensively uses Websockets. Is it only 3.3.2 using websockets ? if that is the case this may be a good lead since HAProxy does not handle websockets traffic

Re: [PATCH] DOC: explain HTTP2 timeout behavior

2017-11-24 Thread Willy Tarreau
On Fri, Nov 24, 2017 at 07:05:12PM +0100, Lukas Tribus wrote: > Clarifies that in HTTP2 we don't consider "timeout http-keep-alive", but > "timeout client" instead. > --- > Willy, feel free to change the wording or drop the note in the "timeout > client" section, I think the important information

[PATCH] DOC: explain HTTP2 timeout behavior

2017-11-24 Thread Lukas Tribus
Clarifies that in HTTP2 we don't consider "timeout http-keep-alive", but "timeout client" instead. --- Willy, feel free to change the wording or drop the note in the "timeout client" section, I think the important information is in http-keep-alive section. Thanks, Lukas ---

Re: [PATCH] Rename the global variable "proxy" to "proxies_list" replace-header

2017-11-24 Thread Willy Tarreau
On Fri, Nov 24, 2017 at 05:08:53PM +0100, Olivier Houchard wrote: > The attached patch renames the global variable "proxy" to "proxies_list". > "proxy" is commonly used as a name for function arguments, and a number of > times, "proxy" was used when another variable was really meant. It worked >

Re: [RFC PATCH] BUG/MINOR: h2: use valid stream id in GOAWAY

2017-11-24 Thread Willy Tarreau
On Fri, Nov 24, 2017 at 05:02:11PM +0100, Lukas Tribus wrote: > It makes sense to keep a HTTP/2 > connection open for a longer time than we did with HTTP/1. "timeout > client" will certainly do the job for now. I agree this is something > that can be changed post release, should the need arise.

Re: [RFC PATCH] BUG/MINOR: h2: use valid stream id in GOAWAY

2017-11-24 Thread Lukas Tribus
Hi, 2017-11-24 15:52 GMT+01:00 Willy Tarreau : >> - "timeout http-keep-alive" is not used > > I thought about trying to use it instead of timeout.client but felt > uncertain about this. Maybe it would make more sense. What's your > opinion ? See below. >> Should http-keep-alive

[PATCH] Rename the global variable "proxy" to "proxies_list" replace-header

2017-11-24 Thread Olivier Houchard
Hi, The attached patch renames the global variable "proxy" to "proxies_list". "proxy" is commonly used as a name for function arguments, and a number of times, "proxy" was used when another variable was really meant. It worked by luck, but can certainly come back to bite us at some point.

Re: [RFC PATCH] BUG/MINOR: h2: use valid stream id in GOAWAY

2017-11-24 Thread Willy Tarreau
Hi Lukas, On Fri, Nov 24, 2017 at 03:37:02PM +0100, Lukas Tribus wrote: > Great work, 401 is now fine. Thanks for confirming. > As for closing the connection, this is what I am seeing with the current code: > > - "timeout http-keep-alive" is not used I thought about trying to use it instead

Re: [RFC PATCH] BUG/MINOR: h2: use valid stream id in GOAWAY

2017-11-24 Thread Lukas Tribus
Hi Willy, 2017-11-24 10:43 GMT+01:00 Willy Tarreau : > So in the end here's what I've done : > > - implemented a new "reject" HTTP action. I initially started with > "close" and while documenting it I noticed it does exactly the same > as the tcp-request "reject" action,

Re: [PATCH] MINOR: ssl: Handle early data with BoringSSL

2017-11-24 Thread Willy Tarreau
On Fri, Nov 24, 2017 at 01:50:26PM +0100, Willy Tarreau wrote: > On Fri, Nov 24, 2017 at 01:45:22PM +0100, Emmanuel Hocdet wrote: > > Hi Willy, > > > > patch rebase from master. > > no merged, thanks guys. s/no/now to avoid any confusion :-) Willy

Re: [PATCH] MINOR: ssl: Handle early data with BoringSSL

2017-11-24 Thread Willy Tarreau
On Fri, Nov 24, 2017 at 01:45:22PM +0100, Emmanuel Hocdet wrote: > Hi Willy, > > patch rebase from master. no merged, thanks guys. Willy

Re: [PATCH] MINOR: ssl: Handle early data with BoringSSL

2017-11-24 Thread Emmanuel Hocdet
Hi Willy, patch rebase from master. ++ Manu 0001-MINOR-ssl-Handle-early-data-with-BoringSSL.patch Description: Binary data

Re: [PATCH] MINOR: ssl: Handle early data with BoringSSL

2017-11-24 Thread Olivier Houchard
Hi Willy, On Thu, Nov 23, 2017 at 07:44:13PM +0100, Willy Tarreau wrote: > On Thu, Nov 23, 2017 at 04:16:39PM +0100, Emmanuel Hocdet wrote: > > > > simplify patch: > > no need to bypass post SSL_do_handshake process, only remove > > CO_FL_EARLY_SSL_HS > > when handshake can't support early

Strange condition never parsed with acl and http-request replace-header

2017-11-24 Thread Vincent Gallissot
Hi all, I'm having a weird behavior with one of my acl and an associated condition. I'm starting to thing one of my 'if' condition is never parsed. Part of my haproxy.cfg config: 88 frontend proxy-front     bind *:80     mode http     acl

Re: [RFC PATCH] BUG/MINOR: h2: use valid stream id in GOAWAY

2017-11-24 Thread Willy Tarreau
Hi Lukas! On Wed, Nov 22, 2017 at 11:12:04AM +0100, Lukas Tribus wrote: > > Also I'd like to change all the error messages to support keep-alive (at > > least in the announce) so that we don't close on 401 etc. > > That makes absolutely sense. In fact, with a couple of 401 exchanges > between