Re: [PATCH] BUG/MINOR: ssl: fix warning about ssl-min/max-ver support

2019-03-05 Thread Willy Tarreau
On Tue, Mar 05, 2019 at 11:14:32PM +0100, Lukas Tribus wrote: > In 84e417d8 ("MINOR: ssl: support Openssl 1.1.1 early callback for > switchctx") the code was extended to also support OpenSSL 1.1.1 > (code already supported BoringSSL). A configuration check warning > was updated but with the wrong

[PATCH] BUG/MINOR: ssl: fix warning about ssl-min/max-ver support

2019-03-05 Thread Lukas Tribus
In 84e417d8 ("MINOR: ssl: support Openssl 1.1.1 early callback for switchctx") the code was extended to also support OpenSSL 1.1.1 (code already supported BoringSSL). A configuration check warning was updated but with the wrong logic, the #ifdef needs a && instead of an ||. Reported in #54.

Re: Does anyone *really* use 51d or WURFL ?

2019-03-05 Thread Baptiste
> > One could argue that 1) not building, 2) not working, and 3) > not being maintained doesn't exactly qualify as "stable". So maybe in the > end I'll do it there as well. And I'm sure it will not affect distros! > But I'm open to opinions on the subject. > > This seems to go against #1 quality

Re: Does anyone *really* use 51d or WURFL ?

2019-03-05 Thread Aleksandar Lazic
Hi. Am 05.03.2019 um 13:47 schrieb Willy Tarreau: > Hi all, > > back to this old thread : > > On Mon, Jan 21, 2019 at 03:36:22PM +0100, Willy Tarreau wrote: >> I don't know if wurfl builds at all by the way since the last update to >> the module is its introduction more than 2 years ago. > >

Re: Does anyone *really* use 51d or WURFL ?

2019-03-05 Thread Willy Tarreau
Hi all, back to this old thread : On Mon, Jan 21, 2019 at 03:36:22PM +0100, Willy Tarreau wrote: > I don't know if wurfl builds at all by the way since the last update to > the module is its introduction more than 2 years ago. So now at least I've got the response. This code doesn't build and

Unable to open a port using haproxy.

2019-03-05 Thread Gayathri Manoj
Hi All, I am getting the below error while loading haproxy service. 'bind :::6971' : unable to load SSL private key into SSL Context '/usr/xxx/yyy/HAProxy.pem.rsa'. Command used for starting the haproxy service : haproxy -D -f /usr/local/conf/haproxy.conf Conf file contains many port and if i