Re: [PATCH] Rename the global variable "proxy" to "proxies_list" replace-header

2017-11-24 Thread Willy Tarreau
On Fri, Nov 24, 2017 at 05:08:53PM +0100, Olivier Houchard wrote: > The attached patch renames the global variable "proxy" to "proxies_list". > "proxy" is commonly used as a name for function arguments, and a number of > times, "proxy" was used when another variable was really meant. It worked >

[PATCH] Rename the global variable "proxy" to "proxies_list" replace-header

2017-11-24 Thread Olivier Houchard
Hi, The attached patch renames the global variable "proxy" to "proxies_list". "proxy" is commonly used as a name for function arguments, and a number of times, "proxy" was used when another variable was really meant. It worked by luck, but can certainly come back to bite us at some point.