Re: [PATCH 1/3] MINOR: cache: Remove the `hash` part of the accept-encoding secondary key

2021-01-18 Thread William Lallemand
On Mon, Jan 18, 2021 at 01:40:44PM +0100, Tim Düsterhus wrote: > Remi, > > Am 18.01.21 um 11:24 schrieb Remi Tricot-Le Breton: > > The patches look good to me. Just one point concerning the first one, > > you could have removed everything related to ACCEPT_ENCODING_MAX_ENTRIES > > since the

[PATCH v2 1/3] MINOR: cache: Remove the `hash` part of the accept-encoding secondary key

2021-01-18 Thread Tim Duesterhus
As of commit 6ca89162dc881df8fecd7713ca1fe5dbaa66b315 this hash no longer is required, because unknown encodings are not longer stored and known encodings do not use the cache. --- include/haproxy/http_ana-t.h | 2 +- src/cache.c | 94 +--- 2

[PATCH v2 3/3] CLEANUP: cache: Use proper data types in secondary_key_cmp()

2021-01-18 Thread Tim Duesterhus
- hash_length is `unsigned int` and so should offset. - idx is compared to a `size_t` and thus it should also be. --- src/cache.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/cache.c b/src/cache.c index ab0799a5d..f03944faf 100644 --- a/src/cache.c +++ b/src/cache.c

[PATCH v2 2/3] CLEANUP: Rename accept_encoding_hash_cmp to accept_encoding_bitmap_cmp

2021-01-18 Thread Tim Duesterhus
For the `accept-encoding` header a bitmap and not a hash is stored. --- src/cache.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/src/cache.c b/src/cache.c index 16dc7d61c..ab0799a5d 100644 --- a/src/cache.c +++ b/src/cache.c @@ -97,7 +97,7 @@ struct

Re: [PATCH 1/3] MINOR: cache: Remove the `hash` part of the accept-encoding secondary key

2021-01-18 Thread Tim Düsterhus
Remi, Am 18.01.21 um 11:24 schrieb Remi Tricot-Le Breton: > The patches look good to me. Just one point concerning the first one, > you could have removed everything related to ACCEPT_ENCODING_MAX_ENTRIES > since the limit was induced by the array that does not exist anymore. I have

Re: [PATCH] BUG/MINOR: init: enforce strict-limits when using master-worker

2021-01-18 Thread William Lallemand
On Thu, Jan 14, 2021 at 12:13:17PM +0100, William Dauchy wrote: > On Thu, Jan 14, 2021 at 11:21 AM William Lallemand > wrote: > > VTest is not really suited to test the process management, for example > > the tests doing a reload have timing issues because VTest is not able to > > know when

Re: [PATCH] improve ssl guarding by switching to macro SSL_CLIENT_HELLO_CB instead of openssl version

2021-01-18 Thread Илья Шипицин
we can do nasty thing. SSL_CLIENT_HELLO_CB is not defined for BoringSSL, we can (in openssl-compat.h) check whether BoringSSL is used and define that macro. I'm not sure it is good thing. if you thing it is, please modify patch when applying. I'm ok with such change. пн, 18 янв. 2021 г. в

Re: [PATCH] improve ssl guarding by switching to macro SSL_CLIENT_HELLO_CB instead of openssl version

2021-01-18 Thread Илья Шипицин
пн, 18 янв. 2021 г. в 15:09, William Lallemand : > Hello, > > On Sat, Jan 16, 2021 at 11:25:05PM +0500, Илья Шипицин wrote: > > Hello, > > > > next openssl guarding patch > > > > Ilya > > > From b5ff0a9f1e0d2edc84981b39050e7f21d2b08ba8 Mon Sep 17 00:00:00 2001 > > From: Ilya Shipitsin > > Date:

Re: [PATCH 1/3] MINOR: cache: Remove the `hash` part of the accept-encoding secondary key

2021-01-18 Thread Remi Tricot-Le Breton
Hello Tim, The patches look good to me. Just one point concerning the first one, you could have removed everything related to ACCEPT_ENCODING_MAX_ENTRIES since the limit was induced by the array that does not exist anymore. The comment of the accept_encoding_normalizer function does not match

Re: [PATCH] improve ssl guarding by switching to macro SSL_CLIENT_HELLO_CB instead of openssl version

2021-01-18 Thread William Lallemand
Hello, On Sat, Jan 16, 2021 at 11:25:05PM +0500, Илья Шипицин wrote: > Hello, > > next openssl guarding patch > > Ilya > From b5ff0a9f1e0d2edc84981b39050e7f21d2b08ba8 Mon Sep 17 00:00:00 2001 > From: Ilya Shipitsin > Date: Sat, 16 Jan 2021 23:15:12 +0500 > Subject: [PATCH] BUILD: ssl: guard

Re: [PATCH] DOC: replace use of HA-Proxy with HAProxy

2021-01-18 Thread William Dauchy
On Mon, Jan 18, 2021 at 6:35 AM John Traweek CCNA, Sec+ wrote: > How do I unsubscribe? send an email to haproxy+unsubscr...@formilux.org -- William

Re: [PATCH] MINOR: build: discard echoing in help target

2021-01-18 Thread William Lallemand
On Sun, Jan 17, 2021 at 06:47:47PM +, Bertrand Jacquin wrote: > When V=1 is used in conjuction with help, the output becomes pretty > difficult to read properly. > > $ make TARGET=linux-glibc V=1 help > .. > DEBUG_USE_ABORT: use abort() for program termination, see >