Re: HTTP/2 in 2.1.x behaves different than in 2.0.x

2020-07-06 Thread Christian Ruppert
Hi Jerome, Willy, thanks! Yeah, it only affected url, not path. I've fixed all cases were we wrongly assumed that url is like path. Thanks for clarifying! On 2020-07-03 19:59, Willy Tarreau wrote: On Fri, Jul 03, 2020 at 02:25:33PM +0200, Jerome Magnin wrote: Hi Christian, On Fri, Jul 03,

Re: HTTP/2 in 2.1.x behaves different than in 2.0.x

2020-07-03 Thread Willy Tarreau
On Fri, Jul 03, 2020 at 02:25:33PM +0200, Jerome Magnin wrote: > Hi Christian, > > On Fri, Jul 03, 2020 at 11:02:48AM +0200, Christian Ruppert wrote: > > Hi List, > > > > we've just noticed and confirmed some strange change in behavior, depending > > on whether the request is made with HTTP 1.x

Re: HTTP/2 in 2.1.x behaves different than in 2.0.x

2020-07-03 Thread Jerome Magnin
Hi Christian, On Fri, Jul 03, 2020 at 11:02:48AM +0200, Christian Ruppert wrote: > Hi List, > > we've just noticed and confirmed some strange change in behavior, depending > on whether the request is made with HTTP 1.x or 2.x. > [...] > That also affects ACLs like url*/path* and probably

HTTP/2 in 2.1.x behaves different than in 2.0.x

2020-07-03 Thread Christian Ruppert
Hi List, we've just noticed and confirmed some strange change in behavior, depending on whether the request is made with HTTP 1.x or 2.x. Steps to reproduce: HAProxy 2.1.x A simple http frontend, including h2 + logging tail -f /var/log/haproxy.log|grep curl curl -s https://example.com -o