Re: Upgrading from 1.7 to 2.0 causes connection spam

2019-09-12 Thread Willy Tarreau
On Thu, Sep 12, 2019 at 11:45:00AM +0200, Elias Abacioglu wrote: > Alright, thanks Willy and Lukas! > > But I wonder why the build-up of connections is between our haproxy-no-tls > and haproxy-tls and not the "real" backends. The communication between > haproxy-no-tls and haproxy-tls is "mode

Re: Upgrading from 1.7 to 2.0 causes connection spam

2019-09-12 Thread Elias Abacioglu
Alright, thanks Willy and Lukas! But I wonder why the build-up of connections is between our haproxy-no-tls and haproxy-tls and not the "real" backends. The communication between haproxy-no-tls and haproxy-tls is "mode tcp" and "http-reuse never" and since it's mode tcp, it shouldn't really use

Re: Upgrading from 1.7 to 2.0 causes connection spam

2019-09-12 Thread Willy Tarreau
Hi guys, On Wed, Sep 11, 2019 at 09:28:23PM +0200, Lukas Tribus wrote: > Hello Elias, > > On Wed, Sep 11, 2019 at 11:52 AM Elias Abacioglu > wrote: > > So we do zero config changes, upgrade haproxy to 2.0.x + restart haproxy > > and like a minute or so then it runs out of resources. > > Each

Re: Upgrading from 1.7 to 2.0 causes connection spam

2019-09-11 Thread Lukas Tribus
Hello Elias, On Wed, Sep 11, 2019 at 11:52 AM Elias Abacioglu wrote: > So we do zero config changes, upgrade haproxy to 2.0.x + restart haproxy and > like a minute or so then it runs out of resources. > Each haproxy (v2.0.5, no-TLS) have an request rate of 55-90K/s. > Each haproxy (v1.7.11,

Upgrading from 1.7 to 2.0 causes connection spam

2019-09-11 Thread Elias Abacioglu
Hi! I have an issue which I've don't know how to go ahead with. So first I will describe my setup. We have a pair of haproxy v2.0.5 that only takes HTTP traffic and relays HTTPS traffic down to a pair of haproxys v1.7.11 doing SSL termination. Here is a more "graphical" layout: Internet