Re: [Haskell-cafe] Utility functions

2004-12-29 Thread Christian Maeder
Derek Elkins wrote: I find myself writing things like, splitListOn :: Eq a = a - [a] - [[a]] similar stuff was discussed in July 2004 on [EMAIL PROTECTED] under the headding Prelude function suggestions, ie. http://www.haskell.org//pipermail/libraries/2004-July/002366.html Cheers Christian

Re: [Haskell-cafe] Named function fields vs. type classes

2004-12-29 Thread Sebastian Sylvan
On Tue, 14 Dec 2004 15:40:13 +, Keith Wansbrough [EMAIL PROTECTED] wrote: On the other hand, it's difficult or impossible to make a list of a bunch of different types of things that have nothing in common save being members of the class. I've recently been playing with making, for

Re: [Haskell-cafe] safe code to run in finalizers: ACIO revisited

2004-12-29 Thread Robert Dockins
There is a lot of interesting discussion on this list about finalizers in Java. It is hard to say exactily how much is transferable to the haskell setting. This appears to be the direction the java folks are leaning: http://www.cs.umd.edu/~pugh/java/memoryModel/archive/2266.html Andy Georges

Re: [Haskell-cafe] Named function fields vs. type classes

2004-12-29 Thread Keean Schupke
There are two ways to do the list of class members, existentials is one way... data MyBox = forall a . MyClass a = MyBox a type MyClassList = [MyBox] f :: MyClassList - MyClassList An alternative is to use a heterogeneous list (see the HList library): http://www.cwi.nl/~ralf/HList This

Re: [Haskell-cafe] GUI

2004-12-29 Thread John Velman
On Mon, Dec 27, 2004 at 11:44:49AM +0100, Arjan van IJzendoorn wrote: However, I want to know if there has been any practical standardisation in the GUI area. Last time I looked at this it seemed some decisions had been made (bind to existing api - wxWindows?). I am waiting for some

Re: [Haskell-cafe] Re: Utility functions

2004-12-29 Thread Philippa Cowderoy
On Wed, 29 Dec 2004, John Goerzen wrote: In which case, it will fall under the default (GPL) license of the library (and may later be given to fptools to be part of the standard library). I would've thought the GPL was incompatible with being part of a standard library intended for use in

[Haskell-cafe] Haskell Pangolins

2004-12-29 Thread Dominic Fox
Hi all, This is just a request for comment - I've written a short Haskell program, intended to demonstrate some of the basic features of the language (how to create a data structure, transform it, and run a user interaction loop). I would like to know if there are any obvious respects in which

Re: [Haskell-cafe] Haskell Pangolins

2004-12-29 Thread Scott Turner
On 2004 December 29 Wednesday 19:13, Dominic Fox wrote: any obvious respects in which this program could be simplified, clarified or made more idiomatic. isYes = `elem` [y, yes, Y, YES] withArticle fullString@(x:xs) = (if x `elem` aeiou then an else a ) ++ fullString withArticle [] = -- in

Re: [Haskell-cafe] Re: Utility functions

2004-12-29 Thread John Goerzen
On Thu, Dec 30, 2004 at 12:02:58AM +, Philippa Cowderoy wrote: On Wed, 29 Dec 2004, John Goerzen wrote: In which case, it will fall under the default (GPL) license of the library (and may later be given to fptools to be part of the standard library). I would've thought the GPL was

Re: [Haskell-cafe] Re: Utility functions

2004-12-29 Thread Mark Carroll
On Wed, 29 Dec 2004, John Goerzen wrote: (snip) I accept patches for things like this for MissingH. You can send me code or diffs as you prefer. I've been accepting code licensed under GPL, LGPL, or BSD, and will need a statement such as: (snip) Can you mix in BSD code with GPL, though,

[Haskell-cafe] Haskell Pangolins

2004-12-29 Thread Derek Elkins
I've rewritten it closer to the way I would have written it. Most of the changes are minor syntactic changes that you may or may not agree with. Probably the most confusing part of the original code was the declaration of the Node datatype as a (sum of) record(s), then the subsequent ignoring

[Haskell-cafe] Re: dummy variables

2004-12-29 Thread Serge D. Mechveliani
What I meant: is this reasonable for future Haskell to make a variable _foo equivalent to `_' ? In this case, one can use _foo as a self-commenting dummy variable: let (x, _newEqs, _newVars) = f a (y, _newEqs, newVars ) = f b in

Re: [Haskell-cafe] Re: Utility functions

2004-12-29 Thread John Goerzen
On Thu, Dec 30, 2004 at 05:24:38AM +, Philippa Cowderoy wrote: This is the bit I was worried about, the idea of GPLed library code in fptools disturbs me somewhat. I don't think anyone is suggesting doing that. I'm not, anyway. I don't think the fptools maintainers would accept it if I