[Haskell-cafe] Crashing - First Graphics Program in Haskell School of Expression(HSOE)

2009-04-10 Thread Raja Koduru
Hi, I am a beginner. Help me. Here is my main.hs, sample code from the book HSOE. module Main where import SOE main = runGraphics ( do w - openWindow My First Graphics Program (300, 300) drawInWindow w (text (100,

[Haskell-cafe] compilation related questions

2009-04-10 Thread minh thu
Hi, There was a 'I want to write a compiler' thread recently. I wonder if there is such kind of pointers for compilation of strict functional languages (perhaps with lazy evaluation annotations) . Although GRIN is designed for lazy languages, would it be ok to use it for a strict one (and

[Haskell-cafe] Re: compilation related questions

2009-04-10 Thread Achim Schneider
minh thu not...@gmail.com wrote: On a related note, I have another question. Say we have some data structure, for instance a list, some functions on this data structure (probably defined with some well known functions, such as map or fold), and a program using them. Is there any research

[Haskell-cafe] Re: compilation related questions

2009-04-10 Thread Achim Schneider
minh thu not...@gmail.com wrote: But for some functions, it can be seen clearly that such information could have been constructed at the same time that the data structure. So it is related to fusion techniques, but with the additional possibility of adding fields to the original data

[Haskell-cafe] Re: Paper: Translating donotation to SQL, Leijden, Meijer

2009-04-10 Thread GüŸnther Schmidt
Hi Shan, thanks but the paper I'm looking for is actually the reference #13 from the document you're pointing me to. Günther Chung-chieh Shan schrieb: Gü?nther Schmidt gue.schm...@web.de wrote in article grcti9$c1...@ger.gmane.org in gmane.comp.lang.haskell.cafe: is the paper Translating

Re: [Haskell-cafe] Trying to write 'safeFromInteger'

2009-04-10 Thread Henning Thielemann
On Wed, 8 Apr 2009, Neil Mitchell wrote: That seems a really weird way to write it! Who decided all auxiliary functions should be called go? (I think I'm blaming dons) - why not: sffi :: (Integral a,Num a) = Integer - Maybe a sffi n | toInteger n2 == n = Just n2 | otherwise = Nothing