[ 
https://issues.apache.org/jira/browse/HDFS-6627?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14052210#comment-14052210
 ] 

Hadoop QA commented on HDFS-6627:
---------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest 
attachment 
  http://issues.apache.org/jira/secure/attachment/12654032/HDFS-6627.txt
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author 
tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include 
any new or modified tests.
                        Please justify why no new tests are needed for this 
patch.
                        Also please list what manual steps were performed to 
verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the 
total number of javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with 
eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new 
Findbugs (version 1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase 
the total number of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in 
hadoop-hdfs-project/hadoop-hdfs.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: 
https://builds.apache.org/job/PreCommit-HDFS-Build/7282//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7282//console

This message is automatically generated.

> getReplicaVisibleLength() should do checkReadAccess insteading of 
> checkWriteAccess
> ----------------------------------------------------------------------------------
>
>                 Key: HDFS-6627
>                 URL: https://issues.apache.org/jira/browse/HDFS-6627
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode
>    Affects Versions: 3.0.0
>            Reporter: Liang Xie
>            Assignee: Liang Xie
>         Attachments: HDFS-6627.txt
>
>
> Just read getReplicaVisibleLength() code and found it, 
> DataNode.checkWriteAccess is only invoked by 
> DataNode.getReplicaVisibleLength(), let's rename it to checkReadAccess to 
> avoid confusing, since the real impl here is check AccessMode.READ:
> {code}
>         blockPoolTokenSecretManager.checkAccess(id, null, block,
>             BlockTokenSecretManager.AccessMode.READ);
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to