Mark Lenser pushed to branch feature/visual-editing-psp1-CHANNELMGR-967 at 
cms-community / hippo-addon-channel-manager


Commits:
b6365071 by Mathijs den Burger at 2016-11-10T20:41:16+01:00
CHANNELMGR-922 Add 'publish' button that views the full document

- - - - -
de5c0acf by Mathijs den Burger at 2016-11-10T20:53:23+01:00
CHANNELMGR-922 Add 'switch to full editor' button

It opens the full document editor.

- - - - -
cbbbcdb7 by Mathijs den Burger at 2016-11-11T14:02:06+01:00
CHANNELMGR-922 Disable 'switch to full editor' button for now

It's not fully complete yet (e.g. it does not save pending changes
before switching to the full editor), so disable it to avoid
confusion.

- - - - -
5ca9db48 by Tobias Jeger at 2016-11-13T11:08:38+01:00
CHANNELMGR-887 Support CHOICE fields

Quite some refactoring has happened (again)
- both list- and compound-based choices are supported
- choices only support compounds at the immediate child level
- field validation is performed on actual values, not on optionals
- FieldTypeContext now also contains reference to parent ContentTypeContext
- recursion during document type scanning (exploding compounds)no longer 
affects the DocumentTypesService API
- reduced duplication of recursion logic

- - - - -
fb490a64 by Tobias Jeger at 2016-11-13T15:24:55+01:00
CHANNELMGR-887 Improve FieldTypeUtils

- relocated to more appropriate package
- refactored for better scoping and readability
- unit tests rewritten for good coverage

- - - - -
4357b095 by Tobias Jeger at 2016-11-13T15:50:18+01:00
CHANNELMGR-887 Refactor awkward init signature

- - - - -
9bda0bee by Tobias Jeger at 2016-11-13T23:11:50+01:00
CHANNELMGR-887 Fix displayName of children of CHOICE

- refactor initialization of CHOICE field type for better readability / 
maintainability.
- refactor initialization code for all FieldType classes.

- - - - -
cd20f98a by Tobias Jeger at 2016-11-14T13:43:58+01:00
CHANNELMGR-887 Remove unused code

- - - - -
e5ebd1eb by Tobias Jeger at 2016-11-14T13:44:52+01:00
CHANNELMGR-887 Remove unused code

- - - - -
b678c759 by Tobias Jeger at 2016-11-14T13:58:14+01:00
CHANNELMGR-887 Refactor DocumentTypesService so locale is no longer optional

- - - - -
f7d756d1 by Tobias Jeger at 2016-11-14T23:42:44+01:00
CHANNELMGR-887 Refactor ChoiceFieldType initialization

- extract ChoiceFieldUtils
- add unit tests for ChoiceFieldUtils
- start unit tests for ChoiceFieldType (to be completed)

- - - - -
57dcc802 by Tobias Jeger at 2016-11-15T11:25:17+01:00
CHANNELMGR-887 Add unit tests for reading a choice field

- - - - -
a5189115 by Tobias Jeger at 2016-11-15T13:02:04+01:00
CHANNELMGR-887 Improve naming of required-validation related method

- - - - -
a45e3f78 by Tobias Jeger at 2016-11-15T15:10:43+01:00
CHANNELMGR-887 Reduce duplicate code

- - - - -
094e5343 by Mathijs den Burger at 2016-11-15T15:14:24+01:00
CHANNELMGR-922 Save changes before viewing doc in Content perspective

- - - - -
bd782a9e by Tobias Jeger at 2016-11-15T15:37:27+01:00
CHANNELMGR-887 Improve choice field utils

- When a choice compound has no supported child fields, we used to *not* add it 
to the ChoiceFieldType's list of choices. Upon writng the value of a choice 
field, this would trigger the deletion of the "invalid" choice node. 
By adding the "empty" compound to the list of valid choices, we make 
sure that these nodes don't get deleted inadvertently.

- - - - -
1e7fa50b by Tobias Jeger at 2016-11-15T15:59:22+01:00
CHANNELMGR-887 Improve choice field type

- improve terminology
- store choices in a map for better accessibility

- - - - -
c24903e9 by Tobias Jeger at 2016-11-15T16:17:48+01:00
CHANNELMGR-887 Improve choice field type

- store choices in a linked hash map to preserve the choice order

- - - - -
110208a2 by Tobias Jeger at 2016-11-15T16:42:02+01:00
CHANNELMGR-887 Add missing unit tests

- - - - -
73b85539 by Tobias Jeger at 2016-11-16T08:54:49+01:00
CHANNELMGR-993 remove one-time binding constraint for document value-related 
bindings

- - - - -
57d53054 by Mathijs den Burger at 2016-11-16T09:46:36+01:00
CHANNELMGR-922 Refactoring after review

- Don't suggest promise chaining of _closePanel and publish
  (_closePanel does not return a promise anyway because we don't want
  to wait until the panel is closed before switching)
- Don't update the document / reset the form when switching since
  that's not necessary.

- - - - -
a404bd38 by Mathijs den Burger at 2016-11-16T10:21:55+01:00
CHANNELMGR-922 Clear document when right side-panel has been closed

A closed sidenav is still present in the DOM, so clearing the
document saves a lot of bindings in each digest cycle.

ChannelSidePanelService.close() now returns a promise so we can
clear the document when it's no longer visible.

- - - - -
888942a5 by Mathijs den Burger at 2016-11-16T10:22:27+01:00
CHANNELMGR-922 Reintegrate feature/visual-editing-psp1-CHANNELMGR-922

- - - - -
1a318c88 by Mark at 2016-11-16T10:27:24+01:00
CHANNELMGR-993 Merge branch 'feature/visual-editing-psp1' into 
feature/visual-editing-psp1-CHANNLEMGR-993

- - - - -
e72e5f0d by Mark at 2016-11-16T10:47:23+01:00
CHANNELMGR-967 Merge branch 'feature/visual-editing-psp1' into 
feature/visual-editing-psp1-CHANNELMGR-967

- - - - -


27 changed files:

- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/ContentResource.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/document/DocumentsService.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/document/DocumentsServiceImpl.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/document/model/Document.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/document/model/EditingInfo.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/document/model/FieldValue.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/ContentTypeContext.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/DocumentTypesService.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/DocumentTypesServiceImpl.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/FieldTypeContext.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/util/FieldTypeUtils.java
 → 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/FieldTypeUtils.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/util/FieldValidators.java
 → 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/FieldValidators.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/sort/NodeOrderFieldSorter.java
- + 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/type/ChoiceFieldType.java
- + 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/type/ChoiceFieldUtils.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/type/CompoundFieldType.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/type/FieldType.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/type/StringFieldType.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/field/validation/ValidationErrorInfo.java
- 
content-service/src/main/java/org/onehippo/cms/channelmanager/content/documenttype/util/LocalizationUtils.java
- 
content-service/src/test/java/org/onehippo/cms/channelmanager/content/ContentResourceTest.java
- 
content-service/src/test/java/org/onehippo/cms/channelmanager/content/document/DocumentsServiceImplTest.java
- 
content-service/src/test/java/org/onehippo/cms/channelmanager/content/documenttype/ContentTypeContextTest.java
- + 
content-service/src/test/java/org/onehippo/cms/channelmanager/content/documenttype/field/FieldTypeUtilsTest.java
- 
content-service/src/test/java/org/onehippo/cms/channelmanager/content/documenttype/field/sort/NodeOrderFieldSorterTest.java
- 
content-service/src/test/java/org/onehippo/cms/channelmanager/content/documenttype/field/sort/TwoColumnFieldSorterTest.java
- + 
content-service/src/test/java/org/onehippo/cms/channelmanager/content/documenttype/field/type/ChoiceFieldTypeTest.java


The diff was not included because it is too large.


View it on GitLab: 
https://code.onehippo.org/cms-community/hippo-addon-channel-manager/compare/eeed590de3b67ac788822fddf3e93b43e47d0067...e72e5f0d23444beb8a9f96e8772416824d683dd6
_______________________________________________
Hippocms-svn mailing list
Hippocms-svn@lists.onehippo.org
https://lists.onehippo.org/mailman/listinfo/hippocms-svn

Reply via email to