[hwloc-devel] 0.9.3rc2 out

2009-11-24 Thread Jeff Squyres
http://www.open-mpi.org/software/hwloc/v0.9/ Please beat it up! -- Jeff Squyres jsquy...@cisco.com

[hwloc-devel] Create success (hwloc r1.0a1r1400)

2009-11-24 Thread MPI Team
Creating nightly hwloc snapshot SVN tarball was a success. Snapshot: hwloc 1.0a1r1400 Start time: Tue Nov 24 21:01:05 EST 2009 End time: Tue Nov 24 21:03:02 EST 2009 Your friendly daemon, Cyrador

Re: [hwloc-devel] 0.9.3rc1 posted

2009-11-24 Thread Jeff Squyres
Oops! Good fix -- thanks... I'll wait a little bit to see if anything else pops up before rolling rc2. On Nov 24, 2009, at 3:18 PM, Samuel Thibault wrote: Samuel Thibault, le Tue 24 Nov 2009 21:03:39 +0100, a écrit : > Jeff Squyres, le Tue 24 Nov 2009 13:14:02 -0500, a écrit : > > A bunch

Re: [hwloc-devel] 0.9.3rc1 posted

2009-11-24 Thread Samuel Thibault
Samuel Thibault, le Tue 24 Nov 2009 21:03:39 +0100, a écrit : > Jeff Squyres, le Tue 24 Nov 2009 13:14:02 -0500, a écrit : > > A bunch of fixes have been applied to the 0.9 branch; v0.9.3rc1 has > > been posted: > > > > http://www.open-mpi.org/software/hwloc/v0.9/ > > > > Please test it as

Re: [hwloc-devel] 0.9.3rc1 posted

2009-11-24 Thread Samuel Thibault
Hello, Jeff Squyres, le Tue 24 Nov 2009 13:14:02 -0500, a écrit : > A bunch of fixes have been applied to the 0.9 branch; v0.9.3rc1 has > been posted: > > http://www.open-mpi.org/software/hwloc/v0.9/ > > Please test it as much as you can so that we can get it out the door. On machines

[hwloc-devel] 0.9.3rc1 posted

2009-11-24 Thread Jeff Squyres
A bunch of fixes have been applied to the 0.9 branch; v0.9.3rc1 has been posted: http://www.open-mpi.org/software/hwloc/v0.9/ Please test it as much as you can so that we can get it out the door. Thanks! -- Jeff Squyres jsquy...@cisco.com

Re: [hwloc-devel] hwloc on ARM [Was: hwloc at SC09]

2009-11-24 Thread Samuel Thibault
Ashley Pittman, le Tue 24 Nov 2009 17:25:18 +, a écrit : > Do you mean the attached file? Yes. It seems to work with the v0.9 branch so it's all good. > gather-topology.sh failed Yes, after building the .tar.gz it dumps what lstopo would see, thus the same failure. Thanks, Samuel

Re: [hwloc-devel] hwloc on ARM [Was: hwloc at SC09]

2009-11-24 Thread Samuel Thibault
Ashley Pittman, le Tue 24 Nov 2009 17:25:18 +, a écrit : > Just to be absolutely clear, head SVN works but the error is running > from a version from two weeks ago. Ah, ok. Samuel

Re: [hwloc-devel] hwloc on ARM [Was: hwloc at SC09]

2009-11-24 Thread Ashley Pittman
Just to be absolutely clear, head SVN works but the error is running from a version from two weeks ago. On Tue, 2009-11-24 at 17:27 +0100, Samuel Thibault wrote: > Ashley Pittman, le Tue 24 Nov 2009 16:18:36 +, a écrit : > > * Topology extraction from /proc/cpuinfo * > > > > 0 online

Re: [hwloc-devel] hwloc on ARM [Was: hwloc at SC09]

2009-11-24 Thread Samuel Thibault
Ashley Pittman, le Tue 24 Nov 2009 16:18:36 +, a écrit : > * Topology extraction from /proc/cpuinfo * > > 0 online processors found, with id max 0 That was it. > Removing empty objects except numa nodes and PCI devices > Segmentation fault Not so fine, then :) Could you post a backtrace

Re: [hwloc-devel] hwloc on ARM [Was: hwloc at SC09]

2009-11-24 Thread Ashley Pittman
I did a svn update this morning and the code works fine now. $ lstopo System(29MB) + P#0 $ On Sat, 2009-11-14 at 01:56 +0100, Samuel Thibault wrote: > So at some point the traversal ends up with a NULL pointer, weird. What > would be useful is output after passing --enable-debug to

Re: [hwloc-devel] Crash with ignoring HWLOC_OBJ_NODE in 0.9.2

2009-11-24 Thread Samuel Thibault
Chris Samuel, le Sat 21 Nov 2009 16:55:12 +1100, a écrit : > - "Michael Raymond" wrote: > > > Our architecture has blades with two Nehalems on > > them, and the blades are connected together in a > > CC-NUMA fashion. > > I've heard on the grapevine that there will be

Re: [hwloc-devel] Crash with ignoring HWLOC_OBJ_NODE in 0.9.2

2009-11-24 Thread Samuel Thibault
Hello, Michael Raymond, le Fri 20 Nov 2009 12:36:13 -0600, a écrit : > I wouldn't say no to the ability to flatten Misc / NUMA. As to the > current issue though, does my patch look acceptable? Thanks. The problem is that it doesn't solve Solaris :) subversion r1372 should however fix the

Re: [hwloc-devel] hwloc in Debian, anybody working on RPMs?

2009-11-24 Thread Jeff Squyres
On Nov 23, 2009, at 9:28 PM, Tony Breeds wrote: > Note that hwloc's .so version number is controlled by the top-level > VERSION file. There's a few comments in that file explaining the > deal. It's meant to be changed manually as part of the release > process. It will always be 0.0.0 on the

[hwloc-devel] PCI discovery for MacOSX

2009-11-24 Thread Brice Goglin
Hello, The current libpci branch uses the pciutils library (/usr/lib/libpci*.so*) to discover the hierarchy of PCI bridges/devices. pciutils works on many platforms, including windows (even if I never actually tried it). Unfortunately, there is no official support for MacOSX. I tried libpciaccess