Hello,

A couple other things that I am not sure about in the API:

* In struct hwloc_topology_info, we talked about renaming "is_fake" into
something else since it means "this topology does not come from the
local machine" but it's not necessarily "fake". Any idea?

* Do we actually need hwloc_get_type_order() or would
hwloc_compare_types() be enough? I can't find any example where some
type "orders" is not used for direct comparison.

* I find it a bit disturbing that get_obj_by_depth() and
get_nbobjs_by_depth() are in hwloc.h while the corresponding _by_type()
functions are in hwloc/helpers.h. The latter are indeed inline helpers
but I think it would be more clear to keep them together? Not sure about
get_system_obj(), this one may still belong to the helpers.

* I think the _above_cpuset() and _below_cpuset() function names are not
very clear. I think "inside" may be better that "below" (and rename
get_cpuset_objs into get_objs_inside_cpuset as well and move it nearby).
And maybe use "covering" instead of "above" since we already have
"covering" somewhere else?

Also, we have __hwloc_restrict everywhere in the public API, but also in
the manpages? Should we convert the latter into a regular "restrict"
keyword ?

That's all for today :) Better fix this now instead of changing the ABI
after the first hwloc release.

Brice

Reply via email to