Re: [hwloc-users] Why do I get such little information back about GPU's on my system

2017-07-07 Thread fabricio
Em 07-07-2017 18:44, Brice Goglin escreveu: Does "ldd /path/to/libhwloc.so" say that it depends on libcuda? Check the end of the configure output, you should see "CUDA" on the "probe/display I/O devices" line: - Hwloc

Re: [hwloc-users] Why do I get such little information back about GPU's on my system

2017-07-07 Thread Brice Goglin
Does "ldd /path/to/libhwloc.so" say that it depends on libcuda? Check the end of the configure output, you should see "CUDA" on the "probe/display I/O devices" line: - Hwloc optional build support status (more details

Re: [hwloc-users] Why do I get such little information back about GPU's on my system

2017-07-07 Thread David Solt
Ok here we have a machine with cuda installed: # rpm -qa | grep cuda cuda-nvgraph-8-0-8.0.54-1.ppc64le cuda-curand-dev-8-0-8.0.54-1.ppc64le cuda-nvrtc-dev-8-0-8.0.54-1.ppc64le cuda-cudart-8-0-8.0.54-1.ppc64le cuda-cusolver-dev-8-0-8.0.54-1.ppc64le cuda-8.0.54-1.ppc64le

Re: [hwloc-users] Why do I get such little information back about GPU's on my system

2017-07-07 Thread David Solt
Oh, Geoff Paulsen will be there at Open MPI meeting and he can help with the discussion. We tried searching for // Iterate over each osdevice and identify the GPU's on each socket. while ((obj = hwloc_get_next_osdev(machine_topology, obj)) != NULL) { if (HWLOC_OBJ_OSDEV_COPROC ==

Re: [hwloc-users] Why do I get such little information back about GPU's on my system

2017-07-07 Thread David Solt
Thank you so much! We are going to try this out and I'll let you know what we find. Yes, I think we got distracted by GPU when CUDA is what we want. I'll give you a status of how it went soon Dave From: Brice Goglin To: hwloc-users@lists.open-mpi.org

Re: [hwloc-users] Why do I get such little information back about GPU's on my system

2017-07-07 Thread Brice Goglin
Le 07/07/2017 20:38, David Solt a écrit : > We are using the hwloc api to identify GPUs on our cluster. While we > are able to "discover" the GPUs, other information about them does not > appear to be getting filled in. See below for example:
 > (gdb) p *obj->attr > $20 = { > cache = { >

[hwloc-users] Why do I get such little information back about GPU's on my system

2017-07-07 Thread David Solt
We are using the hwloc api to identify GPUs on our cluster. While we are able to "discover" the GPUs, other information about them does not appear to be getting filled in. See below for example:
 (gdb) p *obj->attr $20 = { cache = { size = 1, depth = 0, linesize = 0,