Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-02-03 Thread James Elliott
Wow! You are awesome! This works great! Thanks a bunch. James On 2/3/17, Brice Goglin wrote: > Le 03/02/2017 23:01, James Elliott a écrit : >> On 2/3/17, Brice Goglin wrote: >>> What do you mean with shaded? Red or green? Red means unavailable.

Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-02-03 Thread Brice Goglin
Le 03/02/2017 23:01, James Elliott a écrit : > On 2/3/17, Brice Goglin wrote: >> What do you mean with shaded? Red or green? Red means unavailable. >> Requires --whole-system everywhere. Green means that's where the >> process is bound. But XML doesn't store the information

Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-02-03 Thread James Elliott
On 2/3/17, Brice Goglin wrote: > Le 03/02/2017 21:57, James Elliott a écrit : >> Brice, >> >> Thanks for you comments. I have worked with this some, but this is >> not working. >> >> My goal is to generate images of the cpusets inuse when I run a >> parallel code using

Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-02-03 Thread Brice Goglin
Le 03/02/2017 21:57, James Elliott a écrit : > Brice, > > Thanks for you comments. I have worked with this some, but this is > not working. > > My goal is to generate images of the cpusets inuse when I run a > parallel code using mpirun, aprun, srun, etc... The compute nodes > lack the mojo

Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-02-03 Thread James Elliott
Brice, Thanks for you comments. I have worked with this some, but this is not working. My goal is to generate images of the cpusets inuse when I run a parallel code using mpirun, aprun, srun, etc... The compute nodes lack the mojo necessary to generate graphical formats, so I can only extract

Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-01-31 Thread James Elliott
Thanks for the info! On 1/31/2017 11:01 PM, Brice Goglin wrote: shade/highlight is included in the "cpuset" and "allowed_cpuset" fields inside the XML (even when not using --pid). By default, only what's "available" is displayed. If you want "disallowed" things to appear (in different colors),

Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-01-31 Thread Brice Goglin
shade/highlight is included in the "cpuset" and "allowed_cpuset" fields inside the XML (even when not using --pid). By default, only what's "available" is displayed. If you want "disallowed" things to appear (in different colors), add --whole-system when drawing (in the second command-line).

Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-01-31 Thread James
Thanks Brice, I believe I am rebuilding it as you say, but I can retry tomorrow at my desk. I looked in the XML and can see the taskset data, but since I cannot do --pid ###, it seems to not shade/highlight the tasksets. I'll drop the args that are redundant and try the exact form you list.

Re: [hwloc-users] CPUSET shading using xml output of lstopo

2017-01-31 Thread Brice Goglin
Le 01/02/2017 00:19, James Elliott a écrit : > Hi, > > I seem to be stuck. What I would like to do, is us lstopo to generate > files that I can plot on another system (the nodes lack the necessary > libraries for graphical output). > > That is, I would like to see something like > lstopo --only

[hwloc-users] CPUSET shading using xml output of lstopo

2017-01-31 Thread James Elliott
Hi, I seem to be stuck. What I would like to do, is us lstopo to generate files that I can plot on another system (the nodes lack the necessary libraries for graphical output). That is, I would like to see something like lstopo --only core --pid ${pid} --taskset --no-io --no-bridges