Re: [hwloc-users] error from the operating system - Solaris 11.3 - SOLVED

2016-01-07 Thread Brice Goglin
Thanks, I copied useful information from this thread and some links to https://github.com/open-mpi/hwloc/issues/143 However, not sure I'll have time to look at this in the near future :/ Brice Le 07/01/2016 09:03, Matthias Reich a écrit : > Hello, > > To check whether kstat is able to

Re: [hwloc-users] error from the operating system - Solaris 11.3 - SOLVED

2016-01-07 Thread Matthias Reich
Hello, To check whether kstat is able to report the psrset definitions, I defined a set consisting of 2 CPUs (psrset -c 1-2) CPU1 and CPU2. The remaining CPUs (CPU0, CPU2..CPU23) were left undefined. On the machine, we can execute the "kstat" command and receive (among 1000s of lines) the

Re: [hwloc-users] error from the operating system - Solaris 11.3 - SOLVED

2016-01-05 Thread Brice Goglin
Hello So processor sets are not taken into account when Solaris reports topology information in kstat etc. Do you know if hwloc can query processor sets from the C interface? If so, we could apply the processor set mask to hwloc object cpusets during discovery to avoid your error. Brice Le

Re: [hwloc-users] error from the operating system - Solaris 11.3 - SOLVED

2016-01-05 Thread Karl Behler
There was a processor set defined (command psrset) on this machine. Having removed the psrset hwloc-info produces a result without error messages: hwloc-info -v depth 0:1 Machine (type #1) depth 1: 2 NUMANode (type #2) depth 2: 2 Package (type #3) depth 3: 12 Core