Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-05 Thread Sebastian Kuzminsky
On Fri, Oct 5, 2012 at 5:01 PM, Samuel Thibault wrote: > Sebastian Kuzminsky, le Sat 06 Oct 2012 00:55:57 +0200, a écrit : > > binding to CPU0 > > could not bind to CPU0: Resource deadlock avoided > > Mmm, from what I read in the freebsd kernel: > > /* > * Create a set

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-05 Thread Samuel Thibault
Sebastian Kuzminsky, le Sat 06 Oct 2012 00:55:57 +0200, a écrit : > binding to CPU0 > could not bind to CPU0: Resource deadlock avoided Mmm, from what I read in the freebsd kernel: /* * Create a set in the space provided in 'set' with the provided parameters. * The set is returned with a

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-05 Thread Sebastian Kuzminsky
On Thu, Oct 4, 2012 at 6:39 PM, Samuel Thibault wrote: > Sebastian Kuzminsky, le Wed 03 Oct 2012 17:24:55 +0200, a écrit : > > So that's an improvement over the svn trunk > > yesterday, but it's not all the way fixed yet! > > Ok. Apparemently hwloc can't bind itself to

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-04 Thread Samuel Thibault
Sebastian Kuzminsky, le Wed 03 Oct 2012 17:24:55 +0200, a écrit : > So that's an improvement over the svn trunk > yesterday, but it's not all the way fixed yet! Ok. Apparemently hwloc can't bind itself to procs 0-9 for some reason. I have added debug to the trunk, could you try it again (no need

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-03 Thread Brice Goglin
Le 03/10/2012 17:23, Sebastian Kuzminsky a écrit : > On Tue, Oct 2, 2012 at 5:14 PM, Samuel Thibault > > wrote: > > There were two bugs which resulted into cpuid not being properly > compiled. I have fixed them in the trunk, could

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-03 Thread Sebastian Kuzminsky
On Tue, Oct 2, 2012 at 5:14 PM, Samuel Thibault wrote: > There were two bugs which resulted into cpuid not being properly > compiled. I have fixed them in the trunk, could you try again? > I updated my checkout to r4882, reconfigured, rebuilt, and reran it, and it made

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-02 Thread Sebastian Kuzminsky
Wow, that was fast! I'm heading out for the day, but i'll try it first thing in the morning. Thanks :-) On Oct 2, 2012 5:14 PM, "Samuel Thibault" wrote: > Hello, > > Sebastian Kuzminsky, le Wed 03 Oct 2012 01:08:46 +0200, a écrit : > > Here you go (the list server

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-02 Thread Samuel Thibault
Hello, Sebastian Kuzminsky, le Wed 03 Oct 2012 01:08:46 +0200, a écrit : > Here you go (the list server rejected it because it was too big, but this > compressed version should make it through). Thanks! There were two bugs which resulted into cpuid not being properly compiled. I have fixed them

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-02 Thread Samuel Thibault
Sebastian Kuzminsky, le Wed 03 Oct 2012 00:35:48 +0200, a écrit : > [root@host-183 /home/nfshome/seb/tmp/hwloc-svn]# ./bin/lstopo > > > * CPU cpusets * > > cpu 0 (os 0) has cpuset 0x0001 ... > cpu 31 (os 31) has cpuset 0x8000 > Machine#0(local=0KB total=33493800KB Backend=x86

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-02 Thread Sebastian Kuzminsky
On Tue, Oct 2, 2012 at 4:22 PM, Samuel Thibault wrote: > Hello, > > Sebastian Kuzminsky, le Tue 02 Oct 2012 23:47:05 +0200, a écrit : > > I've attached the output from both platforms. > > On freebsd, could you pass --enable-debug to ./configure and rerun > lstopo, to get

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-02 Thread Sebastian Kuzminsky
On Tue, Oct 2, 2012 at 3:53 PM, Brice Goglin wrote: > Le 02/10/2012 23:45, Sebastian Kuzminsky a écrit : > > Any ideas what I'm doing wrong? > > You're probably not doing anything wrong. The Linux output is indeed OK. > The FreeBSD output is generated by reading cpuid

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-02 Thread Samuel Thibault
Hello, Sebastian Kuzminsky, le Tue 02 Oct 2012 23:47:05 +0200, a écrit : > I've attached the output from both platforms. On freebsd, could you pass --enable-debug to ./configure and rerun lstopo, to get more debugging information? Samuel

Re: [hwloc-users] hwloc 1.5, freebsd and linux output on the same hardware

2012-10-02 Thread Brice Goglin
Le 02/10/2012 23:45, Sebastian Kuzminsky a écrit : > Hi folks, I just discovered hwloc and it's really cool. Very useful, > so thanks! > > I'm trying to understand the hardware layout of a computer I'm working > with, an HP Proliant DL360p G8 server with two Intel E5-2690 processors. > > I'm