Re: USS "pwd" returns nothing? Maybe file system created wrong?

2020-06-30 Thread Mike Schwab
Are you using CKD or CCKD64 volumes?  CCKD has a 4GB limit and CKD has
to have a multi file setup.

On Tue, Jun 30, 2020 at 9:29 AM Michael Knigge  wrote:
>
> All,
>
> have you ever came accross something like that?
>
> I can change into an directory, „ls“ works but „pwd“ returns…. Nothing?!?   
> When I’m in this particular directory a „cd ..“ returns „EDC5122I 
> Input/output error.“
>
>
> I’m pretty new to this „USS administration“ (I’m administering a z/OS running 
> with an z/PDT)… So let me tell what I’ve done – I might have done something 
> really wrong….
>
>
> I need some space in USS so I’ve created some new fresh volumes (3390-9) for 
> my zPDT and formatted them.
>
> INIT UNITADDRESS(0AE0) NOVERIFY VOLID(USS010) -
>STORAGEGROUP -
>VTOC(3,0,50) -
>INDEX(1,0,30)
>
> Now I have some volumes each with 10010 free CYLs.
>
> Then I’ve created a Data Set for the ZFS file system:
>
> DEFINE CLUSTER -
>(NAME (USSSET.DAT.ZFS) -
>VOLUMES (USS002 USS003 USS004 USS005  -
> USS006 USS007 USS008 USS009) -
>LINEAR CYL(1 1) SHAREOPTIONS(3))
>
> The idea was that when the file system needs to be enlarged this is done 
> automatically (let z/OS allocate an additional extend of 1 CYLs from one 
> of the dedicated volumes). I know that every extend neary uses the full 
> volume – this is okay for me in this case…
>
> Okay, then I’ve created the file system:
>
> FORMAT EXEC PGM=IOEAGFMT,REGION=0M,
>  PARM=(' -aggregate USSSET.DAT.ZFS -compat -perms 775 ')
>
>
> Mounted… everything all right…. I saw that just one of the volumes was 
> „used“. So I filled the mounted file system and saw that after some time the 
> log messages
>
> IOEZ00312I Dynamic growth of aggregate USSSET.DAT.ZFS in progress, (by user 
> ADCDZ).
> IOEZ00309I Aggregate USSSET.DAT.ZFS successfully dynamically grown (by user 
> ADCDZ).
>
>
> So for me I guess everything worked as expected… But now…. This „pwd anomaly“ 
> ….. Did I something wrong? Any idea how to get thigs working as expected?
>
>
> Thank you,
> Michael
>
>
> Michael Knigge
> Software Engineer
>
> SET GmbH
> Rühmkorffstraße 5
> 30163 Hannover
>
> Telefon: +49 511 330 998 23
> Fax: +49 511 330 998 65
> michael.kni...@set.de
> https://www.set.de
>
> Handelsregister: Amtsgericht Hannover HRB 52778
> Geschäftsführer: Dr.-Ing. Tobias Baum, Arthur Brack, Hendrik Leder
>
>
> Mit freundlichen Grüßen
>
> Michael Knigge
>
>
>
> SET GmbH
> Rühmkorffstraße 5
> 30163 Hannover
>
> Telefon: +49 511 330 998 23
> Fax: +49 511 330 998 65
> michael.kni...@set.de
> www.set.de
>
> Handelsregister: Amtsgericht Hannover HRB 52778
> Geschäftsführer: Tobias Baum, Arthur Brack, Hendrik Leder
>
> --
> For IBM-MAIN subscribe / signoff / archive access instructions,
> send email to lists...@listserv.ua.edu with the message: INFO IBM-MAIN



-- 
Mike A Schwab, Springfield IL USA
Where do Forest Rangers go to get away from it all?

--
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to lists...@listserv.ua.edu with the message: INFO IBM-MAIN


Re: USS "pwd" returns nothing? Maybe file system created wrong?

2020-06-30 Thread Michael Babcock
You are creating a 10,000 cylinder data set.  Is it defined as extended
format?I also seem to recall that you had to define something in z/VM
for a volume when running z/PDT.

On Tue, Jun 30, 2020 at 4:29 AM Michael Knigge 
wrote:

> All,
>
> have you ever came accross something like that?
>
> I can change into an directory, „ls“ works but „pwd“ returns…. Nothing?!?
>  When I’m in this particular directory a „cd ..“ returns „EDC5122I
> Input/output error.“
>
>
> I’m pretty new to this „USS administration“ (I’m administering a z/OS
> running with an z/PDT)… So let me tell what I’ve done – I might have done
> something really wrong….
>
>
> I need some space in USS so I’ve created some new fresh volumes (3390-9)
> for my zPDT and formatted them.
>
> INIT UNITADDRESS(0AE0) NOVERIFY VOLID(USS010) -
>STORAGEGROUP -
>VTOC(3,0,50) -
>INDEX(1,0,30)
>
> Now I have some volumes each with 10010 free CYLs.
>
> Then I’ve created a Data Set for the ZFS file system:
>
> DEFINE CLUSTER -
>(NAME (USSSET.DAT.ZFS) -
>VOLUMES (USS002 USS003 USS004 USS005  -
> USS006 USS007 USS008 USS009) -
>LINEAR CYL(1 1) SHAREOPTIONS(3))
>
> The idea was that when the file system needs to be enlarged this is done
> automatically (let z/OS allocate an additional extend of 1 CYLs from
> one of the dedicated volumes). I know that every extend neary uses the full
> volume – this is okay for me in this case…
>
> Okay, then I’ve created the file system:
>
> FORMAT EXEC PGM=IOEAGFMT,REGION=0M,
>  PARM=(' -aggregate USSSET.DAT.ZFS -compat -perms 775 ')
>
>
> Mounted… everything all right…. I saw that just one of the volumes was
> „used“. So I filled the mounted file system and saw that after some time
> the log messages
>
> IOEZ00312I Dynamic growth of aggregate USSSET.DAT.ZFS in progress, (by
> user ADCDZ).
> IOEZ00309I Aggregate USSSET.DAT.ZFS successfully dynamically grown (by
> user ADCDZ).
>
>
> So for me I guess everything worked as expected… But now…. This „pwd
> anomaly“ ….. Did I something wrong? Any idea how to get thigs working as
> expected?
>
>
> Thank you,
> Michael
>
>
> Michael Knigge
> Software Engineer
>
> SET GmbH
> Rühmkorffstraße 5
> 30163 Hannover
>
> Telefon: +49 511 330 998 23
> Fax: +49 511 330 998 65
> michael.kni...@set.de
> https://www.set.de
>
> Handelsregister: Amtsgericht Hannover HRB 52778
> ​Geschäftsführer: Dr.-Ing. Tobias Baum, Arthur Brack, Hendrik Leder
>
>
> Mit freundlichen Grüßen
>
> Michael Knigge
>
>
>
> SET GmbH
> Rühmkorffstraße 5
> 30163 Hannover
>
> Telefon: +49 511 330 998 23
> Fax: +49 511 330 998 65
> michael.kni...@set.de
> www.set.de
>
> Handelsregister: Amtsgericht Hannover HRB 52778
> ​Geschäftsführer: Tobias Baum, Arthur Brack, Hendrik Leder
>
> --
> For IBM-MAIN subscribe / signoff / archive access instructions,
> send email to lists...@listserv.ua.edu with the message: INFO IBM-MAIN
>
-- 
Michael Babcock
OneMain Financial
z/OS Systems Programmer, Lead

--
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to lists...@listserv.ua.edu with the message: INFO IBM-MAIN


Re: USS "pwd" returns nothing? Maybe file system created wrong?

2020-06-30 Thread Seymour J Metz
It's impossible to tell from the information you've given. Pleas cut and paste 
the entire transaction, from the prompt through the response. There is an error 
code in the message that you need to look up.


--
Shmuel (Seymour J.) Metz
http://mason.gmu.edu/~smetz3


From: IBM Mainframe Discussion List [IBM-MAIN@LISTSERV.UA.EDU] on behalf of 
Michael Knigge [michael.kni...@set.de]
Sent: Tuesday, June 30, 2020 5:29 AM
To: IBM-MAIN@LISTSERV.UA.EDU
Subject: USS "pwd" returns nothing? Maybe file system created wrong?

All,

have you ever came accross something like that?

I can change into an directory, „ls“ works but „pwd“ returns…. Nothing?!?   
When I’m in this particular directory a „cd ..“ returns „EDC5122I Input/output 
error.“


I’m pretty new to this „USS administration“ (I’m administering a z/OS running 
with an z/PDT)… So let me tell what I’ve done – I might have done something 
really wrong….


I need some space in USS so I’ve created some new fresh volumes (3390-9) for my 
zPDT and formatted them.

INIT UNITADDRESS(0AE0) NOVERIFY VOLID(USS010) -
   STORAGEGROUP -
   VTOC(3,0,50) -
   INDEX(1,0,30)

Now I have some volumes each with 10010 free CYLs.

Then I’ve created a Data Set for the ZFS file system:

DEFINE CLUSTER -
   (NAME (USSSET.DAT.ZFS) -
   VOLUMES (USS002 USS003 USS004 USS005  -
USS006 USS007 USS008 USS009) -
   LINEAR CYL(1 1) SHAREOPTIONS(3))

The idea was that when the file system needs to be enlarged this is done 
automatically (let z/OS allocate an additional extend of 1 CYLs from one of 
the dedicated volumes). I know that every extend neary uses the full volume – 
this is okay for me in this case…

Okay, then I’ve created the file system:

FORMAT EXEC PGM=IOEAGFMT,REGION=0M,
 PARM=(' -aggregate USSSET.DAT.ZFS -compat -perms 775 ')


Mounted… everything all right…. I saw that just one of the volumes was „used“. 
So I filled the mounted file system and saw that after some time the log 
messages

IOEZ00312I Dynamic growth of aggregate USSSET.DAT.ZFS in progress, (by user 
ADCDZ).
IOEZ00309I Aggregate USSSET.DAT.ZFS successfully dynamically grown (by user 
ADCDZ).


So for me I guess everything worked as expected… But now…. This „pwd anomaly“ 
….. Did I something wrong? Any idea how to get thigs working as expected?


Thank you,
Michael


Michael Knigge
Software Engineer

SET GmbH
Rühmkorffstraße 5
30163 Hannover

Telefon: +49 511 330 998 23
Fax: +49 511 330 998 65
michael.kni...@set.de
https://secure-web.cisco.com/13l82o2SavKRwtlBGDLf4j3_D3ybgjRIGkZI4S3TTg9XYp8k7Zj2-YnoaNzeP5EYMsWOiVRkU1y5MOkFfWn5VD80yxpI6G2kc4XCISP6OGF2qryTgwuBGZJteIDWU0P7_Uwl9wmgITVoBcn9ZRNmChbWRPr2wwvE1FGu_9LruFjcVVOleoRlx_3i9QkgswCNfy6rZFnXkand-Tw-rU_eg-HGiPIJIJqqVS3yW_4qCLpLoP8Io3GjELpnIdHpwPPgsa6dGZ2G-_S8TE9PkuaRfsGL5Altd8MD0_aREpOdxUKN3r6Ex6j0UiCjFKo2-dB-qO3Qdlj_J9aAuSRSJer1Wy9u_m_ATGsVGvDFVgc0qrzvlxqeEyK_1_xL1magbnmc-g0zip8ITgNFV-YaGmFYcjkebPwCTy5ne7O-Oayfwcdvq5CKw_qlGhWdsKTK2qTxG/https%3A%2F%2Fwww.set.de

Handelsregister: Amtsgericht Hannover HRB 52778
​Geschäftsführer: Dr.-Ing. Tobias Baum, Arthur Brack, Hendrik Leder


Mit freundlichen Grüßen

Michael Knigge



SET GmbH
Rühmkorffstraße 5
30163 Hannover

Telefon: +49 511 330 998 23
Fax: +49 511 330 998 65
michael.kni...@set.de
http://secure-web.cisco.com/1z4WdOg2RFe1HNaPuPdLWTK7ja7FwVJpseaLT1hfWWGcUMYlyjmJHu7pP2Ar4cGdR1EGjuRpvxBa3o3SFg13EH-vtmr_syhrmWrZ7RfYpS8Z0aZkm9AlK3psl_oyhvBpZ0vgPk3nbaM0qBovqwEvHp_SmeTe06Z8MIWkIjX-RTw-HToRpqYbV8AmNXlqcbcKeu0sAtyJhnOoPyteigJPKhyDYTJKcpDHKcgPqelsSUH6xYVx2RVHL3UVg-y7k3bgW0ZHa1t8t6iCsxdQu7fMMTh_5juatUKPdGGNQsCLAS7Duifz367pDocCeYbqkT8TNS7v0beki-BHV3_0FshBn1I2nlNLiXeE6iPnhCQjkudCM7klWsPexFp_UYMmZDw-e3MolvJ8uVuCt8nTEB7TXP02tUoCCjK-twn8et7QZpOx4_G4-WVf2mt5EsWkrIZtr/http%3A%2F%2Fwww.set.de

Handelsregister: Amtsgericht Hannover HRB 52778
​Geschäftsführer: Tobias Baum, Arthur Brack, Hendrik Leder

--
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to lists...@listserv.ua.edu with the message: INFO IBM-MAIN

--
For IBM-MAIN subscribe / signoff / archive access instructions,
send email to lists...@listserv.ua.edu with the message: INFO IBM-MAIN