Re: [PHP-DEV] [RFC] prototyping

2009-01-21 Thread David Zülke
Am 20.01.2009 um 18:41 schrieb Christian Seiler: Hi, maybe an IRC meeting is the easiest way to come to an agreement. How about tomorrow evening 21:00 CEST in #php.closures on freenode? Just for clarification: I assume you mean Wednesday, January 21st, 19:00 UTC (CEST == UTC+2) and thus

Re: [PHP-DEV] [RFC] prototyping

2009-01-21 Thread Lukas Kahwe Smith
On 21.01.2009, at 10:04, David Zülke wrote: Am 20.01.2009 um 18:41 schrieb Christian Seiler: Hi, maybe an IRC meeting is the easiest way to come to an agreement. How about tomorrow evening 21:00 CEST in #php.closures on freenode? Just for clarification: I assume you mean Wednesday,

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Kenan R Sulayman
Thanks, I did propose the function because the construction in user-land is quite expensive; Actually tests showed: the user-land algorithm of mapping these objects (regarding a count of thousand; up to a half million objects / iterations) took 0,2 - 70 seconds to execute! Therefore: I would be

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Karsten Dambekalns
Hi. On 21.01.2009 11:44 Uhr, Kenan R Sulayman wrote: I did propose the function because the construction in user-land is quite expensive; Reflection is expensive, indeed. The way we solved it for FLOW3 is to create a ReflectionService that caches such information as long as the source

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Lukas Kahwe Smith
On 21.01.2009, at 12:00, Karsten Dambekalns wrote: Hi. On 21.01.2009 11:44 Uhr, Kenan R Sulayman wrote: I did propose the function because the construction in user-land is quite expensive; Reflection is expensive, indeed. The way we solved it for FLOW3 is to create a ReflectionService

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Christian Schneider
Lukas Kahwe Smith wrote: On 21.01.2009, at 12:00, Karsten Dambekalns wrote: On 21.01.2009 11:44 Uhr, Kenan R Sulayman wrote: I did propose the function because the construction in user-land is quite expensive; Reflection is expensive, indeed. The way we solved it for FLOW3 is to create a

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Sebastian Bergmann
Christian Schneider schrieb: Yes, please. Keep clutter out of the engine especially for stuff which should not be used often. If you are relying on Reflection to be fast for you everyday code then you're IMHO doing something weird and it is ok that you have to write your own caching for it

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Nathan Rixham
Christian Schneider wrote: Lukas Kahwe Smith wrote: On 21.01.2009, at 12:00, Karsten Dambekalns wrote: On 21.01.2009 11:44 Uhr, Kenan R Sulayman wrote: I did propose the function because the construction in user-land is quite expensive; Reflection is expensive, indeed. The way we solved it

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Kenan R Sulayman
First: I'd understand, I've to build the caching system on my own; Second: I'd vote for speeding up Reflection. Thanks, -- (c) Kenan Sulayman Freelance Designer and Programmer Life's Live Poetry 2009/1/21 Nathan Rixham nrix...@gmail.com Christian Schneider wrote: Lukas Kahwe Smith wrote:

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Christian Schneider
Nathan Rixham wrote: seems to me that many of the new requests coming in, including my own stupid ones are because people want to build fast decent orm's in php - Having built an ORM system myself I can say that you don't need Reflection (or even other fancy features not yet in PHP) for this.

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Nathan Rixham
Christian Schneider wrote: Nathan Rixham wrote: seems to me that many of the new requests coming in, including my own stupid ones are because people want to build fast decent orm's in php - Having built an ORM system myself I can say that you don't need Reflection (or even other fancy

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Roman Borschel
On Jan 21, 2009, at 4:20 PM, Christian Schneider wrote: Nathan Rixham wrote: seems to me that many of the new requests coming in, including my own stupid ones are because people want to build fast decent orm's in php - Having built an ORM system myself I can say that you don't need

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Nate Gordon
My personal favorite use of Reflection is Class Factories. While this could be done with: ?php $className = 'Util'; $obj = new $className(); ? It seems a little blunt to me, it also doesn't support having a variable number of arguments to the constructor. I've seen some pretty egregious

Re: [PHP-DEV] New function proposal: spl_class_vars / params / contents

2009-01-21 Thread Sebastian Bergmann
Roman Borschel schrieb: Would you mind sharing (off-list) how you get data in and out of the objects **transparently** Have a look at lp:php-object-freezer. -- Sebastian Bergmann http://sebastian-bergmann.de/ GnuPG Key: 0xB85B5D69 / 27A7 2B14 09E4 98CD 6277 0E5B 6867

[PHP-DEV] Enhanced __CLASS__ constant

2009-01-21 Thread David Grudl
Especially in namespaced code it should be very useful to have something returning fully qualified name as string. It can be operator, but I think introducing new keyword is bad way, or it can be realized using well known magic constant in new context: Example: function factory($class) {

[PHP-DEV] CVE-2008-5658 unfixed or new problem with Zip::extractTo in 5.2.x?

2009-01-21 Thread sean finney
hi everyone, i'm looking for a sanity check here, as i've already lost more time than i'd like chasing ghosts on my treasure hunt through {bugs,lists,cvs}.php.net :( afaict, CVE-2008-5658[1] is only half-fixed on 5.2.8, while it was supposed to be fixed in 5.2.7. while the zip library no

[PHP-DEV] GSoC 2009

2009-01-21 Thread Scott MacVicar
Hi Everybody, It's almost that time again where we rush at the last minute to organise something for the Google Summer of Code, so in the interest of being prepared I'm thinking it's time to start collecting ideas for potential students. I've updated a few of the Wiki pages with some

Re: [PHP-DEV] CVE-2008-5658 unfixed or new problem with Zip::extractTo in 5.2.x?

2009-01-21 Thread Pierre Joye
hi, On Wed, Jan 21, 2009 at 10:57 PM, sean finney sean...@debian.org wrote: hi everyone, i'm looking for a sanity check here, as i've already lost more time than i'd like chasing ghosts on my treasure hunt through {bugs,lists,cvs}.php.net :( afaict, CVE-2008-5658[1] is only half-fixed on

[PHP-DEV] Re: GSoC 2009

2009-01-21 Thread Elizabeth M Smith
Scott MacVicar wrote: Hi Everybody, It's almost that time again where we rush at the last minute to organise something for the Google Summer of Code, so in the interest of being prepared I'm thinking it's time to start collecting ideas for potential students. I've updated a few of the Wiki

Re: [PHP-DEV] CVE-2008-5658 unfixed or new problem with Zip::extractTo in 5.2.x?

2009-01-21 Thread Pierre Joye
re, I ran a quick test to solve this problem sooner rather than later (using only the crash.zip part): pie...@ubuntu:~/cvs/php53/bld$ ./sapi/cli/php ./ziptest.php opening 'bad' zipfile...ok. extracted. C:\Users\pierre\Documents\php-sdk\php53\vc9\x86\php53cleanDebug\php.exe ziptest.php opening

Re: [PHP-DEV] [RFC lite] implement import of functions in namespace

2009-01-21 Thread Steph Fox
Having ascertained that Lukas did not shoot himself on seeing this... This is a testing of the waters RFC. If there is interest, it will be followed with a patch. It should be noted that the patch for this has been available through the various vortexes of namespace syntax for over a year

Re: [PHP-DEV] [RFC lite] implement import of functions in namespace

2009-01-21 Thread Larry Garfield
On Wednesday 21 January 2009 2:19:53 pm Greg Beaver wrote: [Drawbacks] 1) requires changing the engine near beta Legitimate concern, but I happily defer t the maintainers here. 2) adds new syntax to namespaces If I'm reading the RFC properly, it extends the existing syntax in a logical way

Re: [PHP-DEV] CVE-2008-5658 unfixed or new problem with Zip::extractTo in 5.2.x?

2009-01-21 Thread sean finney
hi pierre sorry, was already asleep when you came looking for me on IRC :) On Wed, Jan 21, 2009 at 11:25:21PM +0100, Pierre Joye wrote: it is fixed in 5.2.7RC2 or RC3, see: http://cvs.php.net/viewvc.cgi/php-src/ext/zip/php_zip.c?r1=1.1.2.43r2=1.1.2.44 FSVO fixed that includes segfaulting,

Re: [PHP-DEV] Enhanced __CLASS__ constant

2009-01-21 Thread Stan Vassilev | FM
Especially in namespaced code it should be very useful to have something returning fully qualified name as string. It can be operator, but I think introducing new keyword is bad way, or it can be realized using well known magic constant in new context: Example: function factory($class) {