Re: [PHP-DEV] [RFC][VOTE] Closure from callable

2016-06-01 Thread Dan Ackroyd
> On 15 May 2016, at 20:29, Dan Ackroyd wrote: > Hello, > > I've opened the voting for the Closure from callable RFC - > https://wiki.php.net/rfc/closurefromcallable Voting was closed, the RFC has passed 40-0. Thanks again to Bob, for helping with (aka doing most of) the

Re: [PHP-DEV] [RFC][VOTE] Closure from callable

2016-05-16 Thread Dan Ackroyd
On 16 May 2016 at 09:31, Dmitry Stogov wrote: > I'm sorry, I didn't follow the RFC discussion. > In general I like the idea, but why not to use Closure constructor? > Hi Dmitry, Several small to medium sized reasons that make me think it's the best way. As Marco said,

Re: [PHP-DEV] [RFC][VOTE] Closure from callable

2016-05-16 Thread Nikita Nefedov
On Mon, 16 May 2016 03:56:38 +0300, Sara Golemon wrote: On Sun, May 15, 2016 at 11:20 AM, Nikita Nefedov wrote: why would you need to support a $this->fieldName case though? Because to not support it would be to deliberately design in a new flavor of

Re: [PHP-DEV] [RFC][VOTE] Closure from callable

2016-05-16 Thread Marco Pivetta
On 16 May 2016 at 10:31, Dmitry Stogov wrote: > I'm sorry, I didn't follow the RFC discussion. > In general I like the idea, but why not to use Closure constructor? > > $f = new Closure("some_func"); > > would look more readable than > > $f = Closure::fromCallable("some_func");

Re: [PHP-DEV] [RFC][VOTE] Closure from callable

2016-05-16 Thread Dmitry Stogov
ore. Thanks. Dmitry. From: Dan Ackroyd <dan...@basereality.com> Sent: Sunday, May 15, 2016 8:29:22 PM To: internals@lists.php.net Subject: [PHP-DEV] [RFC][VOTE] Closure from callable Hello, I've opened the voting for the Closure from callable RFC

Re: [PHP-DEV] [RFC][VOTE] Closure from callable

2016-05-15 Thread Sara Golemon
On Sun, May 15, 2016 at 11:20 AM, Nikita Nefedov wrote: > why would you need to support a $this->fieldName case though? > Because to not support it would be to deliberately design in a new flavor of inconsistency into the language. $obj->memb is a property access in PHP.

Re: [PHP-DEV] [RFC][VOTE] Closure from callable

2016-05-15 Thread Nikita Nefedov
> On 15 May 2016, at 20:29, Dan Ackroyd wrote: > > Hello, > > I've opened the voting for the Closure from callable RFC - > https://wiki.php.net/rfc/closurefromcallable > > Just to note, some people I've spoken to have expressed a desire to > have a more powerful syntax

[PHP-DEV] [RFC][VOTE] Closure from callable

2016-05-15 Thread Dan Ackroyd
Hello, I've opened the voting for the Closure from callable RFC - https://wiki.php.net/rfc/closurefromcallable Just to note, some people I've spoken to have expressed a desire to have a more powerful syntax where 'bare' function names are used, like: callable(someFunctionName)