[PHP-DEV] Re: New function proposal

2015-10-10 Thread Tom Worster
On 10/8/15 11:05 AM, Mattias Gonzalez wrote: I wanted to propose the "var_die($var)" functionallity. My mates and i use a lot var_dump($var);die; Since die() wont print an array just a string, i think it´ll be very useful. It should do the var_dump($var);and die(); what do you think? I

RE: [PHP-DEV] Re: New function: stream_socket_listen()

2013-09-06 Thread Chris Wright
to see a stream_socket_set_option() or similar. My $0.02 Thanks, Chris -Original Message- From: Daniel Lowrey [mailto:rdlow...@gmail.com] Sent: 06 September 2013 06:24 To: Wez Furlong Cc: internals@lists.php.net; Sara Golemon Subject: [PHP-DEV] Re: New function: stream_socket_listen() Hi

Re: [PHP-DEV] Re: New function: stream_socket_listen()

2013-09-06 Thread Daniel Lowrey
] Sent: 06 September 2013 06:24 To: Wez Furlong Cc: internals@lists.php.net; Sara Golemon Subject: [PHP-DEV] Re: New function: stream_socket_listen() Hi! I'm with you @Wez -- allowances for assigning common socket options would be a major win. I'll see what I can do about working on something

Re: [PHP-DEV] Re: New function: stream_socket_listen()

2013-09-06 Thread Steve McKinney
-DEV] Re: New function: stream_socket_listen() Hi! I'm with you @Wez -- allowances for assigning common socket options would be a major win. I'll see what I can do about working on something more robust than this one-off function PR. On Friday, September 6, 2013, Wez Furlong wrote

Re: [PHP-DEV] Re: New function: stream_socket_listen()

2013-09-06 Thread Chris Wright
@lists.php.net; Sara Golemon Subject: [PHP-DEV] Re: New function: stream_socket_listen() Hi! I'm with you @Wez -- allowances for assigning common socket options would be a major win. I'll see what I can do about working on something more robust than this one-off function PR. On Friday, September

Re: [PHP-DEV] Re: New function: stream_socket_listen()

2013-09-06 Thread Daniel Lowrey
Lowrey [mailto:rdlow...@gmail.com] Sent: 06 September 2013 06:24 To: Wez Furlong Cc: internals@lists.php.net; Sara Golemon Subject: [PHP-DEV] Re: New function: stream_socket_listen() Hi! I'm with you @Wez -- allowances for assigning common socket options would be a major win. I'll see what

[PHP-DEV] Re: New function: stream_socket_listen()

2013-09-05 Thread Daniel Lowrey
Hi! I'm with you @Wez -- allowances for assigning common socket options would be a major win. I'll see what I can do about working on something more robust than this one-off function PR. On Friday, September 6, 2013, Wez Furlong wrote: I'm not opposed to the idea; the reason that I didn't

Re: [PHP-DEV] Re: new function: php_get_tmpdir() - bug #35380

2006-05-06 Thread Hartmut Holzgraefe
Pierre wrote: That would really nice to have it. Temp directory detection is a pain. added the function and documentation now, but i'm not sure about the name yet, php_get_tmpdir() seems to be the better choice to me but php_tmpdir() would be more in line with the ohter info functions with

[PHP-DEV] Re: new function: php_get_tmpdir() - bug #35380

2006-05-03 Thread Pierre
On Thu, 04 May 2006 00:53:38 +0200 [EMAIL PROTECTED] (Hartmut Holzgraefe) wrote: http://bugs.php.net/bug.php?id=35380 That would really nice to have it. Temp directory detection is a pain. -- Pierre Did I help you? Please donate :)

[PHP-DEV] Re: new function?

2004-01-13 Thread Christian Schneider
Andrey Hristov wrote: It works like in_array() but checks whether all needles are in the stack array. Looking at the prototype: bool in_array_all(mixed needle1[, mixed needle2], mixed haystack [, bool strict]) I'd say if (and I'm personally -1) this is added it should be bool in_array_all(array

Re: [PHP-DEV] Re: new function?

2004-01-13 Thread Andrey Hristov
Hi Christian, Christian Schneider wrote: Andrey Hristov wrote: It works like in_array() but checks whether all needles are in the stack array. Looking at the prototype: bool in_array_all(mixed needle1[, mixed needle2], mixed haystack [, bool strict]) I'd say if (and I'm personally -1) this

Re: [PHP-DEV] Re: new function?

2004-01-13 Thread Andrey Hristov
Hi, just a correction, I meant array_diff when i wrote array_intersect. array_diff is more handy since just count($res)==0 is enough, $res is the returned array of array_diff(). Andrey Andrey Hristov wrote: So, I did now some testing. Looks like in_array_all() is 6x faster than array_intersect()

Re: [PHP-DEV] Re: new function?

2004-01-13 Thread Andrei Zmievski
On Tue, 13 Jan 2004, Andrey Hristov wrote: Hi, just a correction, I meant array_diff when i wrote array_intersect. array_diff is more handy since just count($res)==0 is enough, $res is the returned array of array_diff(). Did you actually try array_intersect()? - Andrei -- PHP Internals -

Re: [PHP-DEV] Re: new function?

2004-01-13 Thread Andrey Hristov
Hi Andrei :) Andrei Zmievski wrote: On Tue, 13 Jan 2004, Andrey Hristov wrote: Hi, just a correction, I meant array_diff when i wrote array_intersect. array_diff is more handy since just count($res)==0 is enough, $res is the returned array of array_diff(). Did you actually try

Re: [PHP-DEV] Re: new function?

2004-01-13 Thread Christian Schneider
Hi Andrey, My personal feeling is that not enough people use this to make the pure speed improvement worth a new function. I guess the list will decide... - Chris -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php

Re: [PHP-DEV] Re: new function?

2004-01-13 Thread Andrey Hristov
Hi, I didn't write this function to be faster. You asked about array_intersect() and I decided to bechmark (you didn't ask for it though). What I had in mind when I decided to write it was to escape this : if (in_array(some_element, $haystack) in_array(other_element, $haystack)