Re: [PHP-DEV] Re: Local variables for editors

2019-01-22 Thread Nikita Popov
On Sat, Jan 19, 2019 at 10:09 PM Peter Kokot wrote: > On Wed, 29 Nov 2017 at 22:53, Peter Kokot wrote: > > > > Hello, > > > > I'm not sure if this has been discussed before, but I find these local > > variables in C, H and other files a bit strange and bloated: > > > > /* > > * Local

[PHP-DEV] Coalesce assign operator (??=) implemented

2019-01-22 Thread Nikita Popov
Hi internals, Some time ago an RFC for the ??= operator has been accepted: https://wiki.php.net/rfc/null_coalesce_equal_operator However, due to implementation difficulties, the RFC hasn't landed since then. I'm happy to say that these difficulties are resolved now, and ??= has landed with

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Yasuo Ohgaki
On Wed, Jan 23, 2019 at 7:08 AM Girgias wrote: > On Tue, 22 Jan 2019 at 22:52, Yasuo Ohgaki wrote: > >> Hi Girgias >> >> It seems good list in general. >> There would not be issues marking them as deprecated. >> "Deprecation" means "Soft deprecation", correct? >> >> Removing these aliases from

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Rowan Collins
On 22/01/2019 21:27, Midori Koçak wrote: Can we also add strange function names without any naming conventions to this list In short, no. I wish we had an FAQ where we could avoid recapping the arguments around this, but it has come up many times, and the conclusion has always been that it's

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Midori Koçak
Can we also add strange function names without any naming conventions to this list? Without undersore: strcspn, With underscore: str_repeat, chain of abrevs: strnatcasecmp. Similar namings do exist for array functions either. Cheers, Midori On Tue, 22 Jan 2019 at 22:22, Girgias wrote: > On

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Girgias
On Tue, 22 Jan 2019 at 22:52, Yasuo Ohgaki wrote: > Hi Girgias > > It seems good list in general. > There would not be issues marking them as deprecated. > "Deprecation" means "Soft deprecation", correct? > > Removing these aliases from PHP 8 is not good idea. > Aliases should be removed when

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Girgias
On Tue, 22 Jan 2019 at 23:28, Yasuo Ohgaki wrote: > On Wed, Jan 23, 2019 at 7:08 AM Girgias wrote: > > > On Tue, 22 Jan 2019 at 22:52, Yasuo Ohgaki wrote: > > > >> Hi Girgias > >> > >> It seems good list in general. > >> There would not be issues marking them as deprecated. > >> "Deprecation"

[PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Girgias
Greetings PHP internals, After skimming through the PHP documentation, I came up with a list of functions which seem reasonable to deprecate as of PHP 8 and I would like to gather some opinions from Internals. If this seems like it's too early or should be in an RFC draft please let me know and in

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Yasuo Ohgaki
Hi Girgias It seems good list in general. There would not be issues marking them as deprecated. "Deprecation" means "Soft deprecation", correct? Removing these aliases from PHP 8 is not good idea. Aliases should be removed when nobody cares about these aliases. For example, pg_loopen()/etc were

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Yasuo Ohgaki
On Wed, Jan 23, 2019 at 6:28 AM Midori Koçak wrote: > Can we also add strange function names without any naming conventions to > this list? Without undersore: strcspn, With underscore: str_repeat, chain > of abrevs: strnatcasecmp. Similar namings do exist for array functions > either. >

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Stephen Reay
> On 23 Jan 2019, at 03:34, Girgias wrote: > > Greetings PHP internals, > After skimming through the PHP documentation, I came up with a list of > functions which seem > reasonable to deprecate as of PHP 8 and I would like to gather some > opinions from Internals. > If this seems like it's too

Re: [PHP-DEV] Deprecation ideas for PHP 8

2019-01-22 Thread Girgias
On Tue, 22 Jan 2019 at 21:48, Stephen Reay wrote: > > > On 23 Jan 2019, at 03:34, Girgias wrote: > > Classes/Objects functions: > > > > - is_a (use instanceof operator) > > - is_subclass_of (not exactly what it's purpose is but the instanceof > > operator SHOULD be a valid equivalence

Re: [PHP-DEV] Coalesce assign operator (??=) implemented

2019-01-22 Thread Björn Larsson
Hi, Excellent work! I have been waiting for this :) Sara, I came to think on the Short ternary Assignment Operator RFC. Would this implementation make that one more feasible, given it passes a vote? r//Björn Larsson Den 2019-01-22 kl. 11:33, skrev Nikita Popov: Hi internals, Some time ago

Re: [PHP-DEV] Coalesce assign operator (??=) implemented

2019-01-22 Thread Nikita Popov
On Tue, Jan 22, 2019 at 4:51 PM Björn Larsson wrote: > Hi, > > Excellent work! I have been waiting for this :) > > Sara, I came to think on the Short ternary Assignment Operator RFC. > Would this implementation make that one more feasible, given it > passes a vote? > >From an implementation

[PHP-DEV] Re: [RFC][Vote] Covariant Returns and Contravariant Parameters

2019-01-22 Thread Levi Morrison
On Tue, Jan 15, 2019 at 1:27 PM Christoph M. Becker wrote: > > On 04.01.2019 at 20:17, Levi Morrison wrote: > > > I intend to close the vote in a day or two, unless I hear of new> issues > > from Dmitry or others. > Any news here? > > -- > Christoph M. Becker I sent this a week ago to Christoph

Re: [PHP-DEV] Local variables for editors

2019-01-22 Thread Levi Morrison
On Wed, Nov 29, 2017 at 2:54 PM Peter Kokot wrote: > > Hello, > > I'm not sure if this has been discussed before, but I find these local > variables in C, H and other files a bit strange and bloated: > > /* > * Local variables: > * tab-width: 4 > * c-basic-offset: 4 > * End: > * vim600: noet