Re: [PHP-DEV] @@Jit Attribute Considerations

2020-08-04 Thread Benjamin Eberlei
Alternatively make it @@Jit("off") only and any other argument will lead to
an error for now.

Then the problem left becomes "Jit" being a very short global class.

On Mon, Aug 3, 2020 at 10:36 PM Benas IML  wrote:

> `@@NoJit` sounds pretty alright to me.
>
> On Mon, Aug 3, 2020, 11:27 PM Derick Rethans  wrote:
>
>> On 3 August 2020 20:20:35 BST, Benjamin Eberlei 
>> wrote:
>>
>> >In that case maybe we should rename the attribute to @@DisableJit ?
>> >This
>> >would not clutter the global namespace with a "jit" class.
>>
>> Things with a negative name are usually a code smell. I'm not keen on a
>> @[disableJit] attribute name.
>>
>> cheers,
>> Derick
>>
>> --
>> PHP Internals - PHP Runtime Development Mailing List
>> To unsubscribe, visit: https://www.php.net/unsub.php
>>
>>


Re: [PHP-DEV] @@Jit Attribute Considerations

2020-08-03 Thread Benas IML
`@@NoJit` sounds pretty alright to me.

On Mon, Aug 3, 2020, 11:27 PM Derick Rethans  wrote:

> On 3 August 2020 20:20:35 BST, Benjamin Eberlei 
> wrote:
>
> >In that case maybe we should rename the attribute to @@DisableJit ?
> >This
> >would not clutter the global namespace with a "jit" class.
>
> Things with a negative name are usually a code smell. I'm not keen on a
> @[disableJit] attribute name.
>
> cheers,
> Derick
>
> --
> PHP Internals - PHP Runtime Development Mailing List
> To unsubscribe, visit: https://www.php.net/unsub.php
>
>


Re: [PHP-DEV] @@Jit Attribute Considerations

2020-08-03 Thread Derick Rethans
On 3 August 2020 20:20:35 BST, Benjamin Eberlei  wrote:

>In that case maybe we should rename the attribute to @@DisableJit ?
>This
>would not clutter the global namespace with a "jit" class.

Things with a negative name are usually a code smell. I'm not keen on a 
@[disableJit] attribute name.

cheers,
Derick 

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: https://www.php.net/unsub.php



Re: [PHP-DEV] @@Jit Attribute Considerations

2020-08-03 Thread Peter Bowyer
On Mon, 3 Aug 2020 at 19:52, Stanislav Malyshev  wrote:

> I think turning JIT off is a valid use case, the rest looks much more
> iffy. I am not sure we want to let people tell the engine to JIT certain
> functions - are there a lot of cases where the engine wouldn't do it but
> it's actually the right thing to do?
>

Wouldn't a use case be profiling code, to see if JIT makes a difference to
a specific function? So I can profile with JIT disabled globally and @@JIT
on specific code, modify my code and see if it improves the JIT performance?

I'm basing this on my experience with the @jit annotation in Numba (
http://numba.pydata.org/) where it's useful to see the effect on small
pieces of code.

Peter


Re: [PHP-DEV] @@Jit Attribute Considerations

2020-08-03 Thread Benjamin Eberlei
On Mon, Aug 3, 2020 at 8:51 PM Stanislav Malyshev 
wrote:

> Hi!
>
> > Only the trigger mode 4 (attributes) is actually using @@Jit("tracing")
> and
> > "function". This trigger mode feels like micro-management for developers
> > and since it has virtually no spotlight in discussions and blog posts
> about
> > the JIT at the moment, we don't know if it brings benefits.
>
> I think turning JIT off is a valid use case, the rest looks much more
> iffy. I am not sure we want to let people tell the engine to JIT certain
> functions - are there a lot of cases where the engine wouldn't do it but
> it's actually the right thing to do?
>

In that case maybe we should rename the attribute to @@DisableJit ? This
would not clutter the global namespace with a "jit" class.

>
> Don't see any use for "opcache.jit=attributes".
>
> --
> Stas Malyshev
> smalys...@gmail.com
>


Re: [PHP-DEV] @@Jit Attribute Considerations

2020-08-03 Thread Stanislav Malyshev
Hi!

> Only the trigger mode 4 (attributes) is actually using @@Jit("tracing") and
> "function". This trigger mode feels like micro-management for developers
> and since it has virtually no spotlight in discussions and blog posts about
> the JIT at the moment, we don't know if it brings benefits.

I think turning JIT off is a valid use case, the rest looks much more
iffy. I am not sure we want to let people tell the engine to JIT certain
functions - are there a lot of cases where the engine wouldn't do it but
it's actually the right thing to do?

Don't see any use for "opcache.jit=attributes".

-- 
Stas Malyshev
smalys...@gmail.com

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: https://www.php.net/unsub.php