[PATCH] iommu/arm-smmu-v3: Constify arm_smmu_mmu_notifier_ops

2021-12-04 Thread Rikard Falkeborn
The only usage of arm_smmu_mmu_notifier_ops is to assign its address to the ops field in the mmu_notifier struct, which is a pointer to const struct mmu_notifier_ops. Make it const to allow the compiler to put it in read-only memory. Signed-off-by: Rikard Falkeborn ---

[PATCH 3/4] iommu/rockchip: rename dte_index to dte

2021-12-04 Thread Dafna Hirschfeld
In rk_iommu_map, the var dte_index is actually set to the dte and not to the dte index. Rename it. Signed-off-by: Dafna Hirschfeld --- drivers/iommu/rockchip-iommu.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/iommu/rockchip-iommu.c

[PATCH 4/4] iommu/rockchip: replace pt_address cb with dma_addr_dte when setting dt addr

2021-12-04 Thread Dafna Hirschfeld
The dt address is calculated using the dma_addr_dte cb. So when setting the dt address to the DTE_ADDR_DUMMY that cb should be used instead of pt_address. Signed-off-by: Dafna Hirschfeld --- drivers/iommu/rockchip-iommu.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH 1/4] iommu/rockchip: replace 4 with sizeof(u32)

2021-12-04 Thread Dafna Hirschfeld
In log_iova, multiply by 4 is used to calculate the addresses. In other places in this driver, sizeof(u3) is used. So replace 4 with sizeof(u32) for consistency Signed-off-by: Dafna Hirschfeld --- drivers/iommu/rockchip-iommu.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff

[PATCH 2/4] iommu/rockchip: remove redundant var dte_addr

2021-12-04 Thread Dafna Hirschfeld
Using dte_addr as local var is redundant. Instead acces rk_domain->dt[dte_index] directly. Signed-off-by: Dafna Hirschfeld --- drivers/iommu/rockchip-iommu.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/iommu/rockchip-iommu.c

Re: [patch 21/32] NTB/msi: Convert to msi_on_each_desc()

2021-12-04 Thread Thomas Gleixner
Jason, On Fri, Dec 03 2021 at 12:41, Jason Gunthorpe wrote: > On Fri, Dec 03, 2021 at 04:07:58PM +0100, Thomas Gleixner wrote: > Lets do a thought experiment, lets say we forget about the current PCI > MSI API. > > What if it worked more like this: > > probe() > // Access the real PCI SIG

Re: [PATCH 3/4] memory: mtk-smi: Add sleep ctrl function

2021-12-04 Thread Krzysztof Kozlowski
On 03/12/2021 07:40, Yong Wu wrote: > sleep control means that when the larb go to sleep, we should wait a bit s/go/goes/ > until all the current commands are finished. thus, when the larb runtime Please start every sentence with a capital letter. > suspend, we need enable this function to