Re: [PATCH 6/9] swiotlb: refactor swiotlb_tbl_map_single

2021-02-22 Thread Christoph Hellwig
On Mon, Feb 22, 2021 at 02:29:37PM -0500, Konrad Rzeszutek Wilk wrote: > > 'max_slots' should be 'unsigned long' here. Breaks SWIOTLB on RPi4. Do you > > want > > me to send a fix or you prefer editing the patch? > > I can roll it in. Thx! Thanks to both of you!

Re: [PATCH 6/9] swiotlb: refactor swiotlb_tbl_map_single

2021-02-22 Thread Konrad Rzeszutek Wilk
> > +static int find_slots(struct device *dev, size_t alloc_size) > > +{ > > + unsigned long boundary_mask = dma_get_seg_boundary(dev); > > + dma_addr_t tbl_dma_addr = > > + phys_to_dma_unencrypted(dev, io_tlb_start) & boundary_mask; > > + unsigned int max_slots =

Re: [PATCH 6/9] swiotlb: refactor swiotlb_tbl_map_single

2021-02-22 Thread Nicolas Saenz Julienne
Hi Christoph, On Sun, 2021-02-07 at 17:03 +0100, Christoph Hellwig wrote: > Split out a bunch of a self-contained helpers to make the function easier > to follow. > > Signed-off-by: Christoph Hellwig > --- >  kernel/dma/swiotlb.c | 179 +-- >  1 file

[PATCH 6/9] swiotlb: refactor swiotlb_tbl_map_single

2021-02-07 Thread Christoph Hellwig
Split out a bunch of a self-contained helpers to make the function easier to follow. Signed-off-by: Christoph Hellwig --- kernel/dma/swiotlb.c | 179 +-- 1 file changed, 89 insertions(+), 90 deletions(-) diff --git a/kernel/dma/swiotlb.c