KuiLIU created CLOUDSTACK-10359:
-----------------------------------

             Summary: Inconsistent method names
                 Key: CLOUDSTACK-10359
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10359
             Project: CloudStack
          Issue Type: Improvement
      Security Level: Public (Anyone can view this level - this is the default.)
            Reporter: KuiLIU


The following two methods are named "getXXX".
The two method are checking the status of variables.
"getCustomized" is not as intuitive as "isCustomized".
"getIsSystem" is not as intuitive as "isSystem" as well.

{code:java}
    public boolean getCustomized() {
        return (cpuNumber == null || memory == null || cpuSpeed == null);
    }

   public Boolean getIsSystem() {
        return isSystem == null ? false : isSystem;
    }

{code}




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to