[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-03-01 Thread Fei Hui (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15890029#comment-15890029
 ] 

Fei Hui commented on HIVE-16043:


Failed Tests are not related

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Hive QA (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15889565#comment-15889565
 ] 

Hive QA commented on HIVE-16043:




Here are the results of testing the latest attachment:
https://issues.apache.org/jira/secure/attachment/12855284/HIVE-16043.1.patch

{color:red}ERROR:{color} -1 due to no test(s) being added or modified.

{color:red}ERROR:{color} -1 due to 3 failed/errored test(s), 10298 tests 
executed
*Failed tests:*
{noformat}
org.apache.hadoop.hive.cli.TestMiniLlapLocalCliDriver.testCliDriver[schema_evol_text_vec_table]
 (batchId=147)
org.apache.hadoop.hive.cli.TestPerfCliDriver.testCliDriver[query23] 
(batchId=223)
org.apache.hive.jdbc.TestMultiSessionsHS2WithLocalClusterSpark.testSparkQuery 
(batchId=217)
{noformat}

Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/3857/testReport
Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/3857/console
Test logs: http://104.198.109.242/logs/PreCommit-HIVE-Build-3857/

Messages:
{noformat}
Executing org.apache.hive.ptest.execution.TestCheckPhase
Executing org.apache.hive.ptest.execution.PrepPhase
Executing org.apache.hive.ptest.execution.ExecutionPhase
Executing org.apache.hive.ptest.execution.ReportingPhase
Tests exited with: TestsFailedException: 3 tests failed
{noformat}

This message is automatically generated.

ATTACHMENT ID: 12855284 - PreCommit-HIVE-Build

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Fei Hui (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15889438#comment-15889438
 ] 

Fei Hui commented on HIVE-16043:


[~Ferd] thanks i found it on jenkins

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Ferdinand Xu (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15889418#comment-15889418
 ] 

Ferdinand Xu commented on HIVE-16043:
-

@Fei Hui you can check whether the jenkins job is triggered by visiting 
https://builds.apache.org/job/PreCommit-HIVE-Build/ And if not, you can build 
with configuration by providing your attachment ID and issue ID after login.

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Fei Hui (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15889408#comment-15889408
 ] 

Fei Hui commented on HIVE-16043:


[~sershe] thanks. i will resubmit it. i'm confused for testing were not running

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Sergey Shelukhin (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15889372#comment-15889372
 ] 

Sergey Shelukhin commented on HIVE-16043:
-

I was waiting for the tests to run. Perhaps the patch needs to be resubmitted. 
I can commit after that.

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Fei Hui (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15889358#comment-15889358
 ] 

Fei Hui commented on HIVE-16043:


CC [~Ferd] could you please give any suggestions?

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-27 Thread Sergey Shelukhin (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15886340#comment-15886340
 ] 

Sergey Shelukhin commented on HIVE-16043:
-

+1

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-26 Thread Fei Hui (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15885124#comment-15885124
 ] 

Fei Hui commented on HIVE-16043:


CC [~sershe] .I see HIVE-16010 , and find that maybe it is better like this for 
consistent usage.
How do you think, could you please give any suggestions?

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)