[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-03-01 Thread Sergey Shelukhin (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sergey Shelukhin updated HIVE-16043:

   Resolution: Fixed
Fix Version/s: 2.2.0
   Status: Resolved  (was: Patch Available)

Committed to master, thanks for the patch

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Fix For: 2.2.0
>
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Fei Hui (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fei Hui updated HIVE-16043:
---
Attachment: HIVE-16043.1.patch

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Fei Hui (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fei Hui updated HIVE-16043:
---
Status: Patch Available  (was: Open)

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Fei Hui (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fei Hui updated HIVE-16043:
---
Status: Open  (was: Patch Available)

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-28 Thread Fei Hui (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fei Hui updated HIVE-16043:
---
Attachment: (was: HIVE-16043.1.patch)

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-27 Thread Fei Hui (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fei Hui updated HIVE-16043:
---
Status: Open  (was: Patch Available)

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-27 Thread Fei Hui (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fei Hui updated HIVE-16043:
---
Status: Patch Available  (was: Open)

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-26 Thread Fei Hui (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fei Hui updated HIVE-16043:
---
Status: Patch Available  (was: Open)

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
>Assignee: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Updated] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

2017-02-26 Thread Fei Hui (JIRA)

 [ 
https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Fei Hui updated HIVE-16043:
---
Attachment: HIVE-16043.1.patch

patch uploaded

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> -
>
> Key: HIVE-16043
> URL: https://issues.apache.org/jira/browse/HIVE-16043
> Project: Hive
>  Issue Type: Bug
>  Components: Tez
>Affects Versions: 2.2.0
>Reporter: Fei Hui
> Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>private TezSessionState getSession(HiveConf conf, boolean doOpen)
>throws Exception {
>  String queueName = conf.get("tez.queue.name");
>  ...
>}
>   private TezSessionState getNewSessionState(HiveConf conf,
>   String queueName, boolean doOpen) throws Exception {
> TezSessionPoolSession retTezSessionState = 
> createAndInitSession(queueName, false);
> if (queueName != null) {
>   conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
> }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we 
> should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)