Claus Ibsen created KARAF-4455:
----------------------------------

             Summary: Testing with pax-exam - Allow to specify the name of the 
real unpack directory
                 Key: KARAF-4455
                 URL: https://issues.apache.org/jira/browse/KARAF-4455
             Project: Karaf
          Issue Type: Improvement
            Reporter: Claus Ibsen


When testing with pax-exam and you run a bunch of tests its really annoying 
that it uses random directory names.

Then its hard to track down which of these directory has the karaf container 
you want to inspect, such as its logs, or try to start it manually etc.

For example
{code}
davsclaus:~/workspace/camel/tests/camel-itest-karaf/target/paxexam/unpack 
(master)/$ ls
0901403a-88f0-47dd-8853-30d424419b17    3b3dc26e-7186-4c85-a11a-d19e9b24211a    
66227858-ce1c-400d-a276-1ddcee2c6f18    caf36185-315c-4fff-ada5-472ea6288160
0f0c5c99-26fa-462f-a394-45212bd10ad9    3d1b8af9-fc10-48f1-83d4-1fb09461d3cc    
7e82acca-19db-44dd-8c6b-04c0101df22f    cf9636d0-f44f-4be7-a149-bce392530a46
11bd7128-a93d-4fbd-9def-279dfcc07204    400a761d-71d5-47d7-84c1-203cbbec5b9f    
80961ac2-e0d6-4f0f-9460-d7ef077f0c3c    d1daf2ed-b661-4ab5-8950-069f4f7772ad
129eca6c-39cd-46dc-887b-870c666a5bb0    47d86021-c604-4cce-87aa-d5f168e7f329    
945aae77-f15a-4445-939c-22df23267d3b    e13af1f7-ebe3-4e9d-89f2-cc2acd8608d0
149374c0-da94-40ac-9073-2c3717479771    4ece834c-7095-4fd3-9f55-e686f217e7ee    
99dbab81-7769-406d-8b2f-9de7e516b3e8    eba1a3c8-acc7-4b87-ab75-abccfdf45bb5
1617ee3f-b128-4883-a52a-56c557242b6a    52f82410-cd44-4d8c-abac-d93615586f5b    
9b9eded6-4732-473f-9a92-be93f18f1073    f1ba6e7d-52bd-47dd-bbb5-50d026b59f04
2adde2e8-3dcd-4d42-875e-b9ed8fd77227    55d1d84d-be28-4d3e-80ef-b25f8ce74492    
acd39400-bf91-465b-8cc2-34119393e92f    f379a0c3-8f9c-457c-8fa9-fffb94662d1d
2e371760-99c2-49c8-94e4-b7a037f9e5bd    57c803e5-219d-4184-a506-6371a409596d    
ace1f473-8102-42dc-b8a3-23c1ea153a48    f91a762c-83cf-4bd8-9f40-67cf7dcddff7
3201d6ef-bd16-40c4-af07-d6b651acca39    5f04f917-4f61-482b-99f8-3cdd66e8e9d7    
beed3685-4a12-4bca-a9b3-1f2d6a5353be
{code}

So if you could set the unpack directory and its name its using, then you give 
those names a meaning name, such as the name of your unit test etc.

For example with a new unpackName("myTestName") method.
{code}
            KarafDistributionOption.karafDistributionConfiguration()
                    
.frameworkUrl(maven().groupId("org.apache.karaf").artifactId("apache-karaf").type("tar.gz").versionAsInProject())
                    .karafVersion(karafVersion)
                    .name("Apache Karaf")
                    .useDeployFolder(false).unpackDirectory(new 
File("target/paxexam/unpack/")).unpackName("myTestName"),
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to