Jianshi Huang created SPARK-4551:
------------------------------------

             Summary: Allow auto-conversion of field names of case class from 
camelCase to lower_case convention
                 Key: SPARK-4551
                 URL: https://issues.apache.org/jira/browse/SPARK-4551
             Project: Spark
          Issue Type: Improvement
          Components: SQL
    Affects Versions: 1.3.0
            Reporter: Jianshi Huang
            Priority: Minor


In SQL, lower_case is the naming convention for column names. 

We want to keep this convention as much as possible. So when converting a 
RDD[case class] to SchemaRDD, let's make it an option to convert the filed 
names from camelCase to lower_case (e.g. unitAmount => unit_amount)

My proposal:
1) Utility function for case conversion (e.g. 
https://gist.github.com/sidharthkuruvila/3154845)'

2) Add option convertToLowerCase to registerTempTable

  def registerTempTable(tableName: String, convertToLowerCase = false)


Jianshi



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to