[jira] [Updated] (MATH-894) Cleanup of ResizableDoubleArray (o.a.c.m.util)

2012-11-16 Thread Gilles (JIRA)

 [ 
https://issues.apache.org/jira/browse/MATH-894?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Gilles updated MATH-894:


Fix Version/s: (was: 3.1)

Remaining (non backwards-compatible) modifications must be postponed to 4.0.


 Cleanup of ResizableDoubleArray (o.a.c.m.util)
 --

 Key: MATH-894
 URL: https://issues.apache.org/jira/browse/MATH-894
 Project: Commons Math
  Issue Type: Improvement
Affects Versions: 3.0
Reporter: Gilles
Assignee: Gilles
Priority: Minor
 Fix For: 4.0

 Attachments: MATH-894.patch


 Method addElement should not call contract(), as it will almost always 
 make the storage array shrink on the first call since it will be considered 
 too big (for just storing one element).
 See discussion about this change in MATH-757.
 Miscellaneous code modifications are also proposed in order to improve 
 encapsulation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Updated] (MATH-894) Cleanup of ResizableDoubleArray (o.a.c.m.util)

2012-11-14 Thread Gilles (JIRA)

 [ 
https://issues.apache.org/jira/browse/MATH-894?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Gilles updated MATH-894:


Attachment: MATH-894.patch

Please have a look at the attached patch.
Instead of adding a
{code}
public double compute(UnivariateStatistic s)
{code}
in {{o.a.c.m.util.ResizeableDoubleArray}}, I think that it is better to provide 
a subclass with the additional functionality. Mainly, this avoids a class in 
util to depend on another package.
If useful beyond DescriptiveStatistics, the subclass can be made public.

OK to commit?


 Cleanup of ResizableDoubleArray (o.a.c.m.util)
 --

 Key: MATH-894
 URL: https://issues.apache.org/jira/browse/MATH-894
 Project: Commons Math
  Issue Type: Improvement
Affects Versions: 3.0
Reporter: Gilles
Assignee: Gilles
Priority: Minor
 Fix For: 3.1, 4.0

 Attachments: MATH-894.patch


 Method addElement should not call contract(), as it will almost always 
 make the storage array shrink on the first call since it will be considered 
 too big (for just storing one element).
 See discussion about this change in MATH-757.
 Miscellaneous code modifications are also proposed in order to improve 
 encapsulation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Updated] (MATH-894) Cleanup of ResizableDoubleArray (o.a.c.m.util)

2012-11-13 Thread Gilles (JIRA)

 [ 
https://issues.apache.org/jira/browse/MATH-894?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Gilles updated MATH-894:


  Description: 
Method addElement should not call contract(), as it will almost always make 
the storage array shrink on the first call since it will be considered too 
big (for just storing one element).

See discussion about this change in MATH-757.

Miscellaneous code modifications are also proposed in order to improve 
encapsulation.

  was:
Method addElement should not call contract(), as it will almost always make 
the storage array shrink on the first call since it will be considered too 
big (for just storing one element).

See discussion about this change in MATH-757.

Fix Version/s: 4.0
  Summary: Cleanup of ResizableDoubleArray (o.a.c.m.util)  (was: 
Spurious method call in ResizableDoubleArray (o.a.c.m.util))

 Cleanup of ResizableDoubleArray (o.a.c.m.util)
 --

 Key: MATH-894
 URL: https://issues.apache.org/jira/browse/MATH-894
 Project: Commons Math
  Issue Type: Improvement
Affects Versions: 3.0
Reporter: Gilles
Assignee: Gilles
Priority: Minor
 Fix For: 3.1, 4.0


 Method addElement should not call contract(), as it will almost always 
 make the storage array shrink on the first call since it will be considered 
 too big (for just storing one element).
 See discussion about this change in MATH-757.
 Miscellaneous code modifications are also proposed in order to improve 
 encapsulation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira