[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2018-03-21 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
Fix Version/s: 2.0.0

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Assignee: Balazs Meszaros
>Priority: Blocker
> Fix For: 2.0.0-alpha-3, 2.0.0
>
> Attachments: 14998.txt, HBASE-14998.master.001.patch, 
> HBASE-14998.master.002.patch, HBASE-14998.master.003.patch, 
> HBASE-14998.master.003.patch
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-09-13 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
  Resolution: Fixed
Hadoop Flags: Reviewed
Release Note: 
 * Deprecates getAlterStatus. Everywhere else we talk of 'modify' rather
   'alter' and should use Future returned from async instead.
 * isTableAvailable(TableName, byte [][]) has been deprecated to be
   removed; use the overrie instead. This is a weird method.
 * Changed listTableDescriptor to getDescriptor.
 * Renamed other like methods to have same pattern (deprecating the old):
balancer => balance
setBalancerRunning => balancerSwitch
setNormalizerRunning => normalizerSwitch
enableCatalogJanitor => catalogJanitorSwitch
setCleanerChoreRunning => cleanerChoreSwitch
setSplitOrMergeEnabled => splitOrMergeEnabledSwitch

 * Renamed (with deprecation of old) runCatalogScan => runCatalogJanitor.
 * Reviewed generated javadoc and made some edits; purged reference to
   hbase issues from our API, fixed param names, etc.
 * Made all the enable services methods have same pattern.
 * Renamed takeSnapshotAsync as snapshotAsync (with deprecation of old)
 * Renamed execProcedureWithRet as execProcedureWithReturn (with
   deprecation)
  Status: Resolved  (was: Patch Available)

Pushed to branch-2 and master. Thanks for work [~balazs.meszaros]

Follow-on will concentrate on making AsyncAdmin better mirror what is here in 
Admin (except in case where it does it better -- in these cases, we'll keep 
AsyncAdmin way of doing things; e.g. returning a List or CompletableFuture 
instead of array or Future).

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Assignee: Balazs Meszaros
>Priority: Blocker
> Fix For: 2.0.0-alpha-3
>
> Attachments: 14998.txt, HBASE-14998.master.001.patch, 
> HBASE-14998.master.002.patch, HBASE-14998.master.003.patch, 
> HBASE-14998.master.003.patch
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-09-13 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
Status: Patch Available  (was: In Progress)

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Assignee: stack
>Priority: Blocker
> Fix For: 2.0.0-alpha-3
>
> Attachments: 14998.txt, HBASE-14998.master.001.patch, 
> HBASE-14998.master.002.patch, HBASE-14998.master.003.patch, 
> HBASE-14998.master.003.patch
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-09-13 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
Attachment: HBASE-14998.master.003.patch

Retry

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Assignee: Balazs Meszaros
>Priority: Blocker
> Fix For: 2.0.0-alpha-3
>
> Attachments: 14998.txt, HBASE-14998.master.001.patch, 
> HBASE-14998.master.002.patch, HBASE-14998.master.003.patch, 
> HBASE-14998.master.003.patch
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-09-13 Thread Balazs Meszaros (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Balazs Meszaros updated HBASE-14998:

Attachment: HBASE-14998.master.003.patch

+1

Fixed some typos (s/< Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Assignee: Balazs Meszaros
>Priority: Blocker
> Fix For: 2.0.0-alpha-3
>
> Attachments: 14998.txt, HBASE-14998.master.001.patch, 
> HBASE-14998.master.002.patch, HBASE-14998.master.003.patch
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-09-12 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
Attachment: HBASE-14998.master.002.patch

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Assignee: Balazs Meszaros
>Priority: Blocker
> Fix For: 2.0.0-alpha-3
>
> Attachments: 14998.txt, HBASE-14998.master.001.patch, 
> HBASE-14998.master.002.patch
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-09-12 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
Attachment: HBASE-14998.master.001.patch

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Assignee: Balazs Meszaros
>Priority: Blocker
> Fix For: 2.0.0-alpha-3
>
> Attachments: 14998.txt, HBASE-14998.master.001.patch
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-09-11 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
Attachment: 14998.txt

Minor changes...

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Assignee: Balazs Meszaros
>Priority: Blocker
> Fix For: 2.0.0-alpha-3
>
> Attachments: 14998.txt
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-08-17 Thread Mike Drob (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Mike Drob updated HBASE-14998:
--
Fix Version/s: (was: 2.0.0)
   2.0.0-alpha-3

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Priority: Blocker
> Fix For: 2.0.0-alpha-3
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-08-10 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
Priority: Blocker  (was: Critical)

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Priority: Blocker
> Fix For: 2.0.0
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)


[jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup

2017-06-30 Thread stack (JIRA)

 [ 
https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-14998:
--
Priority: Critical  (was: Major)

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---
>
> Key: HBASE-14998
> URL: https://issues.apache.org/jira/browse/HBASE-14998
> Project: HBase
>  Issue Type: Sub-task
>Reporter: Enis Soztutar
>Priority: Critical
> Fix For: 2.0.0
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some 
> unification in method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it 
> (modifyTable(), versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be 
> removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)