[ 
https://issues.apache.org/jira/browse/MESOS-9959?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16922398#comment-16922398
 ] 

Andrei Sekretenko commented on MESOS-9959:
------------------------------------------

This was partially tackled in the following patches:

{code}
commit 997df8bf880dfcc0f848fb3eedceff7a256edf66 (HEAD -> master, origin/master, 
origin/HEAD)
Author: Andrei Sekretenko <asekrete...@mesosphere.io>
Date:   Tue Sep 3 10:28:05 2019 -0700

    Renamed *Allocation into *Offering in __generateOffers().
    
    Review: https://reviews.apache.org/r/71402/
{code}
{code}
commit 3947dcdee6153b24acc40316c57a7d8168c32c30
Author: Andrei Sekretenko <asekrete...@mesosphere.io>
Date:   Tue Sep 3 10:27:59 2019 -0700

    Renamed totalAllocatedReservation -> totalOfferedOrAllocatedReservation.
    
    Review: https://reviews.apache.org/r/71401/
{code}
{code}
commit dcce9ad9ab2ed588ac64481cee7265f63e0aa4f6
Author: Andrei Sekretenko <asekrete...@mesosphere.io>
Date:   Tue Sep 3 10:27:53 2019 -0700

    Renamed `toAllocate` into `toOffer` in `HierarchialAllocatorProcess`.
    
    Review: https://reviews.apache.org/r/71400/
{code}
{code}
commit e2904eb319d6783714765da4c52554bf83b1ec8b
Author: Andrei Sekretenko <asekrete...@mesosphere.io>
Date:   Tue Sep 3 10:27:37 2019 -0700

    Renamed `allocate` and its derivatives in HierarchialAllocatorProcess.
    
    This patch makes the `HierarchialAllocatorProcess` code more consistent
    with naming of different subsets of resources in the master
    (where "resource belongs to `offered`" is equivalent to "there is an
    offer with this resource", "resource belongs to `allocated`"
    is equivalent to "there is a task/executor with this resource" and
    `offered` has no intersection with `allocated`).
    
    Review: https://reviews.apache.org/r/71399/
{code}
{code}
commit ebe4a4a4985ba2205bf9f242a57b56a72d0f013f
Author: Andrei Sekretenko <asekrete...@mesosphere.io>
Date:   Tue Sep 3 10:26:49 2019 -0700


    Made `allocated` mean "allocated but not offered" in `allocator::Slave`.
    
    This patch makes the `allocator::Slave` code more consistent
    with naming of different subsets of resources in the master
    (where "resource belongs to `offered`" is equivalent to "there is an
    offer with this resource", "resource belongs to `allocated`"
    is equivalent to "there is a task/executor with this resource" and
    `offered` has no intersection with `allocated`).
{code}

However, some occurrences of "allocated" which actually mean "allocated or 
offered" still remain, the most notorious being 
"trackAllocatedResources()/untrackAllocatedResources()".

> Make naming of different resource subsets consistent between master and 
> allocator
> ---------------------------------------------------------------------------------
>
>                 Key: MESOS-9959
>                 URL: https://issues.apache.org/jira/browse/MESOS-9959
>             Project: Mesos
>          Issue Type: Improvement
>          Components: allocation
>            Reporter: Andrei Sekretenko
>            Priority: Major
>              Labels: resource-management
>
> Currently, the master actor and the `/roles` endpoint use  the following 
> names for different resource subsets:
> there is an offer with this resource -> *offered*
> there is a task/executor running on this resource -> *allocated*
> resource is reserved (maybe offered or allocated, maybe not) -> *reserved*
> resource is subject to quota and allocated or reserved ->* quota consumption*
> (note that *offered* and *allocated* are disjoint: a resource is either 
> allocated or offered, but never both)
> However, the word *allocated* (and related ones) are still used throughout 
> the allocator code for designating all resources which has been offered at 
> some point but have not been recovered yet.
> We should make the nomenclature used in the allocator code consistent with 
> the master.



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Reply via email to