[jira] [Updated] (KAFKA-18582) Rename num_zk parameter in e2e

2026-08-13 Thread Omnia Ibrahim (Jira)


 [ 
https://issues.apache.org/jira/browse/KAFKA-18582?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Omnia Ibrahim updated KAFKA-18582:
--
Fix Version/s: 4.5.0
   (was: 4.4.0)

> Rename num_zk parameter in e2e
> --
>
> Key: KAFKA-18582
> URL: https://issues.apache.org/jira/browse/KAFKA-18582
> Project: Kafka
>  Issue Type: Improvement
>  Components: system tests
>Reporter: TengYao Chi
>Assignee: TengYao Chi
>Priority: Major
> Fix For: 4.5.0
>
>
> `num_zk` parameter is confusingly named since it serves two purposes: it 
> defines both the zk quorum size and can override the number of KRaft 
> controllers. We should rename this parameter.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Updated] (KAFKA-18582) Rename num_zk parameter in e2e

2026-04-09 Thread Mickael Maison (Jira)


 [ 
https://issues.apache.org/jira/browse/KAFKA-18582?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Mickael Maison updated KAFKA-18582:
---
Fix Version/s: 4.4.0
   (was: 4.3.0)

> Rename num_zk parameter in e2e
> --
>
> Key: KAFKA-18582
> URL: https://issues.apache.org/jira/browse/KAFKA-18582
> Project: Kafka
>  Issue Type: Improvement
>  Components: system tests
>Reporter: TengYao Chi
>Assignee: TengYao Chi
>Priority: Major
> Fix For: 4.4.0
>
>
> `num_zk` parameter is confusingly named since it serves two purposes: it 
> defines both the zk quorum size and can override the number of KRaft 
> controllers. We should rename this parameter.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Updated] (KAFKA-18582) Rename num_zk parameter in e2e

2025-12-18 Thread Christo Lolov (Jira)


 [ 
https://issues.apache.org/jira/browse/KAFKA-18582?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Christo Lolov updated KAFKA-18582:
--
Fix Version/s: 4.3.0
   (was: 4.2.0)

> Rename num_zk parameter in e2e
> --
>
> Key: KAFKA-18582
> URL: https://issues.apache.org/jira/browse/KAFKA-18582
> Project: Kafka
>  Issue Type: Improvement
>  Components: system tests
>Reporter: TengYao Chi
>Assignee: TengYao Chi
>Priority: Major
> Fix For: 4.3.0
>
>
> `num_zk` parameter is confusingly named since it serves two purposes: it 
> defines both the zk quorum size and can override the number of KRaft 
> controllers. We should rename this parameter.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)


[jira] [Updated] (KAFKA-18582) Rename num_zk parameter in e2e

2025-06-25 Thread Mickael Maison (Jira)


 [ 
https://issues.apache.org/jira/browse/KAFKA-18582?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Mickael Maison updated KAFKA-18582:
---
Fix Version/s: 4.2.0
   (was: 4.1.0)

> Rename num_zk parameter in e2e
> --
>
> Key: KAFKA-18582
> URL: https://issues.apache.org/jira/browse/KAFKA-18582
> Project: Kafka
>  Issue Type: Improvement
>  Components: system tests
>Reporter: TengYao Chi
>Assignee: TengYao Chi
>Priority: Major
> Fix For: 4.2.0
>
>
> `num_zk` parameter is confusingly named since it serves two purposes: it 
> defines both the zk quorum size and can override the number of KRaft 
> controllers. We should rename this parameter.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)