This is a bug-fix release with the following changes:

   - Export endpoint_from_name as well (#174)
   - Rename Endpoint.joined to Endpoint.is_joined (#168)
   - Only pass one copy of self to Endpoint method handlers (#172)
   - Make Endpoint.from_flag return None for unset flags (#173)
   - Fix hard-coded version in docs config (#167)
   - Fix documentation of unit_name and application_name on RelatedUnit
   (#165)
   - Fix setdefault on Endpoint data collections (#163)

The full changelog can be found at
https://charmsreactive.readthedocs.io/en/latest/changelog.html

A special call-out of the change from #173 is warranted: the
endpoint_from_flag (previously relation_from_state) helper was incorrectly
returning an Endpoint instance when the flag in question was not set if an
interface layer was implemented using the new Endpoint pattern.  It now
returns None to match the previous behavior with RelationBase
implementations.  If for some reason you need to get an instance of the
Endpoint regardless of the state of the flag, you can use
endpoint_from_name with the name of the endpoint rather than the full flag,
although this is not generally recommended as it does not work with older
RelationBase implementations, since they require the context provided by
the flag.
-- 
Juju mailing list
Juju@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/juju

Reply via email to