Re: Makefile target names

2015-01-22 Thread Simon Davy
On 22 January 2015 at 15:13, David Britton david.brit...@canonical.com wrote: lint: - make lint Could we also make[1] the charm linter lint the makefile for the presence of targets agreed in the outcome of this thread? [1] Pun fully intended :) -- Simon -- Juju mailing list

Re: Makefile target names

2015-01-22 Thread Charles Butler
On Thu, Jan 22, 2015 at 10:13 AM, David Britton david.brit...@canonical.com wrote: functional tests: - make functional-test We need to be careful about things like this - as bundletester is already looking in tests/ for the amulet suite and might end up running the integration tests

Re: Makefile target names

2015-01-22 Thread Ryan Beisner
Thanks for pointing out the yaml control file, that could be useful. But before we make any modifications to the OpenStack charms, I think it would be helpful to have an agreed-upon convention for the following in terms of Makefile target names: - nose / unit tests - make test

Re: Makefile target names

2015-01-22 Thread David Britton
+1, but I would propose using hyphens for word separators, not underscores -- at least for the recommendation. I would also recommend *not* having multiple default names. As mentioned, the yaml control file I think can be used to override all this, so it still leaves room for individual

Re: Makefile target names

2015-01-22 Thread Ryan Beisner
Same here, the OpenStack charms have charm proof in the lint target. I expect it would be run twice in that case. On Thu, Jan 22, 2015 at 10:36 AM, Simon Davy bloodearn...@gmail.com wrote: On 22 January 2015 at 16:29, David Britton david.brit...@canonical.com wrote: On Thu, Jan 22, 2015 at

Re: Makefile target names

2015-01-22 Thread Wes Mason
On 22 January 2015 at 16:36, Simon Davy bloodearn...@gmail.com wrote: On 22 January 2015 at 16:29, David Britton david.brit...@canonical.com wrote: On Thu, Jan 22, 2015 at 04:17:26PM +, Simon Davy wrote: On 22 January 2015 at 15:13, David Britton david.brit...@canonical.com wrote:

Re: Makefile target names

2015-01-22 Thread Tim Van Steenburgh
Marco, I like your proposal with one change - we don't need the test.yaml changes. Instead I would suggest we add 'unit-test' to the list of default bundletester targets. So bundletester will run proof, lint, test, and unit-test (charm author should choose test or unit-test, not both).

Re: Makefile target names

2015-01-22 Thread Simon Davy
On 22 January 2015 at 16:29, David Britton david.brit...@canonical.com wrote: On Thu, Jan 22, 2015 at 04:17:26PM +, Simon Davy wrote: On 22 January 2015 at 15:13, David Britton david.brit...@canonical.com wrote: lint: - make lint Could we also make[1] the charm linter lint the

Re: Makefile target names

2015-01-22 Thread Marco Ceppi
We can also add Makefile checking to charm proof, for an even greater redundancy. To avoid multiple invocations of charm proof (not terrible, IMO) lint could be broken down further: lint: proof code_lint proof: charm proof code_lint: # Your code here Then have bundle tester sniff out

Re: Makefile target names

2015-01-22 Thread David Britton
On Thu, Jan 22, 2015 at 04:57:36PM +, Marco Ceppi wrote: test: lint unit-test functional-test -1, I'd rather 'test' be unit testing only. Many charms have this already and it seems like unecessary busy work to change it. ``` makefile: - code-lint - unit-test ``` -1, vote for

Re: Makefile target names

2015-01-21 Thread Benjamin Saller
policy. -Ben On Wed, Jan 21, 2015 at 9:05 AM, Ryan Beisner ryan.beis...@canonical.com wrote: Greetings, I'd like to invite discussion on Makefile target names. I've seen a few different takes on Makefile target naming conventions across charms. For example, in the OpenStack charms, `make

Makefile target names

2015-01-21 Thread Ryan Beisner
Greetings, I'd like to invite discussion on Makefile target names. I've seen a few different takes on Makefile target naming conventions across charms. For example, in the OpenStack charms, `make test` runs amulet and `make unit_test` performs nose tests. In many/most other charms, `make test