[valgrind] [Bug 385207] PPC64, generate_store_FPRF() generates too many Iops

2017-10-05 Thread Carl Love
https://bugs.kde.org/show_bug.cgi?id=385207

Carl Love  changed:

   What|Removed |Added

 Status|RESOLVED|CLOSED

-- 
You are receiving this mail because:
You are watching all bug changes.

[valgrind] [Bug 385207] PPC64, generate_store_FPRF() generates too many Iops

2017-10-05 Thread Carl Love
https://bugs.kde.org/show_bug.cgi?id=385207

Carl Love  changed:

   What|Removed |Added

 Status|CONFIRMED   |RESOLVED
 Resolution|--- |FIXED

-- 
You are receiving this mail because:
You are watching all bug changes.

[valgrind] [Bug 385207] PPC64, generate_store_FPRF() generates too many Iops

2017-10-03 Thread Carl Love
https://bugs.kde.org/show_bug.cgi?id=385207

Carl Love  changed:

   What|Removed |Added

 Status|UNCONFIRMED |CONFIRMED
 Ever confirmed|0   |1

--- Comment #3 from Carl Love  ---
patch committed:  commit acdeb75d2a58f4f3910ddaf9b2bc2ec74378fa3a

-- 
You are receiving this mail because:
You are watching all bug changes.

[valgrind] [Bug 385207] PPC64, generate_store_FPRF() generates too many Iops

2017-10-03 Thread Julian Seward
https://bugs.kde.org/show_bug.cgi?id=385207

--- Comment #2 from Julian Seward  ---
+#define V128_FRACTION_MASK 0xULL  /* upper 64-bit fractional
mask */
+
+ULong generate_C_FPCC_helper( ULong size, ULong src_hi, ULong src ) {
+   UInt NaN, inf, zero, norm, dnorm, pos;
+   UInt bit0, bit1, bit2, bit3;

* nit: { on its own line, in the house style

* Please rename 'size' here to 'irType', because that's what it really is



+   if ( size == Ity_I16 ) {
+  frac_part = I16_FRACTION_MASK & src;
+  exp_mask = I16_EXP_MASK;
...
+ exp_mask = V128_EXP_MASK;
+ exp_part = exp_mask & src_hi;
+ sign_bit = src_hi >> 63;
+   }

Add

  else {
vassert(0);
  }

so as to cause the system to fail if any other value is passed for irType.


OK to land with the above points fixed.

-- 
You are receiving this mail because:
You are watching all bug changes.

[valgrind] [Bug 385207] PPC64, generate_store_FPRF() generates too many Iops

2017-09-29 Thread Carl Love
https://bugs.kde.org/show_bug.cgi?id=385207

--- Comment #1 from Carl Love  ---
Created attachment 108093
  --> https://bugs.kde.org/attachment.cgi?id=108093=edit
replace body of generate_store_FPRF with C helper  function.

replace the generate_store_FPRF function body with a C Helper function.

-- 
You are receiving this mail because:
You are watching all bug changes.