D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-28 Thread David Faure
dfaure added inline comments. INLINE COMMENTS > broulik wrote in applicationlauncherjob.cpp:155 > With this it starts to look as hard to follow as KRun :) Not even close :-) (OpenUrlJob will be more complicated, somewhere in between this one and KRun...) REPOSITORY R241 KIO BRANCH

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-28 Thread David Faure
This revision was automatically updated to reflect the committed changes. Closed by commit R241:f0ae038490e6: Move handling of untrusted programs to ApplicationLauncherJob. (authored by dfaure). REPOSITORY R241 KIO CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D29153?vs=81173=81472

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-28 Thread Kai Uwe Broulik
broulik accepted this revision. broulik added inline comments. This revision is now accepted and ready to land. INLINE COMMENTS > applicationlauncherjob.cpp:155 > +} > +proceedAfterSecurityChecks(); > +} With this it starts to look as hard to follow as KRun :) REPOSITORY R241 KIO

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-27 Thread David Faure
dfaure added a comment. @broulik ping? REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D29153 To: dfaure, ahmadsamir, broulik, ngraham, mdlubakowski Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-26 Thread David Faure
dfaure added a task: T11549: KIO: remove unneeded QWidget dependencies to set parent windows or display errors. REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D29153 To: dfaure, ahmadsamir, broulik, ngraham, mdlubakowski Cc: kde-frameworks-devel, LeGast00n, cblack,

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-25 Thread David Faure
dfaure added a comment. > The question is how that will work in conjunction with KNotificationJobUiDelegate? In principle we could also make it emit a KNotification with buttons We would need a KIO::NotificationJobUiDelegate subclass of KNotificationJobUiDelegate in KIOGui, which also

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-25 Thread David Faure
dfaure updated this revision to Diff 81173. dfaure added a comment. Make UntrustedProgramHandlerInterface async. This required a nasty QEventLoop for KRun though, since it has a sync API. REPOSITORY R241 KIO CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D29153?vs=81158=81173

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-25 Thread David Faure
dfaure added inline comments. INLINE COMMENTS > broulik wrote in untrustedprogramhandlerinterface.h:79 > I was wondering if this should be done async? Nested event loops are quite a > problem when QML is involved. I don't see a nested event loop in makeServiceFileExecutable. I guess your

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-25 Thread Kai Uwe Broulik
broulik added a comment. The question is how that will work in conjunction with `KNotificationJobUiDelegate`? In principle we could also make it emit a `KNotification` with buttons INLINE COMMENTS > untrustedprogramhandlerinterface.h:79 > + */ > +bool

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-25 Thread David Faure
dfaure updated this revision to Diff 81158. dfaure added a comment. Also set a KIO::JobUiDelegate in KRun itself (which simplifies its code) REPOSITORY R241 KIO CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D29153?vs=8=81158 BRANCH 2020_04_UntrustedProgramHandler REVISION

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-24 Thread David Faure
dfaure added a reviewer: mdlubakowski. REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D29153 To: dfaure, ahmadsamir, broulik, ngraham, mdlubakowski Cc: kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-24 Thread David Faure
dfaure updated this revision to Diff 8. dfaure added a comment. Fix error message box after the user clicks Cancel. REPOSITORY R241 KIO CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D29153?vs=81108=8 BRANCH 2020_04_UntrustedProgramHandler REVISION DETAIL

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-24 Thread David Faure
dfaure updated this revision to Diff 81108. dfaure added a comment. improve docu, add test in kruntest REPOSITORY R241 KIO CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D29153?vs=81101=81108 BRANCH 2020_04_UntrustedProgramHandler REVISION DETAIL

D29153: Move handling of untrusted programs to ApplicationLauncherJob.

2020-04-24 Thread David Faure
dfaure created this revision. dfaure added reviewers: ahmadsamir, broulik, ngraham. Herald added a project: Frameworks. Herald added a subscriber: kde-frameworks-devel. dfaure requested review of this revision. REVISION SUMMARY This was still in KRun so the porting to ApplicationLauncherJob