D29526: Thumbnails: make thumbnail generation dpr-aware

2020-09-08 Thread Stefan Brüns
bruns added a comment. In D29526#676402 , @meven wrote: > In D29526#676386 , @bruns wrote: > > > For all but text the DPR is completely irrelevant, large@1 is identical to normal@2. > > > Yes

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-09-08 Thread Méven Car
meven added a comment. In D29526#676386 , @bruns wrote: > For all but text the DPR is completely irrelevant, large@1 is identical to normal@2. Yes and that's up to thumbnail creators to decide. To take advantage of this, we would need

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-09-07 Thread Stefan Brüns
bruns added inline comments. INLINE COMMENTS > imagecreator.cpp:48 > +ir.setQuality(75); // set quality so that the jpeg handler will use a > high quality downscaler > + > img = ir.read(); This whole hunk should not be part of this submission. Also, the comment ("jpeg") is likely

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-09-07 Thread Stefan Brüns
bruns added inline comments. INLINE COMMENTS > thumbnail.cpp:143 > > +bool createThumbnail(ThumbCreator *creator, const QString , int width, > int height, QImage , qreal devicePixelRatio = 1.0) > +{ Has to be static or in an anonymous namespace. > thumbnail.cpp:149 > +} else { > +

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-09-07 Thread Stefan Brüns
bruns requested changes to this revision. bruns added a comment. This revision now requires changes to proceed. For all but text the DPR is completely irrelevant, large@1 is identical to normal@2. REPOSITORY R320 KIO Extras REVISION DETAIL https://phabricator.kde.org/D29526 To: meven,

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-09-07 Thread Méven Car
meven added a comment. I just sent a specification evolution to cover this use case : https://gitlab.freedesktop.org/xdg/xdg-specs/-/merge_requests/35 REPOSITORY R320 KIO Extras REVISION DETAIL https://phabricator.kde.org/D29526 To: meven, #frameworks, dfaure, broulik, sitter, ngraham

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-05-13 Thread Méven Car
meven added inline comments. INLINE COMMENTS > sitter wrote in thumbnail.cpp:774 > Var naming is a bit inconsistent across the code base now. In the > implementations there are maxWidth/H that are device-adjusted but in here > they are not. Not a huge concern, just noticed. Will take care >

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-05-13 Thread Harald Sitter
sitter added a comment. You do seem to calculate the deviceWidth and height an awful lot, it makes reading a bit clunky. I'd much rather have the multiplication done once and then always use the var instead. In fact, perhaps it'd make sense to have createV3 feed the values into the

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-05-09 Thread Méven Car
meven updated this revision to Diff 82332. meven added a comment. Store thumbnails with dpr 2 in @2x folders REPOSITORY R320 KIO Extras CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D29526?vs=82254=82332 BRANCH thumbnail-dpr REVISION DETAIL

D29526: Thumbnails: make thumbnail generation dpr-aware

2020-05-08 Thread Méven Car
meven created this revision. meven added reviewers: Frameworks, dfaure, broulik, sitter, ngraham. Herald added projects: Dolphin, Frameworks. Herald added subscribers: kfm-devel, kde-frameworks-devel. meven requested review of this revision. REVISION SUMMARY Thumbnail ioslave can now receive a