D10363: [KIO] Add support for XDG_TEMPLATES_DIR in KNewFileMenu

2018-04-29 Thread Marijo Mustac
mmustac marked an inline comment as done. mmustac added a comment. No problem David, it's okay :) I will work on your suggestions and update this revision accordingly. > But actually, shouldn't we still have New Folder and New Text File at the top before everything else? Kai mentio

D12593: KFileWidget: Save places panel width also after hiding panel

2018-04-29 Thread Nathaniel Graham
ngraham accepted this revision. ngraham added a comment. This revision is now accepted and ready to land. Nice catch. REPOSITORY R241 KIO BRANCH fix-hidden-places-width-saving (branched from master) REVISION DETAIL https://phabricator.kde.org/D12593 To: rkflx, #frameworks, ngraham Cc:

D12590: KFileWidget: Disable zoom buttons once reached minimum or maximum

2018-04-29 Thread Nathaniel Graham
ngraham added a comment. Looks and works great; just one style comment below: INLINE COMMENTS > kfilewidget.cpp:108 > + iconSizeSlider(nullptr), > + furtherAction(nullptr), > + closerAction(nullptr) While we're at it, why don't we rename these to be clearer: I'd pr

D11880: Add firewalld icons

2018-04-29 Thread Noah Davis
ndavis added a comment. Can someone review this? REPOSITORY R266 Breeze Icons REVISION DETAIL https://phabricator.kde.org/D11880 To: ndavis, #vdg, #breeze Cc: #frameworks, michaelh, bruns

D12588: KFileWidget: Set minimum size for zoom slider

2018-04-29 Thread Nathaniel Graham
ngraham accepted this revision. ngraham added a comment. This revision is now accepted and ready to land. Perfecto. REPOSITORY R241 KIO BRANCH slider-min-size (branched from master) REVISION DETAIL https://phabricator.kde.org/D12588 To: rkflx, #frameworks, ngraham Cc: ngraham, michael

D12592: KFileWidget: Prevent places panel width from growing 1px iteratively

2018-04-29 Thread Nathaniel Graham
ngraham accepted this revision. ngraham added a comment. This revision is now accepted and ready to land. Indeed, very nice! REPOSITORY R241 KIO BRANCH fix-places-width-growth (branched from master) REVISION DETAIL https://phabricator.kde.org/D12592 To: rkflx, #frameworks, ngraham Cc:

D12594: KFileWidget: Perfectly align filename widget with icon view

2018-04-29 Thread Nathaniel Graham
ngraham accepted this revision. ngraham added a comment. This revision is now accepted and ready to land. Ah yes, this tiny discrepancy was so annoying. With this patch, alignment is also perfect when the Filter combobox turns into a dropdown menu button for many save dialogs. Unrelatedl

D12420: Make the warning text for deletion operations emphasize its permanency and irreversibility

2018-04-29 Thread Nathaniel Graham
ngraham edited the test plan for this revision. REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D12420 To: ngraham, #frameworks, #dolphin, elvisangelaccio Cc: broulik, michaelh, bruns

D12420: Make the warning text for deletion operations emphasize its permanency and irreversibility

2018-04-29 Thread Nathaniel Graham
ngraham updated this revision to Diff 33310. ngraham added a comment. Add extra linebreak and fix a tag REPOSITORY R241 KIO CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D12420?vs=33074&id=33310 BRANCH more-serious-delete-text (branched from master) REVISION DETAIL https://p

D12420: Make the warning text for deletion operations emphasize its permanency and irreversibility

2018-04-29 Thread Nathaniel Graham
ngraham marked an inline comment as done. REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D12420 To: ngraham, #frameworks, #dolphin, elvisangelaccio Cc: broulik, michaelh, bruns

D12591: KFileWidget: Provide faster access to the icon position setting

2018-04-29 Thread Nathaniel Graham
ngraham accepted this revision. ngraham added a comment. This revision is now accepted and ready to land. +1, much better than having a submenu with only two items when the main menu is itself not very big. Works great. One thought: with this patch, there will be two disabled and inapplic

D12587: Indentation script for R

2018-04-29 Thread Dominik Haumann
dhaumann added a comment. @devillemereuil If I remember correctly, you do not have to run all tests. It is enough to start the indenter test (look into the bin folder) and add as parameter you indent test folder (relative, e.g. cstyle). And, what Thomas says is correct. Typically a test case

D12587: Indentation script for R

2018-04-29 Thread Thomas Friedrichsmeier
tfry added a comment. Regarding the unit tests: Take a look at e.g. https://cgit.kde.org/ktexteditor.git/tree/autotests/input/indent/cmake/enter1 . You start with an initial text "origin", then emulate some input "input.js", an specify the expected state at the end "expected". Again, I

D12321: Hide file preview when icon is too small

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added a comment. In D12321#253903 , @rkflx wrote: > @elvisangelaccio We'd love to hear your opinion on the feature and on the code, and we'd be interested whether the same change would be a good idea for #Dolphin

D12321: Hide file preview when icon is too small

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added inline comments. INLINE COMMENTS > kdiroperator.cpp:2589 > + > +KToggleAction *previewAction = static_cast *>(actionCollection->action(QStringLiteral("inline preview"))); > +previewAction->setEnabled(iconSizeBigEnoughForPreview); `qobject_cast` > kdiroperator.cpp:2

D12593: KFileWidget: Save places panel width also after hiding panel

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added a comment. +1 REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D12593 To: rkflx, #frameworks Cc: elvisangelaccio, michaelh, bruns

D12591: KFileWidget: Provide faster access to the icon position setting

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added a comment. > While the submenu itself is not advertised in the API docs, it was publicly accessible Where? Isn't it a member of `KDirOperator::Private`? (I'm referring to `decorationMenu`) REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D12591

D12594: KFileWidget: Perfectly align filename widget with icon view

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added a comment. +1 REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D12594 To: rkflx, #frameworks Cc: elvisangelaccio, michaelh, bruns

D12327: Show Detailed Tree View by default

2018-04-29 Thread Nathaniel Graham
ngraham added a comment. In D12327#255621 , @elvisangelaccio wrote: > FWIW I also disagree with D12077 . I don't see why we should show only two buttons (for short and detailed tree view), when we have four v

D12592: KFileWidget: Prevent places panel width from growing 1px iteratively

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added a comment. Wow, excellent analysis. +1 REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D12592 To: rkflx, #frameworks Cc: elvisangelaccio, michaelh, bruns

D12327: Show Detailed Tree View by default

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added a comment. In D12327#250799 , @rkflx wrote: > In D12327#250797 , @elvisangelaccio wrote: > > > But Detailed View and Detailed Tree View are two different things, no? (I'm not e

D12508: Make KMessageWidget match Kirigami inlineMessage's style

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio resigned from this revision. elvisangelaccio added a comment. I'll just leave my +1 to the visual change. REPOSITORY R236 KWidgetsAddons REVISION DETAIL https://phabricator.kde.org/D12508 To: ngraham, hein, #plasma, #vdg, cfeck Cc: broulik, anemeth, abetts, cfeck, mart, f

D12599: KFileOperator: fix apidox of fileHighlighted()

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio created this revision. elvisangelaccio added a reviewer: dfaure. Restricted Application added a project: Frameworks. Restricted Application added a subscriber: Frameworks. elvisangelaccio requested review of this revision. REVISION SUMMARY Since 966f0b2054

D12544: Don't select file extension

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added inline comments. INLINE COMMENTS > kfilewidget.cpp:1290 > > // don't change selection when user has clicked on an item > +if (operationMode == KFileWidget::Saving) { This comment makes little sense to me. Since it was part of the same commit spotted by @rkflx (0

D12591: KFileWidget: Provide faster access to the icon position setting

2018-04-29 Thread Henrik Fehlauer
rkflx added a dependent revision: D12598: FileView: Provide faster access to the icon position setting. REPOSITORY R241 KIO REVISION DETAIL https://phabricator.kde.org/D12591 To: rkflx, #frameworks Cc: michaelh, bruns

D11863: Add virt-manager icons

2018-04-29 Thread Andreas Kainz
andreask closed this revision. andreask added a comment. Thanks for the commit. I checked the icons and optimize the icon size. virt-manager is now in master. https://cgit.kde.org/breeze-icons.git/commit/?id=63450fec7aa14ba3a32972a434064c499ea048a9 REPOSITORY R266 Breeze Icons RE

D11880: Add firewalld icons

2018-04-29 Thread Noah Davis
ndavis added a reviewer: Breeze. REPOSITORY R266 Breeze Icons REVISION DETAIL https://phabricator.kde.org/D11880 To: ndavis, #vdg, #breeze Cc: #frameworks, michaelh, bruns

D11863: Add virt-manager icons

2018-04-29 Thread Noah Davis
ndavis added a reviewer: Breeze. REPOSITORY R266 Breeze Icons BRANCH virt-manager_icons (branched from master) REVISION DETAIL https://phabricator.kde.org/D11863 To: ndavis, #vdg, ngraham, andreaska, andreask, #breeze Cc: ngraham, andreaska, #frameworks, michaelh, bruns

D11863: Add virt-manager icons

2018-04-29 Thread Noah Davis
ndavis added a comment. Since I don't have a developer account, can someone land this for me? REPOSITORY R266 Breeze Icons BRANCH virt-manager_icons (branched from master) REVISION DETAIL https://phabricator.kde.org/D11863 To: ndavis, #vdg, ngraham, andreaska, andreask Cc: ngraham, an

D12587: Indentation script for R

2018-04-29 Thread Pierre de Villemereuil
devillemereuil added a comment. In D12587#255484 , @dhaumann wrote: > I think this is very cool. But there is one thing we require for new indenters: unit tests. > > There is a subfolder autotest in the KTextEditor git module. Could you have

D12420: Make the warning text for deletion operations emphasize its permanency and irreversibility

2018-04-29 Thread Elvis Angelaccio
elvisangelaccio added a comment. I liked more the version with two newlines before the bold sentence, is there a reason why you changed to only one? INLINE COMMENTS > jobuidelegate.cpp:239 > widget, > - i18nc("@info", "Do you want to permanen

D12587: Indentation script for R

2018-04-29 Thread Dominik Haumann
dhaumann added a comment. I think this is very cool. But there is one thing we require for new indenters: unit tests. There is a subfolder autotest in the KTextEditor git module. Could you have a look into this? Without such automated tests, we will likely introduce regressions in futur