D28745: Skip caching thumbnails on encrypted filesystems

2020-08-27 Thread Marcin Gurtowski
marcingu marked 2 inline comments as done.

REPOSITORY
  R320 KIO Extras

REVISION DETAIL
  https://phabricator.kde.org/D28745

To: marcingu, ivan, broulik, #dolphin, ngraham, meven, bruns, dfaure
Cc: dfaure, thiago, bruns, meven, ngraham, kde-frameworks-devel, kfm-devel, 
waitquietly, azyx, nikolaik, pberestov, iasensio, aprcela, fprice, LeGast00n, 
cblack, fbampaloukas, alexde, Codezela, feverfew, michaelh, spoorun, 
navarromorales, firef, andrebarros, emmanuelp, rdieter, mikesomov


D28745: Skip caching thumbnails on encrypted filesystems

2020-08-27 Thread Marcin Gurtowski
marcingu updated this revision to Diff 83358.
marcingu added a comment.


  Renaming "deviceIdUnset" to "s_deviceIdUnset"

REPOSITORY
  R320 KIO Extras

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D28745?vs=83357&id=83358

REVISION DETAIL
  https://phabricator.kde.org/D28745

AFFECTED FILES
  thumbnail/thumbnail.cpp
  thumbnail/thumbnail.h

To: marcingu, ivan, broulik, #dolphin, ngraham, meven, bruns, dfaure
Cc: dfaure, thiago, bruns, meven, ngraham, kde-frameworks-devel, kfm-devel, 
waitquietly, azyx, nikolaik, pberestov, iasensio, aprcela, fprice, LeGast00n, 
cblack, fbampaloukas, alexde, Codezela, feverfew, michaelh, spoorun, 
navarromorales, firef, andrebarros, emmanuelp, rdieter, mikesomov


D28745: Skip caching thumbnails on encrypted filesystems

2020-08-27 Thread David Faure
dfaure added inline comments.

INLINE COMMENTS

> thumbnail.cpp:741
> +bool allowCache;
> +allowCache = sharesFilesystemWithThumbRoot(filePath);
> +if (!allowCache) {

join with previous line (this isn't C) ;)

> thumbnail.h:95
> +#ifndef Q_OS_WIN
> +static const dev_t deviceIdUnset = std::numeric_limits::max();
> +dev_t m_thumbnailDirDeviceId = deviceIdUnset;

Suggestion: name it s_deviceIdUnset (s for static, to match m for member).

This makes things more readable when looking at the .cpp file (looks like a 
local variable otherwise).

REPOSITORY
  R320 KIO Extras

REVISION DETAIL
  https://phabricator.kde.org/D28745

To: marcingu, ivan, broulik, #dolphin, ngraham, meven, bruns, dfaure
Cc: dfaure, thiago, bruns, meven, ngraham, kde-frameworks-devel, kfm-devel, 
waitquietly, azyx, nikolaik, pberestov, iasensio, aprcela, fprice, LeGast00n, 
cblack, fbampaloukas, alexde, Codezela, feverfew, michaelh, spoorun, 
navarromorales, firef, andrebarros, emmanuelp, rdieter, mikesomov