D27709: Move job classes to kaccounts lib and rename to *Job

2020-02-28 Thread Nicolas Fella
This revision was automatically updated to reflect the committed changes.
Closed by commit R155:2030bb498ed3: Move job classes to kaccounts lib and 
rename to *Job (authored by nicolasfella).

REPOSITORY
  R155 KAccounts Integration

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D27709?vs=76580=76609

REVISION DETAIL
  https://phabricator.kde.org/D27709

AFFECTED FILES
  example/accounts.qml
  src/declarative/CMakeLists.txt
  src/declarative/kaccountsdeclarativeplugin.cpp
  src/jobs/accountservicetoggle.cpp
  src/jobs/accountservicetoggle.h
  src/jobs/createaccount.cpp
  src/jobs/createaccount.h
  src/kcm/package/contents/ui/AvailableAccounts.qml
  src/kcm/package/contents/ui/AvailableServices.qml
  src/lib/CMakeLists.txt
  src/lib/accountservicetogglejob.cpp
  src/lib/accountservicetogglejob.h
  src/lib/createaccountjob.cpp
  src/lib/createaccountjob.h
  src/lib/uipluginsmanager.cpp

To: nicolasfella, #frameworks, bshah, leinir


D27709: Move job classes to kaccounts lib and rename to *Job

2020-02-28 Thread Dan Leinir Turthra Jensen
leinir accepted this revision.
leinir added a comment.
This revision is now accepted and ready to land.


  As i was going to do this as part of something else, i obviously think this 
is a good idea ;) And yes, the thought process behind it was indeed that this 
is something that'd just make sense in general, not just from QML.

REPOSITORY
  R155 KAccounts Integration

BRANCH
  decl

REVISION DETAIL
  https://phabricator.kde.org/D27709

To: nicolasfella, #frameworks, bshah, leinir


D27709: Move job classes to kaccounts lib and rename to *Job

2020-02-27 Thread Nicolas Fella
nicolasfella retitled this revision from "Move job classes to kaccounts lib" to 
"Move job classes to kaccounts lib and rename to *Job".

REPOSITORY
  R155 KAccounts Integration

REVISION DETAIL
  https://phabricator.kde.org/D27709

To: nicolasfella, #frameworks, bshah, leinir