D10747: Implement zwp_linux_dmabuf_v1

2019-08-06 Thread Roman Gilg
This revision was not accepted when it landed; it landed in state "Needs Review". This revision was automatically updated to reflect the committed changes. Closed by commit R127:1dd57d909165: Implement zwp_linux_dmabuf_v1 (authored by romangg). REPOSITORY R127 KWayland CHANGES SINCE LAST

D10747: Implement zwp_linux_dmabuf_v1

2019-08-06 Thread Roman Gilg
romangg edited the test plan for this revision. REPOSITORY R127 KWayland REVISION DETAIL https://phabricator.kde.org/D10747 To: romangg, #kwin, #plasma, graesslin, davidedmundson, mart, fredrik Cc: zzag, kde-frameworks-devel, romangg, plasma-devel, LeGast00n, hannahk, jraleigh, sgureev,

D10747: Implement zwp_linux_dmabuf_v1

2019-08-06 Thread Roman Gilg
romangg updated this revision to Diff 63224. romangg added a comment. Rebase on master. REPOSITORY R127 KWayland CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D10747?vs=61912=63224 BRANCH dmaBuf REVISION DETAIL https://phabricator.kde.org/D10747 AFFECTED FILES

D10747: Implement zwp_linux_dmabuf_v1

2019-07-17 Thread Roman Gilg
romangg added a comment. If there are no objections I would push this soon. There is one remaining annoyance I have with the current version: the name of the class inside the interface the compositor has to subclass for interfacing with KWayland. I changed the name from Bridge to Impl

D10747: Implement zwp_linux_dmabuf_v1

2019-07-17 Thread Roman Gilg
romangg updated this revision to Diff 61912. romangg added a comment. - Rebase on master - Use packaged dma-buf xml REPOSITORY R127 KWayland CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D10747?vs=60654=61912 BRANCH dmaBuf REVISION DETAIL

D10747: Implement zwp_linux_dmabuf_v1

2019-06-29 Thread Vlad Zagorodniy
zzag added a comment. > Update protocol xml to wayland-protocols master OT: there's a package called wayland-protocols. We could use it in order to avoid copying protocol specs. name=FindWaylandProtocols.cmake #.rst: # FindWaylandProtocols # --- # # Try to

D10747: Implement zwp_linux_dmabuf_v1

2019-06-27 Thread Roman Gilg
romangg added a dependent revision: D10750: wayland: Add support for zwp_linux_dmabuf. REPOSITORY R127 KWayland REVISION DETAIL https://phabricator.kde.org/D10747 To: romangg, #kwin, #plasma, graesslin, davidedmundson, mart, fredrik Cc: kde-frameworks-devel, romangg, plasma-devel,

D10747: Implement zwp_linux_dmabuf_v1

2019-06-25 Thread Roman Gilg
romangg edited the test plan for this revision. REPOSITORY R127 KWayland REVISION DETAIL https://phabricator.kde.org/D10747 To: romangg, #kwin, #plasma, graesslin, davidedmundson, mart, fredrik Cc: kde-frameworks-devel, romangg, plasma-devel, LeGast00n, hannahk, jraleigh, sgureev,

D10747: Implement zwp_linux_dmabuf_v1

2019-06-25 Thread Roman Gilg
romangg updated this revision to Diff 60654. romangg added a comment. - D-pointer DmaBufBuffer - Only allow one create request in any case - Params in private interface class - typedef for LinuxDmabufUnstableV1Interface - Small cleanup - Set buffer privates and delete impl on

D10747: Implement zwp_linux_dmabuf_v1

2019-06-23 Thread Roman Gilg
romangg updated this revision to Diff 60429. romangg added a comment. - Update protocol xml to wayland-protocols master REPOSITORY R127 KWayland CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D10747?vs=60366=60429 BRANCH dmaBuf REVISION DETAIL

D10747: Implement zwp_linux_dmabuf_v1

2019-06-22 Thread Roman Gilg
romangg updated this revision to Diff 60366. romangg added a comment. - Minor style changes REPOSITORY R127 KWayland CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D10747?vs=60364=60366 BRANCH dmaBuf REVISION DETAIL https://phabricator.kde.org/D10747 AFFECTED FILES

D10747: Implement zwp_linux_dmabuf_v1

2019-06-22 Thread Roman Gilg
romangg updated this revision to Diff 60364. romangg added a comment. - Revert drm_fourcc.h whitespace changes REPOSITORY R127 KWayland CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D10747?vs=60360=60364 BRANCH dmaBuf REVISION DETAIL https://phabricator.kde.org/D10747

D10747: Implement zwp_linux_dmabuf_v1

2019-06-22 Thread Roman Gilg
romangg updated this revision to Diff 60360. romangg added a comment. Rebase on master. REPOSITORY R127 KWayland CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D10747?vs=28986=60360 BRANCH dmaBuf REVISION DETAIL https://phabricator.kde.org/D10747 AFFECTED FILES

D10747: Implement zwp_linux_dmabuf_v1

2019-06-22 Thread Roman Gilg
romangg commandeered this revision. romangg added a reviewer: fredrik. romangg added a comment. Thanks @fredrik for initiating this. I'll try to finish the patches up. REPOSITORY R127 KWayland REVISION DETAIL https://phabricator.kde.org/D10747 To: romangg, #kwin, #plasma, graesslin,

D10747: Implement zwp_linux_dmabuf_v1

2018-06-01 Thread Roman Gilg
romangg added a comment. Restricted Application edited subscribers, added: kde-frameworks-devel; removed: Frameworks. What's the current state of this patch and the KWin one? REPOSITORY R127 KWayland REVISION DETAIL https://phabricator.kde.org/D10747 To: fredrik, #kwin, #plasma,

D10747: Implement zwp_linux_dmabuf_v1

2018-04-30 Thread David Edmundson
davidedmundson added inline comments. INLINE COMMENTS > linuxdmabuf_v1_interface.cpp:364 > + > +static void unbind(wl_client *client, wl_resource *resource); > +static void createParamsCallback(wl_client *client, wl_resource > *resource, uint32_t id); is this defined? I can't find it

D10747: Implement zwp_linux_dmabuf_v1

2018-04-11 Thread Fredrik Höglund
fredrik added a comment. In D10747#237235 , @romangg wrote: > Regarding the "drm_fourcc.h" file: do we want to copy it in KWayland's code base or could we use the system one? It's only available on Linux? In this case could we include it as a

D10747: Implement zwp_linux_dmabuf_v1

2018-03-30 Thread Roman Gilg
romangg added a comment. Regarding the "drm_fourcc.h" file: do we want to copy it in KWayland's code base or could we use the system one? It's only available on Linux? In this case could we include it as a dummy only on non-Linunx systems? This way we could use the system one on Linux.

D10747: Implement zwp_linux_dmabuf_v1

2018-03-07 Thread Fredrik Höglund
fredrik updated this revision to Diff 28986. fredrik added a comment. Import the context. REPOSITORY R127 KWayland CHANGES SINCE LAST UPDATE https://phabricator.kde.org/D10747?vs=27735=28986 REVISION DETAIL https://phabricator.kde.org/D10747 AFFECTED FILES

D10747: Implement zwp_linux_dmabuf_v1

2018-03-07 Thread Roman Gilg
romangg added a comment. Please import the context. This makes reviews more easy. Either via -U9 flag to git diff or (for future diffs) by using arc directly on a feature branch. REPOSITORY R127 KWayland REVISION DETAIL https://phabricator.kde.org/D10747 To: fredrik, #kwin,

D10747: Implement zwp_linux_dmabuf_v1

2018-02-23 Thread Roman Gilg
romangg added a task: T8067: Support zwp_linux_dmabuf. Restricted Application edited projects, added Plasma on Wayland; removed Plasma. REPOSITORY R127 KWayland REVISION DETAIL https://phabricator.kde.org/D10747 To: fredrik, #kwin, #plasma, graesslin, davidedmundson, mart Cc: plasma-devel,

D10747: Implement zwp_linux_dmabuf_v1

2018-02-22 Thread Fredrik Höglund
fredrik added inline comments. Restricted Application edited projects, added Plasma; removed Plasma on Wayland. INLINE COMMENTS > linuxdmabuf_v1_interface.h:39 > + > +namespace LinuxDmabuf > +{ Do we want these nested namespaces? We could have LinuxDmabufFlags, LinuxDmabufBuffer etc. instead.

D10747: Implement zwp_linux_dmabuf_v1

2018-02-22 Thread Marco Martin
mart added a comment. Restricted Application edited projects, added Plasma on Wayland; removed Plasma. +1 on my machine opengl apps seems to work well on wayland (after the first revision in which they were flipped upside down, now they are ok) would need a final ship it by someone more

D10747: Implement zwp_linux_dmabuf_v1

2018-02-22 Thread Fredrik Höglund
fredrik created this revision. fredrik added reviewers: KWin, Plasma, graesslin, davidedmundson, mart. Restricted Application added projects: Plasma on Wayland, Frameworks. Restricted Application added subscribers: Frameworks, plasma-devel. fredrik requested review of this revision. Restricted