[Kernel-packages] [Bug 1773637] Re: Distribution upgrade to 18.04: used nvidia display driver is commented out

2018-12-02 Thread James Gross
https://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-release-
upgrader/trunk/view/head:/DistUpgrade/xorg_fix_proprietary.py#L112

apt-file search nvidia_drv.so
nvidia-340: /usr/lib/nvidia-340/xorg/nvidia_drv.so
xserver-xorg-video-nvidia-390: 
/usr/lib/x86_64-linux-gnu/nvidia/xorg/nvidia_drv.so
xserver-xorg-video-nvidia-legacy-340xx: 
/usr/lib/nvidia/legacy-340xx/nvidia_drv.so
xserver-xorg-video-nvidia-legacy-390xx: 
/usr/lib/nvidia/legacy-390xx/nvidia_drv.so

The file the release upgrader is looking for doesn't exist in the
current nvidia packages or exists in another location.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to nvidia-graphics-drivers-390 in Ubuntu.
https://bugs.launchpad.net/bugs/1773637

Title:
  Distribution upgrade to 18.04: used nvidia display driver is commented
  out

Status in nvidia-graphics-drivers-390 package in Ubuntu:
  Confirmed
Status in ubuntu-release-upgrader package in Ubuntu:
  Confirmed

Bug description:
  I upgraded my system from 17.10 to 18.04 Bionic Beaver via do-release-upgrade.
  After the installation had finished, Xorg wouldn't start. I later found out 
that this was because the installation routine had commented out the nvidia 
display driver I used in the xorg.conf:

  Section "Device"
  Identifier "nvidia"
  #Driver "nvidia"
  BusID "PCI:10@0:0:0"
  Option "ConstrainCursor" "off"
  EndSection

  As the installtion routine backuped my xorg.conf I could verify that
  the line hadn't been commented out before upgrading. Removing the "#"
  solved the problem.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7
  ProcVersionSignature: Ubuntu 4.15.0-22.24-generic 4.15.17
  Uname: Linux 4.15.0-22-generic x86_64
  NonfreeKernelModules: wl nvidia_modeset nvidia
  .proc.driver.nvidia.gpus..0a.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:0a:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  390.48  Thu Mar 22 00:42:57 
PDT 2018
   GCC version:  gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sun May 27 11:43:16 2018
  DistUpgraded: 2018-05-21 10:52:35,978 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus:
   bcmwl, 6.30.223.271+bdcom, 4.15.0-20-generic, x86_64: installed
   bcmwl, 6.30.223.271+bdcom, 4.15.0-22-generic, x86_64: installed
   nvidia, 390.48, 4.15.0-20-generic, x86_64: installed
   nvidia, 390.48, 4.15.0-22-generic, x86_64: installed
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation HD Graphics 5500 [8086:1616] (rev 09) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 5500 [103c:229d]
 Subsystem: Hewlett-Packard Company GM108M [GeForce 840M] [103c:229d]
  InstallationDate: Installed on 2017-11-02 (205 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
  MachineType: Hewlett-Packard HP ENVY 17 Notebook PC
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-22-generic 
root=UUID=2c76a9d7-c435-4600-abc9-2ecd10fc3001 ro quiet splash vt.handoff=1
  SourcePackage: xorg
  UpgradeStatus: Upgraded to bionic on 2018-05-21 (6 days ago)
  dmi.bios.date: 11/28/2014
  dmi.bios.vendor: Insyde
  dmi.bios.version: F.33
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: 229D
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: 78.15
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnInsyde:bvrF.33:bd11/28/2014:svnHewlett-Packard:pnHPENVY17NotebookPC:pvr097312405F1620180:rvnHewlett-Packard:rn229D:rvr78.15:cvnHewlett-Packard:ct10:cvrChassisVersion:
  dmi.product.family: 103C_5335KV G=N L=CON B=HP S=ENV X=Null
  dmi.product.name: HP ENVY 17 Notebook PC
  dmi.product.version: 097312405F1620180
  dmi.sys.vendor: Hewlett-Packard
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.91-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.0~rc5-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.0~rc5-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:

[Kernel-packages] [Bug 1773637] Re: Distribution upgrade to 18.04: used nvidia display driver is commented out

2018-12-02 Thread James Gross
** Also affects: ubuntu-release-upgrader (Ubuntu)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to nvidia-graphics-drivers-390 in Ubuntu.
https://bugs.launchpad.net/bugs/1773637

Title:
  Distribution upgrade to 18.04: used nvidia display driver is commented
  out

Status in nvidia-graphics-drivers-390 package in Ubuntu:
  Confirmed
Status in ubuntu-release-upgrader package in Ubuntu:
  Confirmed

Bug description:
  I upgraded my system from 17.10 to 18.04 Bionic Beaver via do-release-upgrade.
  After the installation had finished, Xorg wouldn't start. I later found out 
that this was because the installation routine had commented out the nvidia 
display driver I used in the xorg.conf:

  Section "Device"
  Identifier "nvidia"
  #Driver "nvidia"
  BusID "PCI:10@0:0:0"
  Option "ConstrainCursor" "off"
  EndSection

  As the installtion routine backuped my xorg.conf I could verify that
  the line hadn't been commented out before upgrading. Removing the "#"
  solved the problem.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7
  ProcVersionSignature: Ubuntu 4.15.0-22.24-generic 4.15.17
  Uname: Linux 4.15.0-22-generic x86_64
  NonfreeKernelModules: wl nvidia_modeset nvidia
  .proc.driver.nvidia.gpus..0a.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/:0a:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  390.48  Thu Mar 22 00:42:57 
PDT 2018
   GCC version:  gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)
  ApportVersion: 2.20.9-0ubuntu7
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sun May 27 11:43:16 2018
  DistUpgraded: 2018-05-21 10:52:35,978 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus:
   bcmwl, 6.30.223.271+bdcom, 4.15.0-20-generic, x86_64: installed
   bcmwl, 6.30.223.271+bdcom, 4.15.0-22-generic, x86_64: installed
   nvidia, 390.48, 4.15.0-20-generic, x86_64: installed
   nvidia, 390.48, 4.15.0-22-generic, x86_64: installed
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes
  GraphicsCard:
   Intel Corporation HD Graphics 5500 [8086:1616] (rev 09) (prog-if 00 [VGA 
controller])
 Subsystem: Hewlett-Packard Company HD Graphics 5500 [103c:229d]
 Subsystem: Hewlett-Packard Company GM108M [GeForce 840M] [103c:229d]
  InstallationDate: Installed on 2017-11-02 (205 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
  MachineType: Hewlett-Packard HP ENVY 17 Notebook PC
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-22-generic 
root=UUID=2c76a9d7-c435-4600-abc9-2ecd10fc3001 ro quiet splash vt.handoff=1
  SourcePackage: xorg
  UpgradeStatus: Upgraded to bionic on 2018-05-21 (6 days ago)
  dmi.bios.date: 11/28/2014
  dmi.bios.vendor: Insyde
  dmi.bios.version: F.33
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: 229D
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: 78.15
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnInsyde:bvrF.33:bd11/28/2014:svnHewlett-Packard:pnHPENVY17NotebookPC:pvr097312405F1620180:rvnHewlett-Packard:rn229D:rvr78.15:cvnHewlett-Packard:ct10:cvrChassisVersion:
  dmi.product.family: 103C_5335KV G=N L=CON B=HP S=ENV X=Null
  dmi.product.name: HP ENVY 17 Notebook PC
  dmi.product.version: 097312405F1620180
  dmi.sys.vendor: Hewlett-Packard
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.91-2
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.0~rc5-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.0~rc5-1ubuntu1
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1773637/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1720197] Re: Every second(?) boot fails to display anything [MSHYBRID mode]

2017-09-29 Thread James Gross
System76 here.  We have also had luck with this grub flag:

GRUB_GFXPAYLOAD_LINUX=1920*1080

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1720197

Title:
  Every second(?) boot fails to display anything [MSHYBRID mode]

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  When this laptop's firmware is set to MSHYBRID mode (intel/nvidia
  switchable graphics) it seems that every second boot it fails to
  display anything.

  This appears to be regardless of whether or not I enter the grub menu.

  ProblemType: Bug
  DistroRelease: Ubuntu 17.10
  Package: linux-image-4.13.0-12-generic 4.13.0-12.13
  ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
  Uname: Linux 4.13.0-12-generic x86_64
  NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
  ApportVersion: 2.20.7-0ubuntu1
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  chris  3020 F pulseaudio
  CurrentDesktop: GNOME
  Date: Thu Sep 28 13:41:53 2017
  InstallationDate: Installed on 2017-09-20 (8 days ago)
  InstallationMedia: Ubuntu-GNOME 17.10 "Artful Aardvark" - Alpha amd64 
(20170919)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
   Bus 001 Device 002: ID 1c7a:0603 LighTuning Technology Inc. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: System76 Oryx Pro
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-12-generic.efi.signed 
root=ZFS=rpool/system ro
  RelatedPackageVersions:
   linux-restricted-modules-4.13.0-12-generic N/A
   linux-backports-modules-4.13.0-12-generic  N/A
   linux-firmware 1.168
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/20/2017
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1.05.02dRSA1 02/20/2017
  dmi.board.asset.tag: Tag 12345
  dmi.board.name: Oryx Pro
  dmi.board.vendor: System76
  dmi.board.version: oryp3-ess
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: System76
  dmi.chassis.version: N/A
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr1.05.02dRSA102/20/2017:bd02/20/2017:svnSystem76:pnOryxPro:pvroryp3-ess:rvnSystem76:rnOryxPro:rvroryp3-ess:cvnSystem76:ct10:cvrN/A:
  dmi.product.family: Not Applicable
  dmi.product.name: Oryx Pro
  dmi.product.version: oryp3-ess
  dmi.sys.vendor: System76

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1720197/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp