[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2019-02-08 Thread Joseph Salisbury
** Changed in: linux (Ubuntu) Assignee: Joseph Salisbury (jsalisbury) => (unassigned) ** Changed in: linux (Ubuntu Xenial) Assignee: Joseph Salisbury (jsalisbury) => (unassigned) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-27 Thread Nivedita Singhvi
We now believe this to be the case. The above is an issue of new HW enablement. I believe this can be closed Will Not Fix. For standard kernels, enablement available via the -hwe kernel upgrade. For FIPS kernels, new HW enablement is not expected to be backported/patched in existing

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-21 Thread Nivedita Singhvi
This issue is not any of the above mentioned bugs, after some checking. This is possibly enablement of new HW as BradF suggested might be the case, and Dan Streetman identified the driver/device in question. Driver: megaraid_sas PCI dev id: 0016 #define PCI_DEVICE_ID_LSI_HARPOON 0x0016 All

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-20 Thread Joseph Salisbury
I started a "Reverse" kernel bisect between v4.10 final and v4.11-rc1. The kernel bisect will require testing of about 7-10 test kernels. I built the first test kernel, up to the following commit: caa59428971d5ad81d19512365c9ba580d83268c The test kernel can be downloaded from:

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-20 Thread Nivedita Singhvi
Or the missing crypto packages (I should have added). It's not likely the second URL above. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1809168 Title: FIPS and Ubuntu standard

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-20 Thread Nivedita Singhvi
One check to see if the above is the issue: 1. dpkg -l | grep crypt 2. dpkg -l | grep lvm If lvm2 is not installed, for instance, it should be possible to do the following to fix the problem: 1. # apt install lvm2 2. # update-initramfs -c -k all -- You received this bug notification because

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-20 Thread Nivedita Singhvi
There are some similar issues out there: https://feeding.cloud.geek.nz/posts/recovering-from-unbootable-ubuntu- encrypted-lvm-root-partition/ https://bugs.launchpad.net/ubuntu/+source/xubuntu-meta/+bug/1801629 -- You received this bug notification because you are a member of Kernel Packages,

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-20 Thread Nivedita Singhvi
v4.10 Final < FAILS v4.11-rc1 < WORKS -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1809168 Title: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-19 Thread Nivedita Singhvi
The disk in question is a PERC_H740P_Adp. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1809168 Title: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-19 Thread Nivedita Singhvi
Thanks, Joe. I'll update this bug as soon as I get the results from the reporter. -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1809168 Title: FIPS and Ubuntu standard kernels prior to

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-19 Thread Joseph Salisbury
** Changed in: linux (Ubuntu) Assignee: (unassigned) => Joseph Salisbury (jsalisbury) ** Changed in: linux (Ubuntu Xenial) Assignee: (unassigned) => Joseph Salisbury (jsalisbury) -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-19 Thread Joseph Salisbury
We can perform a "Reverse" bisect to identify the commit that fixes this bug in 4.11.0-1.6. It is easiest to bisect the mainline kernel. Per the description, 4.11 final works. Can you test the following two kernels? v4.10 Final: https://kernel.ubuntu.com/~kernel-ppa/mainline/v4.10/ v4.11-rc1:

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-19 Thread Joseph Salisbury
** Also affects: linux (Ubuntu Xenial) Importance: Undecided Status: New ** Changed in: linux (Ubuntu Xenial) Status: New => Triaged ** Changed in: linux (Ubuntu) Status: Confirmed => Triaged ** Changed in: linux (Ubuntu Xenial) Importance: Undecided => High -- You

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-19 Thread Nivedita Singhvi
** Changed in: linux (Ubuntu) Status: Incomplete => Confirmed -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1809168 Title: FIPS and Ubuntu standard kernels prior to 4.11.0 won't

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-19 Thread Nivedita Singhvi
** Changed in: linux (Ubuntu) Importance: Undecided => High -- You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu. https://bugs.launchpad.net/bugs/1809168 Title: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot;

[Kernel-packages] [Bug 1809168] Re: FIPS and Ubuntu standard kernels prior to 4.11.0 won't boot; root device not found

2018-12-19 Thread Nivedita Singhvi
** Attachment added: "Commit list for the artful window where fix went in" https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1809168/+attachment/5223616/+files/Ubuntu-4.10.0-26.30---Ubuntu-4.11.0-0.5---commitlist -- You received this bug notification because you are a member of Kernel