[Kernel-packages] [Bug 1561830] Re: Hard disk writes fail in 16.04 daily on nForce 430

2016-03-24 Thread Stephen Worthington
** Package changed: ubuntu => linux (Ubuntu)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561830

Title:
  Hard disk writes fail in 16.04 daily on nForce 430

Status in linux package in Ubuntu:
  New

Bug description:
  I have an old PC I use for testing new operating systems.  It has
  previously had Ubuntu 15.10 installed and working.  The motherboard is
  an Asus M2NPV-VM, with Nvidia nForce 430 chipset and Nvidia GeForce
  6150 GPU.  I have installed an Nvidia GT220 card to use for more
  modern video support.

  When I attempt to install Ubuntu 16.04 beta (daily xenial-desktop-
  amd64.iso file downloaded 24/03/2016  18:17), it starts to write to
  the hard disk (Samsung HD103UJ), and after a short time the install
  got lots of disk write errors in kern.log.  After the errors, the disk
  was unable to be read either, with "fdisk -l /dev/sda" failing to read
  a sector, where it had worked before starting the install.  Unplugging
  the SATA cable to the drive and plugging it in again made the drive
  work again (on /dev/sdc), but another attempt to install failed with
  the same write errors.

  I noticed that the log had swap write errors also, so I rebooted the
  install DVD again, and this time did a "swapoff -a" command before
  attempting to install, but got the same errors again.  So I found my
  Ubuntu 15.10 install DVD and tried a new install from that, which
  worked just fine.

  On rebooting with my 16.04 daily DVD, I again did "swapoff -a" so that
  the DVD based system would run normally, then tried mounting the EXT4
  system partition I had just installed using the 15.10 install DVD.
  That worked, so I tried dd commands to do test writes to that
  partition.  The following commands worked:

dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=10k
dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=100k

  but when I did this command:

dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=1000k

  after a while errors started appearing in kern.log, just as with the
  attempts to install 16.04.

  It appears that with sustained write activity, the errors will start
  and then the drive will become unusable until it is unplugged and
  plugged in again.

  I have attached the kern.log and syslog files from the 15.10 install
  that worked, and the 16.04 install attempt that failed.  The first
  error message appears to be this:

  ata3: EH in SWNCQ mode,QC:qc_active 0x1FFF sactive 0x1FFF
  ata3: SWNCQ:qc_active 0x1 defer_bits 0x1FFE last_issue_tag 0x0
  dhfis 0x1 dmafis 0x0 sdbfis 0x0

  which leads me to suspect a problem with the handling of the SATA
  controller's interrupts.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561830/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561830] [NEW] Hard disk writes fail in 16.04 daily on nForce 430

2016-03-24 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

I have an old PC I use for testing new operating systems.  It has
previously had Ubuntu 15.10 installed and working.  The motherboard is
an Asus M2NPV-VM, with Nvidia nForce 430 chipset and Nvidia GeForce 6150
GPU.  I have installed an Nvidia GT220 card to use for more modern video
support.

When I attempt to install Ubuntu 16.04 beta (daily xenial-desktop-
amd64.iso file downloaded 24/03/2016  18:17), it starts to write to the
hard disk (Samsung HD103UJ), and after a short time the install got lots
of disk write errors in kern.log.  After the errors, the disk was unable
to be read either, with "fdisk -l /dev/sda" failing to read a sector,
where it had worked before starting the install.  Unplugging the SATA
cable to the drive and plugging it in again made the drive work again
(on /dev/sdc), but another attempt to install failed with the same write
errors.

I noticed that the log had swap write errors also, so I rebooted the
install DVD again, and this time did a "swapoff -a" command before
attempting to install, but got the same errors again.  So I found my
Ubuntu 15.10 install DVD and tried a new install from that, which worked
just fine.

On rebooting with my 16.04 daily DVD, I again did "swapoff -a" so that
the DVD based system would run normally, then tried mounting the EXT4
system partition I had just installed using the 15.10 install DVD.  That
worked, so I tried dd commands to do test writes to that partition.  The
following commands worked:

  dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=10k
  dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=100k

but when I did this command:

  dd if=/dev/zero of=/mnt/sda8/tmp/output bs=8k count=1000k

after a while errors started appearing in kern.log, just as with the
attempts to install 16.04.

It appears that with sustained write activity, the errors will start and
then the drive will become unusable until it is unplugged and plugged in
again.

I have attached the kern.log and syslog files from the 15.10 install
that worked, and the 16.04 install attempt that failed.  The first error
message appears to be this:

ata3: EH in SWNCQ mode,QC:qc_active 0x1FFF sactive 0x1FFF
ata3: SWNCQ:qc_active 0x1 defer_bits 0x1FFE last_issue_tag 0x0
dhfis 0x1 dmafis 0x0 sdbfis 0x0

which leads me to suspect a problem with the handling of the SATA
controller's interrupts.

** Affects: linux (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: bot-comment
-- 
Hard disk writes fail in 16.04 daily on nForce 430
https://bugs.launchpad.net/bugs/1561830
You received this bug notification because you are a member of Kernel Packages, 
which is subscribed to linux in Ubuntu.

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1559252] Re: linux: 4.4.0-15.31 -proposed tracker

2016-03-24 Thread Adam Conrad
** Changed in: kernel-development-workflow/promote-to-release
   Status: New => Fix Released

** Changed in: kernel-development-workflow/regression-testing
   Status: Confirmed => Fix Released

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1559252

Title:
  linux: 4.4.0-15.31 -proposed tracker

Status in Kernel Development Workflow:
  In Progress
Status in Kernel Development Workflow automated-testing series:
  Fix Released
Status in Kernel Development Workflow prepare-package series:
  Fix Released
Status in Kernel Development Workflow prepare-package-meta series:
  Fix Released
Status in Kernel Development Workflow prepare-package-signed series:
  Fix Released
Status in Kernel Development Workflow promote-to-proposed series:
  Fix Released
Status in Kernel Development Workflow promote-to-release series:
  Fix Released
Status in Kernel Development Workflow regression-testing series:
  Fix Released
Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Xenial:
  Fix Released

Bug description:
  This bug is for tracking the 4.4.0-15.31 upload package. This bug will
  contain status and testing results related to that upload.

  For an explanation of the tasks and the associated workflow see: 
https://wiki.ubuntu.com/Kernel/kernel-sru-workflow
  kernel-Prepare-package-start:Friday, 18. March 2016 18:44 UTC
  kernel-stable-Promote-to-proposed-end:Friday, 18. March 2016 19:00 UTC
  kernel-phase-changed:Saturday, 19. March 2016 01:12 UTC
  kernel-phase:Uploaded

  -- swm properties --
  phase: Uploaded
  prepare-package:
finished: Saturday, 19. March 2016 01:12 UTC
started: Saturday, 19. March 2016 01:12 UTC
  prepare-package-meta:
finished: Saturday, 19. March 2016 01:12 UTC
started: Saturday, 19. March 2016 01:12 UTC
  prepare-package-signed:
finished: Saturday, 19. March 2016 01:12 UTC
started: Saturday, 19. March 2016 01:12 UTC
  proposed-announcement-sent: true

To manage notifications about this bug go to:
https://bugs.launchpad.net/kernel-development-workflow/+bug/1559252/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1518642] Re: rtl8192cu kernel driver not working

2016-03-24 Thread Launchpad Bug Tracker
[Expired for linux (Ubuntu) because there has been no activity for 60
days.]

** Changed in: linux (Ubuntu)
   Status: Incomplete => Expired

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1518642

Title:
  rtl8192cu kernel driver not working

Status in linux package in Ubuntu:
  Expired

Bug description:
  Connection is dropped after some time. 
  Workaround install patched dkms driver.
  Should work out of the box for "normal users"

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-18-generic 4.2.0-18.22
  ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
  Uname: Linux 4.2.0-18-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  vincent1352 F pulseaudio
   /dev/snd/controlC0:  vincent1352 F pulseaudio
  CurrentDesktop: Unity
  Date: Sun Nov 22 00:58:18 2015
  HibernationDevice: RESUME=UUID=2dfaf257-b29b-4238-b562-b7769b0aaa49
  InstallationDate: Installed on 2015-11-21 (0 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: System manufacturer System Product Name
  ProcFB: 0 EFI VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-18-generic.efi.signed 
root=UUID=23870d18-dac9-4325-be37-c76e2a75da2e ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-18-generic N/A
   linux-backports-modules-4.2.0-18-generic  N/A
   linux-firmware1.149.2
  RfKill:
   
  SourcePackage: linux
  UdevLog: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden: 
'/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/09/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3603
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: Maximus IV GENE-Z
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3603:bd11/09/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnMaximusIVGENE-Z:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1518642/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561474] Re: Bluetooth will be disable after reusme from suspend on Xenial

2016-03-24 Thread Po-Hsu Lin
This bug is fixed in the mainline kernel, 4.5.0-040500-generic
#201603140130

** Changed in: linux (Ubuntu)
   Status: Incomplete => Confirmed

** Tags added: kernel-fixed-upstream

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561474

Title:
  Bluetooth will be disable after reusme from suspend on Xenial

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  CID: 201208-11536 Dell Latitude 6430u

  The Bluetooth will be disabled after resume from suspend.
  You will need to use "hciconfig hci0 reset" to enable it.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-15-generic 4.4.0-15.31
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1202 F pulseaudio
  CurrentDesktop: Unity
  Date: Thu Mar 24 19:14:07 2016
  HibernationDevice: RESUME=UUID=25c03762-079c-4c6d-aedb-ec768318a6bf
  InstallationDate: Installed on 2016-03-24 (0 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151209)
  MachineType: Dell Inc. Latitude 6430U
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic 
root=UUID=18cfda3e-4f3d-40cf-8e7e-a83030819487 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/15/2012
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A02
  dmi.board.asset.tag: 1234567
  dmi.board.name: 0MN74V
  dmi.board.vendor: Dell Inc.
  dmi.board.version: X01
  dmi.chassis.asset.tag: 1234567
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA02:bd11/15/2012:svnDellInc.:pnLatitude6430U:pvr01:rvnDellInc.:rn0MN74V:rvrX01:cvnDellInc.:ct9:cvr:
  dmi.product.name: Latitude 6430U
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561474/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1520139] Re: [Feature] Enable I2C on Broxton-P

2016-03-24 Thread Tim Gardner
** Information type changed from Proprietary to Public

** Also affects: linux (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Changed in: linux (Ubuntu Xenial)
   Status: New => Fix Committed

** Changed in: linux (Ubuntu Xenial)
 Assignee: (unassigned) => Tim Gardner (timg-tpi)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1520139

Title:
  [Feature] Enable I2C on Broxton-P

Status in intel:
  New
Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  I2C designware controller is a PCI/ACPI enumerated device on BXT-P.
  So, we need the corresponding device driver to power manage I2C designware 
device.
  (1) BXT-P I2C controller PCI driver support
  (2) BXT-P I2C suspend/resume support
  (3) BXT-P I2C devidle support

  HW: Apollo Lake

  Upstream:
  kernel: 4.4

To manage notifications about this bug go to:
https://bugs.launchpad.net/intel/+bug/1520139/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1560764] Re: "fails to request state" when trying to perform actions in mokutil

2016-03-24 Thread Launchpad Bug Tracker
This bug was fixed in the package mokutil - 0.3.0-0ubuntu1

---
mokutil (0.3.0-0ubuntu1) xenial; urgency=medium

  * New upstream version.
- Now uses efivar which supports immutable attributes (LP: #1560764)
  * B-D on libefivar-dev, dh-autoreconf
  * debian/rules: use autoreconf
  * Backport cdb4b6f3 from upstream to fix i386 builds.

 -- Mario Limonciello   Tue, 22 Mar 2016
21:25:22 -0500

** Changed in: mokutil (Ubuntu)
   Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560764

Title:
  "fails to request state" when trying to perform actions in mokutil

Status in linux package in Ubuntu:
  Won't Fix
Status in mokutil package in Ubuntu:
  Fix Released

Bug description:
  Recently it's been observed that mokutil is unable to make changes to
  the various Mok* variables.  It complains that  "fails to request
  state" when trying most actions or similar errors.

  The root of these problems is because the variables have been set as 
immutable after this kernel commit:
  
https://github.com/torvalds/linux/commit/ed8b0de5a33d2a2557dce7f9429dca8cb5bc5879

  In many instances mokutil 0.2 will delete the variable and recreate
  it, so changing it with chattr isn't a workable solution as the kernel
  will just recreate it with the immutable attribute and it will fail
  over again.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560764/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


Re: [Kernel-packages] [Bug 1560224] Re: [Dell Inc. Inspiron 3537] suspend/resume failure

2016-03-24 Thread Viktor Pálinkás
Hi There,

In the meantime I did install more updates as BETA is freezed now and my
current kernel is:
4.4.0-14-generic

Since then my issue did not happen so far. If it does I'll resubmit the bug
report and try the 4.5 kernel.

Thank you,
Viktor

2016-03-23 21:03 GMT+01:00 Joseph Salisbury 
:

> Did this issue start happening after an update/upgrade?  Was there a
> prior kernel version where you were not having this particular problem?
>
> Would it be possible for you to test the latest upstream kernel? Refer
> to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
> v4.5 kernel[0].
>
> If this bug is fixed in the mainline kernel, please add the following
> tag 'kernel-fixed-upstream'.
>
> If the mainline kernel does not fix this bug, please add the tag:
> 'kernel-bug-exists-upstream'.
>
> Once testing of the upstream kernel is complete, please mark this bug as
> "Confirmed".
>
>
> Thanks in advance.
>
> [0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/
>
> ** Changed in: linux (Ubuntu)
>Importance: Undecided => Medium
>
> ** Changed in: linux (Ubuntu)
>Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1560224
>
> Title:
>   [Dell Inc. Inspiron 3537] suspend/resume failure
>
> Status in linux package in Ubuntu:
>   Incomplete
>
> Bug description:
>   ...
>
>   ProblemType: KernelOops
>   DistroRelease: Ubuntu 16.04
>   Package: linux-image-4.4.0-14-generic 4.4.0-14.30
>   ProcVersionSignature: Ubuntu 4.4.0-14.30-generic 4.4.5
>   Uname: Linux 4.4.0-14-generic x86_64
>   Annotation: This occurred during a previous suspend, and prevented the
> system from resuming properly.
>   ApportVersion: 2.20-0ubuntu3
>   Architecture: amd64
>   AudioDevicesInUse:
>USERPID ACCESS COMMAND
>/dev/snd/controlC1:  cefre001872 F pulseaudio
>/dev/snd/controlC0:  cefre001872 F pulseaudio
>   Date: Sat Mar 19 20:50:59 2016
>   DuplicateSignature: suspend/resume:Dell Inc. Inspiron 3537:A06
>   ExecutablePath: /usr/share/apport/apportcheckresume
>   Failure: suspend/resume
>   HibernationDevice: RESUME=UUID=8cfcecee-87f7-4cf4-bd92-79464cdd3733
>   InstallationDate: Installed on 2016-02-18 (32 days ago)
>   InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
>   InterpreterPath: /usr/bin/python3.5
>   MachineType: Dell Inc. Inspiron 3537
>   ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
>   ProcFB: 0 inteldrmfb
>   ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-14-generic
> root=UUID=1c08c9f9-54ca-416e-b4ed-8fcf5e13fe85 ro quiet splash vt.handoff=7
>   PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No
> PulseAudio daemon running, or not running as session daemon.
>   RelatedPackageVersions:
>linux-restricted-modules-4.4.0-14-generic N/A
>linux-backports-modules-4.4.0-14-generic  N/A
>linux-firmware1.156
>   SourcePackage: linux
>   Title: [Dell Inc. Inspiron 3537] suspend/resume failure
>   UpgradeStatus: Upgraded to xenial on 2016-03-19 (2 days ago)
>   UserGroups:
>
>   dmi.bios.date: 09/27/2013
>   dmi.bios.vendor: Dell Inc.
>   dmi.bios.version: A06
>   dmi.board.name: 0PHTY0
>   dmi.board.vendor: Dell Inc.
>   dmi.board.version: A00
>   dmi.chassis.type: 8
>   dmi.chassis.vendor: Dell Inc.
>   dmi.chassis.version: A06
>   dmi.modalias:
> dmi:bvnDellInc.:bvrA06:bd09/27/2013:svnDellInc.:pnInspiron3537:pvrA06:rvnDellInc.:rn0PHTY0:rvrA00:cvnDellInc.:ct8:cvrA06:
>   dmi.product.name: Inspiron 3537
>   dmi.product.version: A06
>   dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560224/+subscriptions
>

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560224

Title:
  [Dell Inc. Inspiron 3537] suspend/resume failure

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  ...

  ProblemType: KernelOops
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-14-generic 4.4.0-14.30
  ProcVersionSignature: Ubuntu 4.4.0-14.30-generic 4.4.5
  Uname: Linux 4.4.0-14-generic x86_64
  Annotation: This occurred during a previous suspend, and prevented the system 
from resuming properly.
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  cefre001872 F pulseaudio
   /dev/snd/controlC0:  cefre001872 F pulseaudio
  Date: Sat Mar 19 20:50:59 2016
  DuplicateSignature: suspend/resume:Dell Inc. Inspiron 3537:A06
  ExecutablePath: /usr/share/apport/apportcheckresume
  Failure: suspend/resume
  HibernationDevice: RESUME=UUID=8cfcecee-87f7-4cf4-bd92-79464cdd3733
  InstallationDate: Installed on 2016-02-18 (32 days ago)
  

[Kernel-packages] [Bug 1561729] Status changed to Confirmed

2016-03-24 Thread Brad Figg
This change was made by a bot.

** Changed in: linux (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561729

Title:
  Screen flickering on i915_bpo

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Hey Guys,

  i am encountering some random screen flickering after i launched
  google-chrome. this persists even after clsoing chrome.

  dmesg reports:  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]]
  *ERROR* CPU pipe A FIFO underrun

  Description:  Ubuntu Xenial Xerus (development branch)
  Release:  16.04

  PS: its an dell XPS 13 with no external display attached. internal
  display is an FHD one

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561729/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1554003] Re: xenial kernel crash on HP BL460c G7 (qla24xx problem?)

2016-03-24 Thread Attila Zsiros
b11f66aebbf8369707ddde3a9a7bb01b6cb41d58 is good!

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1554003

Title:
  xenial kernel crash on HP BL460c G7 (qla24xx problem?)

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  Dear Members,

  Latest Xenial kernel (linux-image-generic-4.4.0-8-generic) is crash on
  booting. Same problem with 4.4.0-9 and 4.4.0-10.

  
  [1.654419] qla2xxx [:06:00.1]-0034:3: MSI-X: Unsupported ISP 
  2432 SSVID/SSDID (0x103C,0x1705).
  [1.685273] hid-generic 0003:03F0:7029.0001: in
  [1.685273] hid-generic 0003:03F0:7029.0001: input,hidraw0: USB HID 
  v1.01 Keyboard [HP  Virtual Keyboard ] on usb-:01:00.4-1/input0
  [1.685455] input: HP  Virtual Keyboard  as 
  
/devices/pci:00/:00:1c.4/:01:00.4/usb6/6-1/6-1:1.1/0003:03F0:7029.0002/input/inpu
 
  1048576 bytes) :0
  1:00.4/usb6/6-1/6-1:1.1/0003:03F0:7029.0002/input/inpu
  [2.001109] CR2: 0050
  [2.001170] ---
  [ end trace 20a247b9d60f8e00 ]---
  [2.001232] Kernel panic - not syncing: Fatal exception in interrup
  [2.001232] Kernel panic - not syncing: Fatal exception in interrupt
  [2.001813] Kernel Offset: disabled
  [2.001873] ---
  [ end Kernel panic - not syncing: Fatal exception in interrupt
  [1.997314]  [] do_IRQ+0x4b/0xd0
  [1.997379]  [] common_interrupt+0x82/0x82
  [1.997441]  
  [1.997336] hpsa :0c:00.0: scsi 1:3:0:0: added RAID  HP
  [1.997491]  [] ? cpuidle_enter_state+0x12d/0x270
  [1.997609]  [] cpuidle_enter+0x17/0x20
  [1.997674]  [] call_cpuidle+0x32/0x60
  [1.997737]  [] ? cpuidle_select+0x13/0x20
  [1.997800]  [] cpu_startup_entry+0x266/0x320
  [1.997866]  [] rest_init+0x7c/0x80
  [1.997930]  [] start_kernel+0x481/0x4a2
  [1.997994]  [] ? early_idt_handler_array+0x120/0x120
  [1.998058]  [] x86_64_start_reservations+0x2a/0x2c
  [1.998123]  [] x86
  [1.998123]  [] x86_64_start_kernel+0x14a/0x16d
  [1.998186] Code: 00 48 89 45 d0 31 c0 48 8b 47 58 a8 02 0f 84 cf 00 
  00 00 48 8b 46 50 49 89 fd 49 89 f4 65 8b 15 06 34 e7 3f 4c 8b b7 10 02 
  00 00 <39> 50 50 74 11
89 50 50 48 8b 46 50 8b 40 50 41 89 86 58 8put,hidraw0: USB HID v1.01 
  Key 74 11 89 50 50 48 8b 46 50 8b 40 50 41 89 86 58 8b 00
  [2.000922] RIP  [] 
  qla24xx_process_response_queue+0x49/0x4a0 [qla2xxx]
  [2.001050]  RSP 
  hpiLO-> exit

  Best regards Attila
  --- 
  AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 
2: ls: cannot access '/dev/snd/': No such file or directory
  AplayDevices: Error: [Errno 2] No such file or directory
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp3', '/dev/dsp1', 
'/dev/dsp2', '/dev/dsp', '/dev/sequencer'] failed with exit code 1:
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-02-03 (32 days ago)
  InstallationMedia: Ubuntu-Server 14.04.3 LTS "Trusty Tahr" - Beta amd64 
(20150805)
  MachineType: HP ProLiant BL460c G7
  NonfreeKernelModules: raid10 raid456 async_raid6_recov async_memcpy async_pq 
async_xor async_tx xor raid6_pq raid1 raid0 multipath linear be2iscsi qla2xxx 
iscsi_boot_sysfs libiscsi ipmi_si hpsa scsi_transport_fc scsi_transport_iscsi 
ipmi_msghandler 8021q garp stp mrp llc ghash_clmulni_intel hid_generic be2net 
aesni_intel aes_x86_64 ablk_helper usbhid cryptd lrw vxlan gf128mul 
ip6_udp_tunnel glue_helper usb_storage hid udp_tunnel
  Package: linux (not installed)
  PciMultimedia:
   
  ProcEnviron:
   LANGUAGE=en_US:en
   TERM=bterm
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/sh
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=linux priority=low vga=788 initrd=initrd.gz ---
  ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-16-generic N/A
   linux-backports-modules-4.2.0-16-generic  N/A
   linux-firmware1.156
  RfKill: Error: [Errno 2] No such file or directory
  Tags:  xenial
  Uname: Linux 4.2.0-16-generic x86_64
  UpgradeStatus: Upgraded to xenial on 2016-02-04 (31 days ago)
  UserGroups:
   
  _MarkForUpload: True
  dmi.bios.date: 05/05/2011
  dmi.bios.vendor: HP
  dmi.bios.version: I27
  dmi.chassis.type: 28
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrI27:bd05/05/2011:svnHP:pnProLiantBL460cG7:pvr:cvnHP:ct28:cvr:
  dmi.product.name: ProLiant BL460c G7
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1554003/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages

[Kernel-packages] [Bug 1561350] Re: Bluetooth doesn't work

2016-03-24 Thread Jeremy
See comments 5 and 11 from https://bugs.launchpad.net/ubuntu/+source
/linux-lts-wily/+bug/1542944

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1561350

Title:
  Bluetooth doesn't work

Status in bluez package in Ubuntu:
  New

Bug description:
  I can turn it on and off change visibility and so on. I can use any console 
tools for it - everything looks fine.
  But it looks like it is only visibility of working because it can’t find any 
devices nearby and can’t be found.

  I've check all related topics and try all possible solutions/advices -
  no result.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: bluetooth 5.35-0ubuntu2
  ProcVersionSignature: Ubuntu 4.2.0-34.39-generic 4.2.8-ckt4
  Uname: Linux 4.2.0-34-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu Mar 24 12:11:10 2016
  InstallationDate: Installed on 2015-12-01 (113 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  InterestingModules: rfcomm bnep btusb bluetooth
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 0489:e095 Foxconn / Hon Hai 
   Bus 001 Device 002: ID 04f2:b47f Chicony Electronics Co., Ltd 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Acer Aspire ES1-331
  PackageArchitecture: all
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-34-generic.efi.signed 
root=UUID=82b73f79-8d4f-453e-b9ad-fc07955aaa21 ro quiet splash vt.handoff=7
  SourcePackage: bluez
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/07/2015
  dmi.bios.vendor: Insyde Corp.
  dmi.bios.version: V1.13
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: Aspire ES1-331
  dmi.board.vendor: Acer
  dmi.board.version: V1.13
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Acer
  dmi.chassis.version: V1.13
  dmi.modalias: 
dmi:bvnInsydeCorp.:bvrV1.13:bd12/07/2015:svnAcer:pnAspireES1-331:pvrV1.13:rvnAcer:rnAspireES1-331:rvrV1.13:cvnAcer:ct10:cvrV1.13:
  dmi.product.name: Aspire ES1-331
  dmi.product.version: V1.13
  dmi.sys.vendor: Acer
  hciconfig:
   hci0:Type: BR/EDR  Bus: USB
BD Address: 70:77:81:2D:04:7E  ACL MTU: 1022:8  SCO MTU: 183:5
UP RUNNING 
RX bytes:700 acl:0 sco:0 events:51 errors:0
TX bytes:3477 acl:0 sco:0 commands:51 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1561350/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561729] Re: Screen flickering on i915_bpo

2016-03-24 Thread Daniel Basten
** Attachment added: "dmesg.log"
   
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561729/+attachment/4610344/+files/dmesg.log

** Description changed:

  Hey Guys,
  
  i am encountering some random screen flickering after i launched google-
  chrome. this persists even after clsoing chrome.
+ 
+ i am not sure if that is a problem with i915 driver or something else.
  
  dmesg reports:  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]]
  *ERROR* CPU pipe A FIFO underrun
  
  Description:  Ubuntu Xenial Xerus (development branch)
  Release:  16.04

** Description changed:

  Hey Guys,
  
  i am encountering some random screen flickering after i launched google-
  chrome. this persists even after clsoing chrome.
- 
- i am not sure if that is a problem with i915 driver or something else.
  
  dmesg reports:  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]]
  *ERROR* CPU pipe A FIFO underrun
  
  Description:  Ubuntu Xenial Xerus (development branch)
  Release:  16.04
+ 
+ PS: its an dell XPS 13 with no external display attached. internal
+ display is an FHD one

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561729

Title:
  Screen flickering on i915_bpo

Status in linux package in Ubuntu:
  New

Bug description:
  Hey Guys,

  i am encountering some random screen flickering after i launched
  google-chrome. this persists even after clsoing chrome.

  dmesg reports:  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]]
  *ERROR* CPU pipe A FIFO underrun

  Description:  Ubuntu Xenial Xerus (development branch)
  Release:  16.04

  PS: its an dell XPS 13 with no external display attached. internal
  display is an FHD one

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561729/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561729] Re: Screen flickering on i915_bpo

2016-03-24 Thread Daniel Basten
** Attachment added: "lspci-vnvn.log"
   
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561729/+attachment/4610343/+files/lspci-vnvn.log

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561729

Title:
  Screen flickering on i915_bpo

Status in linux package in Ubuntu:
  New

Bug description:
  Hey Guys,

  i am encountering some random screen flickering after i launched
  google-chrome. this persists even after clsoing chrome.

  dmesg reports:  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]]
  *ERROR* CPU pipe A FIFO underrun

  Description:  Ubuntu Xenial Xerus (development branch)
  Release:  16.04

  PS: its an dell XPS 13 with no external display attached. internal
  display is an FHD one

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561729/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561729] [NEW] Screen flickering on i915_bpo

2016-03-24 Thread Daniel Basten
Public bug reported:

Hey Guys,

i am encountering some random screen flickering after i launched google-
chrome. this persists even after clsoing chrome.

dmesg reports:  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]]
*ERROR* CPU pipe A FIFO underrun

Description:Ubuntu Xenial Xerus (development branch)
Release:16.04

PS: its an dell XPS 13 with no external display attached. internal
display is an FHD one

** Affects: linux (Ubuntu)
 Importance: Undecided
 Status: New

** Attachment added: "version.log"
   
https://bugs.launchpad.net/bugs/1561729/+attachment/4610342/+files/version.log

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561729

Title:
  Screen flickering on i915_bpo

Status in linux package in Ubuntu:
  New

Bug description:
  Hey Guys,

  i am encountering some random screen flickering after i launched
  google-chrome. this persists even after clsoing chrome.

  dmesg reports:  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]]
  *ERROR* CPU pipe A FIFO underrun

  Description:  Ubuntu Xenial Xerus (development branch)
  Release:  16.04

  PS: its an dell XPS 13 with no external display attached. internal
  display is an FHD one

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561729/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561727] [NEW] linux: 4.4.0-16.32 -proposed tracker

2016-03-24 Thread Tim Gardner
Public bug reported:

This bug is for tracking the 4.4.0-16.32 upload package. This bug will
contain status and testing results related to that upload.

For an explanation of the tasks and the associated workflow see: 
https://wiki.ubuntu.com/Kernel/kernel-sru-workflow
kernel-Prepare-package-start:Thursday, 24. March 2016 20:30 UTC
kernel-phase-changed:Thursday, 24. March 2016 20:30 UTC
kernel-phase:Prepare

** Affects: kernel-development-workflow
 Importance: Medium
 Status: In Progress

** Affects: kernel-development-workflow/automated-testing
 Importance: Medium
 Assignee: Canonical Kernel Team (canonical-kernel-team)
 Status: New

** Affects: kernel-development-workflow/prepare-package
 Importance: Medium
 Assignee: Canonical Kernel Team (canonical-kernel-team)
 Status: New

** Affects: kernel-development-workflow/prepare-package-meta
 Importance: Medium
 Assignee: Canonical Kernel Team (canonical-kernel-team)
 Status: New

** Affects: kernel-development-workflow/prepare-package-signed
 Importance: Medium
 Assignee: Canonical Kernel Team (canonical-kernel-team)
 Status: New

** Affects: kernel-development-workflow/promote-to-proposed
 Importance: Medium
 Assignee: Canonical Kernel Team (canonical-kernel-team)
 Status: New

** Affects: kernel-development-workflow/promote-to-release
 Importance: Medium
 Assignee: Ubuntu Package Archive Administrators (ubuntu-archive)
 Status: New

** Affects: kernel-development-workflow/regression-testing
 Importance: Medium
 Assignee: Canonical Kernel Team (canonical-kernel-team)
 Status: New

** Affects: linux (Ubuntu)
 Importance: Medium
 Status: New

** Affects: linux (Ubuntu Xenial)
 Importance: Medium
 Status: New


** Tags: block-proposed kernel-release-tracking-bug xenial

** Tags added: kernel-release-tracking-bug

** Tags added: block-proposed

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Tags added: xenial

** Also affects: kernel-development-workflow/automated-testing
   Importance: Undecided
   Status: New

** Also affects: kernel-development-workflow/prepare-package
   Importance: Undecided
   Status: New

** Also affects: kernel-development-workflow/prepare-package-meta
   Importance: Undecided
   Status: New

** Also affects: kernel-development-workflow/prepare-package-signed
   Importance: Undecided
   Status: New

** Also affects: kernel-development-workflow/promote-to-proposed
   Importance: Undecided
   Status: New

** Also affects: kernel-development-workflow/promote-to-release
   Importance: Undecided
   Status: New

** Also affects: kernel-development-workflow/regression-testing
   Importance: Undecided
   Status: New

** Changed in: kernel-development-workflow
   Status: New => In Progress

** Changed in: kernel-development-workflow
   Importance: Undecided => Medium

** Changed in: kernel-development-workflow/automated-testing
   Importance: Undecided => Medium

** Changed in: kernel-development-workflow/automated-testing
 Assignee: (unassigned) => Canonical Kernel Team (canonical-kernel-team)

** Changed in: kernel-development-workflow/prepare-package
   Importance: Undecided => Medium

** Changed in: kernel-development-workflow/prepare-package
 Assignee: (unassigned) => Canonical Kernel Team (canonical-kernel-team)

** Changed in: kernel-development-workflow/prepare-package-meta
   Importance: Undecided => Medium

** Changed in: kernel-development-workflow/prepare-package-meta
 Assignee: (unassigned) => Canonical Kernel Team (canonical-kernel-team)

** Changed in: kernel-development-workflow/prepare-package-signed
   Importance: Undecided => Medium

** Changed in: kernel-development-workflow/prepare-package-signed
 Assignee: (unassigned) => Canonical Kernel Team (canonical-kernel-team)

** Changed in: kernel-development-workflow/promote-to-proposed
   Importance: Undecided => Medium

** Changed in: kernel-development-workflow/promote-to-proposed
 Assignee: (unassigned) => Canonical Kernel Team (canonical-kernel-team)

** Changed in: kernel-development-workflow/promote-to-release
   Importance: Undecided => Medium

** Changed in: kernel-development-workflow/promote-to-release
 Assignee: (unassigned) => Ubuntu Package Archive Administrators 
(ubuntu-archive)

** Changed in: kernel-development-workflow/regression-testing
   Importance: Undecided => Medium

** Changed in: kernel-development-workflow/regression-testing
 Assignee: (unassigned) => Canonical Kernel Team (canonical-kernel-team)

** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561727

Title:
  linux: 4.4.0-16.32 -proposed tracker

Status in Kernel Development Workflow:
 

[Kernel-packages] [Bug 1561676] Re: fix thermal throttling due to commit "Thermal: initialize thermal zone device correctly"

2016-03-24 Thread Tim Gardner
Colin - I went ahead and cherry-picked
81ad4276b505e987dd8ebbdf63605f92cd172b52 since it is already marked for
stable.

** Also affects: linux (Ubuntu Xenial)
   Importance: Medium
 Assignee: Colin Ian King (colin-king)
   Status: In Progress

** Changed in: linux (Ubuntu Xenial)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561676

Title:
  fix thermal throttling due to commit "Thermal: initialize thermal zone
  device correctly"

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  Commit bb431ba26c5cd0a17c941ca6c3a195a3a6d5d461 ("Thermal: initialize
  thermal zone device correctly") has been causing some issues with
  Lenovo laptops being throttled incorrectly.  Upstream fix
  81ad4276b505e987dd8ebbdf63605f92cd172b52 ("Thermal: Ignore invalid
  trip points") is a fix to this.

  I'm going to test this fix out over the next week and I don't see any
  regressions we should apply this fix.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561676/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561714] Re: Vivid update to v3.19.8-ckt17 stable release

2016-03-24 Thread Kamal Mostafa
** Description changed:

+ SRU Justification
  
- SRU Justification
+ Impact:
+    The upstream process for stable tree updates is quite similar
+    in scope to the Ubuntu SRU process, e.g., each patch has to
+    demonstrably fix a bug, and each patch is vetted by upstream
+    by originating either directly from a mainline/stable Linux tree or
+    a minimally backported form of that patch. The v3.19.8-ckt17 upstream 
stable
+    patch set is now available. It should be included in the Ubuntu
+    kernel as well.
  
- Impact:
-The upstream process for stable tree updates is quite similar
-in scope to the Ubuntu SRU process, e.g., each patch has to
-demonstrably fix a bug, and each patch is vetted by upstream
-by originating either directly from a mainline/stable Linux tree or
-a minimally backported form of that patch. The v3.19.8-ckt17 upstream 
stable
-patch set is now available. It should be included in the Ubuntu
-kernel as well.
+    git://kernel.ubuntu.com/ubuntu/linux.git
  
-git://kernel.ubuntu.com/ubuntu/linux.git
+ TEST CASE: TBD
  
- TEST CASE: TBD
+    The following patches from the v3.19.8-ckt17 stable release shall
+ be applied:
  
-The following patches from the v3.19.8-ckt17 stable release shall
- be applied:
+ Linux 3.19.8-ckt17
+ IB/core: Use GRH when the path hop-limit > 0
+ mld, igmp: Fix reserved tailroom calculation
+ net: moxa: fix an error code
+ net: qca_spi: Don't clear IFF_BROADCAST
+ cdc_ncm: do not call usbnet_link_change from cdc_ncm_bind
+ ipv6: re-enable fragment header matching in ipv6_find_hdr
+ net/mlx4_core: Allow resetting VF admin mac to zero
+ ext4: iterate over buffer heads correctly in move_extent_per_page()
+ tcp: convert cached rtt from usec to jiffies when feeding initial rto
+ gpio: rcar: Add Runtime PM handling for interrupts
+ MIPS: Fix build error when SMP is used without GIC
+ KVM: MMU: fix ept=0/pte.u=1/pte.w=0/CR0.WP=0/CR4.SMEP=1/EFER.NX=0 combo
+ tracing: Fix check for cpu online when event is disabled
+ KVM: VMX: disable PEBS before a guest entry
+ jffs2: reduce the breakage on recovery from halfway failed rename()
+ KVM: PPC: Book3S HV: Sanitize special-purpose register values on guest exit
+ ARM: dts: dra7: do not gate cpsw clock due to errata i877
+ ARM: OMAP2+: hwmod: Introduce ti,no-idle dt property
+ target: Drop incorrect ABORT_TASK put for completed commands
+ ubi: Fix out of bounds write in volume update code
+ MIPS: traps: Fix SIGFPE information leak from `do_ov' and `do_trap_or_bp'
+ ovl: copy new uid/gid into overlayfs runtime inode
+ ovl: fix getcwd() failure after unsuccessful rmdir
+ ALSA: hda - Fix mic issues on Acer Aspire E1-472
+ PM / sleep / x86: Fix crash on graph trace through x86 suspend
+ drm/radeon/pm: update current crtc info after setting the powerstate
+ USB: qcserial: add Sierra Wireless EM74xx device ID
+ drm/ast: Fix incorrect register check for DRAM width
+ ALSA: seq: oss: Don't drain at closing a client
+ mac80211: Fix Public Action frame RX in AP mode
+ USB: serial: option: add support for Quectel UC20
+ USB: serial: option: add support for Telit LE922 PID 0x1045
+ ASoC: wm_adsp: Fix enum ctl accesses in a wrong type
+ ASoC: wm8994: Fix enum ctl accesses in a wrong type
+ ASoC: wm8958: Fix enum ctl accesses in a wrong type
+ USB: cp210x: Add ID for Parrot NMEA GPS Flight Recorder
+ USB: qcserial: add Dell Wireless 5809e Gobi 4G HSPA+ (rev3)
+ ALSA: hdsp: Fix wrong boolean ctl value accesses
+ ALSA: hdspm: Fix zero-division
+ ALSA: hdspm: Fix wrong boolean ctl value accesses
+ arm/arm64: KVM: Fix ioctl error handling
+ Fix cifs_uniqueid_to_ino_t() function for s390x
+ CIFS: Fix SMB2+ interim response processing for read requests
+ cifs: fix out-of-bounds access in lease parsing
+ ALSA: timer: Fix ioctls for X32 ABI
+ ALSA: timer: Fix broken compat timer user status ioctl
+ ALSA: rawmidi: Fix ioctls X32 ABI
+ ALSA: ctl: Fix ioctls for X32 ABI
+ vfio: fix ioctl error handling
+ can: gs_usb: fixed disconnect bug by removing erroneous use of kfree()
+ libata: Align ata_device's id on a cacheline
+ iommu/amd: Apply workaround for ATS write permission check
+ iommu/amd: Fix boot warning when device 00:00.0 is not iommu covered
+ Fix directory hardlinks from deleted directories
+ jffs2: Fix page lock / f->sem deadlock
+ Revert "jffs2: Fix lock acquisition order bug in jffs2_write_begin"
+ usb: chipidea: otg: change workqueue ci_otg as freezable
+ mac80211: minstrel_ht: set default tx aggregation timeout to 0
+ Adding Intel Lewisburg device IDs for SATA
+ ahci: Order SATA device IDs for codename Lewisburg
+ ahci: add new Intel device IDs
+ [media] adv7604: fix tx 5v detect regression
+ iwlwifi: mvm: inc pending frames counter also when txing non-sta
+ libata: fix HDIO_GET_32BIT ioctl
+ mac80211: fix use of uninitialised values in RX aggregation
+ cfg80211/wext: fix message ordering
+ wext: fix 

[Kernel-packages] [Bug 1560202] Re: [LENOVO 80LM] suspend/resume failure

2016-03-24 Thread Joseph Salisbury
Did this issue start happening after an update/upgrade?  Was there a
prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v4.5 kernel[0].

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:
'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as
"Confirmed".


Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/

** Changed in: linux (Ubuntu)
   Importance: Undecided => Critical

** Changed in: linux (Ubuntu)
   Importance: Critical => Medium

** Changed in: linux (Ubuntu)
   Status: Confirmed => Incomplete

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560202

Title:
  [LENOVO 80LM] suspend/resume failure

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  Lenovo B51 with Ubuntu Mate 16.04, fresh and up to date installed. The
  system fails to suspend from any known method (dm menu, session menu,
  pm-suspend). Hard reset required after every  attempt.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-15-generic 4.4.0-15.31
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/pcmC0D0p:   sergio 1920 F...m pulseaudio
   /dev/snd/controlC0:  sergio 1920 F pulseaudio
  CurrentDesktop: MATE
  Date: Mon Mar 21 21:12:47 2016
  EcryptfsInUse: Yes
  HibernationDevice: RESUME=UUID=b2e611bd-bf9b-4a08-a32f-f2691d75c3c9
  InstallationDate: Installed on 2016-03-21 (0 days ago)
  InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Alpha amd64 
(20160224)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 8087:0a2a Intel Corp. 
   Bus 001 Device 002: ID 174f:14f2 Syntek 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 80LM
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic 
root=UUID=15117e0b-6e2f-4471-83be-5d0c22689f0f ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/12/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: D7CN15WW(V1.01)
  dmi.board.asset.tag: NO Asset Tag
  dmi.board.name: Lenovo B51-80
  dmi.board.vendor: LENOVO
  dmi.board.version: No DPK
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo B51-80
  dmi.modalias: 
dmi:bvnLENOVO:bvrD7CN15WW(V1.01):bd08/12/2015:svnLENOVO:pn80LM:pvrLenovoB51-80:rvnLENOVO:rnLenovoB51-80:rvrNoDPK:cvnLENOVO:ct10:cvrLenovoB51-80:
  dmi.product.name: 80LM
  dmi.product.version: Lenovo B51-80
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560202/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1553811] Re: Thinkpad T460: Trackpoint mouse buttons instantly generate "release" event on press

2016-03-24 Thread Tim Gardner
** Changed in: linux (Ubuntu Xenial)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-lts-utopic in Ubuntu.
https://bugs.launchpad.net/bugs/1553811

Title:
  Thinkpad T460: Trackpoint mouse buttons instantly generate "release"
  event on press

Status in linux package in Ubuntu:
  Fix Committed
Status in linux-lts-utopic package in Ubuntu:
  In Progress
Status in linux-lts-vivid package in Ubuntu:
  In Progress
Status in linux source package in Trusty:
  In Progress
Status in linux-lts-utopic source package in Trusty:
  In Progress
Status in linux-lts-vivid source package in Trusty:
  In Progress
Status in linux source package in Wily:
  In Progress
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  When using the trackpoint mouse buttons on the laptop, when any of the
  buttons are pressed a release event immediately follows, even if the
  mouse button is being held down. This prevents moving of windows,
  typical drag & drop operations, selection etc with the mouse.

  Example output from xev for button 1:

  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097221, (116,59), root:(116,142),
  state 0x0, button 1, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097229, (116,59), root:(116,142),
  state 0x100, button 1, same_screen YES

  Button 2:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x0, button 2, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x200, button 2, same_screen YES

  Button 3:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098467, (116,59), root:(116,142),
  state 0x0, button 3, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098477, (116,59), root:(116,142),
  state 0x400, button 3, same_screen YES

  
  Possibly relevant output from journal:
  kernel: thinkpad_acpi: ThinkPad ACPI Extras v0.25
  kernel: thinkpad_acpi: http://ibm-acpi.sf.net/
  kernel: thinkpad_acpi: ThinkPad BIOS R06ET33W (1.07 ), EC unknown
  kernel: thinkpad_acpi: Lenovo ThinkPad T460, model 20FNCTO1WW
  kernel: thinkpad_acpi: detected a 8-level brightness capable ThinkPad
  kernel: thinkpad_acpi: unknown version of the HKEY interface: 0x200
  kernel: thinkpad_acpi: please report this to 
ibm-acpi-de...@lists.sourceforge.net
  kernel: thinkpad_acpi: radio switch found; radios are enabled
  kernel: thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness 
control, supported by the ACPI video driver
  kernel: thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
  kernel: thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
  kernel: thinkpad_acpi: Standard ACPI backlight interface available, not 
loading native one
  kernel: input: ThinkPad Extra Buttons as 
/devices/platform/thinkpad_acpi/input/input7
  sensors[1000]: thinkpad-isa-
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed
  kernel: thinkpad_acpi: acpi_evalf(GTRW, dd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot read adaptive keyboard mode.
  kernel: thinkpad_acpi: acpi_evalf(STRW, vd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot set adaptive keyboard mode.
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-10-generic 4.4.0-10.25
  ProcVersionSignature: Ubuntu 4.4.0-10.25-generic 4.4.3
  Uname: Linux 4.4.0-10-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Sun Mar  6 12:38:59 2016
  HibernationDevice: RESUME=UUID=04e04e17-3976-4daa-a1dd-2dd369aee83d
  InstallationDate: Installed on 2015-09-21 (166 days ago)
  InstallationMedia: It
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20FNCTO1WW
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-10-generic 
root=/dev/mapper/it--vg-root ro quiet intel_pstate=no_hwp
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-10-generic N/A
   linux-backports-modules-4.4.0-10-generic  N/A
   linux-firmware1.156
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-02-24 (10 days ago)
  dmi.bios.date: 01/05/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R06ET33W (1.07 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20FNCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No 

[Kernel-packages] [Bug 1532498] Re: Atheros wifi qca6174 hw3.2 is not supported

2016-03-24 Thread David
Not yet solved for Xenial
4.4.0-15-generic #31-Ubuntu SMP Fri Mar 18 19:08:31 UTC 2016 x86_64 x86_64 
x86_64 GNU/Linux
linux-firmware 1.157

Happy to debug further

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1532498

Title:
  Atheros wifi qca6174 hw3.2 is not supported

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Wifi hardware not supported under Ubuntu 15.10 kernel 4.2.0-23-generic

  $ dmesg | grep ath10k
  [1.729989] ath10k_pci :3b:00.0: enabling device ( -> 0002)
  [1.733061] ath10k_pci :3b:00.0: pci irq msi-x interrupts 8 irq_mode 0 
reset_mode 0
  [1.935127] ath10k_pci :3b:00.0: Direct firmware load for 
ath10k/cal-pci-:3b:00.0.bin failed with error -2
  [1.938035] ath10k_pci :3b:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/board-pci-168c:003e:144d:412f.bin failed with error -2
  [1.938038] ath10k_pci :3b:00.0: failed to load spec board file, 
falling back to generic: -2
  [1.938624] ath10k_pci :3b:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
  [1.938627] ath10k_pci :3b:00.0: could not fetch firmware file 
'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
  [4.064026] ath10k_pci :3b:00.0: qca6174 hw3.2 (0x0503, 
0x00340aff, 168c:003e:144d:412f fallback) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 api 
4 htt 3.26 wmi 4 cal otp max_sta 32
  [4.064029] ath10k_pci :3b:00.0: debug 0 debugfs 1 tracing 1 dfs 0 
testmode 0
  [5.061061] ath10k_pci :3b:00.0: suspend timed out - target pause 
event never came
  [8.136872] ath10k_pci :3b:00.0 wlp59s0: renamed from wlan0
  [   13.371834] ath10k_pci :3b:00.0: failed to enable dynamic BW: -11
  [   16.371511] ath10k_pci :3b:00.0: could not suspend target (-11)
  [   24.658229] ath10k_pci :3b:00.0: failed to enable dynamic BW: -11
  [   27.657788] ath10k_pci :3b:00.0: could not suspend target (-11)

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-23-generic 4.2.0-23.28
  ProcVersionSignature: Ubuntu 4.2.0-23.28-generic 4.2.6
  Uname: Linux 4.2.0-23-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  dwebber1658 F pulseaudio
  CurrentDesktop: Unity
  Date: Sat Jan  9 18:20:08 2016
  HibernationDevice: RESUME=UUID=0df65023-ded0-4eac-aa6d-d8494ecd7206
  InstallationDate: Installed on 2015-12-22 (18 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 940Z5L
  ProcEnviron:
   LANGUAGE=en_US
   TERM=xterm-256color
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-23-generic.efi.signed 
root=UUID=24c27814-5135-4a80-9ce1-b932e2513949 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-23-generic N/A
   linux-backports-modules-4.2.0-23-generic  N/A
   linux-firmware1.149.3
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/20/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P04AFC.084.151020.SH
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: NP940Z5L-X01US
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: SGL8554A1H-C01-G001-S0001+10.0.10240
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: N/A
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP04AFC.084.151020.SH:bd10/20/2015:svnSAMSUNGELECTRONICSCO.,LTD.:pn940Z5L:pvrP04AFC:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP940Z5L-X01US:rvrSGL8554A1H-C01-G001-S0001+10.0.10240:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
  dmi.product.name: 940Z5L
  dmi.product.version: P04AFC
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1532498/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1549354] Re: After upgrading to 4.2.0.30 Elantech touchpad not detected

2016-03-24 Thread Joseph Salisbury
I built the next test kernel, up to the following commit:
a7dbd2e3268627cedc6b10adc39b5e544a71655f

The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1549354

Can you test that kernel and report back if it has the bug or not? I
will build the next test kernel based on your test results.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1549354

Title:
  After upgrading to 4.2.0.30 Elantech touchpad not detected

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Wily:
  In Progress

Bug description:
  Elan Touchpad not listed as "Elan Touchpad" after "xinput list" or "cat 
/proc/bus/input/devices"
   . Not detected properly? For sure it does not work.
  External mouse working well. 
  Downgrading to 4.2.0-27-generic kernel solves problem(touchpad works). 
  My computer model is Toshiba Chromebook 2 with Gnome ubuntu 15.10

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-30-generic 4.2.0-30.35
  ProcVersionSignature: Ubuntu 4.2.0-30.35-generic 4.2.8-ckt3
  Uname: Linux 4.2.0-30-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  siulkilulki909 F pulseaudio
  CurrentDesktop: GNOME
  Date: Wed Feb 24 16:55:47 2016
  InstallationDate: Installed on 2015-12-06 (80 days ago)
  InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 
(20151021)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 8087:07dc Intel Corp. 
   Bus 001 Device 003: ID 04f2:b48b Chicony Electronics Co., Ltd 
   Bus 001 Device 002: ID 1ea7:0011  
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: GOOGLE Swanky
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-30-generic 
root=UUID=20463b36-edda-428c-a236-f715f1d7bb85 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-30-generic N/A
   linux-backports-modules-4.2.0-30-generic  N/A
   linux-firmware1.149.3
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/22/2014
  dmi.bios.vendor: coreboot
  dmi.chassis.type: 3
  dmi.chassis.vendor: GOOGLE
  dmi.modalias: 
dmi:bvncoreboot:bvr:bd08/22/2014:svnGOOGLE:pnSwanky:pvr1.0:cvnGOOGLE:ct3:cvr:
  dmi.product.name: Swanky
  dmi.product.version: 1.0
  dmi.sys.vendor: GOOGLE

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1549354/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1553811] Re: Thinkpad T460: Trackpoint mouse buttons instantly generate "release" event on press

2016-03-24 Thread Joseph Salisbury
** Also affects: linux-lts-vivid (Ubuntu)
   Importance: Undecided
   Status: New

** Also affects: linux-lts-utopic (Ubuntu)
   Importance: Undecided
   Status: New

** No longer affects: linux-lts-utopic (Ubuntu Xenial)

** No longer affects: linux-lts-vivid (Ubuntu Xenial)

** Also affects: linux (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-lts-utopic (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-lts-vivid (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-lts-utopic (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-lts-vivid (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-lts-utopic (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-lts-vivid (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** No longer affects: linux (Ubuntu Vivid)

** Changed in: linux (Ubuntu Wily)
   Status: New => In Progress

** Changed in: linux (Ubuntu Wily)
 Assignee: (unassigned) => Joseph Salisbury (jsalisbury)

** Changed in: linux (Ubuntu Trusty)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu Trusty)
   Status: New => In Progress

** Changed in: linux (Ubuntu Trusty)
 Assignee: (unassigned) => Joseph Salisbury (jsalisbury)

** Changed in: linux (Ubuntu Wily)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu Xenial)
   Importance: High => Medium

** No longer affects: linux-lts-utopic (Ubuntu Vivid)

** No longer affects: linux-lts-utopic (Ubuntu Wily)

** No longer affects: linux-lts-vivid (Ubuntu Vivid)

** No longer affects: linux-lts-vivid (Ubuntu Wily)

** Changed in: linux-lts-utopic (Ubuntu)
   Status: New => In Progress

** Changed in: linux-lts-utopic (Ubuntu)
   Importance: Undecided => Medium

** Changed in: linux-lts-utopic (Ubuntu)
 Assignee: (unassigned) => Joseph Salisbury (jsalisbury)

** Changed in: linux-lts-utopic (Ubuntu Trusty)
   Status: New => In Progress

** Changed in: linux-lts-utopic (Ubuntu Trusty)
   Importance: Undecided => Medium

** Changed in: linux-lts-utopic (Ubuntu Trusty)
 Assignee: (unassigned) => Joseph Salisbury (jsalisbury)

** Changed in: linux-lts-vivid (Ubuntu)
 Assignee: (unassigned) => Joseph Salisbury (jsalisbury)

** Changed in: linux-lts-vivid (Ubuntu)
   Importance: Undecided => Medium

** Changed in: linux-lts-vivid (Ubuntu)
   Status: New => In Progress

** Changed in: linux-lts-vivid (Ubuntu Trusty)
   Status: New => In Progress

** Changed in: linux-lts-vivid (Ubuntu Trusty)
   Importance: Undecided => Medium

** Changed in: linux-lts-vivid (Ubuntu Trusty)
 Assignee: (unassigned) => Joseph Salisbury (jsalisbury)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-lts-vivid in Ubuntu.
https://bugs.launchpad.net/bugs/1553811

Title:
  Thinkpad T460: Trackpoint mouse buttons instantly generate "release"
  event on press

Status in linux package in Ubuntu:
  In Progress
Status in linux-lts-utopic package in Ubuntu:
  In Progress
Status in linux-lts-vivid package in Ubuntu:
  In Progress
Status in linux source package in Trusty:
  In Progress
Status in linux-lts-utopic source package in Trusty:
  In Progress
Status in linux-lts-vivid source package in Trusty:
  In Progress
Status in linux source package in Wily:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  When using the trackpoint mouse buttons on the laptop, when any of the
  buttons are pressed a release event immediately follows, even if the
  mouse button is being held down. This prevents moving of windows,
  typical drag & drop operations, selection etc with the mouse.

  Example output from xev for button 1:

  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097221, (116,59), root:(116,142),
  state 0x0, button 1, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097229, (116,59), root:(116,142),
  state 0x100, button 1, same_screen YES

  Button 2:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x0, button 2, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x200, button 2, same_screen YES

  Button 3:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098467, (116,59), root:(116,142),
  state 0x0, button 3, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, 

[Kernel-packages] [Bug 1561714] [NEW] Vivid update to v3.19.8-ckt17 stable release

2016-03-24 Thread Kamal Mostafa
Public bug reported:


SRU Justification

Impact:
   The upstream process for stable tree updates is quite similar
   in scope to the Ubuntu SRU process, e.g., each patch has to
   demonstrably fix a bug, and each patch is vetted by upstream
   by originating either directly from a mainline/stable Linux tree or
   a minimally backported form of that patch. The v3.19.8-ckt17 upstream 
stable
   patch set is now available. It should be included in the Ubuntu
   kernel as well.

   git://kernel.ubuntu.com/ubuntu/linux.git

TEST CASE: TBD

   The following patches from the v3.19.8-ckt17 stable release shall
be applied:

** Affects: linux (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: linux (Ubuntu Vivid)
 Importance: Undecided
 Status: New


** Tags: kernel-stable-tracking-bug

** Tags added: kernel-stable-tracking-bug

** Also affects: linux (Ubuntu Vivid)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561714

Title:
  Vivid update to v3.19.8-ckt17 stable release

Status in linux package in Ubuntu:
  New
Status in linux source package in Vivid:
  New

Bug description:
  
  SRU Justification

  Impact:
 The upstream process for stable tree updates is quite similar
 in scope to the Ubuntu SRU process, e.g., each patch has to
 demonstrably fix a bug, and each patch is vetted by upstream
 by originating either directly from a mainline/stable Linux tree or
 a minimally backported form of that patch. The v3.19.8-ckt17 upstream 
stable
 patch set is now available. It should be included in the Ubuntu
 kernel as well.

 git://kernel.ubuntu.com/ubuntu/linux.git

  TEST CASE: TBD

 The following patches from the v3.19.8-ckt17 stable release
  shall be applied:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561714/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1560583] Re: reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

2016-03-24 Thread John Johansen
Please note, this will require future backport kernels to be patched to
maintain this semantic for the LTS release.  Upstream kernels and future
ubuntu kernels will not retain the broken semantic.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560583

Title:
  reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  $ cat ./t
  #include 

  profile t {
 #include 
 /bin/cat ixr,
 /sys/kernel/security/apparmor/profiles r,
  }

  $ sudo apparmor_parser -r ./t
  $ sudo aa-exec -p t -- cat /sys/kernel/security/apparmor/profiles 
  cat: /sys/kernel/security/apparmor/profiles: Permission denied
  [1]

  kernel: [   62.203035] audit: type=1400 audit(1458665428.726:128):
  apparmor="DENIED" operation="capable" profile="t" pid=3683 comm="cat"
  capability=33  capname="mac_admin"

  This is new in the -15 kernel.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560583/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561677] Re: Wily update to v4.2.8-ckt6 stable release

2016-03-24 Thread Kamal Mostafa
** Changed in: linux (Ubuntu Wily)
   Status: New => Fix Committed

** Description changed:

+ SRU Justification
  
- SRU Justification
+ Impact:
+    The upstream process for stable tree updates is quite similar
+    in scope to the Ubuntu SRU process, e.g., each patch has to
+    demonstrably fix a bug, and each patch is vetted by upstream
+    by originating either directly from a mainline/stable Linux tree or
+    a minimally backported form of that patch. The v4.2.8-ckt6 upstream 
stable
+    patch set is now available. It should be included in the Ubuntu
+    kernel as well.
  
- Impact:
-The upstream process for stable tree updates is quite similar
-in scope to the Ubuntu SRU process, e.g., each patch has to
-demonstrably fix a bug, and each patch is vetted by upstream
-by originating either directly from a mainline/stable Linux tree or
-a minimally backported form of that patch. The v4.2.8-ckt6 upstream 
stable
-patch set is now available. It should be included in the Ubuntu
-kernel as well.
+    git://kernel.ubuntu.com/ubuntu/linux.git
  
-git://kernel.ubuntu.com/ubuntu/linux.git
+ TEST CASE: TBD
  
- TEST CASE: TBD
+    The following patches from the v4.2.8-ckt6 stable release shall
+ be applied:
  
-The following patches from the v4.2.8-ckt6 stable release shall
- be applied:
+ Linux 4.2.8-ckt6
+ mld, igmp: Fix reserved tailroom calculation
+ net: moxa: fix an error code
+ net: qca_spi: Don't clear IFF_BROADCAST
+ cdc_ncm: do not call usbnet_link_change from cdc_ncm_bind
+ net/mlx5e: Remove wrong poll CQ optimization
+ ipv6: re-enable fragment header matching in ipv6_find_hdr
+ net/mlx4_core: Allow resetting VF admin mac to zero
+ ppp: release rtnl mutex when interface creation fails
+ ext4: iterate over buffer heads correctly in move_extent_per_page()
+ tcp: convert cached rtt from usec to jiffies when feeding initial rto
+ be2net: Don't leak iomapped memory on removal.
+ tcp: fix tcpi_segs_in after connection establishment
+ MIPS: smp.c: Fix uninitialised temp_foreign_map
+ dmaengine: pxa_dma: fix cyclic transfers
+ IB/core: Use GRH when the path hop-limit > 0
+ MIPS: Fix build error when SMP is used without GIC
+ dmaengine: at_xdmac: fix residue computation
+ KVM: MMU: fix ept=0/pte.u=1/pte.w=0/CR0.WP=0/CR4.SMEP=1/EFER.NX=0 combo
+ tracing: Fix check for cpu online when event is disabled
+ arm64: account for sparsemem section alignment when choosing vmemmap offset
+ KVM: VMX: disable PEBS before a guest entry
+ jffs2: reduce the breakage on recovery from halfway failed rename()
+ ncpfs: fix a braino in OOM handling in ncp_fill_cache()
+ KVM: PPC: Book3S HV: Sanitize special-purpose register values on guest exit
+ PCI: Allow a NULL "parent" pointer in pci_bus_assign_domain_nr()
+ ARM: dts: dra7: do not gate cpsw clock due to errata i877
+ ARM: OMAP2+: hwmod: Introduce ti,no-idle dt property
+ target: Drop incorrect ABORT_TASK put for completed commands
+ ubi: Fix out of bounds write in volume update code
+ MIPS: traps: Fix SIGFPE information leak from `do_ov' and `do_trap_or_bp'
+ ovl: ignore lower entries when checking purity of non-directory entries
+ ovl: fix getcwd() failure after unsuccessful rmdir
+ ovl: fix working on distributed fs as lower layer
+ ALSA: hda - Fix mic issues on Acer Aspire E1-472
+ PM / sleep / x86: Fix crash on graph trace through x86 suspend
+ drm/amdgpu: return from atombios_dp_get_dpcd only when error
+ drm/radeon/pm: update current crtc info after setting the powerstate
+ drm/amdgpu/pm: update current crtc info after setting the powerstate
+ USB: qcserial: add Sierra Wireless EM74xx device ID
+ drm/ast: Fix incorrect register check for DRAM width
+ parisc: Fix ptrace syscall number and return value modification
+ ALSA: seq: oss: Don't drain at closing a client
+ i2c: brcmstb: allocate correct amount of memory for regmap
+ mac80211: Fix Public Action frame RX in AP mode
+ mac80211: check PN correctly for GCMP-encrypted fragmented MPDUs
+ ALSA: usb-audio: Add a quirk for Plantronics DA45
+ USB: serial: option: add support for Quectel UC20
+ USB: serial: option: add support for Telit LE922 PID 0x1045
+ ASoC: wm_adsp: Fix enum ctl accesses in a wrong type
+ ASoC: wm8994: Fix enum ctl accesses in a wrong type
+ ASoC: wm8958: Fix enum ctl accesses in a wrong type
+ ASoC: dapm: Fix ctl value accesses in a wrong type
+ USB: cp210x: Add ID for Parrot NMEA GPS Flight Recorder
+ USB: qcserial: add Dell Wireless 5809e Gobi 4G HSPA+ (rev3)
+ use ->d_seq to get coherency between ->d_inode and ->d_flags
+ ALSA: hdsp: Fix wrong boolean ctl value accesses
+ ALSA: hdspm: Fix zero-division
+ ALSA: hdspm: Fix wrong boolean ctl value accesses
+ MIPS: kvm: Fix ioctl error handling.
+ arm/arm64: KVM: Fix ioctl error handling
+ Fix cifs_uniqueid_to_ino_t() function for s390x
+ CIFS: Fix SMB2+ interim response processing for read requests
+ cifs: fix 

[Kernel-packages] [Bug 1560583] Re: reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

2016-03-24 Thread Tyler Hicks
I spoke with John in IRC. While he still doesn't like the two patches
that were written to fix this bug, he understands the reasoning.

They're needed for 16.04 so do not revert them.

In a future release, we'll do a more complete lock down of the
apparmorfs profiles file and apparmorfs profile directory to satisfy the
goal that John has.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560583

Title:
  reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  $ cat ./t
  #include 

  profile t {
 #include 
 /bin/cat ixr,
 /sys/kernel/security/apparmor/profiles r,
  }

  $ sudo apparmor_parser -r ./t
  $ sudo aa-exec -p t -- cat /sys/kernel/security/apparmor/profiles 
  cat: /sys/kernel/security/apparmor/profiles: Permission denied
  [1]

  kernel: [   62.203035] audit: type=1400 audit(1458665428.726:128):
  apparmor="DENIED" operation="capable" profile="t" pid=3683 comm="cat"
  capability=33  capname="mac_admin"

  This is new in the -15 kernel.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560583/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1553811] Re: Thinkpad T460: Trackpoint mouse buttons instantly generate "release" event on press

2016-03-24 Thread Lukas Humbel
Ok, I just ran the two kernels. The issue exists in both.

Thanks for your work!

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1553811

Title:
  Thinkpad T460: Trackpoint mouse buttons instantly generate "release"
  event on press

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  When using the trackpoint mouse buttons on the laptop, when any of the
  buttons are pressed a release event immediately follows, even if the
  mouse button is being held down. This prevents moving of windows,
  typical drag & drop operations, selection etc with the mouse.

  Example output from xev for button 1:

  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097221, (116,59), root:(116,142),
  state 0x0, button 1, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097229, (116,59), root:(116,142),
  state 0x100, button 1, same_screen YES

  Button 2:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x0, button 2, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x200, button 2, same_screen YES

  Button 3:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098467, (116,59), root:(116,142),
  state 0x0, button 3, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098477, (116,59), root:(116,142),
  state 0x400, button 3, same_screen YES

  
  Possibly relevant output from journal:
  kernel: thinkpad_acpi: ThinkPad ACPI Extras v0.25
  kernel: thinkpad_acpi: http://ibm-acpi.sf.net/
  kernel: thinkpad_acpi: ThinkPad BIOS R06ET33W (1.07 ), EC unknown
  kernel: thinkpad_acpi: Lenovo ThinkPad T460, model 20FNCTO1WW
  kernel: thinkpad_acpi: detected a 8-level brightness capable ThinkPad
  kernel: thinkpad_acpi: unknown version of the HKEY interface: 0x200
  kernel: thinkpad_acpi: please report this to 
ibm-acpi-de...@lists.sourceforge.net
  kernel: thinkpad_acpi: radio switch found; radios are enabled
  kernel: thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness 
control, supported by the ACPI video driver
  kernel: thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
  kernel: thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
  kernel: thinkpad_acpi: Standard ACPI backlight interface available, not 
loading native one
  kernel: input: ThinkPad Extra Buttons as 
/devices/platform/thinkpad_acpi/input/input7
  sensors[1000]: thinkpad-isa-
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed
  kernel: thinkpad_acpi: acpi_evalf(GTRW, dd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot read adaptive keyboard mode.
  kernel: thinkpad_acpi: acpi_evalf(STRW, vd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot set adaptive keyboard mode.
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-10-generic 4.4.0-10.25
  ProcVersionSignature: Ubuntu 4.4.0-10.25-generic 4.4.3
  Uname: Linux 4.4.0-10-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Sun Mar  6 12:38:59 2016
  HibernationDevice: RESUME=UUID=04e04e17-3976-4daa-a1dd-2dd369aee83d
  InstallationDate: Installed on 2015-09-21 (166 days ago)
  InstallationMedia: It
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20FNCTO1WW
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-10-generic 
root=/dev/mapper/it--vg-root ro quiet intel_pstate=no_hwp
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-10-generic N/A
   linux-backports-modules-4.4.0-10-generic  N/A
   linux-firmware1.156
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-02-24 (10 days ago)
  dmi.bios.date: 01/05/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R06ET33W (1.07 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20FNCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrR06ET33W(1.07):bd01/05/2016:svnLENOVO:pn20FNCTO1WW:pvrThinkPadT460:rvnLENOVO:rn20FNCTO1WW:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20FNCTO1WW
  dmi.product.version: ThinkPad T460
  dmi.sys.vendor: LENOVO

To manage 

[Kernel-packages] [Bug 1549354] Re: After upgrading to 4.2.0.30 Elantech touchpad not detected

2016-03-24 Thread Thomas Zell
I confirm that commit cc0a33f849da5571bd1cae03bde0ac59f9fe9a45 works.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1549354

Title:
  After upgrading to 4.2.0.30 Elantech touchpad not detected

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Wily:
  In Progress

Bug description:
  Elan Touchpad not listed as "Elan Touchpad" after "xinput list" or "cat 
/proc/bus/input/devices"
   . Not detected properly? For sure it does not work.
  External mouse working well. 
  Downgrading to 4.2.0-27-generic kernel solves problem(touchpad works). 
  My computer model is Toshiba Chromebook 2 with Gnome ubuntu 15.10

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-30-generic 4.2.0-30.35
  ProcVersionSignature: Ubuntu 4.2.0-30.35-generic 4.2.8-ckt3
  Uname: Linux 4.2.0-30-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  siulkilulki909 F pulseaudio
  CurrentDesktop: GNOME
  Date: Wed Feb 24 16:55:47 2016
  InstallationDate: Installed on 2015-12-06 (80 days ago)
  InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 
(20151021)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 8087:07dc Intel Corp. 
   Bus 001 Device 003: ID 04f2:b48b Chicony Electronics Co., Ltd 
   Bus 001 Device 002: ID 1ea7:0011  
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: GOOGLE Swanky
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-30-generic 
root=UUID=20463b36-edda-428c-a236-f715f1d7bb85 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-30-generic N/A
   linux-backports-modules-4.2.0-30-generic  N/A
   linux-firmware1.149.3
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/22/2014
  dmi.bios.vendor: coreboot
  dmi.chassis.type: 3
  dmi.chassis.vendor: GOOGLE
  dmi.modalias: 
dmi:bvncoreboot:bvr:bd08/22/2014:svnGOOGLE:pnSwanky:pvr1.0:cvnGOOGLE:ct3:cvr:
  dmi.product.name: Swanky
  dmi.product.version: 1.0
  dmi.sys.vendor: GOOGLE

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1549354/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1560583] Re: reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

2016-03-24 Thread John Johansen
To clarify "necessary to open up".

1. the old behavior was wrong. It allowed introspection of policy in situation 
that it should not have.
2. In order to open up the profiles file so that more than the system root 
could introspect it, DAC restrictions needed to be removed and the permission 
checking of what is allowed needed to be moved fully into apparmor. Since there 
was not time for fine grained mediation in the first iteration, the tightest 
restriction with original intent was used.

That is that only the policy admin is allowed fully view of loaded
policy. This can be opened up with further development but is the
original intent of how policy introspection was supposed to work (hence
#1 noting that implementation was flawed and wrong).

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560583

Title:
  reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  $ cat ./t
  #include 

  profile t {
 #include 
 /bin/cat ixr,
 /sys/kernel/security/apparmor/profiles r,
  }

  $ sudo apparmor_parser -r ./t
  $ sudo aa-exec -p t -- cat /sys/kernel/security/apparmor/profiles 
  cat: /sys/kernel/security/apparmor/profiles: Permission denied
  [1]

  kernel: [   62.203035] audit: type=1400 audit(1458665428.726:128):
  apparmor="DENIED" operation="capable" profile="t" pid=3683 comm="cat"
  capability=33  capname="mac_admin"

  This is new in the -15 kernel.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560583/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1556562] Re: VIA C7-D machine "kernel NULL pointer dereference" in skcipher_recvmsg_async

2016-03-24 Thread Kamal Mostafa
Jeffrey-  Thanks for testing and confirming the fix.  We'll get those
patches into the (likely next) Wily 4.2 kernel.  A message will be
posted to this bug once the fix lands in -proposed.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1556562

Title:
  VIA C7-D machine "kernel NULL pointer dereference" in
  skcipher_recvmsg_async

Status in linux package in Ubuntu:
  Confirmed
Status in linux source package in Wily:
  In Progress

Bug description:
  I'm working on an Lubuntu 15 machine. It was chosen because it
  supports VIA C7-D processor and the VIA PM400 chipset without crashing
  (also see ). Lubuntu 15 uses the 4.2 kernel:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:Ubuntu 15.10
Release:15.10
Codename:   wily

  And:

$ uname -a
Linux via 4.2.0-30-generic #36-Ubuntu SMP Fri Feb 26 00:57:19 UTC 2016 i686 
i686 i686 GNU/Linux

  When running a particular program (details below), it hangs in syscall
  248 and results in the following dmesg/syslog output. The process
  cannot be killed, the machine does not respond to a 'shutdown -r now',
  and the machine requires a hard reset.

  ...
  [ 4505.429577] BUG: unable to handle kernel NULL pointer dereference at 
0008
  [ 4505.429593] IP: [] skcipher_recvmsg_async.isra.13+0x4b2/0x500 
[algif_skcipher]
  [ 4505.429607] *pdpt = 34ee3001 *pde =  
  [ 4505.429614] Oops:  [#3] SMP 
  [ 4505.429621] Modules linked in: jitterentropy_rng drbg ansi_cprng 
algif_skcipher af_alg snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel 
snd_hda_codec snd_hda_core snd_hwdep snd_pcm snd_seq_midi snd_seq_midi_event 
snd_rawmidi padlock_sha snd_seq padlock_aes snd_seq_device via_cputemp 
snd_timer hwmon_vid via_rng snd input_leds serio_raw soundcore i2c_viapro 
shpchp 8250_fintek mac_hid parport_pc ppdev lp parport autofs4 pata_acpi 
hid_generic usbhid hid psmouse r8169 pata_via sata_via mii
  [ 4505.429689] CPU: 0 PID: 1532 Comm: afalgtest Tainted: G  D 
4.2.0-30-generic #36-Ubuntu
  [ 4505.429695] Hardware name: To Be Filled By O.E.M. To Be Filled By 
O.E.M./Weibu, BIOS 080014  11/17/2011
  [ 4505.429700] task: f4e0e040 ti: f4e3c000 task.ti: f4e3c000
  [ 4505.429705] EIP: 0060:[] EFLAGS: 00010202 CPU: 0
  [ 4505.429712] EIP is at skcipher_recvmsg_async.isra.13+0x4b2/0x500 
[algif_skcipher]
  [ 4505.429717] EAX: f3f97c00 EBX: f3f3ee00 ECX: f3f97c00 EDX: 
  [ 4505.429722] ESI: f3f3ee00 EDI: 0ff0 EBP: f4e3ddc8 ESP: f4e3dd70
  [ 4505.429726]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
  [ 4505.429731] CR0: 80050033 CR2: 0008 CR3: 3247a520 CR4: 06b0
  [ 4505.429735] Stack:
  [ 4505.429738]  f3f97df4 f3f97c00 f3f97de0  f3f97c04 0020 
f4e3dd00 0018
  [ 4505.429750]  1ff0 f3fb4400 f3f97c04 0ff0 f4e3de40 f3f97de8 
f4e3de38 f3fa
  [ 4505.429761]  0002 0002 f3f97c00 f1f58180 c1210510 f4e3de38 
f4e3ddf4 f8a6cd6b
  [ 4505.429772] Call Trace:
  [ 4505.429788]  [] ? free_ioctx_users+0xa0/0xa0
  [ 4505.429795]  [] skcipher_recvmsg+0x2b/0x1f0 [algif_skcipher]
  [ 4505.429803]  [] ? skcipher_check_key.isra.8+0x2a/0xb0 
[algif_skcipher]
  [ 4505.429810]  [] skcipher_recvmsg_nokey+0x31/0x40 [algif_skcipher]
  [ 4505.429820]  [] sock_recvmsg+0x3d/0x50
  [ 4505.429826]  [] sock_read_iter+0x84/0xd0
  [ 4505.429833]  [] ? sock_recvmsg+0x50/0x50
  [ 4505.429839]  [] aio_run_iocb+0x110/0x2c0
  [ 4505.429846]  [] ? sock_recvmsg+0x50/0x50
  [ 4505.429854]  [] ? error_code+0x67/0x6c
  [ 4505.429865]  [] ? kmem_cache_alloc+0x1b4/0x1e0
  [ 4505.429875]  [] ? __fdget+0x12/0x20
  [ 4505.429881]  [] do_io_submit+0x1ef/0x4a0
  [ 4505.429893]  [] ? security_file_alloc+0x2f/0x50
  [ 4505.429900]  [] SyS_io_submit+0x20/0x30
  [ 4505.429911]  [] sysenter_do_call+0x12/0x12
  [ 4505.429915] Code: 00 00 00 75 24 8b 45 ac ff 52 0c 89 c7 83 ff 8d 75 8f 8b 
45 e4 3e ff 80 fc 01 00 00 bf ef fd ff ff e9 62 fc ff ff 8d 76 00 89 c8  52 
08 89 c7 eb db 8b 45 e4 31 d2 8b 80 20 02 00 00 8b 58 1c
  [ 4505.429982] EIP: [] skcipher_recvmsg_async.isra.13+0x4b2/0x500 
[algif_skcipher] SS:ESP 0068:f4e3dd70
  [ 4505.429991] CR2: 0008
  [ 4505.429997] ---[ end trace 3cce7cc6be0ad960 ]---

  **

  The process details is this is a failed self test for the upcoming
  OpenSSL 1.1.0. The OpenSSL RT bug report for this issue is at
  http://rt.openssl.org/Ticket/Display.html?id=4411. Two attempts to
  debug it resulted in two hung processes:

  $ ps -A | grep afalgtest
  1030 pts/000:00:00 afalgtest
  1196 pts/000:00:00 afalgtest

  And:

  via:test$ sudo cat /proc/1030/syscall 
  248 0xb7fd6000 0x1 0xbfff98d4 0xb7fb9270 0xbfff98e0 0xb7ec45f7 0xbfff986c 
0xb7fdbbe8
  via:test$ sudo cat /proc/1196/syscall 
  248 0xb7fd6000 0x1 0xbfff98d4 0xb7fb9270 0xbfff98e0 0xb7ec45f7 0xbfff986c 
0xb7fdbbe8

  Its not clear to me 

[Kernel-packages] [Bug 1558120] Re: Kernel can be oopsed using remap_file_pages

2016-03-24 Thread Colin Ian King
The merge base e50f9acafe11781b0163d27172d33faf824caf7b is bad.
This means the bug has been fixed between 
e50f9acafe11781b0163d27172d33faf824caf7b and 
[d207274815a45631952c342a3b6959e79913195b].


** Changed in: linux (Ubuntu)
 Assignee: (unassigned) => Colin Ian King (colin-king)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1558120

Title:
  Kernel can be oopsed using remap_file_pages

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  While faffing around with the deprecated system call remap_file_pages
  I was able to trigger an OOPs that can be reproduced every time.

  uname -a
  Linux lenovo 4.4.0-13-generic #29-Ubuntu SMP Fri Mar 11 19:31:18 UTC 2016 
x86_64 x86_64 x86_64 GNU/Linux

  
  [   27.298469] mmap: stress-ng-remap (4061) uses deprecated 
remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.
  [   28.956497] BUG: unable to handle kernel NULL pointer dereference at 
0228
  [   28.956555] IP: [] shmem_fault+0x38/0x1e0
  [   28.956594] PGD aded1067 PUD add32067 PMD 0
  [   28.956625] Oops:  [#1] SMP
  [   28.956649] Modules linked in: nls_iso8859_1 drbg ansi_cprng xt_CHECKSUM 
iptable_mangle ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_nat_ipv4 
nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ipt_REJECT 
nf_reject_ipv4 xt_tcpudp bridge stp llc ebtable_filter ebtables ip6table_filter 
ip6_tables iptable_filter ip_tables x_tables binfmt_misc zfs(PO) zunicode(PO) 
zcommon(PO) znvpair(PO) spl(O) zavl(PO) uvcvideo intel_rapl 
x86_pkg_temp_thermal intel_powerclamp videobuf2_vmalloc coretemp 
videobuf2_memops crct10dif_pclmul videobuf2_v4l2 crc32_pclmul videobuf2_core 
v4l2_common snd_hda_codec_hdmi videodev aesni_intel snd_hda_codec_realtek 
snd_hda_codec_generic media aes_x86_64 lrw snd_seq_midi gf128mul glue_helper 
ablk_helper snd_seq_midi_event cryptd snd_hda_intel snd_hda_codec snd_hda_core
  [   28.957162]  snd_hwdep snd_rawmidi joydev input_leds arc4 serio_raw 
rtl8192ce rtl_pci rtl8192c_common snd_pcm rtlwifi snd_seq mac80211 
thinkpad_acpi nvram cfg80211 snd_seq_device mei_me mei lpc_ich snd_timer shpchp 
snd soundcore mac_hid kvm_intel kvm irqbypass parport_pc ppdev lp parport 
autofs4 btrfs raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor 
async_tx xor raid6_pq libcrc32c raid1 raid0 multipath linear mmc_block i915 
psmouse i2c_algo_bit drm_kms_helper e1000e ahci syscopyarea libahci sdhci_pci 
sysfillrect sysimgblt sdhci ptp fb_sys_fops pps_core drm wmi fjes video
  [   28.957570] CPU: 2 PID: 4061 Comm: stress-ng-remap Tainted: P   O  
  4.4.0-13-generic #29-Ubuntu
  [   28.957623] Hardware name: LENOVO 2320CTO/2320CTO, BIOS G2ET31WW (1.11 ) 
05/24/2012
  [   28.957666] task: 8800add2ee00 ti: 8800adf7c000 task.ti: 
8800adf7c000
  [   28.957707] RIP: 0010:[]  [] 
shmem_fault+0x38/0x1e0
  [   28.957754] RSP: :8800adf7fd38  EFLAGS: 00010246
  [   28.957780] RAX: 880194f06900 RBX:  RCX: 
0054
  [   28.957820] RDX:  RSI: 8800adf7fda8 RDI: 
8800a990f0c8
  [   28.957860] RBP: 8800adf7fd98 R08:  R09: 
8800adf7fe68
  [   28.957899] R10:  R11: 3000 R12: 
8800a990f0c8
  [   28.957939] R13: 8800adf7fe68 R14: 8800adf0de90 R15: 
7f83ba57b000
  [   28.957979] FS:  7f83bc46c740() GS:88019e28() 
knlGS:
  [   28.958024] CS:  0010 DS:  ES:  CR0: 80050033
  [   28.958056] CR2: 0228 CR3: ade92000 CR4: 
001406e0
  [   28.958096] Stack:
  [   28.958109]  8800aafb3840 0200adf7fd68 8800adfaf108 
8800adfaf190
  [   28.958158]  81a25e80 8800adfaf190  
b7865150
  [   28.958206]   8800a990f0c8 8800adf7fe68 
8800adf0de90
  [   28.958254] Call Trace:
  [   28.958273]  [] __do_fault+0x50/0xe0
  [   28.958305]  [] handle_mm_fault+0xf8b/0x1820
  [   28.958339]  [] ? __dentry_kill+0x162/0x1e0
  [   28.958374]  [] ? mntput+0x24/0x40
  [   28.958405]  [] __do_page_fault+0x197/0x400
  [   28.958439]  [] do_page_fault+0x22/0x30
  [   28.958472]  [] page_fault+0x28/0x30
  [   28.958501] Code: 41 54 53 49 89 fc 48 83 ec 40 c7 45 ac 00 02 00 00 65 48 
8b 04 25 28 00 00 00 48 89 45 d8 31 c0 48 8b 87 a0 00 00 00 48 8b 58 20 <48> 83 
bb 28 02 00 00 00 0f 85 98 00 00 00 48 8b 43 30 48 8d 56
  [   28.958726] RIP  [] shmem_fault+0x38/0x1e0

  How to reproduce:

  git clone git://kernel.ubuntu.com/cking/stress-ng
  cd stress-ng
  make clean; make
  ./stress-ng --remap 8 -t 20
  --- 
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/pcmC0D0p:   king   2522 F...m pulseaudio
   /dev/snd/controlC0:  king   2522 F pulseaudio
  CurrentDesktop: Unity
  

[Kernel-packages] [Bug 1561678] Status changed to Confirmed

2016-03-24 Thread Brad Figg
This change was made by a bot.

** Changed in: linux (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561678

Title:
  package linux-image-3.13.0-79-generic 3.13.0-79.123 failed to
  install/upgrade: subprocess installed post-installation script
  returned error exit status 2

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Not sure if this is the same bug that I've already reported. These
  bugs tend to pop up right after launching the OS.

  ProblemType: Package
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-79-generic 3.13.0-79.123
  ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
  Uname: Linux 3.13.0-77-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  kvols  1979 F pulseaudio
  Date: Thu Mar 24 19:04:59 2016
  ErrorMessage: subprocess installed post-installation script returned error 
exit status 2
  InstallationDate: Installed on 2014-12-14 (465 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.2)
  MachineType: LENOVO 2985FJG
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-77-generic 
root=UUID=6d24a600-7566-4141-8f9a-bad470ee7bbd ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc N/A
  SourcePackage: linux
  Title: package linux-image-3.13.0-79-generic 3.13.0-79.123 failed to 
install/upgrade: subprocess installed post-installation script returned error 
exit status 2
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/31/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6QET66WW (1.36 )
  dmi.board.name: 2985FJG
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr6QET66WW(1.36):bd05/31/2011:svnLENOVO:pn2985FJG:pvrThinkPadX201Tablet:rvnLENOVO:rn2985FJG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 2985FJG
  dmi.product.version: ThinkPad X201 Tablet
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561678/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1560583] Re: reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

2016-03-24 Thread John Johansen
This is not an issue. It is working as designed and is necessary to open
up the file for the stacking work.

This patch should be reverted immediately as it opens up a policy
introspection hole.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560583

Title:
  reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  $ cat ./t
  #include 

  profile t {
 #include 
 /bin/cat ixr,
 /sys/kernel/security/apparmor/profiles r,
  }

  $ sudo apparmor_parser -r ./t
  $ sudo aa-exec -p t -- cat /sys/kernel/security/apparmor/profiles 
  cat: /sys/kernel/security/apparmor/profiles: Permission denied
  [1]

  kernel: [   62.203035] audit: type=1400 audit(1458665428.726:128):
  apparmor="DENIED" operation="capable" profile="t" pid=3683 comm="cat"
  capability=33  capname="mac_admin"

  This is new in the -15 kernel.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560583/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561676] [NEW] fix thermal throttling due to commit "Thermal: initialize thermal zone device correctly"

2016-03-24 Thread Colin Ian King
Public bug reported:

Commit bb431ba26c5cd0a17c941ca6c3a195a3a6d5d461 ("Thermal: initialize
thermal zone device correctly") has been causing some issues with Lenovo
laptops being throttled incorrectly.  Upstream fix
81ad4276b505e987dd8ebbdf63605f92cd172b52 ("Thermal: Ignore invalid trip
points") is a fix to this.

I'm going to test this fix out over the next week and I don't see any
regressions we should apply this fix.

** Affects: linux (Ubuntu)
 Importance: Medium
 Assignee: Colin Ian King (colin-king)
 Status: In Progress

** Changed in: linux (Ubuntu)
   Status: New => In Progress

** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu)
 Assignee: (unassigned) => Colin Ian King (colin-king)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561676

Title:
  fix thermal throttling due to commit "Thermal: initialize thermal zone
  device correctly"

Status in linux package in Ubuntu:
  In Progress

Bug description:
  Commit bb431ba26c5cd0a17c941ca6c3a195a3a6d5d461 ("Thermal: initialize
  thermal zone device correctly") has been causing some issues with
  Lenovo laptops being throttled incorrectly.  Upstream fix
  81ad4276b505e987dd8ebbdf63605f92cd172b52 ("Thermal: Ignore invalid
  trip points") is a fix to this.

  I'm going to test this fix out over the next week and I don't see any
  regressions we should apply this fix.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561676/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561675] Status changed to Confirmed

2016-03-24 Thread Brad Figg
This change was made by a bot.

** Changed in: linux (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561675

Title:
  package linux-image-3.13.0-83-generic 3.13.0-83.127 failed to
  install/upgrade: subprocess installed post-installation script
  returned error exit status 2

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  I have seen these errors on every start-up for some weeks now.

  ProblemType: Package
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-83-generic 3.13.0-83.127
  ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
  Uname: Linux 3.13.0-77-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  kvols  1979 F pulseaudio
  Date: Thu Mar 24 19:05:15 2016
  ErrorMessage: subprocess installed post-installation script returned error 
exit status 2
  InstallationDate: Installed on 2014-12-14 (465 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.2)
  MachineType: LENOVO 2985FJG
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-77-generic 
root=UUID=6d24a600-7566-4141-8f9a-bad470ee7bbd ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc N/A
  SourcePackage: linux
  Title: package linux-image-3.13.0-83-generic 3.13.0-83.127 failed to 
install/upgrade: subprocess installed post-installation script returned error 
exit status 2
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/31/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6QET66WW (1.36 )
  dmi.board.name: 2985FJG
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr6QET66WW(1.36):bd05/31/2011:svnLENOVO:pn2985FJG:pvrThinkPadX201Tablet:rvnLENOVO:rn2985FJG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 2985FJG
  dmi.product.version: ThinkPad X201 Tablet
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561675/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561675] [NEW] package linux-image-3.13.0-83-generic 3.13.0-83.127 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

2016-03-24 Thread P.Kvols
Public bug reported:

I have seen these errors on every start-up for some weeks now.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-83-generic 3.13.0-83.127
ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
Uname: Linux 3.13.0-77-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  kvols  1979 F pulseaudio
Date: Thu Mar 24 19:05:15 2016
ErrorMessage: subprocess installed post-installation script returned error exit 
status 2
InstallationDate: Installed on 2014-12-14 (465 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: LENOVO 2985FJG
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-77-generic 
root=UUID=6d24a600-7566-4141-8f9a-bad470ee7bbd ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc N/A
SourcePackage: linux
Title: package linux-image-3.13.0-83-generic 3.13.0-83.127 failed to 
install/upgrade: subprocess installed post-installation script returned error 
exit status 2
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/31/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET66WW (1.36 )
dmi.board.name: 2985FJG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: 
dmi:bvnLENOVO:bvr6QET66WW(1.36):bd05/31/2011:svnLENOVO:pn2985FJG:pvrThinkPadX201Tablet:rvnLENOVO:rn2985FJG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2985FJG
dmi.product.version: ThinkPad X201 Tablet
dmi.sys.vendor: LENOVO

** Affects: linux (Ubuntu)
 Importance: Undecided
 Status: Confirmed


** Tags: amd64 apport-package trusty

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561675

Title:
  package linux-image-3.13.0-83-generic 3.13.0-83.127 failed to
  install/upgrade: subprocess installed post-installation script
  returned error exit status 2

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  I have seen these errors on every start-up for some weeks now.

  ProblemType: Package
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-83-generic 3.13.0-83.127
  ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
  Uname: Linux 3.13.0-77-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  kvols  1979 F pulseaudio
  Date: Thu Mar 24 19:05:15 2016
  ErrorMessage: subprocess installed post-installation script returned error 
exit status 2
  InstallationDate: Installed on 2014-12-14 (465 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.2)
  MachineType: LENOVO 2985FJG
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-77-generic 
root=UUID=6d24a600-7566-4141-8f9a-bad470ee7bbd ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc N/A
  SourcePackage: linux
  Title: package linux-image-3.13.0-83-generic 3.13.0-83.127 failed to 
install/upgrade: subprocess installed post-installation script returned error 
exit status 2
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/31/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6QET66WW (1.36 )
  dmi.board.name: 2985FJG
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr6QET66WW(1.36):bd05/31/2011:svnLENOVO:pn2985FJG:pvrThinkPadX201Tablet:rvnLENOVO:rn2985FJG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 2985FJG
  dmi.product.version: ThinkPad X201 Tablet
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561675/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561677] [NEW] Wily update to v4.2.8-ckt6 stable release

2016-03-24 Thread Kamal Mostafa
Public bug reported:


SRU Justification

Impact:
   The upstream process for stable tree updates is quite similar
   in scope to the Ubuntu SRU process, e.g., each patch has to
   demonstrably fix a bug, and each patch is vetted by upstream
   by originating either directly from a mainline/stable Linux tree or
   a minimally backported form of that patch. The v4.2.8-ckt6 upstream 
stable
   patch set is now available. It should be included in the Ubuntu
   kernel as well.

   git://kernel.ubuntu.com/ubuntu/linux.git

TEST CASE: TBD

   The following patches from the v4.2.8-ckt6 stable release shall
be applied:

** Affects: linux (Ubuntu)
 Importance: Undecided
 Status: New

** Affects: linux (Ubuntu Wily)
 Importance: Undecided
 Status: New


** Tags: kernel-stable-tracking-bug

** Tags added: kernel-stable-tracking-bug

** Also affects: linux (Ubuntu Wily)
   Importance: Undecided
   Status: New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561677

Title:
  Wily update to v4.2.8-ckt6 stable release

Status in linux package in Ubuntu:
  New
Status in linux source package in Wily:
  New

Bug description:
  
  SRU Justification

  Impact:
 The upstream process for stable tree updates is quite similar
 in scope to the Ubuntu SRU process, e.g., each patch has to
 demonstrably fix a bug, and each patch is vetted by upstream
 by originating either directly from a mainline/stable Linux tree or
 a minimally backported form of that patch. The v4.2.8-ckt6 upstream 
stable
 patch set is now available. It should be included in the Ubuntu
 kernel as well.

 git://kernel.ubuntu.com/ubuntu/linux.git

  TEST CASE: TBD

 The following patches from the v4.2.8-ckt6 stable release shall
  be applied:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561677/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561678] [NEW] package linux-image-3.13.0-79-generic 3.13.0-79.123 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

2016-03-24 Thread P.Kvols
Public bug reported:

Not sure if this is the same bug that I've already reported. These bugs
tend to pop up right after launching the OS.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-79-generic 3.13.0-79.123
ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
Uname: Linux 3.13.0-77-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  kvols  1979 F pulseaudio
Date: Thu Mar 24 19:04:59 2016
ErrorMessage: subprocess installed post-installation script returned error exit 
status 2
InstallationDate: Installed on 2014-12-14 (465 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: LENOVO 2985FJG
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-77-generic 
root=UUID=6d24a600-7566-4141-8f9a-bad470ee7bbd ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc N/A
SourcePackage: linux
Title: package linux-image-3.13.0-79-generic 3.13.0-79.123 failed to 
install/upgrade: subprocess installed post-installation script returned error 
exit status 2
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/31/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET66WW (1.36 )
dmi.board.name: 2985FJG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: 
dmi:bvnLENOVO:bvr6QET66WW(1.36):bd05/31/2011:svnLENOVO:pn2985FJG:pvrThinkPadX201Tablet:rvnLENOVO:rn2985FJG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2985FJG
dmi.product.version: ThinkPad X201 Tablet
dmi.sys.vendor: LENOVO

** Affects: linux (Ubuntu)
 Importance: Undecided
 Status: Confirmed


** Tags: amd64 apport-package trusty

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561678

Title:
  package linux-image-3.13.0-79-generic 3.13.0-79.123 failed to
  install/upgrade: subprocess installed post-installation script
  returned error exit status 2

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Not sure if this is the same bug that I've already reported. These
  bugs tend to pop up right after launching the OS.

  ProblemType: Package
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-79-generic 3.13.0-79.123
  ProcVersionSignature: Ubuntu 3.13.0-77.121-generic 3.13.11-ckt32
  Uname: Linux 3.13.0-77-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  kvols  1979 F pulseaudio
  Date: Thu Mar 24 19:04:59 2016
  ErrorMessage: subprocess installed post-installation script returned error 
exit status 2
  InstallationDate: Installed on 2014-12-14 (465 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.2)
  MachineType: LENOVO 2985FJG
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-77-generic 
root=UUID=6d24a600-7566-4141-8f9a-bad470ee7bbd ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions: grub-pc N/A
  SourcePackage: linux
  Title: package linux-image-3.13.0-79-generic 3.13.0-79.123 failed to 
install/upgrade: subprocess installed post-installation script returned error 
exit status 2
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/31/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6QET66WW (1.36 )
  dmi.board.name: 2985FJG
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr6QET66WW(1.36):bd05/31/2011:svnLENOVO:pn2985FJG:pvrThinkPadX201Tablet:rvnLENOVO:rn2985FJG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 2985FJG
  dmi.product.version: ThinkPad X201 Tablet
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561678/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1549354] Re: After upgrading to 4.2.0.30 Elantech touchpad not detected

2016-03-24 Thread Joseph Salisbury
I built the next test kernel, up to the following commit:
cc0a33f849da5571bd1cae03bde0ac59f9fe9a45

The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1549354

Can you test that kernel and report back if it has the bug or not? I
will build the next test kernel based on your test results.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1549354

Title:
  After upgrading to 4.2.0.30 Elantech touchpad not detected

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Wily:
  In Progress

Bug description:
  Elan Touchpad not listed as "Elan Touchpad" after "xinput list" or "cat 
/proc/bus/input/devices"
   . Not detected properly? For sure it does not work.
  External mouse working well. 
  Downgrading to 4.2.0-27-generic kernel solves problem(touchpad works). 
  My computer model is Toshiba Chromebook 2 with Gnome ubuntu 15.10

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-30-generic 4.2.0-30.35
  ProcVersionSignature: Ubuntu 4.2.0-30.35-generic 4.2.8-ckt3
  Uname: Linux 4.2.0-30-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  siulkilulki909 F pulseaudio
  CurrentDesktop: GNOME
  Date: Wed Feb 24 16:55:47 2016
  InstallationDate: Installed on 2015-12-06 (80 days ago)
  InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 
(20151021)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 8087:07dc Intel Corp. 
   Bus 001 Device 003: ID 04f2:b48b Chicony Electronics Co., Ltd 
   Bus 001 Device 002: ID 1ea7:0011  
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: GOOGLE Swanky
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-30-generic 
root=UUID=20463b36-edda-428c-a236-f715f1d7bb85 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-30-generic N/A
   linux-backports-modules-4.2.0-30-generic  N/A
   linux-firmware1.149.3
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/22/2014
  dmi.bios.vendor: coreboot
  dmi.chassis.type: 3
  dmi.chassis.vendor: GOOGLE
  dmi.modalias: 
dmi:bvncoreboot:bvr:bd08/22/2014:svnGOOGLE:pnSwanky:pvr1.0:cvnGOOGLE:ct3:cvr:
  dmi.product.name: Swanky
  dmi.product.version: 1.0
  dmi.sys.vendor: GOOGLE

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1549354/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1554003] Re: xenial kernel crash on HP BL460c G7 (qla24xx problem?)

2016-03-24 Thread Joseph Salisbury
I built the next test kernel, up to the following commit:
b11f66aebbf8369707ddde3a9a7bb01b6cb41d58

The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1554003

Can you test that kernel and report back if it has the bug or not? I
will build the next test kernel based on your test results.

Thanks in advance

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1554003

Title:
  xenial kernel crash on HP BL460c G7 (qla24xx problem?)

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  Dear Members,

  Latest Xenial kernel (linux-image-generic-4.4.0-8-generic) is crash on
  booting. Same problem with 4.4.0-9 and 4.4.0-10.

  
  [1.654419] qla2xxx [:06:00.1]-0034:3: MSI-X: Unsupported ISP 
  2432 SSVID/SSDID (0x103C,0x1705).
  [1.685273] hid-generic 0003:03F0:7029.0001: in
  [1.685273] hid-generic 0003:03F0:7029.0001: input,hidraw0: USB HID 
  v1.01 Keyboard [HP  Virtual Keyboard ] on usb-:01:00.4-1/input0
  [1.685455] input: HP  Virtual Keyboard  as 
  
/devices/pci:00/:00:1c.4/:01:00.4/usb6/6-1/6-1:1.1/0003:03F0:7029.0002/input/inpu
 
  1048576 bytes) :0
  1:00.4/usb6/6-1/6-1:1.1/0003:03F0:7029.0002/input/inpu
  [2.001109] CR2: 0050
  [2.001170] ---
  [ end trace 20a247b9d60f8e00 ]---
  [2.001232] Kernel panic - not syncing: Fatal exception in interrup
  [2.001232] Kernel panic - not syncing: Fatal exception in interrupt
  [2.001813] Kernel Offset: disabled
  [2.001873] ---
  [ end Kernel panic - not syncing: Fatal exception in interrupt
  [1.997314]  [] do_IRQ+0x4b/0xd0
  [1.997379]  [] common_interrupt+0x82/0x82
  [1.997441]  
  [1.997336] hpsa :0c:00.0: scsi 1:3:0:0: added RAID  HP
  [1.997491]  [] ? cpuidle_enter_state+0x12d/0x270
  [1.997609]  [] cpuidle_enter+0x17/0x20
  [1.997674]  [] call_cpuidle+0x32/0x60
  [1.997737]  [] ? cpuidle_select+0x13/0x20
  [1.997800]  [] cpu_startup_entry+0x266/0x320
  [1.997866]  [] rest_init+0x7c/0x80
  [1.997930]  [] start_kernel+0x481/0x4a2
  [1.997994]  [] ? early_idt_handler_array+0x120/0x120
  [1.998058]  [] x86_64_start_reservations+0x2a/0x2c
  [1.998123]  [] x86
  [1.998123]  [] x86_64_start_kernel+0x14a/0x16d
  [1.998186] Code: 00 48 89 45 d0 31 c0 48 8b 47 58 a8 02 0f 84 cf 00 
  00 00 48 8b 46 50 49 89 fd 49 89 f4 65 8b 15 06 34 e7 3f 4c 8b b7 10 02 
  00 00 <39> 50 50 74 11
89 50 50 48 8b 46 50 8b 40 50 41 89 86 58 8put,hidraw0: USB HID v1.01 
  Key 74 11 89 50 50 48 8b 46 50 8b 40 50 41 89 86 58 8b 00
  [2.000922] RIP  [] 
  qla24xx_process_response_queue+0x49/0x4a0 [qla2xxx]
  [2.001050]  RSP 
  hpiLO-> exit

  Best regards Attila
  --- 
  AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 
2: ls: cannot access '/dev/snd/': No such file or directory
  AplayDevices: Error: [Errno 2] No such file or directory
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp3', '/dev/dsp1', 
'/dev/dsp2', '/dev/dsp', '/dev/sequencer'] failed with exit code 1:
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-02-03 (32 days ago)
  InstallationMedia: Ubuntu-Server 14.04.3 LTS "Trusty Tahr" - Beta amd64 
(20150805)
  MachineType: HP ProLiant BL460c G7
  NonfreeKernelModules: raid10 raid456 async_raid6_recov async_memcpy async_pq 
async_xor async_tx xor raid6_pq raid1 raid0 multipath linear be2iscsi qla2xxx 
iscsi_boot_sysfs libiscsi ipmi_si hpsa scsi_transport_fc scsi_transport_iscsi 
ipmi_msghandler 8021q garp stp mrp llc ghash_clmulni_intel hid_generic be2net 
aesni_intel aes_x86_64 ablk_helper usbhid cryptd lrw vxlan gf128mul 
ip6_udp_tunnel glue_helper usb_storage hid udp_tunnel
  Package: linux (not installed)
  PciMultimedia:
   
  ProcEnviron:
   LANGUAGE=en_US:en
   TERM=bterm
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/sh
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=linux priority=low vga=788 initrd=initrd.gz ---
  ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-16-generic N/A
   linux-backports-modules-4.2.0-16-generic  N/A
   linux-firmware1.156
  RfKill: Error: [Errno 2] No such file or directory
  Tags:  xenial
  Uname: Linux 4.2.0-16-generic x86_64
  UpgradeStatus: Upgraded to xenial on 2016-02-04 (31 days ago)
  UserGroups:
   
  _MarkForUpload: True
  dmi.bios.date: 05/05/2011
  dmi.bios.vendor: HP
  dmi.bios.version: I27
  dmi.chassis.type: 28
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrI27:bd05/05/2011:svnHP:pnProLiantBL460cG7:pvr:cvnHP:ct28:cvr:
  dmi.product.name: ProLiant BL460c G7
  dmi.sys.vendor: 

[Kernel-packages] [Bug 1549660] Re: Fix speaker volume on a Dell machine

2016-03-24 Thread Brad Figg
** Tags removed: verification-needed-wily
** Tags added: verification-passed-wily

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1549660

Title:
  Fix speaker volume on a Dell machine

Status in HWE Next:
  New
Status in linux package in Ubuntu:
  Fix Committed

Bug description:
  On one of the machines we enable, we found that the actual speaker
  volume did not always correspond to the volume set in alsamixer.

  This bug is for tracking purposes; please do not triage.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1549660/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1520343] Re: Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

2016-03-24 Thread Jeremy
Dennis

Can you post current

dmesg | grep ath10k

Kernel 4.5 provides crc32 checksums for firmware and board files

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1520343

Title:
  Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  ---

  STATUS 2016-03-17:

  ==
  WARNING: You need at least kernel 4.5.0 for the following new fix to work, 
else refer to the old method described in post #22
  ==

  The support for this card has now been merged to
  https://github.com/kvalo/ath10k-firmware. The repository now contains
  the required board.bin, board-2.bin and firmware-4.bin files for the
  card to initialize and connect to a bgn-access point (5GHz (ac-
  protocol) is still untested, feel free to modify this if you can
  confirm it works). Here are the new commands to get you online:

  sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/

  sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board.bin?raw=true

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board-2.bin?raw=true

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin
  https://github.com/kvalo/ath10k-
  
firmware/blob/master/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

  Reboot or reload the ath10k_pci module and you should be able to
  connect!

  ---

  STATUS 2015-12-22:

  Currently there is a fix for this problem in post #22 (originally post
  #19, but reposted due to command typos!) which seems to have fixed the
  issue for many. This bug is unique to revision 32 of the card
  [168c:003e], fixes for older revisions don't seem to work.

  There are a couple of issues regarding the fix for some people (not
  all):

  1. Wireless works, but network throughput stops some time after
  connecting to access point

  2. Bluetooth communications take a noticeable performance hit when
  transferring something over WiFi

  ---

  Original description:

  I have recently installed Ubuntu 15.10 (64-bit) alongside Windows 10 on an 
Acer Aspire VN7-792G-76ZH and discovered, that the Qualcomm wireless card 
doesn't work in it or 16.04.
  The card has the device id 168c:003e as many other cards, for example the 
Qualcomm Atheros Killer 
(https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184), but it has a 
newer revision number (32) and the suggested fixes work only partially and the 
wireless is unusable.

  The computer has just been released this summer and is Intel Skylake
  -based.

  I've tried the patch from bug 1383184, which has a fix for the card revision 
20:
  Make the directory /lib/firmware/ath10k/QCA6174/hw3.0/ and put in the patch 
files:
  board.bin
  firmware-4.bin
  notice_ath10k_firmware-4.txt

  ath10k_pci succeeds in loading the firmware, but it seems that the
  firmware is not working correctly:

  dmesg | grep ath
  [5.452683] ath10k_pci :07:00.0: pci irq msi-x interrupts 8 irq_mode 0 
reset_mode 0
  [5.678420] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/cal-pci-:07:00.0.bin failed with error -2
  [5.678773] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
  [5.678781] ath10k_pci :07:00.0: failed to load spec board file, 
falling back to generic: -2
  [5.679445] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
  [5.679453] ath10k_pci :07:00.0: could not fetch firmware file 
'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
  [7.802316] ath10k_pci :07:00.0: qca6174 hw3.2 (0x0503, 
0x00340aff, 168c:003e:11ad:0807 fallback) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 api 
4 htt 3.26 wmi 4 cal otp max_sta 32
  [7.802329] ath10k_pci :07:00.0: debug 0 debugfs 1 tracing 1 dfs 0 
testmode 0
  [8.200607] ath: EEPROM regdomain: 0x6c
  [8.200614] ath: EEPROM indicates we should expect a direct regpair map
  [8.200619] ath: Country alpha2 being used: 00
  [8.200621] ath: Regpair used: 0x6c
  [8.216605] ath10k_pci :07:00.0 wlp7s0: renamed from wlan0
  [   13.462029] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   16.461416] ath10k_pci :07:00.0: could not suspend target (-11)
  [   24.760062] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   27.759534] ath10k_pci :07:00.0: could not suspend target (-11)
  [   36.046205] ath10k_pci :07:00.0: failed 

[Kernel-packages] [Bug 1494350] Re: QEMU: causes vCPU steal time overflow on live migration

2016-03-24 Thread Bernd Eckenfels
Just hit the same bug (decreasing steal time counters after live
migration of kvm) on a Trusty guest. Would be nice to get that as LTS.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1494350

Title:
  QEMU: causes vCPU steal time overflow on live migration

Status in Linux:
  Fix Committed
Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Trusty:
  In Progress
Status in linux source package in Vivid:
  In Progress
Status in linux source package in Wily:
  In Progress
Status in linux source package in Xenial:
  Fix Released

Bug description:
  [Impact]
  It is possible to have vcpu->arch.st.last_steal initialized
  from a thread other than vcpu thread, say the main thread, via
  KVM_SET_MSRS. That can cause steal_time overflow later (when subtracting from 
vcpu threads sched_info.run_delay).

  [Test Case]
  Testing Steps with patched trusty kernel:
  Using savemv & loadvm to simulate the migration process.

  In guest:
  1. check steal_time data location
  rdmsr 0x4b564d03 <- returns the start address 0x7fc0d000

  2. exam the steal time before savevm in qemu monitor
  (qemu) xp /ug 0x7fc0d000
  xp /ug 0x7fc0d000
  7fc0d000:144139048 < steal time value before 
savevm
  (qemu) savevm mytestvm7
  savevm mytestvm7
  (qemu) quit
  quit

  3. give some load to the host system, e.g. stress --cpu 

  4. start the guest with "-loadvm mytestvm7" to restore the state of
  the VM, thus the steal_time MSR

  5. exam the steal time value again
  (qemu) xp /ug 0x7fc0d000
  xp /ug 0x7fc0d000
  7fc0d000:147428917 < with high cpu load after 
loadvm, steal time still shows a linear increase

  The steal_time value would go backward (because of the overflow) after
  the restoration of the VM state without the fix.

  -

  I'm pasting in text from Debian Bug 785557
  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=785557
  b/c I couldn't find this issue reported.

  It is present in QEMU 2.3, but I haven't tested later versions.
  Perhaps someone else will find this bug and confirm for later
  versions.  (Or I will when I have time!)

  


  Hi,

  I'm trying to debug an issue we're having with some debian.org machines
  running in QEMU 2.1.2 instances (see [1] for more background). In short,
  after a live migration guests running Debian Jessie (linux 3.16) stop
  accounting CPU time properly. /proc/stat in the guest shows no increase
  in user and system time anymore (regardless of workload) and what stands
  out are extremely large values for steal time:

   % cat /proc/stat
   cpu  2400 0 1842 650879168 2579640 0 25 136562317270 0 0
   cpu0 1366 0 1028 161392988 1238598 0 11 383803090749 0 0
   cpu1 294 0 240 162582008 639105 0 8 39686436048 0 0
   cpu2 406 0 338 163331066 383867 0 4 333994238765 0 0
   cpu3 332 0 235 163573105 318069 0 1 1223752959076 0 0
   intr 355773871 33 10 0 0 0 0 3 0 1 0 0 36 144 0 0 1638612 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 5 5001741 41 0 8516993 0 3669582 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
   ctxt 837862829
   btime 1431642967
   processes 8529939
   procs_running 1
   procs_blocked 0
   softirq 225193331 2 77532878 172 7250024 819289 0 54 33739135 176552 
105675225

  Reading the memory pointed to by the steal time MSRs pre- and
  post-migration, I can see that post-migration the high bytes are 

[Kernel-packages] [Bug 1559201] Re: Bluetooth connection broken while autoconnect

2016-03-24 Thread Pat McGowan
** Also affects: bluez (Ubuntu)
   Importance: Undecided
   Status: New

** Tags added: bluetooth

** Changed in: canonical-devices-system-image
   Status: New => Confirmed

** Changed in: canonical-devices-system-image
 Assignee: (unassigned) => John McAleely (john.mcaleely)

** Changed in: bluez (Ubuntu)
 Assignee: (unassigned) => Simon Fels (morphis)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1559201

Title:
  Bluetooth connection broken while autoconnect

Status in Bluez Utilities:
  New
Status in Canonical System Image:
  Confirmed
Status in PulseAudio:
  New
Status in bluez package in Ubuntu:
  New

Bug description:
  Hello,

  When I set up phone and click connect - music plays fine. But when I
  turn off bluetooth (and mark 'connect automatically to that device'),
  turn it again - phone connect to that device again, but music don't
  play at all or plays with big disruptions. This issue does not occur
  when I've got 'automatically connect' turned off and manually click
  'connect'.

  Maybe this is related to bug [1]
  https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1494225 (because
  this problem happen to me only in device also affected by [1] - in
  other devices working correctly (not affected by [1]) there is no
  problem).

To manage notifications about this bug go to:
https://bugs.launchpad.net/bluez/+bug/1559201/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1403152] Re: unregister_netdevice: waiting for lo to become free. Usage count

2016-03-24 Thread Dan Streetman
If anyone is able to reproduce this, I have a debug kernel at this ppa:
https://launchpad.net/~ddstreet/+archive/ubuntu/lp1403152

it prints a debug line when any loopback interface is dev_put/dev_hold,
which may help show where the extra loopback reference is coming from
when this problem happens.  If anyone can reproduce the problem using
the debug kernel, please attach the logs (and/or sosreport).

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-lts-utopic in Ubuntu.
https://bugs.launchpad.net/bugs/1403152

Title:
  unregister_netdevice: waiting for lo to become free. Usage count

Status in Linux:
  Unknown
Status in linux package in Ubuntu:
  Fix Released
Status in linux-lts-utopic package in Ubuntu:
  Confirmed
Status in linux source package in Trusty:
  Fix Released
Status in linux-lts-utopic source package in Trusty:
  Fix Released
Status in linux source package in Vivid:
  Fix Released

Bug description:
  SRU Justification:

  [Impact]

  Users of kernels that utilize NFS may see the following messages when
  shutting down and starting containers:

  unregister_netdevice: waiting for lo to become free. Usage count =
  1

  This can cause issues when trying to create net network namespace and
  thus block a user from creating new containers.

  [Test Case]

  Setup multiple containers in parallel to mount and NFS share, create
  some traffic and shutdown. Eventually you will see the kernel message.

  Dave's script here:
  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1403152/comments/24

  [Fix]
  commit de84d89030fa4efa44c02c96c8b4a8176042c4ff upstream

  --

  I currently running trusty latest patches and i get on these hardware
  and software:

  Ubuntu 3.13.0-43.72-generic 3.13.11.11

  processor : 7
  vendor_id : GenuineIntel
  cpu family: 6
  model : 77
  model name: Intel(R) Atom(TM) CPU  C2758  @ 2.40GHz
  stepping  : 8
  microcode : 0x11d
  cpu MHz   : 2400.000
  cache size: 1024 KB
  physical id   : 0
  siblings  : 8
  core id   : 7
  cpu cores : 8
  apicid: 14
  initial apicid: 14
  fpu   : yes
  fpu_exception : yes
  cpuid level   : 11
  wp: yes
  flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov 
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm 
constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc 
aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm 
sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch 
arat epb dtherm tpr_shadow vnmi flexpriority ept vpid tsc_adjust smep erms
  bogomips  : 4799.48
  clflush size  : 64
  cache_alignment   : 64
  address sizes : 36 bits physical, 48 bits virtual
  power management:

  somehow reproducable the subjected error, and lxc is working still but
  not more managable until a reboot.

  managable means every command hangs.

  I saw there are alot of bugs but they seams to relate to older version
  and are closed, so i decided to file a new one?

  I run alot of machine with trusty an lxc containers but only these kind of 
machines produces these errors, all
  other don't show these odd behavior.

  thx in advance

  meno

To manage notifications about this bug go to:
https://bugs.launchpad.net/linux/+bug/1403152/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561604] Re: x-gene2: fix rtc load error during kernel boot

2016-03-24 Thread Craig Magina
** Changed in: linux (Ubuntu)
 Assignee: (unassigned) => Craig Magina (craig.magina)

** Changed in: linux (Ubuntu)
   Status: New => Incomplete

** Changed in: linux (Ubuntu)
   Status: Incomplete => In Progress

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561604

Title:
  x-gene2: fix rtc load error during kernel boot

Status in linux package in Ubuntu:
  In Progress

Bug description:
  This error "[ 0.981954] hctosys: unable to open rtc device (rtc0)" is
  seen while booting a new xgene2 board. This causes issues with any
  service (like MAAS) who tries to get the system time early in the
  booting process. The fix for this is two patches, one of which is
  already in the xenial kernel, the other is upstream in Linus's linux
  tree already, and changing a kernel module to be built-in for arm64.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561604/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561447] Re: MFG HOT: ubuntu installer device detection issue on Firestone and Garrison

2016-03-24 Thread Steve Langasek
This is a firmware issue. The kernel only enumerates the set of devices
exposed to it by the hardware/firmware; it doesn't have any way to know
you don't want them until it's too late.  If they can be turned off in
the firmware, that's probably the best solution.

The failure of parted to partition /dev/sdj on the Garrison sounds like
a different issue.  We do not have access to Garrison hardware so are
not going to be able to help with debugging that.  We have successfully
installed Ubuntu on Firestone as part of our certification process.

** Package changed: debian-installer (Ubuntu) => linux (Ubuntu)

** Changed in: linux (Ubuntu)
   Status: New => Invalid

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561447

Title:
  MFG HOT: ubuntu installer device detection issue on Firestone and
  Garrison

Status in linux package in Ubuntu:
  Invalid

Bug description:
  == Comment: #0 - Lucas J. Schroeder  - 2015-07-15 
15:59:37 ==
  ---Problem Description---
  The installer for 14.04.02 and 15.04 is detecting hard disk media that does 
not exist.  In my preseed files for both Firestone and Garrison, the 
debconfig-set partman-auto/disk has to followed by /dev/sdj.  Trying to use 
/dev/sda will result in an installer error
   
  Contact Information = lschr...@us.ibm.com 
   
  ---uname output---
  Linux rcx2c360 3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:42:36 
UTC 2015 ppc64le ppc64le ppc64le GNU/Linux
   
  Machine Type = Firestone 8335-GTA, Garrison 8335-GTB 
   
  ---boot type---
  Network boot
   
  ---bootloader---
  opal
   
  ---Kernel cmdline used to launch install---
  cd /tmp

  tftp -g -l ./initrd -r /tftpboot/initrd.Ubuntu14_1502.gz 9.10.192.40

  tftp -g -l ./vmlinux -r /tftpboot/vmlinux.Ubuntu14_1502 9.10.192.40

  kexec -l ./vmlinux --initrd ./initrd --append 
   
  ---Bootloader protocol---
  unsure
   
  ---Install repository type---
  Local repository
   
  ---Install repository Location---
  http://9.10.192.40/install/ppc/Ubuntu14_1502/CD1
   
  ---Point of failure---
  Other failure during installation (stage 1)

  
  == Comment: #5 - NISHANTH ARAVAMUDAN  - 2015-07-16 
11:48:54 ==
  Michael,

  I think this is the same issue we see on our Garrison as well.

  Lucas, Michael will take a look at it.

  -Nish

  == Comment: #7 - NISHANTH ARAVAMUDAN  - 2015-07-16 
12:16:47 ==
  HA!

  From our Garrison:

  Jul 15 19:20:35 kernel: [7.544664] scsi 0:0:0:0: CD-ROMAMI
  Virtual CDROM0   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.548145] scsi 0:0:0:1: CD-ROMAMI
  Virtual CDROM1   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.552144] scsi 0:0:0:2: CD-ROMAMI
  Virtual CDROM2   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.554643] scsi 0:0:0:3: CD-ROMAMI
  Virtual CDROM3   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.925426] scsi 1:0:0:0: Direct-Access AMI
  Virtual Floppy0  1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.925672] scsi 2:0:0:0: Direct-Access AMI
  Virtual HDisk0   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.927825] scsi 1:0:0:1: Direct-Access AMI
  Virtual Floppy1  1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.928042] scsi 2:0:0:1: Direct-Access AMI
  Virtual HDisk1   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.928547] scsi 1:0:0:2: Direct-Access AMI
  Virtual Floppy2  1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.928805] scsi 2:0:0:2: Direct-Access AMI
  Virtual HDisk2   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.929173] scsi 1:0:0:3: Direct-Access AMI
  Virtual Floppy3  1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.929669] scsi 2:0:0:3: Direct-Access AMI
  Virtual HDisk3   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [7.931045] scsi 2:0:0:4: Direct-Access AMI
  Virtual HDisk4   1.00 PQ: 0 ANSI: 0 CCS
  Jul 15 19:20:35 kernel: [8.031783] sr 0:0:0:0: [sr0] scsi-1 drive
  Jul 15 19:20:35 kernel: [8.031908] cdrom: Uniform CD-ROM driver Revision: 
3.20
  Jul 15 19:20:35 kernel: [8.032391] sr 0:0:0:0: Attached scsi CD-ROM sr0
  Jul 15 19:20:35 kernel: [8.032526] sr 0:0:0:0: Attached scsi generic sg0 
type 5
  Jul 15 19:20:35 kernel: [8.083910] sr 0:0:0:1: [sr1] scsi-1 drive
  Jul 15 19:20:35 kernel: [8.084253] sr 0:0:0:1: Attached scsi CD-ROM sr1
  Jul 15 19:20:35 kernel: [8.084359] sr 0:0:0:1: Attached scsi generic sg1 
type 5
  Jul 15 19:20:35 kernel: [8.112910] sr 0:0:0:2: [sr2] scsi-1 drive
  Jul 15 19:20:35 kernel: [8.113230] sr 0:0:0:2: Attached scsi CD-ROM sr2
  Jul 15 19:20:35 kernel: [8.113349] sr 0:0:0:2: Attached scsi generic sg2 
type 5
  Jul 15 19:20:35 kernel: [8.124786] sr 0:0:0:3: [sr3] 

[Kernel-packages] [Bug 1553811] Re: Thinkpad T460: Trackpoint mouse buttons instantly generate "release" event on press

2016-03-24 Thread Lukas Humbel
Actually: no idea. I think, that the same bug exists there as well. When
I got my Thinkpad I wasn't able to get 15.10 installed, because of some
(i guess) syslinux/isolinux issue. So I went straight to 16.04 beta. If
it makes sense, I can compile an old kernel on 16.04 and check if the
issue is there. Let me know what kernel versions might make sense.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1553811

Title:
  Thinkpad T460: Trackpoint mouse buttons instantly generate "release"
  event on press

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  When using the trackpoint mouse buttons on the laptop, when any of the
  buttons are pressed a release event immediately follows, even if the
  mouse button is being held down. This prevents moving of windows,
  typical drag & drop operations, selection etc with the mouse.

  Example output from xev for button 1:

  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097221, (116,59), root:(116,142),
  state 0x0, button 1, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097229, (116,59), root:(116,142),
  state 0x100, button 1, same_screen YES

  Button 2:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x0, button 2, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x200, button 2, same_screen YES

  Button 3:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098467, (116,59), root:(116,142),
  state 0x0, button 3, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098477, (116,59), root:(116,142),
  state 0x400, button 3, same_screen YES

  
  Possibly relevant output from journal:
  kernel: thinkpad_acpi: ThinkPad ACPI Extras v0.25
  kernel: thinkpad_acpi: http://ibm-acpi.sf.net/
  kernel: thinkpad_acpi: ThinkPad BIOS R06ET33W (1.07 ), EC unknown
  kernel: thinkpad_acpi: Lenovo ThinkPad T460, model 20FNCTO1WW
  kernel: thinkpad_acpi: detected a 8-level brightness capable ThinkPad
  kernel: thinkpad_acpi: unknown version of the HKEY interface: 0x200
  kernel: thinkpad_acpi: please report this to 
ibm-acpi-de...@lists.sourceforge.net
  kernel: thinkpad_acpi: radio switch found; radios are enabled
  kernel: thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness 
control, supported by the ACPI video driver
  kernel: thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
  kernel: thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
  kernel: thinkpad_acpi: Standard ACPI backlight interface available, not 
loading native one
  kernel: input: ThinkPad Extra Buttons as 
/devices/platform/thinkpad_acpi/input/input7
  sensors[1000]: thinkpad-isa-
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed
  kernel: thinkpad_acpi: acpi_evalf(GTRW, dd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot read adaptive keyboard mode.
  kernel: thinkpad_acpi: acpi_evalf(STRW, vd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot set adaptive keyboard mode.
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-10-generic 4.4.0-10.25
  ProcVersionSignature: Ubuntu 4.4.0-10.25-generic 4.4.3
  Uname: Linux 4.4.0-10-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Sun Mar  6 12:38:59 2016
  HibernationDevice: RESUME=UUID=04e04e17-3976-4daa-a1dd-2dd369aee83d
  InstallationDate: Installed on 2015-09-21 (166 days ago)
  InstallationMedia: It
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20FNCTO1WW
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-10-generic 
root=/dev/mapper/it--vg-root ro quiet intel_pstate=no_hwp
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-10-generic N/A
   linux-backports-modules-4.4.0-10-generic  N/A
   linux-firmware1.156
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-02-24 (10 days ago)
  dmi.bios.date: 01/05/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R06ET33W (1.07 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20FNCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  

[Kernel-packages] [Bug 1359689] Re: cryptsetup password prompt not shown

2016-03-24 Thread sudodus
This problem is still there in Lubuntu desktop, which means the desktop
iso file with the graphical user interface.

The problem appears on desktop computers as well as on laptop computers,
and I think it is caused by problems with plymouth (which displays
nothing, no logo, no dots, (and no passphrase if disk encryption is
selected).

The problem is that the passphrase is not displayed, but it is still
possible to type it and finish with the Enter key. That brings you to
the login screen of the installed Lubuntu system.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1359689

Title:
  cryptsetup password prompt not shown

Status in linux package in Ubuntu:
  Triaged
Status in linux source package in Utopic:
  Won't Fix
Status in linux source package in Vivid:
  Triaged
Status in plymouth package in Debian:
  Fix Released

Bug description:
  Currently in utopic the following happens when booting an encrypted
  setup:

  Press enter in grub, after a while screen freezes (or turns completely
  black) and stays like that. When I press the down key, I can see the
  password prompt. When I press the up key again, I get to the graphical
  password prompt.

  This is demonstrated in the following screencast:
  https://drive.google.com/file/d/0B7EMvd1LJKgZREJocHBueEhpa2s/edit?usp=sharing

  Maybe this is related to the version of plymouth utopic currently uses, a 
similar debian bug report seems to be resolved with a newer version 0.9.0-6, 
see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752752.
  --- 
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
  DistroRelease: Ubuntu 14.10
  InstallationDate: Installed on 2014-08-21 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
  Package: plymouth 0.9.0-0ubuntu3
  PackageArchitecture: amd64
  ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
  Tags:  utopic
  Uname: Linux 3.16.0-9-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  --- 
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
  DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
  DistroRelease: Ubuntu 14.10
  InstallationDate: Installed on 2014-08-21 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
  MachineType: Dell Inc. Precision M4600
  Package: plymouth 0.9.0-0ubuntu3
  PackageArchitecture: amd64
  ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-9-generic 
root=/dev/mapper/VG--Ubuntu-LV--Ubuntu--ROOT ro rootflags=subvol=@ 
cryptopts=target=Ubuntu,source=/dev/disk/by-uuid/6fc200da-aa04-4e73-b6a7-a2326f0b6204,lvm=VG-Ubuntu
 quiet splash vt.handoff=7
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-9-generic 
root=/dev/mapper/VG--Ubuntu-LV--Ubuntu--ROOT ro rootflags=subvol=@ 
cryptopts=target=Ubuntu,source=/dev/disk/by-uuid/6fc200da-aa04-4e73-b6a7-a2326f0b6204,lvm=VG-Ubuntu
 quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
  Tags:  utopic
  TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
  Uname: Linux 3.16.0-9-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  dmi.bios.date: 03/10/2013
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A14
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA14:bd03/10/2013:svnDellInc.:pnPrecisionM4600:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
  dmi.product.name: Precision M4600
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1359689/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1520343] Re: Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

2016-03-24 Thread Jeremy
Queeq

Somehow your firmware didn't update from kvallo github, you should
delete the ath10k-firmware folder from home and use git clone again

Comment 52 shows version WLAN.RM.1.1-00141 and the one on the site is
WLAN.RM.2.0-00180

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1520343

Title:
  Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  ---

  STATUS 2016-03-17:

  The support for this card has now been merged to
  https://github.com/kvalo/ath10k-firmware. The repository now contains
  the required board.bin, board-2.bin and firmware-4.bin files for the
  card to initialize and connect to a bgn-access point (5GHz (ac-
  protocol) is still untested, feel free to modify this if you can
  confirm it works). Here are the new commands to get you online:

  sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/

  sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board.bin?raw=true

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board-2.bin?raw=true

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin
  https://github.com/kvalo/ath10k-
  
firmware/blob/master/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

  Reboot or reload the ath10k_pci module and you should be able to
  connect!

  ---

  STATUS 2015-12-22:

  Currently there is a fix for this problem in post #22 (originally post
  #19, but reposted due to command typos!) which seems to have fixed the
  issue for many. This bug is unique to revision 32 of the card
  [168c:003e], fixes for older revisions don't seem to work.

  There are a couple of issues regarding the fix for some people (not
  all):

  1. Wireless works, but network throughput stops some time after
  connecting to access point

  2. Bluetooth communications take a noticeable performance hit when
  transferring something over WiFi

  ---

  Original description:

  I have recently installed Ubuntu 15.10 (64-bit) alongside Windows 10 on an 
Acer Aspire VN7-792G-76ZH and discovered, that the Qualcomm wireless card 
doesn't work in it or 16.04.
  The card has the device id 168c:003e as many other cards, for example the 
Qualcomm Atheros Killer 
(https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184), but it has a 
newer revision number (32) and the suggested fixes work only partially and the 
wireless is unusable.

  The computer has just been released this summer and is Intel Skylake
  -based.

  I've tried the patch from bug 1383184, which has a fix for the card revision 
20:
  Make the directory /lib/firmware/ath10k/QCA6174/hw3.0/ and put in the patch 
files:
  board.bin
  firmware-4.bin
  notice_ath10k_firmware-4.txt

  ath10k_pci succeeds in loading the firmware, but it seems that the
  firmware is not working correctly:

  dmesg | grep ath
  [5.452683] ath10k_pci :07:00.0: pci irq msi-x interrupts 8 irq_mode 0 
reset_mode 0
  [5.678420] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/cal-pci-:07:00.0.bin failed with error -2
  [5.678773] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
  [5.678781] ath10k_pci :07:00.0: failed to load spec board file, 
falling back to generic: -2
  [5.679445] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
  [5.679453] ath10k_pci :07:00.0: could not fetch firmware file 
'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
  [7.802316] ath10k_pci :07:00.0: qca6174 hw3.2 (0x0503, 
0x00340aff, 168c:003e:11ad:0807 fallback) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 api 
4 htt 3.26 wmi 4 cal otp max_sta 32
  [7.802329] ath10k_pci :07:00.0: debug 0 debugfs 1 tracing 1 dfs 0 
testmode 0
  [8.200607] ath: EEPROM regdomain: 0x6c
  [8.200614] ath: EEPROM indicates we should expect a direct regpair map
  [8.200619] ath: Country alpha2 being used: 00
  [8.200621] ath: Regpair used: 0x6c
  [8.216605] ath10k_pci :07:00.0 wlp7s0: renamed from wlan0
  [   13.462029] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   16.461416] ath10k_pci :07:00.0: could not suspend target (-11)
  [   24.760062] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   27.759534] ath10k_pci :07:00.0: could not suspend target (-11)
  [   36.046205] ath10k_pci :07:00.0: failed to set arp ac override 
parameter: -11
  [ 

[Kernel-packages] [Bug 1561474] Re: Bluetooth will be disable after reusme from suspend on Xenial

2016-03-24 Thread Joseph Salisbury
Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v4.5 kernel[0].

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:
'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as
"Confirmed".


Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/


** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu)
   Status: Confirmed => Incomplete

** Tags added: kernel-da-key

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561474

Title:
  Bluetooth will be disable after reusme from suspend on Xenial

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  CID: 201208-11536 Dell Latitude 6430u

  The Bluetooth will be disabled after resume from suspend.
  You will need to use "hciconfig hci0 reset" to enable it.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-15-generic 4.4.0-15.31
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1202 F pulseaudio
  CurrentDesktop: Unity
  Date: Thu Mar 24 19:14:07 2016
  HibernationDevice: RESUME=UUID=25c03762-079c-4c6d-aedb-ec768318a6bf
  InstallationDate: Installed on 2016-03-24 (0 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151209)
  MachineType: Dell Inc. Latitude 6430U
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic 
root=UUID=18cfda3e-4f3d-40cf-8e7e-a83030819487 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/15/2012
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A02
  dmi.board.asset.tag: 1234567
  dmi.board.name: 0MN74V
  dmi.board.vendor: Dell Inc.
  dmi.board.version: X01
  dmi.chassis.asset.tag: 1234567
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA02:bd11/15/2012:svnDellInc.:pnLatitude6430U:pvr01:rvnDellInc.:rn0MN74V:rvrX01:cvnDellInc.:ct9:cvr:
  dmi.product.name: Latitude 6430U
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561474/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1515301] Re: [Hyper-V] issues with linux-next on 15.04 kdump functionality

2016-03-24 Thread Joseph Salisbury
Is this still an issue?  If so, I'll research this bug in parallel to
working on 1400319.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1515301

Title:
  [Hyper-V] issues with linux-next on 15.04 kdump functionality

Status in linux package in Ubuntu:
  Triaged

Bug description:
  Using linux-next 4.3.0-next-20151106 kdump is failing to start as a service.
  On RHEL and SLES with upstream, kdump is working as expected so only Ubuntu 
has this issue as observed from our testing.

  A similar issue with the same error message from kdump has been already 
reported here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1400319
  However that behavior was on 32bit Ubuntu only, and now with upstream this 
seems to extend to 64bit as well.
  So I'm not sure if we should link these 2 bug reports at this point.

  Issues description:
  1. kdump-tools service fails to start on 15.04 64bit, when runnig the 
linux-next kernel
  Error returned is: Starting kdump-tools: Could not find a free area of memory 
of 0xa637000 bytes...
  (full log below)
  By default, kdump sets crashkernel to 394M-:128M

  2. If crashkernel is set to 384M, the dump file will fail to create due to 
OOM messages when a crash is triggered. 
  Attaching the full serial log with crashkernel=384M. The log is the same with 
512M as crashkernel.
  Can this be a memory leak in the kdump kernel, making even already high 
values as 512M for the crashkernel to not be enough?
  VM RAM has been set to 2GB and also 4GB, and with minimal load on the system 
that isn't a problem.

  Work-around for issue #1:
  Set crashkernel size to 384M, instead of the default 384M-:128M.
  With this, kdump-tools will start.
  However the dump file doesn't get written and the system will hang, without 
rebooting.

  Values used to trigger a kdump:
  - 384M
  - 512M
  - 384M-:128M - kdump-tools will not properly load.

  Full kdump service log:
  root@ubuntu1504srv:~# service kdump-tools status
  â kdump-tools.service - Kernel crash dump capture service
 Loaded: loaded (/lib/systemd/system/kdump-tools.service; enabled; vendor 
preset: enabled)
 Active: active (exited) since Wed 2015-11-11 06:02:28 PST; 20min ago
Process: 792 ExecStart=/etc/init.d/kdump-tools start (code=exited, 
status=0/SUCCESS)
   Main PID: 792 (code=exited, status=0/SUCCESS)
 CGroup: /system.slice/kdump-tools.service

  Nov 11 06:02:20 ubuntu1504srv systemd[1]: Starting Kernel crash dump capture 
service...
  Nov 11 06:02:28 ubuntu1504srv kdump-tools[792]: Starting kdump-tools: Could 
not find a free area of memory of 0xa637000 bytes...
  Nov 11 06:02:28 ubuntu1504srv kdump-tools[792]: locate_hole failed
  Nov 11 06:02:28 ubuntu1504srv kdump-tools[792]: * failed to load kdump kernel
  Nov 11 06:02:28 ubuntu1504srv systemd[1]: Started Kernel crash dump capture 
service.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1515301/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561604] [NEW] x-gene2: fix rtc load error during kernel boot

2016-03-24 Thread Craig Magina
Public bug reported:

This error "[ 0.981954] hctosys: unable to open rtc device (rtc0)" is
seen while booting a new xgene2 board. This causes issues with any
service (like MAAS) who tries to get the system time early in the
booting process. The fix for this is two patches, one of which is
already in the xenial kernel, the other is upstream in Linus's linux
tree already, and changing a kernel module to be built-in for arm64.

** Affects: linux (Ubuntu)
 Importance: Undecided
 Status: New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561604

Title:
  x-gene2: fix rtc load error during kernel boot

Status in linux package in Ubuntu:
  New

Bug description:
  This error "[ 0.981954] hctosys: unable to open rtc device (rtc0)" is
  seen while booting a new xgene2 board. This causes issues with any
  service (like MAAS) who tries to get the system time early in the
  booting process. The fix for this is two patches, one of which is
  already in the xenial kernel, the other is upstream in Linus's linux
  tree already, and changing a kernel module to be built-in for arm64.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561604/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1553811] Re: Thinkpad T460: Trackpoint mouse buttons instantly generate "release" event on press

2016-03-24 Thread Joseph Salisbury
There are kernels already available for prior releases.  I just want to
confirm if I only need to request this commit in Xenial or also in the
stable releases.  Can you test the following kernels:


Wily: 
https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/ppa/+build/9330343
Trusty: 
https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/ppa/+build/9330920

Note, with these kernels, you need to install both the linux-image and
linux-image-extra .deb packages.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1553811

Title:
  Thinkpad T460: Trackpoint mouse buttons instantly generate "release"
  event on press

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  When using the trackpoint mouse buttons on the laptop, when any of the
  buttons are pressed a release event immediately follows, even if the
  mouse button is being held down. This prevents moving of windows,
  typical drag & drop operations, selection etc with the mouse.

  Example output from xev for button 1:

  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097221, (116,59), root:(116,142),
  state 0x0, button 1, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097229, (116,59), root:(116,142),
  state 0x100, button 1, same_screen YES

  Button 2:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x0, button 2, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x200, button 2, same_screen YES

  Button 3:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098467, (116,59), root:(116,142),
  state 0x0, button 3, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098477, (116,59), root:(116,142),
  state 0x400, button 3, same_screen YES

  
  Possibly relevant output from journal:
  kernel: thinkpad_acpi: ThinkPad ACPI Extras v0.25
  kernel: thinkpad_acpi: http://ibm-acpi.sf.net/
  kernel: thinkpad_acpi: ThinkPad BIOS R06ET33W (1.07 ), EC unknown
  kernel: thinkpad_acpi: Lenovo ThinkPad T460, model 20FNCTO1WW
  kernel: thinkpad_acpi: detected a 8-level brightness capable ThinkPad
  kernel: thinkpad_acpi: unknown version of the HKEY interface: 0x200
  kernel: thinkpad_acpi: please report this to 
ibm-acpi-de...@lists.sourceforge.net
  kernel: thinkpad_acpi: radio switch found; radios are enabled
  kernel: thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness 
control, supported by the ACPI video driver
  kernel: thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
  kernel: thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
  kernel: thinkpad_acpi: Standard ACPI backlight interface available, not 
loading native one
  kernel: input: ThinkPad Extra Buttons as 
/devices/platform/thinkpad_acpi/input/input7
  sensors[1000]: thinkpad-isa-
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed
  kernel: thinkpad_acpi: acpi_evalf(GTRW, dd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot read adaptive keyboard mode.
  kernel: thinkpad_acpi: acpi_evalf(STRW, vd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot set adaptive keyboard mode.
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-10-generic 4.4.0-10.25
  ProcVersionSignature: Ubuntu 4.4.0-10.25-generic 4.4.3
  Uname: Linux 4.4.0-10-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Sun Mar  6 12:38:59 2016
  HibernationDevice: RESUME=UUID=04e04e17-3976-4daa-a1dd-2dd369aee83d
  InstallationDate: Installed on 2015-09-21 (166 days ago)
  InstallationMedia: It
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20FNCTO1WW
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-10-generic 
root=/dev/mapper/it--vg-root ro quiet intel_pstate=no_hwp
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-10-generic N/A
   linux-backports-modules-4.4.0-10-generic  N/A
   linux-firmware1.156
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-02-24 (10 days ago)
  dmi.bios.date: 01/05/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R06ET33W (1.07 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20FNCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  

[Kernel-packages] [Bug 1553811] Re: Thinkpad T460: Trackpoint mouse buttons instantly generate "release" event on press

2016-03-24 Thread Joseph Salisbury
@Ryan @Lukas,

Do you know if this bug only affects Xenial, or do prior releases need
the new patch as well?

** Also affects: linux (Ubuntu Xenial)
   Importance: High
 Assignee: Joseph Salisbury (jsalisbury)
   Status: In Progress

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1553811

Title:
  Thinkpad T460: Trackpoint mouse buttons instantly generate "release"
  event on press

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  When using the trackpoint mouse buttons on the laptop, when any of the
  buttons are pressed a release event immediately follows, even if the
  mouse button is being held down. This prevents moving of windows,
  typical drag & drop operations, selection etc with the mouse.

  Example output from xev for button 1:

  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097221, (116,59), root:(116,142),
  state 0x0, button 1, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1097229, (116,59), root:(116,142),
  state 0x100, button 1, same_screen YES

  Button 2:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x0, button 2, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1100941, (116,59), root:(116,142),
  state 0x200, button 2, same_screen YES

  Button 3:
  ButtonPress event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098467, (116,59), root:(116,142),
  state 0x0, button 3, same_screen YES

  ButtonRelease event, serial 40, synthetic NO, window 0x7e1,
  root 0xb6, subw 0x0, time 1098477, (116,59), root:(116,142),
  state 0x400, button 3, same_screen YES

  
  Possibly relevant output from journal:
  kernel: thinkpad_acpi: ThinkPad ACPI Extras v0.25
  kernel: thinkpad_acpi: http://ibm-acpi.sf.net/
  kernel: thinkpad_acpi: ThinkPad BIOS R06ET33W (1.07 ), EC unknown
  kernel: thinkpad_acpi: Lenovo ThinkPad T460, model 20FNCTO1WW
  kernel: thinkpad_acpi: detected a 8-level brightness capable ThinkPad
  kernel: thinkpad_acpi: unknown version of the HKEY interface: 0x200
  kernel: thinkpad_acpi: please report this to 
ibm-acpi-de...@lists.sourceforge.net
  kernel: thinkpad_acpi: radio switch found; radios are enabled
  kernel: thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness 
control, supported by the ACPI video driver
  kernel: thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
  kernel: thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
  kernel: thinkpad_acpi: Standard ACPI backlight interface available, not 
loading native one
  kernel: input: ThinkPad Extra Buttons as 
/devices/platform/thinkpad_acpi/input/input7
  sensors[1000]: thinkpad-isa-
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed
  kernel: thinkpad_acpi: acpi_evalf(GTRW, dd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot read adaptive keyboard mode.
  kernel: thinkpad_acpi: acpi_evalf(STRW, vd, ...) failed: AE_NOT_FOUND
  kernel: thinkpad_acpi: Cannot set adaptive keyboard mode.
  kernel: thinkpad_acpi: EC reports that Thermal Table has changed

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-10-generic 4.4.0-10.25
  ProcVersionSignature: Ubuntu 4.4.0-10.25-generic 4.4.3
  Uname: Linux 4.4.0-10-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Sun Mar  6 12:38:59 2016
  HibernationDevice: RESUME=UUID=04e04e17-3976-4daa-a1dd-2dd369aee83d
  InstallationDate: Installed on 2015-09-21 (166 days ago)
  InstallationMedia: It
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20FNCTO1WW
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-10-generic 
root=/dev/mapper/it--vg-root ro quiet intel_pstate=no_hwp
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-10-generic N/A
   linux-backports-modules-4.4.0-10-generic  N/A
   linux-firmware1.156
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-02-24 (10 days ago)
  dmi.bios.date: 01/05/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R06ET33W (1.07 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20FNCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 

[Kernel-packages] [Bug 1470250] Re: [Hyper-V] Ubuntu 14.04.2 LTS Generation 2 SCSI Errors on VSS Based Backups

2016-03-24 Thread Joseph Salisbury
I've been running the test script on CentOS 7 now for almost 20 hours.
I can usually reproduce the bug in 8-9 hours, so it may be safe to say
the bug cannot be reproduced with CentOS 7.

I'm going to let the test run for a couple more hours, then I'll try the
other LIS versions suggested by Josh.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1470250

Title:
  [Hyper-V] Ubuntu 14.04.2 LTS Generation 2 SCSI Errors on VSS Based
  Backups

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Trusty:
  In Progress
Status in linux source package in Vivid:
  In Progress
Status in linux source package in Wily:
  In Progress

Bug description:
  Customers have reported running various versions of Ubuntu 14.04.2 LTS
  on Generation 2 Hyper-V Hosts.On a random Basis, the file system
  will be mounted Read-Only due to a "disk error" (which really isn't
  the case here).As a result, they must reboot the Ubuntu guest to
  get the file system to mount RW again.

  The Error seen are the following:
  Apr 30 00:02:01 balticnetworkstraining kernel: [640153.968142] storvsc: Sense 
Key : Unit Attention [current] 
  Apr 30 00:02:01 balticnetworkstraining kernel: [640153.968145] storvsc: Add. 
Sense: Changed operating definition
  Apr 30 00:02:01 balticnetworkstraining kernel: [640153.968161] sd 0:0:0:0: 
Warning! Received an indication that the operating parameters on this target 
have changed. The Linux SCSI layer does not automatically adjust these 
parameters.
  Apr 30 01:23:26 balticnetworkstraining kernel: [645039.584164] hv_storvsc 
vmbus_0_4: cmd 0x2a scsi status 0x2 srb status 0x82
  Apr 30 01:23:26 balticnetworkstraining kernel: [645039.584178] hv_storvsc 
vmbus_0_4: stor pkt 88006eb6c700 autosense data valid - len 18
  Apr 30 01:23:26 balticnetworkstraining kernel: [645039.584180] storvsc: Sense 
Key : Unit Attention [current] 
  Apr 30 01:23:26 balticnetworkstraining kernel: [645039.584183] storvsc: Add. 
Sense: Changed operating definition
  Apr 30 01:23:26 balticnetworkstraining kernel: [645039.584198] sd 0:0:0:0: 
Warning! Received an indication that the operating parameters on this target 
have changed.  The Linux SCSI layer does not automatically adjust these 
parameters.

  This relates to the VSS "Windows Server Backup" process that kicks off at 
midnight on the host and finishes an hour and half later.   
  Yes, we do have hv_vss_daemon and hv_kvp_daemon running for the correct 
kernel version we have.   We're currently running kernel version 
3.13.0-49-generic #83 on one system and 3.16.0-34-generic #37 on the other. -- 
We see the same errors on both.
  As a result, we've been hesitant to drop any more ubuntu guests on our 2012R2 
hyper-v system because of this.   We can stop the backup process and all is 
good, but we need nightly backups to image all of our VM's.   All the windows 
guests have no issues of course.   We also have some CentOS based guests 
running without issues from what we've seen.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1470250/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1359689] Re: cryptsetup password prompt not shown

2016-03-24 Thread Erick Brunzell
I was not able to reproduce this behavior using the Ubuntu GNOME Xenial
20160323.1 images.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1359689

Title:
  cryptsetup password prompt not shown

Status in linux package in Ubuntu:
  Triaged
Status in linux source package in Utopic:
  Won't Fix
Status in linux source package in Vivid:
  Triaged
Status in plymouth package in Debian:
  Fix Released

Bug description:
  Currently in utopic the following happens when booting an encrypted
  setup:

  Press enter in grub, after a while screen freezes (or turns completely
  black) and stays like that. When I press the down key, I can see the
  password prompt. When I press the up key again, I get to the graphical
  password prompt.

  This is demonstrated in the following screencast:
  https://drive.google.com/file/d/0B7EMvd1LJKgZREJocHBueEhpa2s/edit?usp=sharing

  Maybe this is related to the version of plymouth utopic currently uses, a 
similar debian bug report seems to be resolved with a newer version 0.9.0-6, 
see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752752.
  --- 
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
  DistroRelease: Ubuntu 14.10
  InstallationDate: Installed on 2014-08-21 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
  Package: plymouth 0.9.0-0ubuntu3
  PackageArchitecture: amd64
  ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
  Tags:  utopic
  Uname: Linux 3.16.0-9-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  --- 
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
  DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
  DistroRelease: Ubuntu 14.10
  InstallationDate: Installed on 2014-08-21 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
  MachineType: Dell Inc. Precision M4600
  Package: plymouth 0.9.0-0ubuntu3
  PackageArchitecture: amd64
  ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-9-generic 
root=/dev/mapper/VG--Ubuntu-LV--Ubuntu--ROOT ro rootflags=subvol=@ 
cryptopts=target=Ubuntu,source=/dev/disk/by-uuid/6fc200da-aa04-4e73-b6a7-a2326f0b6204,lvm=VG-Ubuntu
 quiet splash vt.handoff=7
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-9-generic 
root=/dev/mapper/VG--Ubuntu-LV--Ubuntu--ROOT ro rootflags=subvol=@ 
cryptopts=target=Ubuntu,source=/dev/disk/by-uuid/6fc200da-aa04-4e73-b6a7-a2326f0b6204,lvm=VG-Ubuntu
 quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
  Tags:  utopic
  TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
  Uname: Linux 3.16.0-9-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  dmi.bios.date: 03/10/2013
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A14
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA14:bd03/10/2013:svnDellInc.:pnPrecisionM4600:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
  dmi.product.name: Precision M4600
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1359689/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561301] Re: [SAMSUNG ELECTRONICS CO., LTD. 870Z5E/880Z5E/680Z5E] suspend/resume failure

2016-03-24 Thread Joseph Salisbury
Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v4.5 kernel[0].

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:
'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as
"Confirmed".


Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/


** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu)
   Status: Confirmed => Incomplete

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561301

Title:
  [SAMSUNG ELECTRONICS CO., LTD. 870Z5E/880Z5E/680Z5E] suspend/resume
  failure

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  laptop will not suspend when instructed to. it seems to suspend
  partiallyexternal usb drive will suspend but fan and keyboard back
  lights do not shut off. In Ubuntu 14.04.4 it works properly. No
  keystroke will "wake" the laptop. I need to hold down the power key
  for 5-10 seconds to re-boot the computer. currently testing Ubuntu
  Mate 16.04

  ProblemType: KernelOops
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-15-generic 4.4.0-15.31
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  Annotation: This occurred during a previous suspend, and prevented the system 
from resuming properly.
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  jim1521 F pulseaudio
  Date: Wed Mar 23 21:53:35 2016
  DuplicateSignature: suspend/resume:SAMSUNG ELECTRONICS CO., LTD. 
870Z5E/880Z5E/680Z5E:P05ADH.017.140421.SH
  ExecutablePath: /usr/share/apport/apportcheckresume
  Failure: suspend/resume
  HibernationDevice: RESUME=UUID=8a7057dd-5682-4a01-b6cf-aba2e088a2e8
  InstallationDate: Installed on 2016-03-23 (0 days ago)
  InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Alpha amd64 
(20160224)
  InterpreterPath: /usr/bin/python3.5
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 870Z5E/880Z5E/680Z5E
  ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_US.UTF-8
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic.efi.signed 
root=UUID=e3144a26-7183-4650-b7a9-22fdaf6dc28a ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware1.157
  SourcePackage: linux
  Title: [SAMSUNG ELECTRONICS CO., LTD. 870Z5E/880Z5E/680Z5E] suspend/resume 
failure
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  dmi.bios.date: 04/21/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P05ADH.017.140421.SH
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: NP880Z5E-X01UB
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: SEC_SW_REVISION_1234567890ABCD
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: N/A
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP05ADH.017.140421.SH:bd04/21/2014:svnSAMSUNGELECTRONICSCO.,LTD.:pn870Z5E/880Z5E/680Z5E:pvrP05ADH:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP880Z5E-X01UB:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
  dmi.product.name: 870Z5E/880Z5E/680Z5E
  dmi.product.version: P05ADH
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561301/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1520343] Re: Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

2016-03-24 Thread Dennis Marttinen
Sorry! I forgot to add, that you need the latest mainline kernel (4.5.0)
for the updated fix to work. My mistake, I will update the description.
If you don't want to update your kernel, you have to use the old method
(post #22), but 5GHz wireless will definitely not work with it. The new
kernel has an updated version of the ath10k driver, which can utilize
both board.bin and board-2.bin from kvalo's repository (now enabling
5GHz), but the ath10k version Ubuntu 15.10 currently uses in it's kernel
(4.2.0) requires the single board-file from FireWalkerX.

Sorry for the inconvenience!

** Description changed:

  ---
  
  STATUS 2016-03-17:
+ 
+ ==
+ WARNING: You need at least kernel 4.5.0 for the following new fix to work, 
else refer to the old method described in post #22
+ ==
  
  The support for this card has now been merged to
  https://github.com/kvalo/ath10k-firmware. The repository now contains
  the required board.bin, board-2.bin and firmware-4.bin files for the
  card to initialize and connect to a bgn-access point (5GHz (ac-protocol)
  is still untested, feel free to modify this if you can confirm it
  works). Here are the new commands to get you online:
  
  sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/
  
  sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null
  
  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board.bin?raw=true
  
  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board-2.bin?raw=true
  
  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin
  https://github.com/kvalo/ath10k-
  
firmware/blob/master/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true
  
  Reboot or reload the ath10k_pci module and you should be able to
  connect!
  
  ---
  
  STATUS 2015-12-22:
  
  Currently there is a fix for this problem in post #22 (originally post
  #19, but reposted due to command typos!) which seems to have fixed the
  issue for many. This bug is unique to revision 32 of the card
  [168c:003e], fixes for older revisions don't seem to work.
  
  There are a couple of issues regarding the fix for some people (not
  all):
  
  1. Wireless works, but network throughput stops some time after
  connecting to access point
  
  2. Bluetooth communications take a noticeable performance hit when
  transferring something over WiFi
  
  ---
  
  Original description:
  
  I have recently installed Ubuntu 15.10 (64-bit) alongside Windows 10 on an 
Acer Aspire VN7-792G-76ZH and discovered, that the Qualcomm wireless card 
doesn't work in it or 16.04.
  The card has the device id 168c:003e as many other cards, for example the 
Qualcomm Atheros Killer 
(https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184), but it has a 
newer revision number (32) and the suggested fixes work only partially and the 
wireless is unusable.
  
  The computer has just been released this summer and is Intel Skylake
  -based.
  
  I've tried the patch from bug 1383184, which has a fix for the card revision 
20:
  Make the directory /lib/firmware/ath10k/QCA6174/hw3.0/ and put in the patch 
files:
  board.bin
  firmware-4.bin
  notice_ath10k_firmware-4.txt
  
  ath10k_pci succeeds in loading the firmware, but it seems that the
  firmware is not working correctly:
  
  dmesg | grep ath
  [5.452683] ath10k_pci :07:00.0: pci irq msi-x interrupts 8 irq_mode 0 
reset_mode 0
  [5.678420] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/cal-pci-:07:00.0.bin failed with error -2
  [5.678773] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
  [5.678781] ath10k_pci :07:00.0: failed to load spec board file, 
falling back to generic: -2
  [5.679445] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
  [5.679453] ath10k_pci :07:00.0: could not fetch firmware file 
'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
  [7.802316] ath10k_pci :07:00.0: qca6174 hw3.2 (0x0503, 
0x00340aff, 168c:003e:11ad:0807 fallback) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 api 
4 htt 3.26 wmi 4 cal otp max_sta 32
  [7.802329] ath10k_pci :07:00.0: debug 0 debugfs 1 tracing 1 dfs 0 
testmode 0
  [8.200607] ath: EEPROM regdomain: 0x6c
  [8.200614] ath: EEPROM indicates we should expect a direct regpair map
  [8.200619] ath: Country alpha2 being used: 00
  [8.200621] ath: Regpair used: 0x6c
  [8.216605] ath10k_pci :07:00.0 wlp7s0: renamed from wlan0
  [   13.462029] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   16.461416] ath10k_pci 

[Kernel-packages] [Bug 1520343] Re: Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

2016-03-24 Thread Dennis Marttinen
Gary, I've figured out that the binary files are read by ath10k rather
than executed directly, so they don't need executable permissions.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1520343

Title:
  Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  ---

  STATUS 2016-03-17:

  ==
  WARNING: You need at least kernel 4.5.0 for the following new fix to work, 
else refer to the old method described in post #22
  ==

  The support for this card has now been merged to
  https://github.com/kvalo/ath10k-firmware. The repository now contains
  the required board.bin, board-2.bin and firmware-4.bin files for the
  card to initialize and connect to a bgn-access point (5GHz (ac-
  protocol) is still untested, feel free to modify this if you can
  confirm it works). Here are the new commands to get you online:

  sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/

  sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board.bin?raw=true

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board-2.bin?raw=true

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin
  https://github.com/kvalo/ath10k-
  
firmware/blob/master/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

  Reboot or reload the ath10k_pci module and you should be able to
  connect!

  ---

  STATUS 2015-12-22:

  Currently there is a fix for this problem in post #22 (originally post
  #19, but reposted due to command typos!) which seems to have fixed the
  issue for many. This bug is unique to revision 32 of the card
  [168c:003e], fixes for older revisions don't seem to work.

  There are a couple of issues regarding the fix for some people (not
  all):

  1. Wireless works, but network throughput stops some time after
  connecting to access point

  2. Bluetooth communications take a noticeable performance hit when
  transferring something over WiFi

  ---

  Original description:

  I have recently installed Ubuntu 15.10 (64-bit) alongside Windows 10 on an 
Acer Aspire VN7-792G-76ZH and discovered, that the Qualcomm wireless card 
doesn't work in it or 16.04.
  The card has the device id 168c:003e as many other cards, for example the 
Qualcomm Atheros Killer 
(https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184), but it has a 
newer revision number (32) and the suggested fixes work only partially and the 
wireless is unusable.

  The computer has just been released this summer and is Intel Skylake
  -based.

  I've tried the patch from bug 1383184, which has a fix for the card revision 
20:
  Make the directory /lib/firmware/ath10k/QCA6174/hw3.0/ and put in the patch 
files:
  board.bin
  firmware-4.bin
  notice_ath10k_firmware-4.txt

  ath10k_pci succeeds in loading the firmware, but it seems that the
  firmware is not working correctly:

  dmesg | grep ath
  [5.452683] ath10k_pci :07:00.0: pci irq msi-x interrupts 8 irq_mode 0 
reset_mode 0
  [5.678420] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/cal-pci-:07:00.0.bin failed with error -2
  [5.678773] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
  [5.678781] ath10k_pci :07:00.0: failed to load spec board file, 
falling back to generic: -2
  [5.679445] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
  [5.679453] ath10k_pci :07:00.0: could not fetch firmware file 
'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
  [7.802316] ath10k_pci :07:00.0: qca6174 hw3.2 (0x0503, 
0x00340aff, 168c:003e:11ad:0807 fallback) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 api 
4 htt 3.26 wmi 4 cal otp max_sta 32
  [7.802329] ath10k_pci :07:00.0: debug 0 debugfs 1 tracing 1 dfs 0 
testmode 0
  [8.200607] ath: EEPROM regdomain: 0x6c
  [8.200614] ath: EEPROM indicates we should expect a direct regpair map
  [8.200619] ath: Country alpha2 being used: 00
  [8.200621] ath: Regpair used: 0x6c
  [8.216605] ath10k_pci :07:00.0 wlp7s0: renamed from wlan0
  [   13.462029] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   16.461416] ath10k_pci :07:00.0: could not suspend target (-11)
  [   24.760062] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   27.759534] ath10k_pci :07:00.0: could not suspend target (-11)
  [   36.046205] ath10k_pci 

[Kernel-packages] [Bug 1549354] Re: After upgrading to 4.2.0.30 Elantech touchpad not detected

2016-03-24 Thread Thomas Zell
Commit 0f8e1864193330c04ce01ba9c9ee45e43e91f540 does NOT work.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1549354

Title:
  After upgrading to 4.2.0.30 Elantech touchpad not detected

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Wily:
  In Progress

Bug description:
  Elan Touchpad not listed as "Elan Touchpad" after "xinput list" or "cat 
/proc/bus/input/devices"
   . Not detected properly? For sure it does not work.
  External mouse working well. 
  Downgrading to 4.2.0-27-generic kernel solves problem(touchpad works). 
  My computer model is Toshiba Chromebook 2 with Gnome ubuntu 15.10

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-30-generic 4.2.0-30.35
  ProcVersionSignature: Ubuntu 4.2.0-30.35-generic 4.2.8-ckt3
  Uname: Linux 4.2.0-30-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  siulkilulki909 F pulseaudio
  CurrentDesktop: GNOME
  Date: Wed Feb 24 16:55:47 2016
  InstallationDate: Installed on 2015-12-06 (80 days ago)
  InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 
(20151021)
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 8087:07dc Intel Corp. 
   Bus 001 Device 003: ID 04f2:b48b Chicony Electronics Co., Ltd 
   Bus 001 Device 002: ID 1ea7:0011  
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: GOOGLE Swanky
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-30-generic 
root=UUID=20463b36-edda-428c-a236-f715f1d7bb85 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-30-generic N/A
   linux-backports-modules-4.2.0-30-generic  N/A
   linux-firmware1.149.3
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/22/2014
  dmi.bios.vendor: coreboot
  dmi.chassis.type: 3
  dmi.chassis.vendor: GOOGLE
  dmi.modalias: 
dmi:bvncoreboot:bvr:bd08/22/2014:svnGOOGLE:pnSwanky:pvr1.0:cvnGOOGLE:ct3:cvr:
  dmi.product.name: Swanky
  dmi.product.version: 1.0
  dmi.sys.vendor: GOOGLE

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1549354/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1546260] Re: kexec/kdump not working in ubuntu 16.04

2016-03-24 Thread Breno Leitão
Good news! The patches were just accepted earlier today:

http://git.kernel.org/cgit/utils/kernel/kexec/kexec-tools.git/commit/?id=4a2ae3a39c64dc43e9d094be9541253234ff4822
http://git.kernel.org/cgit/utils/kernel/kexec/kexec-tools.git/commit/?id=1e423dc297d10eb7ff25c829d2856ef12fc81d77
http://git.kernel.org/cgit/utils/kernel/kexec/kexec-tools.git/commit/?id=3debb8cf3272216119cb2e59a4963ce3c18fe8e3

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to kexec-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1546260

Title:
  kexec/kdump not working in ubuntu 16.04

Status in kexec-tools package in Ubuntu:
  Confirmed

Bug description:
  == Comment: #0 - Praveen K. Pandey  - 2016-02-04 
04:11:48 ==
  Hi 

I installed Ubuntu16.04 as PowerVM/KVM/PowerNV and setup kdump as
  well use PPA build to resolve sym link problem broken installed kdump-
  tools   1:1.5.9-4~lp1536904, and trigger kdump .While dumping process
  console hung not able to get vmcore.

  
  Reproducible Step:

  1- Installed Ubuntu16.04 
  2- Installed PPA build of Kdump mentioned in bug135822
  3- Start kdump service 
  4- Trigger a panic 

  Expected Result :

  Able to generate kdump

  Actual Result :

  System halt on dump process , seems me having initrd issue

  LOG:

  root@ubuntu:~# kdump-config load
  Modified cmdline:BOOT_IMAGE=/boot/vmlinux-4.4.0-2-generic 
root=UUID=9d1662d4-db2a-4a1a-b8d7-8b0d4e7872dd  ro splash quiet irqpoll 
maxcpus=1 nousb systemd.unit=kdump-tools.service elfcorehdr=156288K 
   * loaded kdump kernel


  root@ubuntu:~# kdump-config show
  DUMP_MODE:kdump
  USE_KDUMP:1
  KDUMP_SYSCTL: kernel.panic_on_oops=1
  KDUMP_COREDIR:/var/crash
  crashkernel addr: 
 /var/lib/kdump/vmlinuz: symbolic link to /boot/vmlinux-4.4.0-2-generic
  kdump initrd: 
 /var/lib/kdump/initrd.img: symbolic link to 
/var/lib/kdump/initrd.img-4.4.0-2-generic
  current state:ready to kdump

  kexec command:
/sbin/kexec -p --command-line="BOOT_IMAGE=/boot/vmlinux-4.4.0-2-generic 
root=UUID=2a78d070-4b73-4da6-b7eb-d41164c909fa ro splash quiet irqpoll 
maxcpus=1 nousb systemd.unit=kdump-tools.service" 
--initrd=/var/lib/kdump/initrd.img /var/lib/kdump/vmlinuz
  root@ubuntu:~# 
  root@ubuntu:~# kdump-config status
  current state   : ready to kdump
  root@ubuntu:~#

  root@ubuntu:~# echo 1 > /proc/sys/kernel/sysrq

  
  root@ubuntu:~# echo c > /proc/sysrq-trigger
  [  164.495349] sysrq: SysRq : Trigger a crash
  [  164.495360] Unable to handle kernel paging request for data at address 
0x
  [  164.495364] Faulting instruction address: 0xc0654db4
  [  164.495368] Oops: Kernel access of bad area, sig: 11 [#1]
  [  164.495370] SMP NR_CPUS=2048 NUMA pSeries
  [  164.495374] Modules linked in: rpadlpar_io rpaphp dccp_diag dccp tcp_diag 
udp_diag inet_diag unix_diag af_packet_diag netlink_diag binfmt_misc uas 
usb_storage pseries_rng rtc_generic autofs4 ibmvscsi ibmveth
  [  164.495389] CPU: 0 PID: 1281 Comm: bash Not tainted 4.4.0-2-generic 
#16-Ubuntu
  [  164.495393] task: c003f1f2a200 ti: c6ef8000 task.ti: 
c6ef8000
  [  164.495396] NIP: c0654db4 LR: c0655e68 CTR: 
c0654d80
  [  164.495399] REGS: c6efb990 TRAP: 0300   Not tainted  
(4.4.0-2-generic)
  [  164.495401] MSR: 80009033   CR: 2824  
XER: 0001
  [  164.495410] CFAR: c0008468 DAR:  DSISR: 4200 
SOFTE: 1 
  GPR00: c0655e68 c6efbc10 c1583800 0063 
  GPR04: c003ff609c50 c003ff61b4f0 c003ffe6c200 015b 
  GPR08: 0007 0001  c003ffe72710 
  GPR12: c0654d80 c7ae  2200 
  GPR16: 10170710 01002c890608 101406f0 100c7100 
  GPR20:  1017df98 10140588  
  GPR24: 10153440 1017b848 c14c8540 0004 
  GPR28: c14c8900 0063 c14810bc  
  [  164.495451] NIP [c0654db4] sysrq_handle_crash+0x34/0x50
  [  164.495454] LR [c0655e68] __handle_sysrq+0xe8/0x270
  [  164.495456] Call Trace:
  [  164.495460] [c6efbc10] [c0de3008] 
_fw_tigon_tg3_bin_name+0x2cc30/0x33d18 (unreliable)
  [  164.495464] [c6efbc30] [c0655e68] __handle_sysrq+0xe8/0x270
  [  164.495468] [c6efbcd0] [c0656608] 
write_sysrq_trigger+0x78/0xa0
  [  164.495472] [c6efbd00] [c0374e70] proc_reg_write+0xb0/0x110
  [  164.495476] [c6efbd50] [c02dcabc] __vfs_write+0x6c/0xe0
  [  164.495480] [c6efbd90] [c02dd7f0] vfs_write+0xc0/0x230
  [  164.495484] [c6efbde0] [c02de82c] SyS_write+0x6c/0x110
  [  164.495488] [c6efbe30] [c0009204] system_call+0x38/0xb4
  [  

[Kernel-packages] [Bug 1561447] [NEW] MFG HOT: ubuntu installer device detection issue on Firestone and Garrison

2016-03-24 Thread Launchpad Bug Tracker
You have been subscribed to a public bug:

== Comment: #0 - Lucas J. Schroeder  - 2015-07-15 15:59:37 
==
---Problem Description---
The installer for 14.04.02 and 15.04 is detecting hard disk media that does not 
exist.  In my preseed files for both Firestone and Garrison, the debconfig-set 
partman-auto/disk has to followed by /dev/sdj.  Trying to use /dev/sda will 
result in an installer error
 
Contact Information = lschr...@us.ibm.com 
 
---uname output---
Linux rcx2c360 3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:42:36 UTC 
2015 ppc64le ppc64le ppc64le GNU/Linux
 
Machine Type = Firestone 8335-GTA, Garrison 8335-GTB 
 
---boot type---
Network boot
 
---bootloader---
opal
 
---Kernel cmdline used to launch install---
cd /tmp

tftp -g -l ./initrd -r /tftpboot/initrd.Ubuntu14_1502.gz 9.10.192.40

tftp -g -l ./vmlinux -r /tftpboot/vmlinux.Ubuntu14_1502 9.10.192.40

kexec -l ./vmlinux --initrd ./initrd --append 
 
---Bootloader protocol---
unsure
 
---Install repository type---
Local repository
 
---Install repository Location---
http://9.10.192.40/install/ppc/Ubuntu14_1502/CD1
 
---Point of failure---
Other failure during installation (stage 1)


== Comment: #5 - NISHANTH ARAVAMUDAN  - 2015-07-16 11:48:54 
==
Michael,

I think this is the same issue we see on our Garrison as well.

Lucas, Michael will take a look at it.

-Nish

== Comment: #7 - NISHANTH ARAVAMUDAN  - 2015-07-16 12:16:47 
==
HA!

>From our Garrison:

Jul 15 19:20:35 kernel: [7.544664] scsi 0:0:0:0: CD-ROMAMI  
Virtual CDROM0   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.548145] scsi 0:0:0:1: CD-ROMAMI  
Virtual CDROM1   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.552144] scsi 0:0:0:2: CD-ROMAMI  
Virtual CDROM2   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.554643] scsi 0:0:0:3: CD-ROMAMI  
Virtual CDROM3   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.925426] scsi 1:0:0:0: Direct-Access AMI  
Virtual Floppy0  1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.925672] scsi 2:0:0:0: Direct-Access AMI  
Virtual HDisk0   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.927825] scsi 1:0:0:1: Direct-Access AMI  
Virtual Floppy1  1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.928042] scsi 2:0:0:1: Direct-Access AMI  
Virtual HDisk1   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.928547] scsi 1:0:0:2: Direct-Access AMI  
Virtual Floppy2  1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.928805] scsi 2:0:0:2: Direct-Access AMI  
Virtual HDisk2   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.929173] scsi 1:0:0:3: Direct-Access AMI  
Virtual Floppy3  1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.929669] scsi 2:0:0:3: Direct-Access AMI  
Virtual HDisk3   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [7.931045] scsi 2:0:0:4: Direct-Access AMI  
Virtual HDisk4   1.00 PQ: 0 ANSI: 0 CCS
Jul 15 19:20:35 kernel: [8.031783] sr 0:0:0:0: [sr0] scsi-1 drive
Jul 15 19:20:35 kernel: [8.031908] cdrom: Uniform CD-ROM driver Revision: 
3.20
Jul 15 19:20:35 kernel: [8.032391] sr 0:0:0:0: Attached scsi CD-ROM sr0
Jul 15 19:20:35 kernel: [8.032526] sr 0:0:0:0: Attached scsi generic sg0 
type 5
Jul 15 19:20:35 kernel: [8.083910] sr 0:0:0:1: [sr1] scsi-1 drive
Jul 15 19:20:35 kernel: [8.084253] sr 0:0:0:1: Attached scsi CD-ROM sr1
Jul 15 19:20:35 kernel: [8.084359] sr 0:0:0:1: Attached scsi generic sg1 
type 5
Jul 15 19:20:35 kernel: [8.112910] sr 0:0:0:2: [sr2] scsi-1 drive
Jul 15 19:20:35 kernel: [8.113230] sr 0:0:0:2: Attached scsi CD-ROM sr2
Jul 15 19:20:35 kernel: [8.113349] sr 0:0:0:2: Attached scsi generic sg2 
type 5
Jul 15 19:20:35 kernel: [8.124786] sr 0:0:0:3: [sr3] scsi-1 drive
Jul 15 19:20:35 kernel: [8.125418] sr 0:0:0:3: Attached scsi CD-ROM sr3
Jul 15 19:20:35 kernel: [8.125523] sr 0:0:0:3: Attached scsi generic sg3 
type 5
Jul 15 19:20:35 kernel: [8.144632] sd 1:0:0:0: Attached scsi generic sg4 
type 0
Jul 15 19:20:35 kernel: [8.147850] sd 1:0:0:1: Attached scsi generic sg5 
type 0
Jul 15 19:20:35 kernel: [8.149422] sd 1:0:0:0: [sda] Attached SCSI 
removable disk
Jul 15 19:20:35 kernel: [8.150210] sd 1:0:0:2: Attached scsi generic sg6 
type 0
Jul 15 19:20:35 kernel: [8.153482] sd 1:0:0:3: Attached scsi generic sg7 
type 0
Jul 15 19:20:35 kernel: [8.156756] sd 1:0:0:1: [sdb] Attached SCSI 
removable disk
Jul 15 19:20:35 kernel: [8.160922] sd 1:0:0:2: [sdc] Attached SCSI 
removable disk
Jul 15 19:20:35 kernel: [8.229248] sd 1:0:0:3: [sdd] Attached SCSI 
removable disk
Jul 15 19:20:35 kernel: [8.513434] sd 2:0:0:0: Attached scsi generic sg8 
type 0
Jul 15 19:20:35 kernel: [8.518483] sd 2:0:0:0: [sde] Attached SCSI 
removable disk
Jul 15 19:20:35 kernel: [8.578842] sd 

[Kernel-packages] [Bug 1515301] Re: [Hyper-V] issues with linux-next on 15.04 kdump functionality

2016-03-24 Thread Chris Valean
This has been fixed in the meantime, the related issue with ubuntu &
linux-next remains that a high crashkernel size must be used - 1GB@1GB
even though the initrd image is now under 200MB.

Let's keep this separate from 1400319 as at this point the issues are different.
Thanks Joe!

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1515301

Title:
  [Hyper-V] issues with linux-next on 15.04 kdump functionality

Status in linux package in Ubuntu:
  Triaged

Bug description:
  Using linux-next 4.3.0-next-20151106 kdump is failing to start as a service.
  On RHEL and SLES with upstream, kdump is working as expected so only Ubuntu 
has this issue as observed from our testing.

  A similar issue with the same error message from kdump has been already 
reported here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1400319
  However that behavior was on 32bit Ubuntu only, and now with upstream this 
seems to extend to 64bit as well.
  So I'm not sure if we should link these 2 bug reports at this point.

  Issues description:
  1. kdump-tools service fails to start on 15.04 64bit, when runnig the 
linux-next kernel
  Error returned is: Starting kdump-tools: Could not find a free area of memory 
of 0xa637000 bytes...
  (full log below)
  By default, kdump sets crashkernel to 394M-:128M

  2. If crashkernel is set to 384M, the dump file will fail to create due to 
OOM messages when a crash is triggered. 
  Attaching the full serial log with crashkernel=384M. The log is the same with 
512M as crashkernel.
  Can this be a memory leak in the kdump kernel, making even already high 
values as 512M for the crashkernel to not be enough?
  VM RAM has been set to 2GB and also 4GB, and with minimal load on the system 
that isn't a problem.

  Work-around for issue #1:
  Set crashkernel size to 384M, instead of the default 384M-:128M.
  With this, kdump-tools will start.
  However the dump file doesn't get written and the system will hang, without 
rebooting.

  Values used to trigger a kdump:
  - 384M
  - 512M
  - 384M-:128M - kdump-tools will not properly load.

  Full kdump service log:
  root@ubuntu1504srv:~# service kdump-tools status
  â kdump-tools.service - Kernel crash dump capture service
 Loaded: loaded (/lib/systemd/system/kdump-tools.service; enabled; vendor 
preset: enabled)
 Active: active (exited) since Wed 2015-11-11 06:02:28 PST; 20min ago
Process: 792 ExecStart=/etc/init.d/kdump-tools start (code=exited, 
status=0/SUCCESS)
   Main PID: 792 (code=exited, status=0/SUCCESS)
 CGroup: /system.slice/kdump-tools.service

  Nov 11 06:02:20 ubuntu1504srv systemd[1]: Starting Kernel crash dump capture 
service...
  Nov 11 06:02:28 ubuntu1504srv kdump-tools[792]: Starting kdump-tools: Could 
not find a free area of memory of 0xa637000 bytes...
  Nov 11 06:02:28 ubuntu1504srv kdump-tools[792]: locate_hole failed
  Nov 11 06:02:28 ubuntu1504srv kdump-tools[792]: * failed to load kdump kernel
  Nov 11 06:02:28 ubuntu1504srv systemd[1]: Started Kernel crash dump capture 
service.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1515301/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1560583] Re: reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

2016-03-24 Thread Tyler Hicks
Hi Tim - Thanks for scooping up those patches. I didn't intend for you
to have to do that and planned to send them out this morning. I
appreciate it! :)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560583

Title:
  reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  $ cat ./t
  #include 

  profile t {
 #include 
 /bin/cat ixr,
 /sys/kernel/security/apparmor/profiles r,
  }

  $ sudo apparmor_parser -r ./t
  $ sudo aa-exec -p t -- cat /sys/kernel/security/apparmor/profiles 
  cat: /sys/kernel/security/apparmor/profiles: Permission denied
  [1]

  kernel: [   62.203035] audit: type=1400 audit(1458665428.726:128):
  apparmor="DENIED" operation="capable" profile="t" pid=3683 comm="cat"
  capability=33  capname="mac_admin"

  This is new in the -15 kernel.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560583/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1560869] Re: Concurrent zfs create and rename operations can lock a zpool completely

2016-03-24 Thread Colin Ian King
** Changed in: zfs-linux (Ubuntu)
   Status: New => In Progress

** Changed in: zfs-linux (Ubuntu)
   Importance: Undecided => High

** Changed in: zfs-linux (Ubuntu)
 Assignee: (unassigned) => Colin Ian King (colin-king)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560869

Title:
  Concurrent zfs create and rename operations can lock a zpool
  completely

Status in linux package in Ubuntu:
  Incomplete
Status in zfs-linux package in Ubuntu:
  In Progress

Bug description:
  When doing "zfs create -V" and "zfs rename" operations on the same
  zpool in parallel, there is a high chance for a deadlock leading to a
  complete hang of the zpool in question (i.e., all further zfs
  operations hang indefinitely).

  Attached you find a simple perl script that should trigger the bug
  (the pool variable needs to be set to your pool name), if run in two
  shells at the same time:

  $ for i in `seq 1 100`; do sudo ./zfsrenamebug.pl "A$i"; done

  $ for i in `seq 1 100`; do sudo ./zfsrenamebug.pl "B$i"; done

  Reported upstream in https://github.com/zfsonlinux/zfs/issues/4404 and 
apparently fixed with the linked commits.
  --- 
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 16.04
  HibernationDevice: RESUME=UUID=41b79831-ff2c-4d62-8d09-0fd00a3fafad
  InstallationDate: Installed on 2016-03-18 (4 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160307)
  IwConfig:
   ens18 no wireless extensions.
   
   lono wireless extensions.
  Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
  NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
  Package: zfs-linux
  ProcFB: 0 qxldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic 
root=UUID=ff5bf1a3-8ced-46a8-9e2e-e3e7d0e522c0 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware1.157
  RfKill:
   
  Tags:  xenial
  Uname: Linux 4.4.0-15-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 04/01/2014
  dmi.bios.vendor: SeaBIOS
  dmi.bios.version: rel-1.8.2-0-g33fbe13 by qemu-project.org
  dmi.chassis.type: 1
  dmi.chassis.vendor: QEMU
  dmi.chassis.version: pc-i440fx-2.5
  dmi.modalias: 
dmi:bvnSeaBIOS:bvrrel-1.8.2-0-g33fbe13byqemu-project.org:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-2.5:cvnQEMU:ct1:cvrpc-i440fx-2.5:
  dmi.product.name: Standard PC (i440FX + PIIX, 1996)
  dmi.product.version: pc-i440fx-2.5
  dmi.sys.vendor: QEMU

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560869/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1359689] Re: cryptsetup password prompt not shown

2016-03-24 Thread Xtien
The issue seems to be with desktop computers, not laptops? Full disk
encryption works well on my laptop, has always worked well, just not on
my desktop computer.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1359689

Title:
  cryptsetup password prompt not shown

Status in linux package in Ubuntu:
  Triaged
Status in linux source package in Utopic:
  Won't Fix
Status in linux source package in Vivid:
  Triaged
Status in plymouth package in Debian:
  Fix Released

Bug description:
  Currently in utopic the following happens when booting an encrypted
  setup:

  Press enter in grub, after a while screen freezes (or turns completely
  black) and stays like that. When I press the down key, I can see the
  password prompt. When I press the up key again, I get to the graphical
  password prompt.

  This is demonstrated in the following screencast:
  https://drive.google.com/file/d/0B7EMvd1LJKgZREJocHBueEhpa2s/edit?usp=sharing

  Maybe this is related to the version of plymouth utopic currently uses, a 
similar debian bug report seems to be resolved with a newer version 0.9.0-6, 
see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752752.
  --- 
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
  DistroRelease: Ubuntu 14.10
  InstallationDate: Installed on 2014-08-21 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
  Package: plymouth 0.9.0-0ubuntu3
  PackageArchitecture: amd64
  ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
  Tags:  utopic
  Uname: Linux 3.16.0-9-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  --- 
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
  DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
  DistroRelease: Ubuntu 14.10
  InstallationDate: Installed on 2014-08-21 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
  MachineType: Dell Inc. Precision M4600
  Package: plymouth 0.9.0-0ubuntu3
  PackageArchitecture: amd64
  ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-9-generic 
root=/dev/mapper/VG--Ubuntu-LV--Ubuntu--ROOT ro rootflags=subvol=@ 
cryptopts=target=Ubuntu,source=/dev/disk/by-uuid/6fc200da-aa04-4e73-b6a7-a2326f0b6204,lvm=VG-Ubuntu
 quiet splash vt.handoff=7
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-9-generic 
root=/dev/mapper/VG--Ubuntu-LV--Ubuntu--ROOT ro rootflags=subvol=@ 
cryptopts=target=Ubuntu,source=/dev/disk/by-uuid/6fc200da-aa04-4e73-b6a7-a2326f0b6204,lvm=VG-Ubuntu
 quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
  Tags:  utopic
  TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
  Uname: Linux 3.16.0-9-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  dmi.bios.date: 03/10/2013
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A14
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA14:bd03/10/2013:svnDellInc.:pnPrecisionM4600:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
  dmi.product.name: Precision M4600
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1359689/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1389716] Re: 168c:003e (rev 20) WNIC Qualcomm Atheros Device not working

2016-03-24 Thread Jeremy
Upstream developers are waiting for an answer from Qualcomm to fix this
bluetooth issue

http://www.spinics.net/lists/linux-bluetooth/msg66420.html

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1389716

Title:
  168c:003e (rev 20) WNIC Qualcomm Atheros Device not working

Status in linux package in Ubuntu:
  Triaged

Bug description:
  With my brand new MSI GS70 2QE gaming notebook, my WiFi doesn't work.
  I installed the lastest kernel 3.18.0-031800rc3-generic and run apt-
  get update and upgrade but with no result.

  WORKAROUND: I use an RJ45 cable i do get internet though.

  The issuing of the comand "ifconfig -a" is as follow:
  eth0 Link encap:Ethernet HWaddr 44:8a:5b:6e:ec:2c
  inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
  inet6 addr: fe80::468a:5bff:fe6e:ec2c/64 Scope:Link
  UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
  RX packets:15581 errors:0 dropped:0 overruns:0 frame:0
  TX packets:11436 errors:0 dropped:0 overruns:0 carrier:0
  collisions:0 txqueuelen:1000
  RX bytes:17066393 (17.0 MB) TX bytes:1266194 (1.2 MB)
  Interrupt:19

  lo Link encap:Local Loopback
  inet addr:127.0.0.1 Mask:255.0.0.0
  inet6 addr: ::1/128 Scope:Host
  UP LOOPBACK RUNNING MTU:65536 Metric:1
  RX packets:2299 errors:0 dropped:0 overruns:0 frame:0
  TX packets:2299 errors:0 dropped:0 overruns:0 carrier:0
  collisions:0 txqueuelen:0
  RX bytes:327314 (327.3 KB) TX bytes:327314 (327.3 KB)

  as you can see no wlan or wlan0 showing up.

  
  Lastly, when i boot Ubuntu before the user screen password appears get the 
message:
  2.065748 Bluetooth: Patch file not found ar3k/AthrBT_0x02000.dfu
  2.065781 Bluetooth: Loading path file failed

  ---
  ApportVersion: 2.14.1-0ubuntu3.2
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  roblucci   2174 F pulseaudio
   /dev/snd/controlC1:  roblucci   2174 F pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=c1c2bf77-7d55-4317-854f-9126b9272fe3
  InstallationDate: Installed on 2014-11-05 (0 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 
(20140722.2)
  IwConfig:
   eth0  no wireless extensions.

   lono wireless extensions.
  MachineType: Micro-Star International Co., Ltd. GS70 2QE
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-39-generic.efi.signed 
root=UUID=016c94f5-05c7-44d7-b8a3-a80e7b51f739 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.13.0-39.66-generic 3.13.11.8
  RelatedPackageVersions:
   linux-restricted-modules-3.13.0-39-generic N/A
   linux-backports-modules-3.13.0-39-generic  N/A
   linux-firmware 1.127.5
  RfKill:

  Tags:  trusty
  Uname: Linux 3.13.0-39-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 10/22/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: E1773IMS.10A
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: MS-1773
  dmi.board.vendor: Micro-Star International Co., Ltd.
  dmi.board.version: REV:0.B
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Micro-Star International Co., Ltd.
  dmi.chassis.version: N/A
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrE1773IMS.10A:bd10/22/2014:svnMicro-StarInternationalCo.,Ltd.:pnGS702QE:pvrREV1.0:rvnMicro-StarInternationalCo.,Ltd.:rnMS-1773:rvrREV0.B:cvnMicro-StarInternationalCo.,Ltd.:ct10:cvrN/A:
  dmi.product.name: GS70 2QE
  dmi.product.version: REV:1.0
  dmi.sys.vendor: Micro-Star International Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1389716/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1560583] Re: reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

2016-03-24 Thread Tim Gardner
** Also affects: linux (Ubuntu Xenial)
   Importance: High
 Assignee: Tyler Hicks (tyhicks)
   Status: In Progress

** Changed in: linux (Ubuntu Xenial)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560583

Title:
  reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  $ cat ./t
  #include 

  profile t {
 #include 
 /bin/cat ixr,
 /sys/kernel/security/apparmor/profiles r,
  }

  $ sudo apparmor_parser -r ./t
  $ sudo aa-exec -p t -- cat /sys/kernel/security/apparmor/profiles 
  cat: /sys/kernel/security/apparmor/profiles: Permission denied
  [1]

  kernel: [   62.203035] audit: type=1400 audit(1458665428.726:128):
  apparmor="DENIED" operation="capable" profile="t" pid=3683 comm="cat"
  capability=33  capname="mac_admin"

  This is new in the -15 kernel.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560583/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1359689] Re: cryptsetup password prompt not shown

2016-03-24 Thread Martin Wimpress
I just tested this on 3 different computers using Ubuntu MATE 16.04 Beta
2, all were installed with full disk encryption.

  * Thinkpad T43p (i386, Radeon)
  * Thinkpad x201 (amd64, Intel IGP)
  * Thinkpad T61s (amd64, nVidia)

In all cases I could not reproduce this issue. It works are intended.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1359689

Title:
  cryptsetup password prompt not shown

Status in linux package in Ubuntu:
  Triaged
Status in linux source package in Utopic:
  Won't Fix
Status in linux source package in Vivid:
  Triaged
Status in plymouth package in Debian:
  Fix Released

Bug description:
  Currently in utopic the following happens when booting an encrypted
  setup:

  Press enter in grub, after a while screen freezes (or turns completely
  black) and stays like that. When I press the down key, I can see the
  password prompt. When I press the up key again, I get to the graphical
  password prompt.

  This is demonstrated in the following screencast:
  https://drive.google.com/file/d/0B7EMvd1LJKgZREJocHBueEhpa2s/edit?usp=sharing

  Maybe this is related to the version of plymouth utopic currently uses, a 
similar debian bug report seems to be resolved with a newer version 0.9.0-6, 
see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752752.
  --- 
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
  DistroRelease: Ubuntu 14.10
  InstallationDate: Installed on 2014-08-21 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
  Package: plymouth 0.9.0-0ubuntu3
  PackageArchitecture: amd64
  ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
  Tags:  utopic
  Uname: Linux 3.16.0-9-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  --- 
  ApportVersion: 2.14.6-0ubuntu2
  Architecture: amd64
  DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
  DistroRelease: Ubuntu 14.10
  InstallationDate: Installed on 2014-08-21 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140821)
  MachineType: Dell Inc. Precision M4600
  Package: plymouth 0.9.0-0ubuntu3
  PackageArchitecture: amd64
  ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-9-generic 
root=/dev/mapper/VG--Ubuntu-LV--Ubuntu--ROOT ro rootflags=subvol=@ 
cryptopts=target=Ubuntu,source=/dev/disk/by-uuid/6fc200da-aa04-4e73-b6a7-a2326f0b6204,lvm=VG-Ubuntu
 quiet splash vt.handoff=7
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-9-generic 
root=/dev/mapper/VG--Ubuntu-LV--Ubuntu--ROOT ro rootflags=subvol=@ 
cryptopts=target=Ubuntu,source=/dev/disk/by-uuid/6fc200da-aa04-4e73-b6a7-a2326f0b6204,lvm=VG-Ubuntu
 quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
  Tags:  utopic
  TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
  Uname: Linux 3.16.0-9-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:
   
  _MarkForUpload: True
  dmi.bios.date: 03/10/2013
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A14
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA14:bd03/10/2013:svnDellInc.:pnPrecisionM4600:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
  dmi.product.name: Precision M4600
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1359689/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1557298] Re: [Xenial][Bluez5] Low Energy Keyboard is paired incorrectly

2016-03-24 Thread Tony Espy
I see those error messages quite frequently on touch devices running
Bluez5 as well.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.
https://bugs.launchpad.net/bugs/1557298

Title:
  [Xenial][Bluez5] Low Energy Keyboard is paired incorrectly

Status in Unity Control Center:
  New
Status in bluez package in Ubuntu:
  New

Bug description:
  Failed to pair low energy(bluetooth smart, 4.0 or 4.1) devices
  correctly.

  1. bluetooth smart mouse is being listed as "all type" in bluetooth-
  wizard, however it is able to be paired and use, even repair(i'm
  mentioning this because in some circumstance low energy device can be
  only paired once, bug #1515179)

  2. bluetooth smart keyboard is unable to use after bluetooth-wizard
  says "OK". Also the passcode input is also not acting interactively
  like when pairing with bluetooth 3.0 keyboard.

  Above scenario also being verified with bluetoothctl and blueman.

  -
  More details about versions:

  Environment:
  xenial daily (20160307)
  bluez 5.37-0ubuntu5
  gnome-bluetooth 3.18.2-1ubuntu2
  blueman  2.0.3-1ubuntu1
  bluetooth controller 0cf3:e005 Atheros Communications, Inc. (hci version: 4.1)

  Tested devices:
  Designer Mouse, bluetooth smart (pairable, work, re-pair work)
  Designer Keyboard, bluetooth smart (paired, not working)
  BT3.0 keyboard, bluetooth classic (pair and work)
  BT3.0 mouse, bluetooth classic (pair and work)

  -
  In control environment with the same hardware system and devices:
  trusty 14.04.1 + dist-upgrade (stay with 3.13 kernel)
  bluez5 5.35 (ppa: https://launchpad.net/~vidplace7/+archive/ubuntu/bluez5)

  It works with all above devices but can only be pairing through
  bluetoothctl, since the older bluetooth-wizard does not understand
  bluez 5.x. Everything seems works fine, although there are a lot more
  error messages, but since this bug is more about xenial, please let me
  know if we need more information about this, I'm able to reproduce
  this trusty scenario in anytime.

  -
  Additional note:
  A little clarification, since I'm not sure how far the Bluetooth SIG is going 
to use Bluetooth Smart(Low Energy, or even Smart-Ready) to cover the 
versioning, I decided to just use what ever I saw on the product box.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: bluez 5.37-0ubuntu5
  ProcVersionSignature: Ubuntu 4.4.0-12.28-generic 4.4.4
  Uname: Linux 4.4.0-12-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Tue Mar 15 11:40:12 2016
  InstallationDate: Installed on 2016-03-14 (0 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160307)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: Dell Inc. Latitude E5550
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-12-generic.efi.signed 
root=UUID=1079eca4-4293-4e51-ba0e-84f7d681cb2c ro quiet splash vt.handoff=7
  SourcePackage: bluez
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/18/2015
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A11
  dmi.board.name: 0141B2
  dmi.board.vendor: Dell Inc.
  dmi.board.version: X02
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA11:bd11/18/2015:svnDellInc.:pnLatitudeE5550:pvr:rvnDellInc.:rn0141B2:rvrX02:cvnDellInc.:ct9:cvr:
  dmi.product.name: Latitude E5550
  dmi.sys.vendor: Dell Inc.
  hciconfig:
   hci0:Type: BR/EDR  Bus: USB
BD Address: 00:71:CC:39:BD:22  ACL MTU: 1022:8  SCO MTU: 183:5
UP RUNNING PSCAN ISCAN 
RX bytes:862538 acl:39687 sco:0 events:2668 errors:0
TX bytes:26235 acl:904 sco:0 commands:1021 errors:0

To manage notifications about this bug go to:
https://bugs.launchpad.net/unity-control-center/+bug/1557298/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561483] Re: linux: sync to ZFS 0.6.5.6 stable release

2016-03-24 Thread Andy Whitcroft
** Description changed:

- ZFS 0.6.5.6 is now out, so sync this from the spl and zfs packages to
- the kernel
+ ZFS 0.6.5.6 stable release is now out and applied to the main packages.
+ Sync this from the spl and zfs packages to the kernel

** Changed in: linux (Ubuntu)
Milestone: None => ubuntu-16.03

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561483

Title:
  linux: sync to ZFS 0.6.5.6 stable release

Status in linux package in Ubuntu:
  Fix Committed

Bug description:
  ZFS 0.6.5.6 stable release is now out and applied to the main
  packages.  Sync this from the spl and zfs packages to the kernel

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561483/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561492] Re: linux: sync virtualbox drivers to 5.0.16-dfsg-2

2016-03-24 Thread Andy Whitcroft
** Changed in: linux (Ubuntu)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561492

Title:
  linux: sync virtualbox drivers to 5.0.16-dfsg-2

Status in linux package in Ubuntu:
  Fix Committed

Bug description:
  The virtualbox drivers have been updated, sync those into the kernel.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561492/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1520343] Re: Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

2016-03-24 Thread Jeremy
Daniel

If

ls /lib/firmware/ath10k/QCA6174/hw3.0

shows a board.bin and a board-2.bin

sudo mv /lib/firmware/ath10k/QCA6174/hw3.0/board.bin
/lib/firmware/ath10k/QCA6174/hw3.0/board.bin.bak

Reboot

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1520343

Title:
  Qualcomm Atheros wireless card [168c:003e] (rev 32) not supported

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  ---

  STATUS 2016-03-17:

  The support for this card has now been merged to
  https://github.com/kvalo/ath10k-firmware. The repository now contains
  the required board.bin, board-2.bin and firmware-4.bin files for the
  card to initialize and connect to a bgn-access point (5GHz (ac-
  protocol) is still untested, feel free to modify this if you can
  confirm it works). Here are the new commands to get you online:

  sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/

  sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board.bin?raw=true

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin
  https://github.com/kvalo/ath10k-
  firmware/blob/master/QCA6174/hw3.0/board-2.bin?raw=true

  sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin
  https://github.com/kvalo/ath10k-
  
firmware/blob/master/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

  Reboot or reload the ath10k_pci module and you should be able to
  connect!

  ---

  STATUS 2015-12-22:

  Currently there is a fix for this problem in post #22 (originally post
  #19, but reposted due to command typos!) which seems to have fixed the
  issue for many. This bug is unique to revision 32 of the card
  [168c:003e], fixes for older revisions don't seem to work.

  There are a couple of issues regarding the fix for some people (not
  all):

  1. Wireless works, but network throughput stops some time after
  connecting to access point

  2. Bluetooth communications take a noticeable performance hit when
  transferring something over WiFi

  ---

  Original description:

  I have recently installed Ubuntu 15.10 (64-bit) alongside Windows 10 on an 
Acer Aspire VN7-792G-76ZH and discovered, that the Qualcomm wireless card 
doesn't work in it or 16.04.
  The card has the device id 168c:003e as many other cards, for example the 
Qualcomm Atheros Killer 
(https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184), but it has a 
newer revision number (32) and the suggested fixes work only partially and the 
wireless is unusable.

  The computer has just been released this summer and is Intel Skylake
  -based.

  I've tried the patch from bug 1383184, which has a fix for the card revision 
20:
  Make the directory /lib/firmware/ath10k/QCA6174/hw3.0/ and put in the patch 
files:
  board.bin
  firmware-4.bin
  notice_ath10k_firmware-4.txt

  ath10k_pci succeeds in loading the firmware, but it seems that the
  firmware is not working correctly:

  dmesg | grep ath
  [5.452683] ath10k_pci :07:00.0: pci irq msi-x interrupts 8 irq_mode 0 
reset_mode 0
  [5.678420] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/cal-pci-:07:00.0.bin failed with error -2
  [5.678773] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/board-pci-168c:003e:11ad:0807.bin failed with error -2
  [5.678781] ath10k_pci :07:00.0: failed to load spec board file, 
falling back to generic: -2
  [5.679445] ath10k_pci :07:00.0: Direct firmware load for 
ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
  [5.679453] ath10k_pci :07:00.0: could not fetch firmware file 
'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
  [7.802316] ath10k_pci :07:00.0: qca6174 hw3.2 (0x0503, 
0x00340aff, 168c:003e:11ad:0807 fallback) fw WLAN.RM.2.0-00180-QCARMSWPZ-1 api 
4 htt 3.26 wmi 4 cal otp max_sta 32
  [7.802329] ath10k_pci :07:00.0: debug 0 debugfs 1 tracing 1 dfs 0 
testmode 0
  [8.200607] ath: EEPROM regdomain: 0x6c
  [8.200614] ath: EEPROM indicates we should expect a direct regpair map
  [8.200619] ath: Country alpha2 being used: 00
  [8.200621] ath: Regpair used: 0x6c
  [8.216605] ath10k_pci :07:00.0 wlp7s0: renamed from wlan0
  [   13.462029] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   16.461416] ath10k_pci :07:00.0: could not suspend target (-11)
  [   24.760062] ath10k_pci :07:00.0: failed to enable dynamic BW: -11
  [   27.759534] ath10k_pci :07:00.0: could not suspend target (-11)
  [   36.046205] ath10k_pci :07:00.0: failed to set arp ac override 
parameter: -11
  [   39.045729] ath10k_pci 

[Kernel-packages] [Bug 1557690] Re: s390/kconfig: CONFIG_NUMA without CONFIG_NUMA_EMU does not make any sense on s390x

2016-03-24 Thread Tim Gardner
Whoops, missed CONFIG_NUMA_BALANCING_DEFAULT_ENABLED. It will be set to
'n' for s390x in the next upload (linux 4.4.0-16.32)

** Changed in: linux (Ubuntu Xenial)
   Status: Fix Released => Fix Committed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1557690

Title:
  s390/kconfig: CONFIG_NUMA without CONFIG_NUMA_EMU does not make any
  sense on s390x

Status in linux package in Ubuntu:
  Fix Committed
Status in linux source package in Xenial:
  Fix Committed

Bug description:
  == Comment: #0 - Hendrik Brueckner - 2016-03-15 06:33:03 ==
  For NUMA, ensure the setting of these kernel configuration for s390x:

  # CONFIG_NUMA_BALANCING_DEFAULT_ENABLED is not set
  CONFIG_NUMA_EMU=y
  CONFIG_EMU_SIZE=0x1000

  
  CONFIG_NUMA without CONFIG_NUMA_EMU does not make any sense. s390 does not 
provide hardware topology information. However, we do support fake NUMA to 
improve performance issues seen with very large memory configurations. 
Therefore, CONFIG_NUMA_EMU has to be enabled.

  Given that we only support fake NUMA
  CONFIG_NUMA_BALANCING_DEFAULT_ENABLED should be disabled, since it
  moves pages without any benefit but costs additional cpu cycles.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1557690/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561492] [NEW] linux: sync virtualbox drivers to 5.0.16-dfsg-2

2016-03-24 Thread Andy Whitcroft
Public bug reported:

The virtualbox drivers have been updated, sync those into the kernel.

** Affects: linux (Ubuntu)
 Importance: High
 Assignee: Andy Whitcroft (apw)
 Status: In Progress

** Changed in: linux (Ubuntu)
   Status: New => In Progress

** Changed in: linux (Ubuntu)
   Importance: Undecided => High

** Changed in: linux (Ubuntu)
 Assignee: (unassigned) => Andy Whitcroft (apw)

** Changed in: linux (Ubuntu)
Milestone: None => ubuntu-16.03

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561492

Title:
  linux: sync virtualbox drivers to 5.0.16-dfsg-2

Status in linux package in Ubuntu:
  In Progress

Bug description:
  The virtualbox drivers have been updated, sync those into the kernel.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561492/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561483] Re: linux: sync to ZFS 0.6.5.6 stable release

2016-03-24 Thread Andy Whitcroft
** Changed in: linux (Ubuntu)
   Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561483

Title:
  linux: sync to ZFS 0.6.5.6 stable release

Status in linux package in Ubuntu:
  Fix Committed

Bug description:
  ZFS 0.6.5.6 is now out, so sync this from the spl and zfs packages to
  the kernel

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561483/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1550779] Re: [i915]] *ERROR* CPU pipe A FIFO underrun - Xorg glitches

2016-03-24 Thread Hubert Hesse
Can anyone confirm the steps I took where all right? 
What's the difference between the kernel I compiled and the officially 
distributed one (4.2.0-27)? Any patches to reproduce the official binary?

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1550779

Title:
  [i915]] *ERROR* CPU pipe A FIFO underrun - Xorg glitches

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Upgraded linux-image-extra-4.2.0-30-generic I see graphic glitches,
  looks like the graphic buffer gets screwed up

  - funny repetition's patterns  (back in time glitches)
  - black screen (<1sec)
  - graphic errors  

  I can influence the severity of the issue with switching windows and
  using certain programs, e.g. Google Maps in chrome causes this issue
  reproducibly

  dmesg  | grep i915
  [2.726864] [drm] Initialized i915 1.6.0 20150522 for :00:02.0 on 
minor 0
  [2.792005] [drm] GMBUS [i915 gmbus dpb] timed out, falling back to bit 
banging on pin 5
  [3.471092] i915 :00:02.0: fb0: inteldrmfb frame buffer device
  [3.471093] i915 :00:02.0: registered panic notifier
  [9.573129] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU 
pipe A FIFO underrun
  [9.574847] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* 
uncleared pch fifo underrun on pch transcoder A
  [9.574895] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH 
transcoder A FIFO underrun

  linux-image-extra-4.2.0-27-generic works find

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: xorg 1:7.7+7ubuntu4
  ProcVersionSignature: Ubuntu 4.2.0-30.36-generic 4.2.8-ckt3
  Uname: Linux 4.2.0-30-generic x86_64
  .tmp.unity.support.test.0:
   
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  BootLog:
   
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CurrentDesktop: GNOME
  Date: Sat Feb 27 20:26:07 2016
  DistUpgraded: Fresh install
  DistroCodename: wily
  DistroVariant: ubuntu
  DkmsStatus:
   virtualbox, 5.0.14, 4.2.0-27-generic, x86_64: installed
   virtualbox, 5.0.14, 4.2.0-30-generic, x86_64: installed
  EcryptfsInUse: Yes
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GraphicsCard:
   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics 
Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Lenovo Device [17aa:21da]
  InstallationDate: Installed on 2016-02-11 (15 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: LENOVO 42912XG
  ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-4.2.0-30-generic 
root=UUID=cb34d7bb-9316-49b3-aa94-4e2a3512168f ro rootflags=subvol=@ noprompt 
quiet
  SourcePackage: xorg
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/18/2013
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 8DET69WW (1.39 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 42912XG
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr8DET69WW(1.39):bd07/18/2013:svnLENOVO:pn42912XG:pvrThinkPadX220:rvnLENOVO:rn42912XG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 42912XG
  dmi.product.version: ThinkPad X220
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:0.9.12.2+15.10.20151202-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.64-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
  version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 
1:7.5.0+git20150819-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20150808-0ubuntu4
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.11-1ubuntu3
  xserver.bootTime: Sat Feb 27 20:25:23 2016
  xserver.configfile: default
  xserver.errors:
   
  xserver.logfile: /var/log/Xorg.0.log
  xserver.outputs:
   product id   12359 
   vendor SEC
  xserver.version: 2:1.17.2-1ubuntu9.1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1550779/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561483] Re: linux: sync to ZFS 0.6.5.6 stable release

2016-03-24 Thread Andy Whitcroft
** Summary changed:

- Sync ZFS 0.6.5.6 into kernel
+ linux: sync to ZFS 0.6.5.6 stable release

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561483

Title:
  linux: sync to ZFS 0.6.5.6 stable release

Status in linux package in Ubuntu:
  In Progress

Bug description:
  ZFS 0.6.5.6 is now out, so sync this from the spl and zfs packages to
  the kernel

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561483/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561483] [NEW] linux: sync to ZFS 0.6.5.6 stable release

2016-03-24 Thread Colin Ian King
Public bug reported:

ZFS 0.6.5.6 is now out, so sync this from the spl and zfs packages to
the kernel

** Affects: linux (Ubuntu)
 Importance: Medium
 Assignee: Colin Ian King (colin-king)
 Status: In Progress

** Changed in: linux (Ubuntu)
   Status: New => In Progress

** Changed in: linux (Ubuntu)
   Importance: Undecided => Medium

** Changed in: linux (Ubuntu)
 Assignee: (unassigned) => Colin Ian King (colin-king)

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561483

Title:
  linux: sync to ZFS 0.6.5.6 stable release

Status in linux package in Ubuntu:
  In Progress

Bug description:
  ZFS 0.6.5.6 is now out, so sync this from the spl and zfs packages to
  the kernel

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561483/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561474] Status changed to Confirmed

2016-03-24 Thread Brad Figg
This change was made by a bot.

** Changed in: linux (Ubuntu)
   Status: New => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561474

Title:
  Bluetooth will be disable after reusme from suspend on Xenial

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  CID: 201208-11536 Dell Latitude 6430u

  The Bluetooth will be disabled after resume from suspend.
  You will need to use "hciconfig hci0 reset" to enable it.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-15-generic 4.4.0-15.31
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1202 F pulseaudio
  CurrentDesktop: Unity
  Date: Thu Mar 24 19:14:07 2016
  HibernationDevice: RESUME=UUID=25c03762-079c-4c6d-aedb-ec768318a6bf
  InstallationDate: Installed on 2016-03-24 (0 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151209)
  MachineType: Dell Inc. Latitude 6430U
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic 
root=UUID=18cfda3e-4f3d-40cf-8e7e-a83030819487 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/15/2012
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A02
  dmi.board.asset.tag: 1234567
  dmi.board.name: 0MN74V
  dmi.board.vendor: Dell Inc.
  dmi.board.version: X01
  dmi.chassis.asset.tag: 1234567
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA02:bd11/15/2012:svnDellInc.:pnLatitude6430U:pvr01:rvnDellInc.:rn0MN74V:rvrX01:cvnDellInc.:ct9:cvr:
  dmi.product.name: Latitude 6430U
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561474/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561474] [NEW] Bluetooth will be disable after reusme from suspend on Xenial

2016-03-24 Thread Po-Hsu Lin
Public bug reported:

CID: 201208-11536 Dell Latitude 6430u

The Bluetooth will be disabled after resume from suspend.
You will need to use "hciconfig hci0 reset" to enable it.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-15-generic 4.4.0-15.31
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USERPID ACCESS COMMAND
 /dev/snd/controlC0:  ubuntu 1202 F pulseaudio
CurrentDesktop: Unity
Date: Thu Mar 24 19:14:07 2016
HibernationDevice: RESUME=UUID=25c03762-079c-4c6d-aedb-ec768318a6bf
InstallationDate: Installed on 2016-03-24 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151209)
MachineType: Dell Inc. Latitude 6430U
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic 
root=UUID=18cfda3e-4f3d-40cf-8e7e-a83030819487 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-15-generic N/A
 linux-backports-modules-4.4.0-15-generic  N/A
 linux-firmware1.157
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/15/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.asset.tag: 1234567
dmi.board.name: 0MN74V
dmi.board.vendor: Dell Inc.
dmi.board.version: X01
dmi.chassis.asset.tag: 1234567
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: 
dmi:bvnDellInc.:bvrA02:bd11/15/2012:svnDellInc.:pnLatitude6430U:pvr01:rvnDellInc.:rn0MN74V:rvrX01:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude 6430U
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

** Affects: linux (Ubuntu)
 Importance: Undecided
 Status: New


** Tags: 201208-11536 amd64 apport-bug taipei-lab xenial

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1561474

Title:
  Bluetooth will be disable after reusme from suspend on Xenial

Status in linux package in Ubuntu:
  New

Bug description:
  CID: 201208-11536 Dell Latitude 6430u

  The Bluetooth will be disabled after resume from suspend.
  You will need to use "hciconfig hci0 reset" to enable it.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-15-generic 4.4.0-15.31
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ubuntu 1202 F pulseaudio
  CurrentDesktop: Unity
  Date: Thu Mar 24 19:14:07 2016
  HibernationDevice: RESUME=UUID=25c03762-079c-4c6d-aedb-ec768318a6bf
  InstallationDate: Installed on 2016-03-24 (0 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151209)
  MachineType: Dell Inc. Latitude 6430U
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic 
root=UUID=18cfda3e-4f3d-40cf-8e7e-a83030819487 ro quiet splash vt.handoff=7
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/15/2012
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A02
  dmi.board.asset.tag: 1234567
  dmi.board.name: 0MN74V
  dmi.board.vendor: Dell Inc.
  dmi.board.version: X01
  dmi.chassis.asset.tag: 1234567
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: 
dmi:bvnDellInc.:bvrA02:bd11/15/2012:svnDellInc.:pnLatitude6430U:pvr01:rvnDellInc.:rn0MN74V:rvrX01:cvnDellInc.:ct9:cvr:
  dmi.product.name: Latitude 6430U
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1561474/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1560247] Re: [SAMSUNG ELECTRONICS CO., LTD. 305V4A/305V5A/3415VA] suspend/resume failure

2016-03-24 Thread Maxim Baskakov
This issue started happening since upgrading from 4.4.0-11 kernel to
4.4.0-12 from main repo and so on to 4.4.0-15. While tested v.4.5, the
bug still exists.

[b]tags[/b]: kernel-bug-exists-upstream

** Changed in: linux (Ubuntu)
   Status: Incomplete => Confirmed

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1560247

Title:
  [SAMSUNG ELECTRONICS CO., LTD. 305V4A/305V5A/3415VA] suspend/resume
  failure

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  Don't wake up after gibernation

  ProblemType: KernelOops
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-15-generic 4.4.0-15.31
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  Annotation: This occurred during a previous suspend, and prevented the system 
from resuming properly.
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC1:  ksaver11520 F pulseaudio
   /dev/snd/controlC0:  ksaver11520 F pulseaudio
  Date: Tue Mar 22 02:07:51 2016
  DuplicateSignature: suspend/resume:SAMSUNG ELECTRONICS CO., LTD. 
305V4A/305V5A/3415VA:09PW.ME13.20121101.SKK
  ExecutablePath: /usr/share/apport/apportcheckresume
  Failure: suspend/resume
  HibernationDevice: RESUME=UUID=b782452f-51f9-40a8-bc11-9d17250476d5
  InstallationDate: Installed on 2014-09-11 (557 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140905)
  InterpreterPath: /usr/bin/python3.5
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 305V4A/305V5A/3415VA
  ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
  ProcEnviron:
   PATH=(custom, no user)
   LANG=ru_RU.UTF-8
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic 
root=UUID=1d3eb423-3f2f-4529-a70d-6e8c0e028ce6 ro noplymouth ipv6.disable=1
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware1.157
  SourcePackage: linux
  Title: [SAMSUNG ELECTRONICS CO., LTD. 305V4A/305V5A/3415VA] suspend/resume 
failure
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: lp
  dmi.bios.date: 11/01/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 09PW.ME13.20121101.SKK
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: 305V4A/305V4A
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: 09PW
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: N/A
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr09PW.ME13.20121101.SKK:bd11/01/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn305V4A/305V5A/3415VA:pvr09PW:rvnSAMSUNGELECTRONICSCO.,LTD.:rn305V4A/305V4A:rvr09PW:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
  dmi.product.name: 305V4A/305V5A/3415VA
  dmi.product.version: 09PW
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1560247/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 900384] Re: usbipd requires usbip_common_mod.ko and usbip.ko kernel modules, which are not available in any package

2016-03-24 Thread Torsten
found this on usbip.sourceforge.net:

Download

For Linux, the source code of usbip was merged into the staging tree,
and finally has been moved to the mainline since Linux-3.17. Development
is ongoing in the kernel community, not here. Linux distributions will
provide binary packages of usbip. Just for historical records, the
project page keeps old download files of the Linux version. Do not use
them.

However, in newest kernel it don't work (4.4.0-12 / lubuntu 16.04) even if i 
can find:
./lib/modules/4.4.0-12-generic/kernel/drivers/usb/usbip
./lib/modules/4.4.0-12-generic/kernel/drivers/usb/usbip/usbip-host.ko
./lib/modules/4.4.0-12-generic/kernel/drivers/usb/usbip/usbip-core.ko

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/900384

Title:
  usbipd requires usbip_common_mod.ko and usbip.ko kernel modules, which
  are not available in any package

Status in linux package in Ubuntu:
  Fix Released
Status in usbip package in Ubuntu:
  Fix Released

Bug description:
  I'm on Kubuntu oneiric (11.10), using usbip 0.1.7-3 and kernel linux-
  image-3.0.0-13-generic.

  I'm trying to set up USB/IP to share a USB-only printer/scanner over
  the LAN. However, whenever I try to start the demon, it gives the
  error message that the usbip_common_mod.ko and usbip.ko kernel modules
  are required:

  root@curie:~# usbipd -D
  usbip err: stub_driver.c:  33 (open_sysfs_stub_driver) usbip_common_mod.ko 
and usbip.ko must be loaded
  ** ERROR **: driver open failed
  Trace/breakpoint trap

  The package description of usbip says:
  " USB/IP requires kernel support which is included in Linux
   kernels 2.6.28 or newer."

  Unfortunately, I can't find a package that provides those kernel
  module.

  I have also installed the usbip-source package, but
  (1) its /usr/src/modules/usbip/src/README file says:
  "For newer kernels ( >=2.6.28 ), try linux-staging code!"
  and (2) trying to build it with m-a also fails:

  # Build the module
  cd src && /usr/bin/make KSOURCE=/usr/src/linux 
HCD_HEADER=/usr/src/modules/usbip/src/headers/hcd.h KBUILD_VERBOSE=0
  make[2]: Entering directory `/usr/src/modules/usbip/src'
  make -C /usr/src/linux LANG=C KBUILD_VERBOSE=0  M=`pwd` modules
  make[3]: Entering directory `/usr/src/linux-headers-3.0.0-13-generic'
    CC [M]  /usr/src/modules/usbip/src/stub_dev.o
  /usr/src/modules/usbip/src/stub_dev.c: In function ‘stub_probe’:
  /usr/src/modules/usbip/src/stub_dev.c:392:42: error: ‘struct device’ has no 
member named ‘bus_id’
  make[4]: *** [/usr/src/modules/usbip/src/stub_dev.o] Error 1
  make[3]: *** [_module_/usr/src/modules/usbip/src] Error 2
  make[3]: Leaving directory `/usr/src/linux-headers-3.0.0-13-generic'
  make[2]: *** [default] Error 2
  make[2]: Leaving directory `/usr/src/modules/usbip/src'
  make[1]: *** [binary-modules] Error 2
  make[1]: Leaving directory `/usr/src/modules/usbip'
  make: *** [kdist_build] Error 2
  BUILD FAILED!
  See /var/cache/modass/usbip.buildlog.3.0.0-13-generic.1323105464 for details.
  Build failed. Press Return to continue...

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/900384/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1559725] Re: Security bug of overlayfs in linux image kernel

2016-03-24 Thread Cui Wei
Thanks for the explaination!

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1559725

Title:
  Security bug of overlayfs in linux image kernel

Status in linux package in Ubuntu:
  Invalid

Bug description:
  sudo bash

  mkdir -p lower/a upper work merge

  touch lower/a/{1,2,3,4}

  mount -t overlay overlay -olowerdir=lower,upperdir=upper,workdir=work
  merge/   # In "merge/a", there should be "1,2,3,4"

  rm -rf merge/a  # Delete all files in "merge/a" as well as
  folder itself

  mkdir merge/a  # In "merge/a", there should be no files

  touch merge/a/5  # In "merge/a", there should be only one file "5"

  umount -l merge/

  tar czvf layer.tgz upper/  # Store this layer

  rm -rf upper/   # remove folder, assume we want to reconstruct
  merge folder by this layer on another machine

  tar xzvf layer.tgz  # Restore layer data

  mount -t overlay overlay -olowerdir=lower,upperdir=upper,workdir=work
  merge/   # Oops, why "1,2,3,4" exist in "merge/a" ?

  ---

  Wrong exposure of "1,2,3,4" might cause:

  1) applications to crash (such as reading
  "/etc/apt/sources.d/{1,2,..}")

  2) "1,2,3,4" might be dangerous virus which are supposed to be cleaned
  but exposure

  ---

  Aufs doesn't have this bug.

  If we change "mount -t overlay overlay
  -olowerdir=lower,upperdir=upper,workdir=work merge/" above into ->

  "mount -t aufs -o br=upper=rw:lower=ro+wh none merge/",

  and all of other commands don't change, then the final result in
  "merge/a/" are what we supposed to be.

  ---

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-generic 4.4.0.13.14
  ProcVersionSignature: Ubuntu 4.4.0-13.29-generic 4.4.5
  Uname: Linux 4.4.0-13-generic x86_64
  NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 
k4.4.0-13-generic.
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ghostplant   2995 F pulseaudio
   /dev/snd/controlC1:  ghostplant   2995 F pulseaudio
  CurrentDesktop: GNOME-Flashback:Unity
  Date: Sun Mar 20 22:56:55 2016
  JournalErrors:
   Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] 
failed with exit code 1: Hint: You are currently not seeing messages from other 
users and the system.
     Users in the 'systemd-journal' group can see all messages. Pass -q to
     turn off this notice.
   No journal files were opened due to insufficient permissions.
  MachineType: Micro-Star International Co., Ltd. GE60 2PG
  PciMultimedia:

  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-13-generic 
root=UUID=f584608e-f90a-445b-b845-cf3eb246a0d1 ro quiet swapaccount=1
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-13-generic N/A
   linux-backports-modules-4.4.0-13-generic  N/A
   linux-firmware1.156
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  WifiSyslog:

  dmi.bios.date: 12/01/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: E16GFIMS.626
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: MS-16GF
  dmi.board.vendor: Micro-Star International Co., Ltd.
  dmi.board.version: REV:0.B
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrE16GFIMS.626:bd12/01/2014:svnMicro-StarInternationalCo.,Ltd.:pnGE602PG:pvrREV1.0:rvnMicro-StarInternationalCo.,Ltd.:rnMS-16GF:rvrREV0.B:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: GE60 2PG
  dmi.product.version: REV:1.0
  dmi.sys.vendor: Micro-Star International Co., Ltd.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1559725/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1548581] Re: using wacom tablet crashes the whole system in 16.04

2016-03-24 Thread Chris
** Changed in: linux-firmware (Ubuntu)
   Status: Incomplete => New

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-firmware in Ubuntu.
https://bugs.launchpad.net/bugs/1548581

Title:
  using wacom tablet crashes the whole system in 16.04

Status in linux-firmware package in Ubuntu:
  New

Bug description:
  Just tried the daily build and - as I expected, because I tried many
  times - if I try to use my Wacom tablet, the whole system freezes.

  I'm not sure what it is, maybe it gets a kernel panic or it's because
  X.org, but I can't even restart the session, just if I turn off my
  laptop by pressing the power button for seconds, because after trying
  to use the graphics tablet, even the mouse and keyboard are frozen. I
  reproduced this many times and I got the same results every single
  time. But this doesn't even need to be in a drawing software. If I
  move the pen over the tablet the whole system crashes.

  Of course, if I pull it out and after restart I use Ubuntu without it,
  then everything is normal, but in my opinion this is a heavily serious
  issue, considering that we are talking about an LTS release, which has
  to mean rock-solid stability over non-LTS distros. Now I'm in Linux
  Mint, because this happens since 15.10 and Mint is the only Linux
  distribution which has full support for my graphics and art project
  workflow. Whatever they do, it just works, but Ubuntu is seriously
  unstable these days.

  Here are my outputs:
  Linux CNB-NoteBook-Pro 4.4.0-11-generic #26-Ubuntu SMP Sat Mar 5 14:25:21 UTC 
2016 x86_64 x86_64 x86_64 GNU/Linux

  Ubuntu 4.4.0-11.26-generic 4.4.4

  dmesg.log -> http://pastebin.com/WjLQpbvk
  lspci-vvnn.log -> http://pastebin.com/6aYymGAG

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1548581/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561414] [NEW] CVE-2016-2188

2016-03-24 Thread Steve Beattie
*** This bug is a security vulnerability ***

Public security bug reported:

Kernel panic on invalid USB device descriptor (iowarrior driver)

Break-Fix: - 4ec0ef3a82125efc36173062a50624550a900ae0

** Affects: linux (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-flo (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-goldfish (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-lts-quantal (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-mako (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-manta (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-raspi2 (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-ti-omap4 (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-flo (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-lts-utopic (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-mako (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-manta (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-flo (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-vivid (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-wily (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-xenial (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-mako (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-manta (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-armadaxp (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-flo (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-goldfish (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-quantal (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-raring (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-saucy (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-trusty (Ubuntu 

[Kernel-packages] [Bug 1561414] Re: CVE-2016-2188

2016-03-24 Thread Steve Beattie
CVE-2016-2188

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-manta (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-mako (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-goldfish (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-flo (Ubuntu Precise)
   Status: New => Invalid

** Description changed:

- Placeholder
+ Kernel panic on invalid USB device descriptor (iowarrior driver)
+ 
+ Break-Fix: - 4ec0ef3a82125efc36173062a50624550a900ae0

** Changed in: linux-lts-trusty (Ubuntu Precise)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Precise)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Wily)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Trusty)
   Importance: Undecided => Low

** Changed in: linux-lts-quantal (Ubuntu Precise)
   

[Kernel-packages] [Bug 1561411] [NEW] CVE-2016-2186

2016-03-24 Thread Steve Beattie
*** This bug is a security vulnerability ***

Public security bug reported:

Kernel panic on invalid USB device descriptor (powermate driver)

Break-Fix: - 9c6ba456711687b794dcf285856fc14e2c76074f

** Affects: linux (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-flo (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-goldfish (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-lts-quantal (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-mako (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-manta (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-raspi2 (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-ti-omap4 (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-flo (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-lts-utopic (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-mako (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-manta (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-flo (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-vivid (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-wily (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-xenial (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-mako (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-manta (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-armadaxp (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-flo (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-goldfish (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-quantal (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-raring (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-saucy (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-trusty (Ubuntu 

[Kernel-packages] [Bug 1558252] Re: Intel 8260 / iwlwifi Occasionally unusuable after restart

2016-03-24 Thread Marv
I am on Debian Testing and have the same problem with kernels 4.3 and
4.4 (Debian one's) as well as 4.5 (compiled from unmodified source with
Debian config). Sometimes I have to reboot around 10 times to get a
connected with NetworkManager, although the device seems to be available
through iwconfig.

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1558252

Title:
  Intel 8260 / iwlwifi Occasionally unusuable after restart

Status in linux package in Ubuntu:
  Incomplete

Bug description:
  Hello,
  Some times my wifi card is inaccessible immediately after boot. Typically, 
restarting the machine or reloading the iwlwifi kernel module resolves the 
issue.

  dmesg on inaccessible card:

  [   13.146917] iwlwifi :04:00.0: Unsupported splx structure
  [   13.147620] iwlwifi :04:00.0: Direct firmware load for 
iwlwifi-8000C-19.ucode failed with error -2
  [   13.147754] iwlwifi :04:00.0: Direct firmware load for 
iwlwifi-8000C-18.ucode failed with error -2
  [   13.147765] iwlwifi :04:00.0: Direct firmware load for 
iwlwifi-8000C-17.ucode failed with error -2
  [   13.154952] iwlwifi :04:00.0: loaded firmware version 16.242414.0 
op_mode iwlmvm
  [   13.191912] iwlwifi :04:00.0: Detected Intel(R) Dual Band Wireless AC 
8260, REV=0x208
  [   13.198415] iwlwifi :04:00.0: L1 Enabled - LTR Enabled
  [   13.199446] iwlwifi :04:00.0: L1 Enabled - LTR Enabled
  [   13.200661] iwlwifi :04:00.0: can't access the RSA semaphore it is 
write protected
  [   14.218185] iwlwifi :04:00.0: SecBoot CPU1 Status: 0x3090003, CPU2 
Status: 0x0
  [   14.218190] iwlwifi :04:00.0: Failed to start INIT ucode: -110
  [   14.219090] iwlwifi :04:00.0: Failed to run INIT ucode: -110
  [   14.219157] iwlwifi :04:00.0: L1 Enabled - LTR Enabled

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-13-generic 4.4.0-13.29
  ProcVersionSignature: Ubuntu 4.4.0-13.29-generic 4.4.5
  Uname: Linux 4.4.0-13-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse:
   USERPID ACCESS COMMAND
   /dev/snd/controlC0:  ryan   1999 F pulseaudio
  Date: Wed Mar 16 12:00:48 2016
  HibernationDevice: RESUME=UUID=04e04e17-3976-4daa-a1dd-2dd369aee83d
  InstallationDate: Installed on 2015-09-21 (176 days ago)
  InstallationMedia: It
  IwConfig:
   enp0s31f6  no wireless extensions.
   
   lono wireless extensions.
  Lsusb:
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 20FNCTO1WW
  ProcEnviron:
   TERM=xterm
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-13-generic 
root=/dev/mapper/it--vg-root ro quiet intel_pstate=no_hwp
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
  RelatedPackageVersions:
   linux-restricted-modules-4.4.0-13-generic N/A
   linux-backports-modules-4.4.0-13-generic  N/A
   linux-firmware1.156
  RfKill:
   0: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: yes
Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-02-24 (20 days ago)
  dmi.bios.date: 01/05/2016
  dmi.bios.vendor: LENOVO
  dmi.bios.version: R06ET33W (1.07 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20FNCTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40697 WIN
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: None
  dmi.modalias: 
dmi:bvnLENOVO:bvrR06ET33W(1.07):bd01/05/2016:svnLENOVO:pn20FNCTO1WW:pvrThinkPadT460:rvnLENOVO:rn20FNCTO1WW:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
  dmi.product.name: 20FNCTO1WW
  dmi.product.version: ThinkPad T460
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1558252/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp


[Kernel-packages] [Bug 1561411] Re: CVE-2016-2186

2016-03-24 Thread Steve Beattie
CVE-2016-2186

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-manta (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-mako (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-goldfish (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-flo (Ubuntu Precise)
   Status: New => Invalid

** Description changed:

- Placeholder
+ Kernel panic on invalid USB device descriptor (powermate driver)
+ 
+ Break-Fix: - 9c6ba456711687b794dcf285856fc14e2c76074f

** Changed in: linux-lts-trusty (Ubuntu Precise)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Precise)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Wily)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Trusty)
   Importance: Undecided => Low

** Changed in: linux-lts-quantal (Ubuntu Precise)
   

[Kernel-packages] [Bug 1561410] [NEW] CVE-2016-2185

2016-03-24 Thread Steve Beattie
*** This bug is a security vulnerability ***

Public security bug reported:

Kernel panic on invalid USB device descriptor (ati_remote2 driver)

** Affects: linux (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-flo (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-goldfish (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-lts-quantal (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-mako (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-manta (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-raspi2 (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-ti-omap4 (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-flo (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-lts-utopic (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-mako (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-manta (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-flo (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-vivid (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-wily (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-xenial (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-mako (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-manta (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-armadaxp (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-flo (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-goldfish (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-quantal (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-raring (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-saucy (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-trusty (Ubuntu Vivid)
 Importance: Undecided
 Status: 

[Kernel-packages] [Bug 1561410] Re: CVE-2016-2185

2016-03-24 Thread Steve Beattie
CVE-2016-2185

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-manta (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-mako (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-goldfish (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-flo (Ubuntu Precise)
   Status: New => Invalid

** Description changed:

- Placeholder
+ Kernel panic on invalid USB device descriptor (ati_remote2 driver)

** Changed in: linux-lts-trusty (Ubuntu Precise)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Precise)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Wily)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Trusty)
   Importance: Undecided => Low

** Changed in: linux-lts-quantal (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-quantal 

[Kernel-packages] [Bug 1556562] Re: VIA C7-D machine "kernel NULL pointer dereference" in skcipher_recvmsg_async

2016-03-24 Thread Jeffrey Walton
Kamal - the updated kernel files cleared the issue. Thank you so much.

Dmesg shows only the following, which I believe is expected when
creating a socket with "AF_ALG" domain:

[  806.458783] NET: Registered protocol family 38

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1556562

Title:
  VIA C7-D machine "kernel NULL pointer dereference" in
  skcipher_recvmsg_async

Status in linux package in Ubuntu:
  Confirmed
Status in linux source package in Wily:
  In Progress

Bug description:
  I'm working on an Lubuntu 15 machine. It was chosen because it
  supports VIA C7-D processor and the VIA PM400 chipset without crashing
  (also see ). Lubuntu 15 uses the 4.2 kernel:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:Ubuntu 15.10
Release:15.10
Codename:   wily

  And:

$ uname -a
Linux via 4.2.0-30-generic #36-Ubuntu SMP Fri Feb 26 00:57:19 UTC 2016 i686 
i686 i686 GNU/Linux

  When running a particular program (details below), it hangs in syscall
  248 and results in the following dmesg/syslog output. The process
  cannot be killed, the machine does not respond to a 'shutdown -r now',
  and the machine requires a hard reset.

  ...
  [ 4505.429577] BUG: unable to handle kernel NULL pointer dereference at 
0008
  [ 4505.429593] IP: [] skcipher_recvmsg_async.isra.13+0x4b2/0x500 
[algif_skcipher]
  [ 4505.429607] *pdpt = 34ee3001 *pde =  
  [ 4505.429614] Oops:  [#3] SMP 
  [ 4505.429621] Modules linked in: jitterentropy_rng drbg ansi_cprng 
algif_skcipher af_alg snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel 
snd_hda_codec snd_hda_core snd_hwdep snd_pcm snd_seq_midi snd_seq_midi_event 
snd_rawmidi padlock_sha snd_seq padlock_aes snd_seq_device via_cputemp 
snd_timer hwmon_vid via_rng snd input_leds serio_raw soundcore i2c_viapro 
shpchp 8250_fintek mac_hid parport_pc ppdev lp parport autofs4 pata_acpi 
hid_generic usbhid hid psmouse r8169 pata_via sata_via mii
  [ 4505.429689] CPU: 0 PID: 1532 Comm: afalgtest Tainted: G  D 
4.2.0-30-generic #36-Ubuntu
  [ 4505.429695] Hardware name: To Be Filled By O.E.M. To Be Filled By 
O.E.M./Weibu, BIOS 080014  11/17/2011
  [ 4505.429700] task: f4e0e040 ti: f4e3c000 task.ti: f4e3c000
  [ 4505.429705] EIP: 0060:[] EFLAGS: 00010202 CPU: 0
  [ 4505.429712] EIP is at skcipher_recvmsg_async.isra.13+0x4b2/0x500 
[algif_skcipher]
  [ 4505.429717] EAX: f3f97c00 EBX: f3f3ee00 ECX: f3f97c00 EDX: 
  [ 4505.429722] ESI: f3f3ee00 EDI: 0ff0 EBP: f4e3ddc8 ESP: f4e3dd70
  [ 4505.429726]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
  [ 4505.429731] CR0: 80050033 CR2: 0008 CR3: 3247a520 CR4: 06b0
  [ 4505.429735] Stack:
  [ 4505.429738]  f3f97df4 f3f97c00 f3f97de0  f3f97c04 0020 
f4e3dd00 0018
  [ 4505.429750]  1ff0 f3fb4400 f3f97c04 0ff0 f4e3de40 f3f97de8 
f4e3de38 f3fa
  [ 4505.429761]  0002 0002 f3f97c00 f1f58180 c1210510 f4e3de38 
f4e3ddf4 f8a6cd6b
  [ 4505.429772] Call Trace:
  [ 4505.429788]  [] ? free_ioctx_users+0xa0/0xa0
  [ 4505.429795]  [] skcipher_recvmsg+0x2b/0x1f0 [algif_skcipher]
  [ 4505.429803]  [] ? skcipher_check_key.isra.8+0x2a/0xb0 
[algif_skcipher]
  [ 4505.429810]  [] skcipher_recvmsg_nokey+0x31/0x40 [algif_skcipher]
  [ 4505.429820]  [] sock_recvmsg+0x3d/0x50
  [ 4505.429826]  [] sock_read_iter+0x84/0xd0
  [ 4505.429833]  [] ? sock_recvmsg+0x50/0x50
  [ 4505.429839]  [] aio_run_iocb+0x110/0x2c0
  [ 4505.429846]  [] ? sock_recvmsg+0x50/0x50
  [ 4505.429854]  [] ? error_code+0x67/0x6c
  [ 4505.429865]  [] ? kmem_cache_alloc+0x1b4/0x1e0
  [ 4505.429875]  [] ? __fdget+0x12/0x20
  [ 4505.429881]  [] do_io_submit+0x1ef/0x4a0
  [ 4505.429893]  [] ? security_file_alloc+0x2f/0x50
  [ 4505.429900]  [] SyS_io_submit+0x20/0x30
  [ 4505.429911]  [] sysenter_do_call+0x12/0x12
  [ 4505.429915] Code: 00 00 00 75 24 8b 45 ac ff 52 0c 89 c7 83 ff 8d 75 8f 8b 
45 e4 3e ff 80 fc 01 00 00 bf ef fd ff ff e9 62 fc ff ff 8d 76 00 89 c8  52 
08 89 c7 eb db 8b 45 e4 31 d2 8b 80 20 02 00 00 8b 58 1c
  [ 4505.429982] EIP: [] skcipher_recvmsg_async.isra.13+0x4b2/0x500 
[algif_skcipher] SS:ESP 0068:f4e3dd70
  [ 4505.429991] CR2: 0008
  [ 4505.429997] ---[ end trace 3cce7cc6be0ad960 ]---

  **

  The process details is this is a failed self test for the upcoming
  OpenSSL 1.1.0. The OpenSSL RT bug report for this issue is at
  http://rt.openssl.org/Ticket/Display.html?id=4411. Two attempts to
  debug it resulted in two hung processes:

  $ ps -A | grep afalgtest
  1030 pts/000:00:00 afalgtest
  1196 pts/000:00:00 afalgtest

  And:

  via:test$ sudo cat /proc/1030/syscall 
  248 0xb7fd6000 0x1 0xbfff98d4 0xb7fb9270 0xbfff98e0 0xb7ec45f7 0xbfff986c 
0xb7fdbbe8
  via:test$ sudo cat /proc/1196/syscall 
  248 0xb7fd6000 0x1 0xbfff98d4 0xb7fb9270 0xbfff98e0 0xb7ec45f7 

[Kernel-packages] [Bug 1561409] Re: CVE-2016-2184

2016-03-24 Thread Steve Beattie
CVE-2016-2184

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-manta (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-mako (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-goldfish (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-flo (Ubuntu Precise)
   Status: New => Invalid

** Description changed:

- Placeholder
+ Kernel panic on invalid USB device descriptor (snd_usb_audio driver)
+ 
+ Break-Fix: - 0f886ca12765d20124bd06291c82951fd49a33be
+ Break-Fix: - 447d6275f0c21f6cc97a88b3a0c601436a4cdf2a

** Changed in: linux-lts-trusty (Ubuntu Precise)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Importance: Undecided => Low

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Precise)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Wily)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Importance: Undecided => Low

** Changed in: linux-lts-wily (Ubuntu Trusty)
   Importance: Undecided => Low


[Kernel-packages] [Bug 1554003] Re: xenial kernel crash on HP BL460c G7 (qla24xx problem?)

2016-03-24 Thread Attila Zsiros
same, good!

-- 
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.
https://bugs.launchpad.net/bugs/1554003

Title:
  xenial kernel crash on HP BL460c G7 (qla24xx problem?)

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  Dear Members,

  Latest Xenial kernel (linux-image-generic-4.4.0-8-generic) is crash on
  booting. Same problem with 4.4.0-9 and 4.4.0-10.

  
  [1.654419] qla2xxx [:06:00.1]-0034:3: MSI-X: Unsupported ISP 
  2432 SSVID/SSDID (0x103C,0x1705).
  [1.685273] hid-generic 0003:03F0:7029.0001: in
  [1.685273] hid-generic 0003:03F0:7029.0001: input,hidraw0: USB HID 
  v1.01 Keyboard [HP  Virtual Keyboard ] on usb-:01:00.4-1/input0
  [1.685455] input: HP  Virtual Keyboard  as 
  
/devices/pci:00/:00:1c.4/:01:00.4/usb6/6-1/6-1:1.1/0003:03F0:7029.0002/input/inpu
 
  1048576 bytes) :0
  1:00.4/usb6/6-1/6-1:1.1/0003:03F0:7029.0002/input/inpu
  [2.001109] CR2: 0050
  [2.001170] ---
  [ end trace 20a247b9d60f8e00 ]---
  [2.001232] Kernel panic - not syncing: Fatal exception in interrup
  [2.001232] Kernel panic - not syncing: Fatal exception in interrupt
  [2.001813] Kernel Offset: disabled
  [2.001873] ---
  [ end Kernel panic - not syncing: Fatal exception in interrupt
  [1.997314]  [] do_IRQ+0x4b/0xd0
  [1.997379]  [] common_interrupt+0x82/0x82
  [1.997441]  
  [1.997336] hpsa :0c:00.0: scsi 1:3:0:0: added RAID  HP
  [1.997491]  [] ? cpuidle_enter_state+0x12d/0x270
  [1.997609]  [] cpuidle_enter+0x17/0x20
  [1.997674]  [] call_cpuidle+0x32/0x60
  [1.997737]  [] ? cpuidle_select+0x13/0x20
  [1.997800]  [] cpu_startup_entry+0x266/0x320
  [1.997866]  [] rest_init+0x7c/0x80
  [1.997930]  [] start_kernel+0x481/0x4a2
  [1.997994]  [] ? early_idt_handler_array+0x120/0x120
  [1.998058]  [] x86_64_start_reservations+0x2a/0x2c
  [1.998123]  [] x86
  [1.998123]  [] x86_64_start_kernel+0x14a/0x16d
  [1.998186] Code: 00 48 89 45 d0 31 c0 48 8b 47 58 a8 02 0f 84 cf 00 
  00 00 48 8b 46 50 49 89 fd 49 89 f4 65 8b 15 06 34 e7 3f 4c 8b b7 10 02 
  00 00 <39> 50 50 74 11
89 50 50 48 8b 46 50 8b 40 50 41 89 86 58 8put,hidraw0: USB HID v1.01 
  Key 74 11 89 50 50 48 8b 46 50 8b 40 50 41 89 86 58 8b 00
  [2.000922] RIP  [] 
  qla24xx_process_response_queue+0x49/0x4a0 [qla2xxx]
  [2.001050]  RSP 
  hpiLO-> exit

  Best regards Attila
  --- 
  AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 
2: ls: cannot access '/dev/snd/': No such file or directory
  AplayDevices: Error: [Errno 2] No such file or directory
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp3', '/dev/dsp1', 
'/dev/dsp2', '/dev/dsp', '/dev/sequencer'] failed with exit code 1:
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-02-03 (32 days ago)
  InstallationMedia: Ubuntu-Server 14.04.3 LTS "Trusty Tahr" - Beta amd64 
(20150805)
  MachineType: HP ProLiant BL460c G7
  NonfreeKernelModules: raid10 raid456 async_raid6_recov async_memcpy async_pq 
async_xor async_tx xor raid6_pq raid1 raid0 multipath linear be2iscsi qla2xxx 
iscsi_boot_sysfs libiscsi ipmi_si hpsa scsi_transport_fc scsi_transport_iscsi 
ipmi_msghandler 8021q garp stp mrp llc ghash_clmulni_intel hid_generic be2net 
aesni_intel aes_x86_64 ablk_helper usbhid cryptd lrw vxlan gf128mul 
ip6_udp_tunnel glue_helper usb_storage hid udp_tunnel
  Package: linux (not installed)
  PciMultimedia:
   
  ProcEnviron:
   LANGUAGE=en_US:en
   TERM=bterm
   PATH=(custom, no user)
   LANG=C.UTF-8
   SHELL=/bin/sh
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=linux priority=low vga=788 initrd=initrd.gz ---
  ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
  RelatedPackageVersions:
   linux-restricted-modules-4.2.0-16-generic N/A
   linux-backports-modules-4.2.0-16-generic  N/A
   linux-firmware1.156
  RfKill: Error: [Errno 2] No such file or directory
  Tags:  xenial
  Uname: Linux 4.2.0-16-generic x86_64
  UpgradeStatus: Upgraded to xenial on 2016-02-04 (31 days ago)
  UserGroups:
   
  _MarkForUpload: True
  dmi.bios.date: 05/05/2011
  dmi.bios.vendor: HP
  dmi.bios.version: I27
  dmi.chassis.type: 28
  dmi.chassis.vendor: HP
  dmi.modalias: 
dmi:bvnHP:bvrI27:bd05/05/2011:svnHP:pnProLiantBL460cG7:pvr:cvnHP:ct28:cvr:
  dmi.product.name: ProLiant BL460c G7
  dmi.sys.vendor: HP

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1554003/+subscriptions

-- 
Mailing list: https://launchpad.net/~kernel-packages
Post to : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : 

[Kernel-packages] [Bug 1561409] [NEW] CVE-2016-2184

2016-03-24 Thread Steve Beattie
*** This bug is a security vulnerability ***

Public security bug reported:

Kernel panic on invalid USB device descriptor (snd_usb_audio driver)

Break-Fix: - 0f886ca12765d20124bd06291c82951fd49a33be
Break-Fix: - 447d6275f0c21f6cc97a88b3a0c601436a4cdf2a

** Affects: linux (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-flo (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-goldfish (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-lts-quantal (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux-mako (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-manta (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-raspi2 (Ubuntu)
 Importance: Low
 Status: New

** Affects: linux-ti-omap4 (Ubuntu)
 Importance: Low
 Status: Invalid

** Affects: linux (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-flo (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux-lts-utopic (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-mako (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-manta (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Precise)
 Importance: Low
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Precise)
 Importance: Low
 Status: New

** Affects: linux (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-armadaxp (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-flo (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-vivid (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-wily (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-lts-xenial (Ubuntu Trusty)
 Importance: Low
 Status: New

** Affects: linux-mako (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-manta (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Trusty)
 Importance: Low
 Status: Invalid

** Affects: linux (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-armadaxp (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-flo (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-goldfish (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-quantal (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-raring (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-saucy (Ubuntu Vivid)
 Importance: Undecided
  

[Kernel-packages] [Bug 1561403] [NEW] CVE-2016-2117

2016-03-24 Thread Steve Beattie
*** This bug is a security vulnerability ***

Public security bug reported:

memory disclosure to ethernet due to unchecked scatter/gather IO

** Affects: linux (Ubuntu)
 Importance: High
 Status: New

** Affects: linux-armadaxp (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-flo (Ubuntu)
 Importance: High
 Status: New

** Affects: linux-goldfish (Ubuntu)
 Importance: High
 Status: New

** Affects: linux-lts-quantal (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux-mako (Ubuntu)
 Importance: High
 Status: New

** Affects: linux-manta (Ubuntu)
 Importance: High
 Status: New

** Affects: linux-raspi2 (Ubuntu)
 Importance: High
 Status: New

** Affects: linux-ti-omap4 (Ubuntu)
 Importance: High
 Status: Invalid

** Affects: linux (Ubuntu Precise)
 Importance: High
 Status: New

** Affects: linux-armadaxp (Ubuntu Precise)
 Importance: High
 Status: New

** Affects: linux-flo (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Precise)
 Importance: High
 Status: New

** Affects: linux-lts-utopic (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-lts-vivid (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-lts-wily (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-lts-xenial (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-mako (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-manta (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Precise)
 Importance: High
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Precise)
 Importance: High
 Status: New

** Affects: linux (Ubuntu Trusty)
 Importance: High
 Status: New

** Affects: linux-armadaxp (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-flo (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-goldfish (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-lts-quantal (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-lts-raring (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-lts-saucy (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-lts-trusty (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-lts-utopic (Ubuntu Trusty)
 Importance: High
 Status: New

** Affects: linux-lts-vivid (Ubuntu Trusty)
 Importance: High
 Status: New

** Affects: linux-lts-wily (Ubuntu Trusty)
 Importance: High
 Status: New

** Affects: linux-lts-xenial (Ubuntu Trusty)
 Importance: High
 Status: New

** Affects: linux-mako (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-manta (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-raspi2 (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux-ti-omap4 (Ubuntu Trusty)
 Importance: High
 Status: Invalid

** Affects: linux (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-armadaxp (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-flo (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-goldfish (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-quantal (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-raring (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-saucy (Ubuntu Vivid)
 Importance: Undecided
 Status: New

** Affects: linux-lts-trusty (Ubuntu Vivid)
 

[Kernel-packages] [Bug 1561403] Re: CVE-2016-2117

2016-03-24 Thread Steve Beattie
CVE-2016-2117

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-manta (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-mako (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-goldfish (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-flo (Ubuntu Precise)
   Status: New => Invalid

** Description changed:

- Placeholder
+ memory disclosure to ethernet due to unchecked scatter/gather IO

** Changed in: linux-lts-trusty (Ubuntu Precise)
   Importance: Undecided => High

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Importance: Undecided => High

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Importance: Undecided => High

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Importance: Undecided => High

** Changed in: linux-lts-wily (Ubuntu Precise)
   Importance: Undecided => High

** Changed in: linux-lts-wily (Ubuntu Wily)
   Importance: Undecided => High

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Importance: Undecided => High

** Changed in: linux-lts-wily (Ubuntu Trusty)
   Importance: Undecided => High

** Changed in: linux-lts-quantal (Ubuntu Precise)
   Status: New => Invalid

** Changed in: 

[Kernel-packages] [Bug 1561399] Re: CVE-2016-0823

2016-03-24 Thread Steve Beattie
CVE-2016-0823

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Xenial)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Wily)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Vivid)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Trusty)
   Importance: Undecided
   Status: New

** Also affects: linux (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-ti-omap4 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Also affects: linux-raspi2 (Ubuntu Precise)
   Importance: Undecided
   Status: New

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-wily (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-quantal (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-ti-omap4 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-raring (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-armadaxp (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-xenial (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-lts-saucy (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-manta (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-vivid (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-raspi2 (Ubuntu Trusty)
   Status: New => Invalid

** Changed in: linux-mako (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Wily)
   Status: New => Invalid

** Changed in: linux-lts-utopic (Ubuntu Xenial)
   Status: New => Invalid

** Changed in: linux-goldfish (Ubuntu Precise)
   Status: New => Invalid

** Changed in: linux-flo (Ubuntu Precise)
   Status: New => Invalid

** Description changed:

- Placeholder
+ The pagemap_open function in fs/proc/task_mmu.c in the Linux kernel
+ before 3.19.3, as used in Android 6.0.1 before 2016-03-01, allows local
+ users to obtain sensitive physical-address information by reading a
+ pagemap file, aka Android internal bug 25739721.
+ 
+ Break-Fix: - ab676b7d6fbf4b294bf198fb27ade5b0e865c7ce

** Changed in: linux-lts-trusty (Ubuntu Precise)
   Importance: Undecided => Medium

** Changed in: linux-lts-trusty (Ubuntu Wily)
   Importance: Undecided => Medium

** Changed in: linux-lts-trusty (Ubuntu Xenial)
   Importance: Undecided => Medium

** Changed in: linux-lts-trusty (Ubuntu Trusty)
   Importance: Undecided => Medium

** Changed in: linux-lts-wily (Ubuntu Precise)
   Importance: Undecided => Medium

** Changed in: linux-lts-wily (Ubuntu Wily)
   Importance: Undecided => Medium

** 

  1   2   >